Subject: RE: small typo in draft-leach-digest-sasl-03.txt and some questio ns

From: Paul Leach <[email-masked]>
Date: Wed, 7 Jul 1999 17:12:45 -0700

> -----Original Message-----
> From: Tony Hansen [mailto:[email-masked]]
> Sent: Monday, June 14, 1999 11:30 AM
> To: Paul Leach; [email-masked]
> Subject: small typo in draft-leach-digest-sasl-03.txt and 
> some questions
> 
> 
> qdstrval -> qdstr-val

Thanks for catching that.

> 
> Are all name=value pairs permitted to have quotation marks around the
> value?

That wasn't the intent. Only ones that need it because they might contain
stuff that needs to be quoted.

> For example, can you write 
> 
> 	nc="3"

Nope.

> If so, I don't see it from the ABNF.

That's why you don't see it.

> 
> Along a similar vein, I don't see how the qop-spec shown in 
> the example
> 
> 	qop="auth"
> 
> can be produced from the ABNF. (The ABNF lists 
> 
>         qop              = "qop" "=" qop-value
> 
> but qop-value doesn't have quotes around them, since qop-value is also
> used in qop-list within qop-options, which explicitly shows 
> the quotes.)

Yup, it's a bug in the example. Good catch.

In my implementation, following the "be conservative in what you send and
liberal in what you accept" rule, I'd probably allow any name value-pair to
be quoted, and log something. But the spec clearly doesn't allow it.

Paul

---

From: Tony Hansen <[email-masked]>
Date: Fri, 09 Jul 1999 01:03:41 -0400

Paul Leach wrote:
> ...

I have a feeling that many implementations will get this wrong and it
would be worth simplifying things now before we get much further. The
simplification I have in mind is of course to "allow any name value-pair
to be quoted". It makes code, maintenance and the protocol description
much simpler, all around.

	Tony Hansen
	[email-masked]

---

From: Tony Hansen <[email-masked]>
Date: Fri, 09 Jul 1999 01:03:41 -0400

Tony Hansen
	[email-masked]