Subject: rfc2831bis: A2 when qop-value=token

From: Hallvard B Furuseth <[email-masked]>
Date: Wed, 15 Oct 2003 12:58:19 +0200

rfc2831bis 2.1.1 "Step One" says:

        qop-options       = "qop" "=" <"> qop-list <">
        qop-list          = 1#qop-value
        qop-value         = "auth" | "auth-int" | "auth-conf" |
                             token

2.1.2.1 "Response-value" and 2.1.3 "Step Three" define A2 when qop is
"auth", "auth-int" and "auth-conf", but not when it is <token>.

-- 
Hallvard

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 15 Oct 2003 12:33:31 +0100

>"auth", "auth-int" and "auth-conf", but not when it is <token>.
Hi Hallvard,

Token is specifically for future extensions, if you see a qop value you 
don't recognize - you have to ignore it.
If you recognize nothing, you have to fail the authentication exchange.

Do you want any clarifications on this to be added to the document.

(I will go through your big message over weekend).

Cheers,
Alexey
__________________________________________
Isode Limited, http://www.isode.com

Cell: +44 7753759732

IETF standard related pages:
http://orthanc.ab.ca/mel/devel/Links.html

Personal Home Page: http://orthanc.ab.ca/mel
__________________________________________

---

From: Hallvard B Furuseth <[email-masked]>
Date: Mon, 27 Oct 2003 20:25:07 +0100

> Do you want any clarifications on this to be added to the document.

Not sure.  I think it would be good to mention that 'token is for future
extensions' somewhere.  And perhaps that these extensions must define
A2, since rfc2831bis does not.

-- 
Hallvard

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 15 Oct 2003 12:33:31 +0100

Hi Hallvard,

Cheers,
Alexey

Cell: +44 7753759732

---

From: Hallvard B Furuseth <[email-masked]>
Date: Mon, 27 Oct 2003 20:25:07 +0100

-- 
Hallvard