Subject: PLAIN examples

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 03 Dec 2003 15:35:04 -0800

Here are the updated examples section:

This section provides examples of PLAIN authentication exchanges.
The examples are intended to help the readers understand the above
text.  The examples are not definitive.

"C:" and "S:" indicate lines sent by the client and server respectively.
"<NUL>" represents a single NUL (U+0000) character.  The Application
Configuration Access Protocol ([ACAP]) is used in the examples.

The first example shows how the PLAIN mechanism might be used for
user authentication.

S: * ACAP (SASL "CRAM-MD5") (STARTTLS)
C: a001 STARTTLS
S: a001 OK "Begin TLS negotiation now"
<TLS negotiation, further commands are under TLS layer>
S: * ACAP (SASL "CRAM-MD5" "PLAIN")
C: a002 AUTHENTICATE "PLAIN"
S: + ""
C: {21}
C: <NUL>tim<NUL>tanstaaftanstaaf
S: a002 OK "Authenticated"           

The second example shows how the PLAIN mechanism might be used to
assuming the identity of another user.  In this example, the server
rejects the request.  Also, this example makes use of the protocol
optional initial response capability to eliminate a round-trip.

S: * ACAP (SASL "CRAM-MD5") (STARTTLS)
C: a001 STARTTLS
S: a001 OK "Begin TLS negotiation now"
<TLS negotiation, further commands are under TLS layer>
S: * ACAP (SASL "CRAM-MD5" "PLAIN")
C: a002 AUTHENTICATE "PLAIN" {19+}
C: Jane<NUL>John<NUL>xipj3plmq              
S: a002 NO "Not authorized to assume asserted identity"

---

From: Lyndon Nerenberg <[email-masked]>
Date: Thu, 04 Dec 2003 18:21:45 -0800

> C: Jane<NUL>John<NUL>xipj3plmq

I would change Jane and John to something not quite so similar, just to 
make the distinction more obvious.

--lyndon

---

From: Lyndon Nerenberg <[email-masked]>
Date: Thu, 04 Dec 2003 18:21:45 -0800

--lyndon