Subject: OpenBSD 3.4 & cyrus-sasl-2.1.17

From: "Jesus C. Valero Cantu" <[email-masked]>
Date: Fri, 23 Jan 2004 21:40:36 -0600

Hi everybody.

I'm trying to implement, Postfix SMTP AUTH with cyrus-sasl  mysql plugin.

At compiling time, i see messages like this

mv -f .libs/login_init.lo login_init.lo
/bin/sh ../libtool --mode=link gcc  -Wall -W -g -O2  -module -export-dynamic -rpath /usr/lib/sasl2 -L/usr/lib -o liblogin.la  -version-info 2:17:0 login.lo login_init.lo plugin_common.lo   -lresolv
rm -fr .libs/liblogin.la .libs/liblogin.* .libs/liblogin.*

*** Warning: This library needs some functionality provided by -lresolv.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have.

*** Warning: libtool could not satisfy all declared inter-library
*** dependencies of module liblogin.  Therefore, libtool will create
*** a static module, that should work as long as the dlopening
*** application is linked with the -dlopen flag.
ar cru .libs/liblogin.a  login.o login_init.o plugin_common.o 
ranlib .libs/liblogin.a
creating liblogin.la

mv -f .libs/plugin_common.lo plugin_common.lo
/bin/sh ../libtool --mode=link gcc  -Wall -W -g -O2   -L/usr/lib -o libsasl2.la -rpath /usr/local/lib -version-info 2:17:0 auxprop.lo canonusr.lo checkpw.lo client.lo common.lo  config.lo external.lo md5.lo saslutil.lo server.lo seterror.lo  dlopen.lo plugin_common.lo     -lresolv
rm -fr .libs/libsasl2.la .libs/libsasl2.* .libs/libsasl2.*

*** Warning: This library needs some functionality provided by -lresolv.
*** I have the capability to make that library automatically link in when
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have.
*** The inter-library dependencies that have been dropped here will be
*** automatically added whenever a program is linked with this library
*** or is declared to -dlopen it.
cc -shared  -fPIC -o .libs/libsasl2.so.2.17  auxprop.lo canonusr.lo checkpw.lo client.lo common.lo config.lo external.lo md5.lo saslutil.lo server.lo seterror.lo dlopen.lo plugin_common.lo  -L/usr/lib 

--

Then i set up /usr/lib/sasl2 links to /usr/local/lib/sasl2, for libsql.a and libsql.la then i try to connect with postfix and i see this in logs.

 smtp postfix/smtpd[23793]: fatal: no SASL authentication mechanisms
 smtp postfix/master[29064]: warning: process /usr/libexec/postfix/smtpd pid 16234 exit status 1
 smtp postfix/master[29064]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
 smtp postfix/master[29064]: warning: process /usr/libexec/postfix/smtpd pid 783 exit status 1

and this

smtp postfix/smtpd[10835]: Could not find a dlname line in .la file: libsql.la

. 
I supose i see the openbsd port for cyrus-sasl2, it had libsasl.so.2.13 but i don't get this when i compile from source package.

Somebody knows what's going on? what i need?

Thank you.

Jesus

---

From: Ken Murchison <[email-masked]>
Date: Sun, 25 Jan 2004 14:21:31 -0500

I'm moving this discussion to the cyrus-sasl list where it it more 
appropriate.

Jesus C. Valero Cantu wrote:

> /bin/sh ../libtool --mode=link gcc  -Wall -W -g -O2  -module 
> -export-dynamic -rpath /usr/lib/sasl2 -L/usr/lib -o liblogin.la  
> -version-info 2:17:0 login.lo login_init.lo plugin_common.lo   -lresolv
> /bin/sh ../libtool --mode=link gcc  -Wall -W -g -O2   -L/usr/lib -o 
> libsasl2.la -rpath /usr/local/lib -version-info 2:17:0 auxprop.lo 
> canonusr.lo checkpw.lo client.lo common.lo  config.lo external.lo md5.lo 
> saslutil.lo server.lo seterror.lo  dlopen.lo plugin_common.lo     -lresolv
> cc -shared  -fPIC -o .libs/libsasl2.so.2.17  auxprop.lo canonusr.lo 
> checkpw.lo client.lo common.lo config.lo external.lo md5.lo saslutil.lo 
> server.lo seterror.lo dlopen.lo plugin_common.lo  -L/usr/lib
> --
>  
> Then i set up /usr/lib/sasl2 links to /usr/local/lib/sasl2, for libsql.a 
> and libsql.la then i try to connect with postfix and i see this in logs.
>  
> I supose i see the openbsd port for cyrus-sasl2, it had libsasl.so.2.13 
> but i don't get this when i compile from source package.
>  

-- 
Kenneth Murchison     Oceana Matrix Ltd.
Software Engineer     21 Princeton Place
716-662-8973 x26      Orchard Park, NY 14127
--PGP Public Key--    http://www.oceana.com/~ken/ksm.pgp

---

From: Ken Murchison <[email-masked]>
Date: Sun, 25 Jan 2004 14:21:31 -0500