Subject: SASL WG status, 11/5

From: Tom Yu <[email-masked]>
Date: Wed, 05 Nov 2008 17:47:48 -0500

WG Charter - DONE

IETF73 draft WG agenda - Tom - 11/5 - DONE

IETF73 final WG agenda - Tom - 11/10

RFC 4422bis - review needed - WG

RFC 4422 implementation reports - Kurt - past due

RFC 4013bis - dropped from WG

CRAM-MD5 - resolve pending items from Frank:
  * adding Simon's PLAIN/CRAM comparison
  * tying to saslprep revision - N/A due to saslprep puntage
  * resolution on intended track - WG

digest-to-historic - mostly done, awaiting SCRAM

GS2 - Awaiting SCRAM issue resolution (encoding)

SCRAM:
  * PBKDF2 iteration counts - DONE (Alexey)
  * channel binding - Nico?
  * LDAP storage of auth info
        - WG to consider draft-melnikov-sasl-scram-ldap-00
  * make equivalent to a GS2 mech
        - pending WG discussion of encoding issue?

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 06 Nov 2008 10:24:26 +0000

>  * PBKDF2 iteration counts - DONE (Alexey)
Yes, the new draft wasn't posted before the deadline, but the change is 
done.

>  * channel binding - Nico?
I think this is done as well. Nico said that the current text is Ok.

>        - WG to consider draft-melnikov-sasl-scram-ldap-00
Yes, indeed.
I wasn't sure if the format proposed in the draft was reasonable and I 
didn't have time to consult with Kurt or anybody else. We can quickly 
discuss this in Minneapolis.

---

From: Hallvard B Furuseth <[email-masked]>
Date: Thu, 6 Nov 2008 12:15:27 +0100

>         - WG to consider draft-melnikov-sasl-scram-ldap-00

Why not authPassword from RFC 3112?  Value something like
   scram-hmac-sha1$<iter-count>:<salt>$<stored-key>:<server-key>
or scram-hmac-sha1-<iter-count>$<salt>$<stored-key>:<server-key>
where salt and keys are base64-encoded.

For that matter, I've missed why this is a SASL draft instead
of an ldapext draft.  Proof of concept for SCRAM, maybe?

-- 
Hallvard

---

From: Tom Yu <[email-masked]>
Date: Thu, 06 Nov 2008 15:26:55 -0500

> of an ldapext draft.  Proof of concept for SCRAM, maybe?

Chris Newman stated that he would not implmenent SCRAM if there were
no published way to store its authentication secrets in LDAP.  I have
no strong opinion either way on whether to adopt this draft as a SASL
WG item, but I think it needs to get published somehow.

---

From: Kurt Zeilenga <[email-masked]>
Date: Mon, 10 Nov 2008 06:17:04 -0800

> WG item, but I think it needs to get published somehow.

I have a mild preference for engineering this outside of the WG.

-- Kurt