Subject: [SAVA] Charter Proposal To Be Discussed at BoF

From: fergdawg at netzero.net (Paul Ferguson)
Date: Wed, 5 Dec 2007 07:46:32 GMT

- -- Christian Vogt <christian.vogt at nomadiclab.com> wrote:

> - The IPv4 solution depends on tracking the DHCP traffic on a port.

First, let me say that I'm sorry that I cannot be in attendance for
the BoF.

My "day job" issues at the moment, unfortunately, prohibit the
luxury of being there.

Second, I'm a little concerned about the scope of the IPv4 SAVI
"solution" as described in the above BoF agenda item.

Now, I've been following the mailing list traffic, and perhaps
I missed something, but I'm a little unclear on why the focus
of the IPv4 SAVI "solution" is so centrally bound to DHCP?

This seems like a monumental mistake to me.

- - ferg

--
"Fergie", a.k.a. Paul Ferguson
 Engineering Architecture for the Internet
 fergdawg(at)netzero.net
 ferg's tech blog: http://fergdawg.blogspot.com/

---

From: miw at computer.org (Mark Williams)
Date: Wed, 05 Dec 2007 17:00:42 +0800

I tend to agree on the last point.

I mean, having a solution tied to DHCP is important, but actually there 
needs to be solutions for all methods of IP address provisioning.

cheers,

Mark

Paul Ferguson wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> -----BEGIN PGP SIGNATURE-----
> Version: PGP Desktop 9.6.3 (Build 3017)
>
> wj8DBQFHVldVq1pz9mNUZTMRAjffAJsEJwz9hoV1hXwO1GWUoz70KmpJkACfbPQ+
> 1Krn+gOMZ2jG++i0VzFpeGw=
> =dwWn
> -----END PGP SIGNATURE-----
>
> --
> _______________________________________________
> SAVA mailing list
> SAVA at mail.nrc.tsinghua.edu.cn
> http://mail.nrc.tsinghua.edu.cn/cgi-bin/mailman/listinfo/sava
>
>

---

From: jari.arkko at piuha.net (Jari Arkko)
Date: Wed, 05 Dec 2007 01:22:03 -0800

> needs to be solutions for all methods of IP address provisioning.

Its late so I'm probably missing something. But which methods are you
talking about?

Jari

---

From: miw at juniper.net (Mark Williams)
Date: Thu, 06 Dec 2007 05:47:36 +0800

Static address assignment springs immediately to mind. I know it's a 
trivial case, but it's important.

(To tell the truth I thought there were other ways a host could get a 
dynamic IP address besides DHCP, but I can't find evidence of any in 
normal use today based on a quick search.)

cheers,

Mark

-- 
"Product roadmap and/or product discussion in this email set forth
Juniper Networks' current intention and is subject to change at any
time without notice.  No purchases are contingent upon Juniper
Networks delivering any feature or functionality expressed or implied
in this roadmap or product discussion."
-----------------------------------------------------------------
Mark Williams                        Juniper Networks
Liaison                              Beijing Office
Academic Networking Sector           Tel: +86 10 6528 8800 x16032
Asia Pacific                         FAX: +61 7 3251 0155
miw at juniper.net                      Cell: +86 1370-111-4749

---

From: bgreene at cisco.com (Barry Greene (bgreene))
Date: Wed, 5 Dec 2007 13:53:39 -0800

> (To tell the truth I thought there were other ways a host 
> could get a dynamic IP address besides DHCP, but I can't find 
> evidence of any in normal use today based on a quick search.)

Dynamic IP Addressing:

1. AAA (Radius, TACACS+, Kerberos, and Diameter)
2. DHCP
3. PPP with address ranges configured on the network gear (pre DHCP)

There are a couple of other techniques - LAT (DEC), Banyan, and other
really old technologies had dynamic IP address allocation features.
DHCP is the body of work that standardized this patch work.

---

From: pekkas at netcore.fi (Pekka Savola)
Date: Thu, 6 Dec 2007 07:42:31 +0200 (EET)

> 3. PPP with address ranges configured on the network gear (pre DHCP)

+ IKE.

Not sure if I understand how AAA in and of itself can provide 
addresses?  Isn't it used in conjunction with PPP or DHCP?

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings