Subject: [savi] FYI: Juniper support for SEND

From: Pekka Savola <[email-masked]>
Date: Tue, 18 Nov 2008 21:57:51 +0200 (EET)

FYI, FWIW,

I noticed that the recently released JunOS software (9.3) supports SEND.

I guess there must be loud users demanding this feature for it to be 
implemented.  I guess we'll have some hope for SEND after all!

However, it seems that certificate discovery etc. is not supported. 
A SEND-based SAVI solution would probably need this to authorize 
routers to send off-link traffic.

http: //www.juniper.net/techpubs/en_US/junos9.3/information-products/topic-collections/release-notes/9.3/m-mx-t-series-new-features.html

http: //www.juniper.net/techpubs/software/junos/junos93/swconfig-routing/secure-neighbor-discovery-configuration-guidelines.html

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: ZhangDong <[email-masked]>
Date: Wed, 19 Nov 2008 10:37:30 +0800

Thanks, Pwkka.

It makes sense really,especially for me.
I wonder that whether there is open source of SEND.

Dong Zhang

----- 原始邮件 -----
发件人: Pekka Savola <[email-masked]>
日期: 2008年 11月 19日, 星期三,  上午3:58
主题: [savi] FYI: Juniper support for SEND
收件人: [email-masked]

>  _______________________________________________
>  savi mailing list
>  [email-masked]
>  https://www.ietf.org/mailman/listinfo/savi
>

---

From: Pekka Savola <[email-masked]>
Date: Wed, 19 Nov 2008 09:13:59 +0200 (EET)

> I wonder that whether there is open source of SEND.

Yes, Docomo Labs have/had one; they might be willing to hand it over 
to someone

http://www.ietf.org/mail-archive/web/cga-ext/current/msg00173.html
http://www.docomolabs-usa.com/lab_opensource.html

> ----- ???? -----
> ???: Pekka Savola <[email-masked]>
> ??: 2008? 11? 19?, ???,  ??3:58
> ??: [savi] FYI: Juniper support for SEND
> ???: [email-masked]
>
>
>> FYI, FWIW,
>>

---

From: shenshuo 00102542 <[email-masked]>
Date: Wed, 19 Nov 2008 02:11:01 -0600

Docomo USA had one open source implementation of SeND a few years ago. But the project is no longer maintained. I believe many people still have the code, in case you can not find it, let me know.
We just launched a project of a new implementation of SeND. We hope to have a report by the next IETF.
Best, 

Sean

FYI: Docomo SeND project

----- 原邮件 -----
发件人: ZhangDong <[email-masked]>
日期: 星期二, 十一月 18日, 2008 下午8:37
主题: [savi] Reply:  FYI: Juniper support for SEND
收件人: Pekka Savola <[email-masked]>
抄送: [email-masked]

> >  http: //www.juniper.net/techpubs/en_US/junos9.3/information-
> products/topic-collections/release-notes/9.3/m-mx-t-series-new-
> features.html>  
> >  http: 
> //www.juniper.net/techpubs/software/junos/junos93/swconfig-routing/secure-neighbor-discovery-configuration-guidelines.html
> >  
> >  -- 
> >  Systems. Networks. Security. -- George R.R. Martin: A Clash of 
> Kings>  _______________________________________________
> >  savi mailing list
> >  [email-masked]

---

From: shenshuo 00102542 <[email-masked]>
Date: Wed, 19 Nov 2008 02:19:14 -0600

----- 原邮件 -----
发件人: shenshuo 00102542 <[email-masked]>
日期: 星期三, 十一月 19日, 2008 上午2:11
主题: [savi] ***SPAM*** 6.251 (5) 回复 : Reply:  FYI:	Juniper support for SEND
收件人: ZhangDong <[email-masked]>
抄送: [email-masked]

> Docomo USA had one open source implementation of SeND a few years 
> ago. But the project is no longer maintained. I believe many 
> people still have the code, in case you can not find it, let me know.
> > >  I guess there must be loud users demanding this feature for 
> it 
> > to be 
> > > 
> > //www.juniper.net/techpubs/software/junos/junos93/swconfig-
> routing/secure-neighbor-discovery-configuration-guidelines.html
> > >  
> > >  --

---

From: Pekka Savola <[email-masked]>
Date: Wed, 19 Nov 2008 14:25:21 +0200 (EET)

On Wed, 19 Nov 2008, shenshuo 00102542 wrote:
> ago. But the project is no longer maintained. I believe many people 
> still have the code, in case you can not find it, let me know. We 
> just launched a project of a new implementation of SeND. We hope to 
> have a report by the next IETF. Best,

I wonder if anyone would be interested in stepping up to maintain the 
Docomo project for the common benefit?  Based on the mailing-list 
exchanges I referred to, they would be willing.

---

From: shenshuo 00102542 <[email-masked]>
Date: Wed, 19 Nov 2008 09:46:10 -0600

I found there are volunteers who is maintaining the Docomo code. Sorry if my previous message misleaded.
http://www.ietf.org/mail-archive/web/cga-ext/current/msg00180.html

Sean

----- Original Message -----
From: Pekka Savola <[email-masked]>
Date: Wednesday, November 19, 2008 6:49 am
Subject: Re: ??:[savi] Reply:  FYI: Juniper support for SEND
To: shenshuo 00102542 <[email-masked]>
Cc: ZhangDong <[email-masked]>, [email-masked]

> people