Subject: [savi] about draft-ietf-savi-fcfs-02

From: zhengruobin 35664 <[email-masked]>
Date: Fri, 27 Nov 2009 10:08:44 +0800

Hi There,

In the draft-ietf-savi-fcfs-01, there is a description as follows in 3.2.2.  Processing of control packets of draft-ietf-savi-fcfs-01:

"If no NADV message for that Target Address is received in
         DADTimeout, then the status of the entry is change to valid and
         the lifetime of the entry is set to LIFETIME.  In addition, if
         the address contained in the newly created entry is a link
         local address, FCFS SAVI MAY as well create entries for the
         global addresses resulting from concatenating the Interface
         Identifier of the link local address and the global prefixes
         contained in the Prefix List for the Interface through which
         the NSOL message was received."

But the above is not covered in the draft-ietf-savi-fcfs-02. I wonder what happened to this.

Best regards,

Robin

---

From: marcelo bagnulo braun <[email-masked]>
Date: Fri, 27 Nov 2009 08:26:02 +0100

> But the above is not covered in the draft-ietf-savi-fcfs-02. I wonder what happened to this.

i understand you are talking about the optimization defined by the MAY, 
right?
since the version 01 has been through a major rewriting, this was 
dropped unitentionally.

I will include it in the next version if people still think it is a good 
idea

regards, marcelo

> Best regards,
>
> Robin
>
>
> _______________________________________________
> savi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/savi
>
>

---

From: robin <[email-masked]>
Date: Sat, 28 Nov 2009 10:51:01 +0800

Hi marcelo,
In IPv4 world, there is a binding of IPv4 address and port in BRAS for the
sake of security. When migration to IPv6, we do need a method to bind the
IPv6 address and its corresponding port. 
The optimization defined by the MAY in draft-ietf-savi-fcfs-01 provided a
practical solution for this. 

Best Regards,

Robin

-----Original Message-----
From: marcelo bagnulo braun [mailto:[email-masked]] 
Sent: Friday, November 27, 2009 3:26 PM
To: zhengruobin 35664
Cc: [email-masked]
Subject: Re: [savi] about draft-ietf-savi-fcfs-02

zhengruobin 35664 escribió:
> Hi There,
>
> In the draft-ietf-savi-fcfs-01, there is a description as follows in

regards, marcelo

---

From: marcelo bagnulo braun <[email-masked]>
Date: Sat, 28 Nov 2009 09:26:59 +0100

robin escribió:
> Hi marcelo,
> In IPv4 world, there is a binding of IPv4 address and port in BRAS 

what is bras?

> for the
i am not sure i follow (fwiwi i am not oposing to this, i simply fail to 
understnad what you are saying)
even without this optimization, we can create a binding for any IPv6 
address and a port, so i am not sure i understnad what is your point.

The only potential issue that i understnad this optimization is 
addressing, is the case of legacy implementations, that follow 2462 
instead of 4862 that may not do the DAD for the global address if they 
have done so for the corresponding link local.

Regards, marcelo

>> But the above is not covered in the draft-ietf-savi-fcfs-02. I wonder what
>>     
> happened to this.
>   
>>   
>>     
>