Subject: [savi] savi-dhcp-02, state restoration

From: John Kaippallimalil <[email-masked]>
Date: Mon, 22 Mar 2010 12:40:46 -0500

Hi Jun,

In savi-dhcp-02 section 21 (State Restoration), the suggestion is to store
state bindings in non volatile memory. One concern is that non-volatile
memory is not typically write efficient. 

Two alternative solutions:

Alternative 1: 

Use the DHCPLEASEQUERY mechanism to rebuild state. Some details for IPv6
below:

-      when switch recovers, it has lost all session state (could stop
filtering till SAVi state is rebuilt)

-      Switch sends bulk DHCPLEASEQUERY (query by relay id) - RFC5460. 

-      DHCP server replies with DHCP entries related to that relay - used to
rebuild binding state.

However, this alternative requires that the SAVI switch to be a DHCP Relay,
and also support TCP (bulk query transport). 

Alternative 2:
- Upstream router detects SAVi switch failure (and recovery). Example
802.1ag messages.

-      Upon switch recovery, the router sends Neighbor Solicitation, replied
by host with NA. (similar to NUD?)

-      This is used to rebuild binding state in SAVI switch.

This method does not require the switch to be a DHCP relay. However it
requires 802.1ag support in the network.

Regards,

John

---

From: "Bi Jun" <[email-masked]>
Date: Tue, 23 Mar 2010 10:26:45 -0700

Hi John,

Thank you very much for your suggestion.

For alternative 1, it is already added into the section 22 of savi-dhcp-02. However, based on the suggestion from Eric and others, 
it's an optional function, because it will be a heavy cost to savi-switches, especially low end access switches.

For alternative 2,  it needs the upstream router to know the host's address bound at the rebooted switches so that the router can send the NS, right?

thanks,
Jun Bi

From: John Kaippallimalil 
Sent: Monday, March 22, 2010 10:40 AM
To: 'Bi Jun' ; [email-masked] 
Subject: savi-dhcp-02, state restoration

Hi Jun,

In savi-dhcp-02 section 21 (State Restoration), the suggestion is to store state bindings in non volatile memory. One concern is that non-volatile memory is not typically write efficient. 

Alternative 1: 

Use the DHCPLEASEQUERY mechanism to rebuild state. Some details for IPv6 below:

-      when switch recovers, it has lost all session state (could stop filtering till SAVi state is rebuilt)

-      DHCP server replies with DHCP entries related to that relay - used to rebuild binding state.

However, this alternative requires that the SAVI switch to be a DHCP Relay, and also support TCP (bulk query transport). 

Alternative 2:
- Upstream router detects SAVi switch failure (and recovery). Example 802.1ag messages.

-      Upon switch recovery, the router sends Neighbor Solicitation, replied by host with NA. (similar to NUD?)

This method does not require the switch to be a DHCP relay. However it requires 802.1ag support in the network.

Regards,

John

---

From: "Bi Jun" <[email-masked]>
Date: Tue, 23 Mar 2010 10:52:16 -0700

You meant, by the Neighbor table/ARP table of that router (then the router should be the first layer 3 hop in the subnet).

Right. One concern is that the host could spoof the NA and reply.

From: Frank Xia 
Sent: Tuesday, March 23, 2010 10:41 AM
To: 'Bi Jun' ; 'John Kaippallimalil' ; [email-masked] 
Subject: RE: [savi] savi-dhcp-02, state restoration

Hi Bi

Sorry for my jumping in. 

Please see my quick response.

BR

Frank

--------------------------------------------------------------------------------

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bi Jun
Sent: Tuesday, March 23, 2010 12:27 PM
To: John Kaippallimalil; [email-masked]
Subject: Re: [savi] savi-dhcp-02, state restoration

Hi John,

Frank=>Yes. The router already has full information about L2&L3 

information of the host, and the interface(port) that the host is connected.  

thanks,

Jun Bi

Hi Jun,

Alternative 1: 

Alternative 2:

Regards,

John

---

From: John Kaippallimalil <[email-masked]>
Date: Tue, 23 Mar 2010 12:55:20 -0500

Hi Jun,

That is correct: the upstream router would need to know the host's address
bound at the rebooted switch. 

Regarding alternative 1, the suggestion is about 'bulk' DHCPLEASEQUERY using
TCP. But I agree that it would require the switch to be a DHCP Relay (and
TCP connections) - a heavy cost to low end switches.

Regards,

John

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bi
Jun
Sent: Tuesday, March 23, 2010 12:27 PM
To: John Kaippallimalil; [email-masked]
Subject: Re: [savi] savi-dhcp-02, state restoration

Hi John,

For alternative 1, it is already added into the section 22 of savi-dhcp-02.
However, based on the suggestion from Eric and others, 

it's an optional function, because it will be a heavy cost to savi-switches,
especially low end access switches.

For alternative 2,  it needs the upstream router to know the host's address
bound at the rebooted switches so that the router can send the NS, right?

thanks,

Jun Bi

From: John <mailto:[email-masked]>  Kaippallimalil 

To: 'Bi Jun' <mailto:[email-masked]>  ; [email-masked] 

Hi Jun,

Alternative 1: 

Alternative 2:

Regards,

John

---

From: Frank Xia <[email-masked]>
Date: Tue, 23 Mar 2010 13:10:03 -0500

Hi Bi

I am not sure what  "spoof the NA" exactly means.

ND messages always exchange between the host and the router.

Switch failure is only a trigger for the router to send a NS message.

IMHO, there is no any extra security issue introduced.

BR

Frank

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of Bi
Jun
Sent: Tuesday, March 23, 2010 12:52 PM
To: Frank Xia; 'John Kaippallimalil'; [email-masked]
Subject: Re: [savi] savi-dhcp-02, state restoration

You meant, by the Neighbor table/ARP table of that router (then the router
should be the first layer 3 hop in the subnet).

 

From: Frank <mailto:[email-masked]>  Xia 

To: 'Bi Jun' <mailto:[email-masked]>  ; 'John
<mailto:[email-masked]>  Kaippallimalil' ; [email-masked] 

Hi Bi

Sorry for my jumping in. 

BR

Frank

  _____  

Hi John,

 

thanks,

Jun Bi

Hi Jun,

Alternative 1: 

-       DHCP server replies with DHCP entries related to that relay - used
to rebuild binding state.

Alternative 2:

-       Upon switch recovery, the router sends Neighbor Solicitation,
replied by host with NA. (similar to NUD?)

Regards,

John

---

From: John Kaippallimalil <[email-masked]>
Date: Tue, 23 Mar 2010 13:12:26 -0500

Please see inline >>

  _____  

From: Bi Jun [mailto:[email-masked]] 
Sent: Tuesday, March 23, 2010 12:52 PM
To: Frank Xia; 'John Kaippallimalil'; [email-masked]
Subject: Re: [savi] savi-dhcp-02, state restoration

>> The NS message from router --> host is unicast. Host replies with NS, and
both these messages are forwarded by the switch (and used to update the
binding table).

Spoofing by the host would probably not be an issue in that case?

From: Frank Xia <mailto:[email-masked]>  

Hi Bi

Sorry for my jumping in. 

BR

Frank

  _____  

Hi John,

 

thanks,

Jun Bi

Hi Jun,

Alternative 1: 

Alternative 2:

Regards,

John

---

From: "Bi Jun" <[email-masked]>
Date: Tue, 23 Mar 2010 11:21:48 -0700

Hi John and Frank,

read both of your replied emails.
I plan to put it into the document. I think it's a light weight solution because it is triggered by control message (802.1ag).

For alternative 1, we understand it is different than section 22, will consider it as another optional function.

Thank you very much for your constructive suggestions.

Best Regards,
Jun Bi

From: John Kaippallimalil 
Sent: Tuesday, March 23, 2010 11:12 AM
To: 'Bi Jun' ; 'Frank Xia' ; [email-masked] 
Subject: Re: [savi] savi-dhcp-02, state restoration

Please see inline >>

>> The NS message from router à host is unicast. Host replies with NS, and both these messages are forwarded by the switch (and used to update the binding table).

 

From: Frank Xia 

Hi Bi

Sorry for my jumping in. 

BR

Frank

Hi John,

thanks,

Jun Bi

Hi Jun,

Alternative 1: 

Alternative 2:

Regards,

John

_______________________________________________
savi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/savi

---

From: "Guang Yao" <[email-masked]>
Date: Wed, 24 Mar 2010 02:36:42 +0800

A possible vulnerability is that a malicious node may try to pollute the ND
table of the router through spoofed IP before(or during) this process.

Maybe the ND table should be locked until this process is finished.

And it seems the SAVI device loses independence?

From: [email-masked] [mailto:[email-masked]] On Behalf Of John
Kaippallimalil
Sent: Wednesday, March 24, 2010 2:12 AM
To: 'Bi Jun'; 'Frank Xia'; [email-masked]
Subject: Re: [savi] savi-dhcp-02, state restoration

Please see inline >>

  _____  

>> The NS message from router à host is unicast. Host replies with NS, and

 

Hi Bi

Sorry for my jumping in. 

BR

Frank

  _____  

Hi John,

 

thanks,

Jun Bi

Hi Jun,

Alternative 1: 

-  when switch recovers, it has lost all session state (could stop filtering
till SAVi state is rebuilt)

-  Switch sends bulk DHCPLEASEQUERY (query by relay id) – RFC5460. 

-  DHCP server replies with DHCP entries related to that relay – used to
rebuild binding state.

Alternative 2:

-  Upon switch recovery, the router sends Neighbor Solicitation, replied by
host with NA. (similar to NUD?)

Regards,

John

---

From: Eric Levy-Abegnoli <[email-masked]>
Date: Tue, 23 Mar 2010 21:38:27 +0100

John Kaippallimalil a écrit :
>
> Hi Jun,
>
> That is correct: the upstream router would need to know the host’s 
> address bound at the rebooted switch.
>
> Regarding alternative 1, the suggestion is about ‘bulk’ DHCPLEASEQUERY 
> using TCP. But I agree that it would require the switch to be a DHCP 
> Relay (and TCP connections) – a heavy cost to low end switches.
>
And for the high ends as well. Not much in terms of capability, but in 
terms of operation costs. Lots of vlans would have to terminate the 
layer3 on the box.
Eric
>
> Regards,
>
> John
>
> * From: * [email-masked] [mailto:[email-masked]] *On 
> Behalf Of *Bi Jun
> *Sent:* Tuesday, March 23, 2010 12:27 PM
> *To:* John Kaippallimalil; [email-masked]
> *Subject:* Re: [savi] savi-dhcp-02, state restoration
>
> Hi John,
>
> For alternative 1, it is already added into the section 22 of 
> savi-dhcp-02. However, based on the suggestion from Eric and others,
>
> it's an optional function, because it will be a heavy cost to 
> savi-switches, especially low end access switches.
>
> For alternative 2, it needs the upstream router to know the host's 
> address bound at the rebooted switches so that the router can send the 
> NS, right?
>
> thanks,
>
> Jun Bi
>
> * From: * John Kaippallimalil <mailto:[email-masked]>
>
> * Sent: * Monday, March 22, 2010 10:40 AM
>
> * To: * 'Bi Jun' <mailto:[email-masked]> ; [email-masked] 
> <mailto:[email-masked]>
>
> * Subject: * savi-dhcp-02, state restoration
>
> Hi Jun,
>
> In savi-dhcp-02 section 21 (State Restoration), the suggestion is to 
> store state bindings in non volatile memory. One concern is that 
> non-volatile memory is not typically write efficient.
>
> - DHCP server replies with DHCP entries related to that relay – used 
> However, this alternative requires that the SAVI switch to be a DHCP 
> Relay, and also support TCP (bulk query transport).
>
> Alternative 2:
> ------------------------------------------------------------------------
>

---

From: John Kaippallimalil <[email-masked]>
Date: Tue, 23 Mar 2010 16:04:39 -0500

Hi Eric,
Agree about the costs of DHCPLEASEQUERY: DHCP Relay function at switch, etc.
Not clear why the VLANs would be a problem.  If VLAN forwarding is used, it
could be stacked, with an S-VLAN between switch and router.

Regards,
John

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Eric
Levy-Abegnoli
Sent: Tuesday, March 23, 2010 3:38 PM
To: John Kaippallimalil
Cc: [email-masked]
Subject: Re: [savi] savi-dhcp-02, state restoration

---

From: John Kaippallimalil <[email-masked]>
Date: Tue, 23 Mar 2010 16:46:37 -0500

Good point. 

Especially if we cannot make the assumption that a DHCP relay (or server) is
located at the router. 

Regards,

John

  _____  

From: Guang Yao [mailto:[email-masked]] 
Sent: Tuesday, March 23, 2010 1:37 PM
To: 'John Kaippallimalil'
Cc: [email-masked]
Subject: RE: [savi] savi-dhcp-02, state restoration

Please see inline >>

  _____  

 

Hi Bi

Sorry for my jumping in. 

BR

Frank

  _____  

Hi John,

 

thanks,

Jun Bi

Hi Jun,

Alternative 1: 

Alternative 2:

Regards,

John