Subject: Re: [savi] Requirements level for data-packet-triggered binding creation

From: Christian Vogt <[email-masked]>
Date: Thu, 1 Jul 2010 14:48:11 -0700

Everybody:

Thanks for sharing your thoughts on the requirements level for data-
packet-triggered binding creation.  Unquestionably, there is agreement
on the importance of a clear explanation of:

- why data-packet-triggered binding creation is useful, and

- what can happen if the feature is omitted.

While there are different opinions on the formulation -- conditional
SHOULD versus conditional MUST --, Jean-Michel and I believe that the
working group will be fine either way provided we get said explanation
right.  As the chairs, we would hence like to conclude the discussion
with a conditional SHOULD, the preferred choice of the majority.

Authors, please revise your documents accordingly.

- Christian, for Jean-Michel and Christian

On Jun 10, 2010, Christian Vogt wrote:

> Folks:
> 
> In our foregoing discussion, we found that data-packet-triggered binding
> creation would help SAVI solutions minimize loss of legitimate packets. 
> But a question that is yet to be answered is on the requirements level
> that data-packet-triggered binding creation should have:  Should it be a
> MUST, a conditional MUST, a SHOULD, or a MAY?  The foregoing discussion
> indicates that the working group would prefer not to use a MUST, since
> the extra complexity of data-packet-triggered binding creation is not
> required in all cases.  The working group chairs would hence like the
> working group to consider the following two options more closely:
> 
> (1) A conditional MUST, allowing implementations to omit data-packet-
>    triggered binding creation if the SAVI device is known to directly
>    attach to hosts.
> 
> (2) The specification of two modes -- a loose mode and a strict mode --,
>    whereby only the strict mode implements data-packet-triggered
>    binding creation.  Implementations can support either or both modes.
> 
> Please share your view.
> 
> - Christian, for Jean-Michel and Christian

---

From: "Jun Bi" <[email-masked]>
Date: Fri, 2 Jul 2010 11:56:27 +0800

Dear WG Chairs,

Thank you very much for your work.
On behalf of the authors, we will revise dhcp-04 quickly.

Best Regards,
Jun Bi

--------------------------------------------------
From: "Christian Vogt" <[email-masked]>
Sent: Friday, July 02, 2010 5:48 AM
To: "SAVI Mailing List" <[email-masked]>
Cc: "Jean-Michel Combes" <[email-masked]>
Subject: Re: [savi] Requirements level for data-packet-triggered 
bindingcreation

> _______________________________________________
> savi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/savi
>