Subject: [savnet] A variation of DSAV as a BGP extension

From: "Lubashev, Igor" <[email-masked]>
Date: Tue, 22 Mar 2022 04:15:12 +0000

I am glad to see some renewed attention paid to SAV.

Here is a quick proposal I've made on the topic @ IETF-101.
https://datatracker.ietf.org/meeting/101/materials/slides-101-rtgwg-sessb-ingress-filtering-for-asymmetric-routing-01

The quick summary of the above:

1. We have a problem today, because we use the same BGP reachability advertisements for two separate purposes: advertising reachability and SAV.

2. The proposal is a creation of a new "SAV Allow" SAFI. Advertisements with "SAV Allow" SAFI are never used for forwarding and can only be used for SAV.
2a. The advertisements are secured against spoofing by all the usual means that BGP advertisements are secured.
2b. "SAV Allow" SAFI advertisements are transitive, unless a route (a regular or "SAV Allow") with the same or a shorter prefix is advertised to a peer. This is because the advertised route already serves "SAV Allow" purpose.
2c. Only routers that support "SAV Allow" SAFI get these advertisements.

3. The upside is that this seems like it would solve SAV problem and use just a simple BGP extension for it. The downside is that incremental deployment can only start with the routers that are originating the routes -- upgrading an intermediary router does no good, unless all routers between the path originator and itself have been upgraded.
3a. Compared to RFC8704, RFC8704 does not solve SAV completely, but it allows for a much looser increment deployment to be useful.

Happy to discuss this more, of course.

- Igor

---

From: Zhuangshunwan <[email-masked]>
Date: Tue, 22 Mar 2022 06:43:46 +0000

Hi Igor,

Thank you for sharing the useful information! 
Do you have a relevant draft for this new BGP SAFI?

Kind Regards,
Shunwan

> -----Original Message-----
> From: savnet [mailto:[email-masked]] On Behalf Of Lubashev, Igor
> Sent: Tuesday, March 22, 2022 12:15 PM
> To: [email-masked]
> Subject: [savnet] A variation of DSAV as a BGP extension
> 
> https://datatracker.ietf.org/meeting/101/materials/slides-101-rtgwg-sessb-i
> ngress-filtering-for-asymmetric-routing-01
> 
> 1. We have a problem today, because we use the same BGP reachability
> advertisements for two separate purposes: advertising reachability and SAV.
> 
> 2. The proposal is a creation of a new "SAV Allow" SAFI. Advertisements with
> "SAV Allow" SAFI are never used for forwarding and can only be used for SAV.
> 2b. "SAV Allow" SAFI advertisements are transitive, unless a route (a regular
> or "SAV Allow") with the same or a shorter prefix is advertised to a peer. This
> is because the advertised route already serves "SAV Allow" purpose.
> 3. The upside is that this seems like it would solve SAV problem and use just
> a simple BGP extension for it. The downside is that incremental deployment
> can only start with the routers that are originating the routes -- upgrading an
> intermediary router does no good, unless all routers between the path
> originator and itself have been upgraded.
> 3a. Compared to RFC8704, RFC8704 does not solve SAV completely, but it
> allows for a much looser increment deployment to be useful.
> 
> --
> savnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/savnet

---

From: "Lubashev, Igor" <[email-masked]>
Date: Tue, 22 Mar 2022 22:12:42 +0000

Shunwan, thanks for your interest. I do not have a draft right now, but if there is interest in the approach, I am happy to work with someone to put one together.

- Igor

On Mar 22, 2022 2:44 AM, Zhuangshunwan <zhuangshunwan=[email-masked]> wrote:
Hi Igor,

Kind Regards,
Shunwan

> https://urldefense.com/v3/__https://datatracker.ietf.org/meeting/101/materials/slides-101-rtgwg-sessb-i__;!!GjvTz_vk!BwOeb7TQgTAoicxAhEUf643XgxFwqz9uQ8kfsXJ3uvf06VJ553cItMEboYL7NTA$
> https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/savnet__;!!GjvTz_vk!BwOeb7TQgTAoicxAhEUf643XgxFwqz9uQ8kfsXJ3uvf06VJ553cItMEbWA_9Jf0$

---

From: Zhuangshunwan <[email-masked]>
Date: Wed, 23 Mar 2022 01:49:13 +0000

Hi Igor,

The choice of protocol will be discussed in the savnet BOF meeting, and your past thinking and experience will be of great help!
If BGP is chosen, I am willing to make some contributions to this work.
Looking forward to seeing you at the meeting.

Thanks,
Shunwan

From: Lubashev, Igor [mailto:ilubashe=[email-masked]]
Sent: Wednesday, March 23, 2022 6:13 AM
To: [email-masked]; Zhuangshunwan <[email-masked]>
Subject: RE: A variation of DSAV as a BGP extension

- Igor

On Mar 22, 2022 2:44 AM, Zhuangshunwan <zhuangshunwan=[email-masked]<mailto:zhuangshunwan=[email-masked]>> wrote:
Hi Igor,

Kind Regards,
Shunwan

> To: [email-masked]<mailto:[email-masked]>
> https://urldefense.com/v3/__https://datatracker.ietf.org/meeting/101/materials/slides-101-rtgwg-sessb-i__;!!GjvTz_vk!BwOeb7TQgTAoicxAhEUf643XgxFwqz9uQ8kfsXJ3uvf06VJ553cItMEboYL7NTA$<https://urldefense.com/v3/__https:/datatracker.ietf.org/meeting/101/materials/slides-101-rtgwg-sessb-i__;!!GjvTz_vk!BwOeb7TQgTAoicxAhEUf643XgxFwqz9uQ8kfsXJ3uvf06VJ553cItMEboYL7NTA$>
> [email-masked]<mailto:[email-masked]>
> https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/savnet__;!!GjvTz_vk!BwOeb7TQgTAoicxAhEUf643XgxFwqz9uQ8kfsXJ3uvf06VJ553cItMEbWA_9Jf0$<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/savnet__;!!GjvTz_vk!BwOeb7TQgTAoicxAhEUf643XgxFwqz9uQ8kfsXJ3uvf06VJ553cItMEbWA_9Jf0$>

---

From: Jari Arkko <[email-masked]>
Date: Thu, 24 Mar 2022 08:38:36 +0100

Very interesting, thanks Igor!

Jari

> On 22. Mar 2022, at 5.15, Lubashev, Igor <ilubashe=[email-masked]> wrote:
>