Subject: [scim] Survey questions

From: Danny Mayer <[email-masked]>
Date: Wed, 16 Jun 2021 21:57:47 -0400

it occurred to me after the meeting that there were a number of 
additional questions that should be asked:

1) How many users? 1K, 100K, 1M?

2) Is SCIM being used just for provisioning?

3) is SCIM being used for permissions?

4) Is it used for audit and compliance requirements?

FWIW

Danny

---

From: Phil Hunt <[email-masked]>
Date: Fri, 18 Jun 2021 11:57:07 -0700

+1

While we should avoid getting too detailed, I think it is useful to know:

1. A base line number of deployments (total of all surveyed)
2. Number of code implementations available (see simplecloud.info)
3. How many deployments involve multiple vendors (as in interop) and usage for user management, provisioning, or other
4. The scale of users in deployments (10,000 users to 1M+ or larger?). 
5. Adoption of SCIMv2 (vs. SCIMv1) 

This is not unlike the adoption updates we often here in other WGs like TLS.

With that said, I’m not sure it matters to the WG chartering process.  However I do think there may be an incorrect perception that SCIM is not used widely.  My informal surveys have shown otherwise.  I think to the contrary, the SCIM community has been an understated “quiet” bunch with a strong “let’s get this done” approach in the past and present.

Phil Hunt
@independentid
[email-masked]

> On Jun 16, 2021, at 6:57 PM, Danny Mayer <[email-masked]> wrote:
> 
> it occurred to me after the meeting that there were a number of additional questions that should be asked:
> 
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim