Subject: [Sdn] please send charter comments to the list

From: David Meyer <[email-masked]>
Date: Thu, 8 Nov 2012 09:12:36 -0800

Folks,

I want to sharpen up the charter with your ideas/comments so please send
them to the list and I'll rev the charter.

Thnx,

--dmm

---

From: Sharon <[email-masked]>
Date: Fri, 9 Nov 2012 11:23:16 -0800

Suggest the following:

"At the same time network control plane has experienced dramatically slower evolution. In fact, configuring and managing networks continues to be about network element operations (as opposed to network services)."

At the same time network control plane has been slower to evolve for key inherit reasons:

- Control planes had been traditionally anchored on the notion of a network interface as the touch point for setting up forwarding plane operations. This pattern is proving to be less practical as means for instantiating network connectivity services since end-point mobility of both clients and servers is becoming the norm rather then the exception. Controls are therefore need to be put in place instantly wherever end-points "show up".

- Control planes assumed that forwarding operations can be applied either for switching packets in a connectionless service or for switching circuits in a connection oriented service. The evolution of silicon however now allows for the programming of flows at the forwarding plane as means of describing network conversations. Such definitions are much closer means of describing a service, but can still be based on connectionless packet forwarding without the scale and dynamics constraints of circuit switching.

- Control plane designs had to follow one of two patterns, either globally aware but centralized and therefore limited as far as scale and dynamics, or distributed, dynamic, scalable, autonomous, and self-healing, but only locally aware. New software control design patterns in domains such as search and indexing of data have tout us its possible to achieve both global awareness and resilient distribution by making topology efficiency requirements more lenient. Hence placing more pressure on local switching for achieving global and elastic efficiencies.

On Nov 8, 2012, at 9:12, David Meyer <[email-masked]> wrote:

Folks,

I want to sharpen up the charter with your ideas/comments so please send them to the list and I'll rev the charter.

Thnx,

--dmm

_______________________________________________
sdn mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/sdn

---

From: Russ White <[email-masked]>
Date: Sat, 10 Nov 2012 21:35:09 -0500

One thing I think we need to do is add a piece about building a taxonomy
of possible SDN solutions, so we can get our arms around this space. For
instance, is hybrid really SDN? Is IRS?

How can we know what our scope is without knowing what an SDN is? :-)

:-)

Russ

---

From: ramki Krishnan <[email-masked]>
Date: Sat, 10 Nov 2012 21:48:42 -0800

It would be worthwhile to add an item on near term and long term SDN use cases across all vertical markets.

Thanks,
ramki

From: [email-masked] [mailto:[email-masked]] On Behalf Of David Meyer
Sent: Thursday, November 08, 2012 9:13 AM
To: SDN IRTF list
Subject: [Sdn] please send charter comments to the list

Folks,

Thnx,

--dmm

---

From: Scott Brim <[email-masked]>
Date: Sun, 11 Nov 2012 17:20:24 -0500

On 11/08/12 12:12, David Meyer allegedly wrote:
> Folks,
> 
> I want to sharpen up the charter with your ideas/comments so please
> send them to the list and I'll rev the charter.

Y'know, I had a number of suggested changes and then realized that what
you have here is pretty good, so I tossed them out.  Besides small
editorial tweaks like spelling, the only change I would suggest is

> Finally, the SDNRG provides objective definitions, metrics and

--> "seeks to provide".  The beginning is more chatty than I like but is
okay.  The rest, I finally decided, is Good.  I'd leave it except for a
few minor grammar changes, which I'm you'll get plenty of advice on.

Responding to other suggestions ...

> Suggest the following:

The proposed text is very long.  I would not put it in a charter (the
charter already verges on too much background info).  This text could go
in a framework draft.

On 11/10/12 21:35, Russ White allegedly wrote:>
> One thing I think we need to do is add a piece about building a
> taxonomy of possible SDN solutions, so we can get our arms around
> this space. For instance, is hybrid really SDN? Is IRS?
> 

This is covered in "investigates SDN from various perspectives with the
goal of identifying the approaches that can be defined, deployed and
used".  It's no longer possible to define something as not SDN a priori,
so let the scope of the RG be everything that someone claims is SDN (as
is stated here), and as per this charter goal, characterize it.  This is
a good contribution to clarity and knowledge.

On 11/11/12 00:48, ramki Krishnan allegedly wrote:
> It would be worthwhile to add an item on near term and long term SDN >
use cases across all vertical markets.

True, but I suspect that's also already covered in that paragraph.  I
don't like RG charters that get too detailed on outputs, as long as
their scope of activity is defined.  RGs should be very flexible.

Scott

---

From: Sharon <[email-masked]>
Date: Sun, 11 Nov 2012 21:11:55 -0800

>charter already verges on too much background info).  This text could go

Think you are right.
Is someone drafting a framework?
The LISP one is a good starting point .,
- decouples control from interfaces (good)
- misses clear support for flows at the edges
- and misses a more proactive global SW control then DNS

On Nov 11, 2012, at 14:20, Scott Brim <[email-masked]> wrote:

Scott

---

From: Thomas Nadeau <[email-masked]>
Date: Mon, 12 Nov 2012 16:13:11 -0500

> instance, is hybrid really SDN? Is IRS?

	I like this idea, and was the suggestion I had made at the end of my presentation about our working on a "framework" of sorts to guide the work here. 

> How can we know what our scope is without knowing what an SDN is? :-)

	I suggest that we worry about (loosely) defining what SDN is to *this* organization (IRTF).

	--Tom

---

From: Konstantinos Pentikousis <[email-masked]>
Date: Thu, 15 Nov 2012 15:25:58 +0000

Hi Sharon, all,

This is well put. But does it really belong to the charter?

Best Regards,

Kostas

  |-----Original Message-----
  |From: Sharon [mailto:[email-masked]]
  |Sent: Friday, November 09, 2012 8:23 PM
  |To: David Meyer
  |Cc: SDN IRTF list
  |Subject: Re: [Sdn] please send charter comments to the list
  |
  |Suggest the following:
  |
  |
  |"At the same time network control plane has experienced dramatically
  |slower evolution. In fact, configuring and managing networks continues
  |to be about network element operations (as opposed to network
  |services)."
  |
  |
  |At the same time network control plane has been slower to evolve for
  |key inherit reasons:
 
<snip>

---

From: Konstantinos Pentikousis <[email-masked]>
Date: Thu, 15 Nov 2012 15:50:00 +0000

Hi David, Scott, all,

  |> I want to sharpen up the charter with your ideas/comments so please
  |> send them to the list and I'll rev the charter.
  |
  |Y'know, I had a number of suggested changes and then realized that
  |what you have here is pretty good, so I tossed them out.  Besides small
  |editorial tweaks like spelling, the only change I would suggest is

I have some editorial suggestions, please see attached. One point to consider is that the RG should be clearly distinct from other prominent academic fora on SDN. I think this was already brought up in the meeting. In addition, the possibility to actively engage with (existing and future) IETF WGs working in the same area/direction is a distinct advantage of an RG. Currently, the IETF is listed as just another SDO.

<snip>

  |On 11/10/12 21:35, Russ White allegedly wrote:
  |> One thing I think we need to do is add a piece about building a
  |> taxonomy of possible SDN solutions, so we can get our arms around
  |> this space. For instance, is hybrid really SDN? Is IRS?
  |>
  |> How can we know what our scope is without knowing what an SDN is?
  |> :-)
  |
  |This is covered in "investigates SDN from various perspectives with
  |the goal of identifying the approaches that can be defined, deployed and
  |used".  It's no longer possible to define something as not SDN a
  |priori, so let the scope of the RG be everything that someone claims is SDN
  |(as is stated here), and as per this charter goal, characterize it.  This
  |is a good contribution to clarity and knowledge.

I second this.

Wrt the areas of interest, isn't "Classification of SDN models and their relationship to existing IETF work" more like a work item (perhaps akin to the Taxonomy already proposed) than an "area" of research?

Items 3 and 5 are interrelated and could be merged. Finally, I'm not sure why "hybrid models" are singled out. Perhaps "SDN models" is better.

Best Regards,

Kostas

---

From: David Meyer <[email-masked]>
Date: Thu, 15 Nov 2012 08:57:45 -0700

Thanks all for the comments. I will put up a new version tomorrow (or
possibly later today) after I have incorporated everyone's suggestions.

--dmm

On Thu, Nov 15, 2012 at 8:50 AM, Konstantinos Pentikousis <
[email-masked]> wrote:

> I have some editorial suggestions, please see attached. One point to
> consider is that the RG should be clearly distinct from other prominent
> academic fora on SDN. I think this was already brought up in the meeting.
> In addition, the possibility to actively engage with (existing and future)
> IETF WGs working in the same area/direction is a distinct advantage of an
> RG. Currently, the IETF is listed as just another SDO.
>
> <snip>
>
> Wrt the areas of interest, isn't "Classification of SDN models and their
> relationship to existing IETF work" more like a work item (perhaps akin to
> the Taxonomy already proposed) than an "area" of research?
>
> Items 3 and 5 are interrelated and could be merged. Finally, I'm not sure
> why "hybrid models" are singled out. Perhaps "SDN models" is better.
>
> Best Regards,
>
> Kostas
>
>
>
>