Subject: [Sdn] some comments on draft-lee-network-control-function-virtualization-01.txt

From: "Shew, Stephen" <[email-masked]>
Date: Tue, 5 Nov 2013 16:21:57 -0500

I have some comments on draft-lee-network-control-function-virtualization-01.txt that could not be made in this morning's meeting due to time constraints.

1.      In reading the I-D, it was not clear what was being virtualized.  In Network Functions Virtualization (the ETSI ISR), forwarding and network protocols are virtualized onto servers.  Virtualization in this sense is a substitution of a function running on dedicated hardware, to it running in some generic environment (e.g., data center).  In the I-D, it doesn't seem to me that this is what is meant.  That is, the location of the Client Control, VNC, or PNC, is not specified to be on generic hardware.  Instead, the resources of the transport network are being presented in different views to clients.  So what is being virtualized are transport network resources.  The software function to provide the virtualized view of the transport network resources may itself be in a virtual environment, but I don't think that's the main point of the I-D.  Some modification of the I-D title, or a description of whether the VNC is being virtualized, would be helpful.

2.      I suggest that the authors look at ITU-T Recommendations Y.1312 and Y.1313, both on L1 virtual private networks.  Clients can initiate connections to other clients in the same VPN, and VPN topology can be exposed to clients.  In talking with Young Lee this morning, he indicated that the I-D did not refer to L1 VPNs, but the distinction isn't very clear to me.  It would be helpful to explain where the I-D differs from L1 VPNs as described in Y.1312 and Y.1313 as they were written 10 years ago.

Stephen Shew | Director, Standards
[email-masked]<mailto:[email-masked]> | 3500 Carling Ave. | Ottawa CANADA K2H 8E9
Direct +1.613.670.3211

---

From: Leeyoung <[email-masked]>
Date: Wed, 6 Nov 2013 18:52:01 +0000

Hi Stephen,

Thanks for this comment. We have discussed already these questions yesterday in the side meeting. But here's my response inline for a larger audience.

Regards,
Young

From: [email-masked] [mailto:[email-masked]] On Behalf Of Shew, Stephen
Sent: Tuesday, November 05, 2013 3:22 PM
To: [email-masked]
Subject: [Sdn] some comments on draft-lee-network-control-function-virtualization-01.txt

YOUNG>> We are talking about virtual network control functions that operate on abstracted/virtual networks. We are not attempting to extending VNF concept of NFV here. We are inserting virtual control function layer on top of today's optical control plane layer to allow clients to define their virtual services in a programmable fashion. Basically transport network resources are shared across "multi-tenants" while giving clients control over their resources allocated to them.

YOUNG>> We will look into your suggested references.