Subject: Re: [Sdn] Thoughts on Defining control and Management Planes

From: Yaakov Stein <[email-masked]>
Date: Tue, 12 Nov 2013 18:08:46 +0000

> Then routed ip networks don't have a management plane

Sure they do. For example for static routes.
And of course for configuring other router functionality.

Thus in an IDR setting a management plane operation could tell a router to try to avoid a certain path
(because the peering would be expensive),
which the control plane would then respect and prefer a different route,
which the data plane packets then take.

Simple.

Also simple to discover the CAP tradeoffs that led us to do it this way.

Y(J)S

From: Russ White [mailto:[email-masked]]
Sent: 12 November, 2013 01:55
To: Yaakov Stein; 'Robert Raszuk'; 'Pedro Martinez-Julia'
Cc: 'SDN IRTF list'
Subject: RE: [Sdn] Thoughts on Defining control and Management Planes

Then routed ip networks don't have a management plane... But this is another problem with classifying these planes by there characteristics rather than their function.

What functional difference does it make how the packet gets there?

:-)

Russ
________________________________
From: Yaakov Stein<mailto:[email-masked]>
Sent: ‎11/‎11/‎2013 12:43 PM
To: Russ White<mailto:[email-masked]>; 'Robert Raszuk'<mailto:[email-masked]>; 'Pedro Martinez-Julia'<mailto:[email-masked]>
Cc: 'SDN IRTF list'<mailto:[email-masked]>
Subject: RE: [Sdn] Thoughts on Defining control and Management Planes
No, BFD is data plane.

Control plane protocols can be sent out-of-band;
would out-of-band BFD mean anything ?

Y(J)S

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Russ White
Sent: 11 November, 2013 16:31
To: 'Robert Raszuk'; 'Pedro Martinez-Julia'
Cc: 'SDN IRTF list'
Subject: Re: [Sdn] Thoughts on Defining control and Management Planes

> How would you classify BFD running between two devices ? To which
> plane in your "very clear" model does it belong ?

The control plane --it is a protocol which impacts the information used to actually forward packets. Speed doesn't matter, function does.

:-)

Russ

_______________________________________________
sdn mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/sdn

---

From: Francisco Javier Ros Muñoz <[email-masked]>
Date: Tue, 12 Nov 2013 19:45:14 +0100

Just as an exercise...

According to my proposed definition, adding a static route is a control plane operation because it decides the fate of some packets.
On the contrary, configuring an IP address is a management operation (since it configures a resource) that triggers a control plane operation (adding a routing entry that decides the fate of some packets).

Yep, I know that some of you won't like this ;-)

Best,
fran

El 12/11/2013, a las 19:08, Yaakov Stein escribió:

> From: Yaakov Stein
> To: Russ White; 'Robert Raszuk'; 'Pedro Martinez-Julia'
> Cc: 'SDN IRTF list'
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Russ White
> [email-masked]
> [email-masked]

--
Francisco J. Ros, PhD
Dept. of Information and Communications Engineering
University of Murcia, Murcia (Spain)
http://masimum.inf.um.es/fjrm/

---

From: Pedro Martinez-Julia <[email-masked]>
Date: Tue, 12 Nov 2013 20:26:24 +0100

> Yep, I know that some of you won't like this ;-)

According to functionality, and my point of view, "adding a static
route" belongs to the control plane if triggered by an operational
decision (the router does not know how to reach network XX) but it
belongs to the management plane if triggered by an administrative
decision (we want to use this link instead of the one determined by
OSPF).

As I said before, the same protocol/operation may be classified into
different planes according to the function it does.

> fran

Regards,
Pedro

-- 
Pedro Martinez-Julia
Department of Communication and Information Engineering
Faculty of Computer Science
University of Murcia
Email: [email-masked]
---------------------------------------------------------
*** Entia non sunt multiplicanda praeter necessitatem ***

---

From: Francisco Javier Ros Muñoz <[email-masked]>
Date: Tue, 12 Nov 2013 21:06:54 +0100

Hi Pedro,

My "concern" with such approach is that it adds an additional level of indirection. You still have to provide a definition for "control plane operational decisions" and "management plane administrative decisions".
In addition, it leads to function overlapping among planes. In this example, providing the next hop for a destination network might be a control plane or management plane operation... Not sure if this makes things clearer.

IMO whatever the definitions we adopt, they should draw a clear line between each pair of planes. In this way we''ll have clear interfaces.
I'm not so much concerned about function F belonging to either plane X or Y. Whatever criteria we employ that clearly determines if F is in X or not, should suffice. Obviously, we must try to come up with definitions that most people feel comfortable with (ideally they'd capture common wisdom if possible). But again, as long as they are unambiguous, we can start building upon them.

Best,
fran