Subject: [Sdn] SDNRG IETF 89 Call for Presentations

From: David Meyer <[email-masked]>
Date: Fri, 10 Jan 2014 11:05:49 -0800

SDNRG IETF 89 Call for Presentations
----------------------------------------------------------

The Software Defined Networking Research Group (SDNRG) will hold
its next meeting in conjunction with IETF 89, March 02 - 07,
2014, in London, England. The SDNRG Program Committee is now
seeking proposals for presentations for the IETF 89 agenda.

Presentations highlighting current research in Software Defined
Networking and its appplications are encouraged. Areas of
interest include (but are not limited to):

 o Classification of SDN models, including definitions and taxonomies
 o SDN model scalability and applicability
 o Multi-layer programability and feedback control systems
 o System Complexity
 o Network description languages, programming languages
   abstractions, interfaces and compilers including methods and
   mechanisms for (on-line) verification of correct operation of
   network/node function.
 o Security
 o Controller architectures
 o SDN applications programming languages,
 o SDN based network management approaches
 o SDN troubleshooting and debugging techniques

Please send proposals to [email-masked].

Thanks,

Dave & Nick

---

From: AshwoodsmithPeter <[email-masked]>
Date: Tue, 14 Jan 2014 20:25:07 +0000

Please consider this email as a proposal for a presentation on "Source Routed Make-Before-Break for Global Optimization with SDN" in IETF 89 agenda. The presentation would require approximately 20 minutes and in addition to its main material will contain a very brief recorded demo of our working prototype. 

The presentation will:

1- Discuss the impact of global optimization algorithms on traffic interruptions and the need for efficient "Make-Before-Break" mechanisms.

2- Explain the difference between implementing "Make-Before-Break" with hop by hop state v.s. source/segment routed head end only state.

3- Provides a very brief recorded 8 node demo showing an implementation of "Make-Before-Break" with source/segment routed head end only state.

4- And finally, briefly discusses a new technology idea called Protocol Oblivious Forwarding that allows very efficient new data paths, such as very low overhead source/segment routing to be implemented by an SDN controller via extended OpenFlow.

Peter Ashwood-Smith

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of David Meyer
Sent: Friday, January 10, 2014 2:06 PM
To: SDN IRTF list
Subject: [Sdn] SDNRG IETF 89 Call for Presentations

The Software Defined Networking Research Group (SDNRG) will hold its next meeting in conjunction with IETF 89, March 02 - 07, 2014, in London, England. The SDNRG Program Committee is now seeking proposals for presentations for the IETF 89 agenda.

Presentations highlighting current research in Software Defined Networking and its appplications are encouraged. Areas of interest include (but are not limited to):

 o Classification of SDN models, including definitions and taxonomies  o SDN model scalability and applicability  o Multi-layer programability and feedback control systems  o System Complexity  o Network description languages, programming languages
   abstractions, interfaces and compilers including methods and
   mechanisms for (on-line) verification of correct operation of
   network/node function.
 o Security
 o Controller architectures
 o SDN applications programming languages,  o SDN based network management approaches  o SDN troubleshooting and debugging techniques

Thanks,

Dave & Nick
_______________________________________________
sdn mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/sdn

---

From: "Diego R. Lopez" <[email-masked]>
Date: Mon, 27 Jan 2014 15:24:18 +0000

Hi,

This is to propose a presentation on the recently started NetIDE project at the coming SDNRG meeting in London. The presentation will be made by my colleague Pedro Aranda (in Cc:) who is the Technical Leader of the project.

NetIDE is intended to deliver a single integrated development environment to support the whole development lifecycle of SDN apps in a vendor-independent fashion. The NetIDE approach considers an architecture that will allow different representations to be used to program the network and different controllers to execute the network programs. The fundamental research topics in NetIDE are:
* The development of controller agnostic Network Applications (applications that control network behaviour) and Network Services (services that support the task of network controllers)
* Coss-controller debugging and profiling of network programs
* Heterogeneous network programming
* Network programming with simulators in the loop.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
-----------------------------------------

________________________________

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at:
http://www.tid.es/ES/PAGINAS/disclaimer.aspx