Subject: [Sdn] Open source or white box SDN components for research testbed.

From: Doug Montgomery <[email-masked]>
Date: Wed, 18 Mar 2015 20:58:23 -0400

I am looking to build out a SDN testbed to support local research in the
application of SDN to IoT and CPS environments.   To date we have been
working in emulated environments.

I prefer/need open source / white box platforms as we have code/algorithms
that will need to be incorporated into switches.

Support of OF1.3+, OVS 2.0,  interop w/ opendaylight, floodlight, NOX.

I am interested in several classes of devices:

1.  48 or 24 x 1GE switches.

I have been looking at the pica8 platforms.
http://www.pica8.com/white-box-switches/

Comments, or other recommendations?

2. SDN enabled Wifi APs

I am looking at Pantou (
http://archive.openflow.org/wk/index.php/OpenFlow_1.0_for_OpenWRT)

Are there other projects I should be looking at?

3.  Low port density / low power SDN switches.

~5-8 ports (I know the APs above can fit the port density bill).

Anyone have a OVS for the pi?

While research related, maybe it is better to reply to me off list if you
have comments / input on the above.
-- 
DougM

---

From: "Natale, Bob" <[email-masked]>
Date: Thu, 19 Mar 2015 05:14:11 +0000

Hi Doug,

I suspect you are already well aware of this, but just in case, have you checked the open source Open Network Operating System (ONOS) project, http://onosproject.org/?

Avanti,
BobN

From: sdn [mailto:[email-masked]] On Behalf Of Doug Montgomery
Sent: Wednesday, March 18, 2015 8:58 PM
To: [email-masked]
Subject: [Sdn] Open source or white box SDN components for research testbed.

I am looking to build out a SDN testbed to support local research in the application of SDN to IoT and CPS environments.   To date we have been working in emulated environments.

I prefer/need open source / white box platforms as we have code/algorithms that will need to be incorporated into switches.

2. SDN enabled Wifi APs

I am looking at Pantou (http://archive.openflow.org/wk/index.php/OpenFlow_1.0_for_OpenWRT)

While research related, maybe it is better to reply to me off list if you have comments / input on the above.
--
DougM

---

From: Rob Sherwood <[email-masked]>
Date: Thu, 19 Mar 2015 10:26:41 -0700

Hi Doug,

I'm assuming your looking for a switch operating system not a controller?
If so, have you seen Open Network Linux (http://opennetlinux.org)?  It's
still fairly alpha and the openflow agent is in process, but it's a Linux
distribution for bare metal switches.  Take a look at the list of supported
hardware (http://opennetlinux.org/hcl) and jump on the mailing list if this
is of interest.

HTH,

- Rob
.

On Wed, Mar 18, 2015 at 10:14 PM, Natale, Bob <[email-masked]> wrote:

>  Hi Doug,
>
>
>
> I suspect you are already well aware of this, but just in case, have you
> checked the open source Open Network Operating System (ONOS) project,
> http://onosproject.org/?
>
>
>
> Avanti,
>
> BobN
>
>
>
> *From:* sdn [mailto:[email-masked]] *On Behalf Of *Doug Montgomery
> *Sent:* Wednesday, March 18, 2015 8:58 PM
> *To:* [email-masked]
> *Subject:* [Sdn] Open source or white box SDN components for research
> testbed.
>
>
>
>
>
> _______________________________________________
> sdn mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/sdn
>
>