Subject: Re: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

From: Huub van Helvoort <[email-masked]>
Date: Tue, 05 May 2015 10:26:28 +0200

Authors:

Just to avoid any confusion: I assume this is *not* the Specification
and Description Language (SDL) described by the ITU-T in recommendations
Z.100  http://www.itu.int/ITU-T/recommendations/rec.aspx?rec=11387

Regards, Huub.

--------------

On 04-05-15 11:59, [email-masked] wrote:
>
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>
>
>          Title           : Requirements for a Service Description Language and Design Considerations
>          Authors         : Yinben Xia
>                            Sheng Jiang
>                            Susan Hares
> 	Filename        : draft-xia-sdnrg-service-description-language-02.txt
> 	Pages           : 7
> 	Date            : 2015-05-04
>
> Abstract:
>     The more and more complicated IP networks require a new interaction
>     mechanism between their customers and their networks.  A service
>     description language is needed to enable customers to easily describe
>     their diverse intent.  SDN controller would compile the user intent
>     into device configurations.  This document analyzes requirements for
>     such service description language and gives considerations for
>     designing such service description language.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-xia-sdnrg-service-description-language/
>
> There's also a htmlized version available at:
> https://tools.ietf.org/html/draft-xia-sdnrg-service-description-language-02
>
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-xia-sdnrg-service-description-language-02
>
>
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

-- 
*****************************************************************
               请记住，你是独一无二的，就像其他每一个人一样

---

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Tue, 5 May 2015 09:59:35 +0000

Appreciate your comment Huub!
Like to make a comment in a similar direction:
The draft should provide an explicit section on sth like "Inventory of existing languages" in that field, after the requirements section (clause 3) and the language design section (current clause 4) because there are already a plenty of languages in that field!
SDN is all about the control of traffic flows based on packets, i.e., all existing languages in that area a firstly applicable as "service description language" (at the southband interface).
Such kind of languages are known as  
- policy specification languages (PSL), or
- policy  expression  languages  (PEL)  or  
- filter  specification  languages  (FSL) or
- sth similar.
There are already more than 20 PSLs (to my knowldege).
The notion of "language" indicates a) a level of abstraction and b) the need for a final compilation/interpretation for its usage in a packet processing element.

The indicated examples seems to express typical configurations in such PSLs.
Thus, the draft needs a strong justification "why another language" in that field.

My cents,
Albrecht

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of Huub van Helvoort
Sent: Dienstag, 5. Mai 2015 10:26
To: [email-masked]
Subject: Re: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

Authors:

Just to avoid any confusion: I assume this is *not* the Specification and Description Language (SDL) described by the ITU-T in recommendations
Z.100  http://www.itu.int/ITU-T/recommendations/rec.aspx?rec=11387

Regards, Huub.

--------------

On 04-05-15 11:59, [email-masked] wrote:
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Draft directories: http://www.ietf.org/shadow.html or 
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

_______________________________________________
sdn mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/sdn

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 5 May 2015 19:47:03 -0400

Albrecht: 

Would it be acceptable to have a short summary in the document, and point to another document with in-depth review of these other languages? 

Sue 

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of Schwarz, Albrecht (Albrecht)
Sent: Tuesday, May 05, 2015 6:00 AM
To: [email-masked]; [email-masked]
Subject: Re: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

My cents,
Albrecht

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of Huub van Helvoort
Sent: Dienstag, 5. Mai 2015 10:26
To: [email-masked]
Subject: Re: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

Authors:

Regards, Huub.

--------------

---

From: Xiayinben <[email-masked]>
Date: Wed, 6 May 2015 01:02:28 +0000

Hi Huub,

Thanks for your information.
I roughly read the "Overview of SDL-2010"--ITU-T Z.100.

In my understanding, this draft and Z.100 have different target user and different angle of view.
Z.100 is used to describe the internal behavior of telecommunication system, its target user is telecommunication system's designer or developer.
This draft raises requirement of customer about how to describe resource requirement and outside behavior requirement of communication system. Its target user is the customer of communication system.

But Z.100 is still a good reference, thanks again for your information and hope your more comments.

Yinben

-----邮件原件-----
发件人: sdn [mailto:[email-masked]] 代表 Huub van Helvoort
发送时间: 2015年5月5日 16:26
收件人: [email-masked]
主题: Re: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

Authors:

Regards, Huub.

--------------

---

From: Xiayinben <[email-masked]>
Date: Wed, 6 May 2015 01:33:09 +0000

Hi Albrecht,

Thanks for your suggestion, we will consider your suggestion to add a section to explain the relationship with prior arts.
Here I give some quick answer to your comments.
As I reply to Huub, this draft focus on how to easily describe the intent of customer manipulating network.
The customers only want to describe the result they want to get rather than the implementation instructions. And customer's intent is not only for control the traffic but also request resource.
PSLs such as RFC2622/RFC4012 are specific instructions for routing control. They are not customer's intent.
I think it is still short of a language which can simply describe customer manipulating intent. Let's continue this discussion. Any comments are welcome.

Thanks a lot.

Yinben

-----邮件原件-----
发件人: sdn [mailto:[email-masked]] 代表 Schwarz, Albrecht (Albrecht)
发送时间: 2015年5月5日 18:00
收件人: [email-masked]; [email-masked]
主题: Re: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

My cents,
Albrecht

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of Huub van Helvoort
Sent: Dienstag, 5. Mai 2015 10:26
To: [email-masked]
Subject: Re: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

Authors:

Regards, Huub.

--------------

---

From: STUART VENTERS <[email-masked]>
Date: Wed, 6 May 2015 15:18:41 +0000

There appear to be two, separable technical issues in this draft:

1) What information is needed to represent a service request.
2) How to represent and transport the information for a request.

The first part may be a good area.

For the second part, I wonder if there are not already available methods to declare a schema and represent and transport the information governed by it.
It appears the draft is proposing to invent another mechanism.
It would be nice to understand the reasoning behind this choice.

--------------

---

From: Zhoutianran <[email-masked]>
Date: Fri, 8 May 2015 02:56:13 +0000

This is interesting. Here is my two cents.

I agree with you that there are two issues.
And for the first one, I think we need a language to easily express the service request or the user intent.

The second one is about the protocol between the controller and applications. I think we have two option.
1. One is to pass the script as content directly to the controller. And all the compilation/parsing done on the controller.
2. The other option is to parse the intent expression on the application side into some well known format, e.g. xml, json, and then transport the content to the controller.

That's what we need to discuss in the community.

Best,
Terence

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of STUART VENTERS
Sent: Wednesday, May 06, 2015 11:19 PM
To: [email-masked]
Subject: Re: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

--------------

---

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Fri, 8 May 2015 16:00:13 +0000

Terence, et al.,

firstly, the level of languages and level of protocols should be not mixed in the ietf draft.

Secondly, there are even more options:

I) Compilation/interpretation dimension:
O1: in runtime evironment
O2: in advance

II) Signalling (= protocol) dimension (with x= 1, 2):
Ox.1: policy rule explicitly signalled
Ox.2: pointer to policy rule signaled, policy rule then retrieved from a remote, central data base by enforcement element 
Ox.3: pointer to policy rule signaled, policy rule retrieved from a local data base

Furthermore:
Ox.1.1: policy rule signaled in a container, i.e., PSL syntax is different to underlying protocol syntax
Ox.1.2: policy rule signaled in native protocol syntax

Regards,
Albrecht

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of Zhoutianran
Sent: Freitag, 8. Mai 2015 04:56
To: STUART VENTERS; [email-masked]
Cc: [email-masked]
Subject: Re: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

Best,
Terence

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of STUART VENTERS
Sent: Wednesday, May 06, 2015 11:19 PM
To: [email-masked]
Subject: Re: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

--------------

---

From: Zhoutianran <[email-masked]>
Date: Tue, 12 May 2015 06:06:00 +0000

Hi Albrecht,

I agree with you on the second. There are more options. And you gave many examples.
I do not know what you mean for the first comment. Could you give more information?

Best Regards,
Terence

-----Original Message-----
From: Schwarz, Albrecht (Albrecht) [mailto:[email-masked]] 
Sent: Saturday, May 09, 2015 12:00 AM
To: Zhoutianran; STUART VENTERS; [email-masked]
Cc: [email-masked]
Subject: RE: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

Terence, et al.,

Furthermore:

Regards,
Albrecht

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of Zhoutianran
Sent: Freitag, 8. Mai 2015 04:56
To: STUART VENTERS; [email-masked]
Cc: [email-masked]
Subject: Re: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

Best,
Terence

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of STUART VENTERS
Sent: Wednesday, May 06, 2015 11:19 PM
To: [email-masked]
Subject: Re: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

--------------

---

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Wed, 13 May 2015 13:02:05 +0000

Hello Terence,

the scope of your draft covers two topics:
a) requirements for a language and
b) design aspects ("considerations") of a language.

The purpose of this draft is NOT to specify a new language in my understanding, right?

Languages for the description of (commmunication services) are of type "system design language" (using the notion of ITU-T).
(Z.119, 3.3  system design language: A formal notation that has a well-defined syntax and semantics 
that is used for some aspect of the engineering systems ranging from statements of requirements for 
procurement or in standards to the deployment of implemented systems or networks.)

These are formal languages, - whereas your draft so far seems to consider informal language style, if not, then there should be a requirement that the language should support a formal notation...

Regards,
Albrecht

PS
I would state that UML could be the solution in the end to your draft, - or are there any "service description" requirements which can't be satisfied by UML? Don't think so.

PSS
Your examples in clause 4 indicating a specific service aspect only, which fairly overlaps with policy rule control, that's why the PSL side discussion. 

-----Original Message-----
From: Zhoutianran [mailto:[email-masked]] 
Sent: Dienstag, 12. Mai 2015 08:06
To: Schwarz, Albrecht (Albrecht); STUART VENTERS; [email-masked]
Cc: [email-masked]
Subject: RE: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

Hi Albrecht,

Best Regards,
Terence

-----Original Message-----
From: Schwarz, Albrecht (Albrecht) [mailto:[email-masked]]
Sent: Saturday, May 09, 2015 12:00 AM
To: Zhoutianran; STUART VENTERS; [email-masked]
Cc: [email-masked]
Subject: RE: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

Terence, et al.,

Furthermore:

Regards,
Albrecht

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of Zhoutianran
Sent: Freitag, 8. Mai 2015 04:56
To: STUART VENTERS; [email-masked]
Cc: [email-masked]
Subject: Re: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

Best,
Terence

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of STUART VENTERS
Sent: Wednesday, May 06, 2015 11:19 PM
To: [email-masked]
Subject: Re: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

--------------

---

From: Zhoutianran <[email-masked]>
Date: Thu, 14 May 2015 16:29:37 +0000

Hi Albrecht,

Yes, you are right. This draft is not to specify a new language. There is another draft on the proposed intent expression language:
https://tools.ietf.org/html/draft-xia-sdnrg-nemo-language-02

The requirement here is acturally to have a language to express what the user want with the network.
With this description, the compiler can parse the intent and implement it with a network deployment.
I agree the UML is great for system modeling. But it is far from being excuted.
That's why we need a DSL for this.

I am really happy to discuss with you. You knowledge on policy and language would really help on this requirement draft.

Best,
Tianran
________________________________________
发件人: Schwarz, Albrecht (Albrecht) [[email-masked]]
发送时间: 2015年5月13日 21:02
收件人: Zhoutianran; STUART VENTERS; [email-masked]
抄送: [email-masked]
主题: RE: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

Hello Terence,

Regards,
Albrecht

PS

PSS

-----Original Message-----
From: Zhoutianran [mailto:[email-masked]]
Sent: Dienstag, 12. Mai 2015 08:06
To: Schwarz, Albrecht (Albrecht); STUART VENTERS; [email-masked]
Cc: [email-masked]
Subject: RE: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

Hi Albrecht,

Best Regards,
Terence

-----Original Message-----
From: Schwarz, Albrecht (Albrecht) [mailto:[email-masked]]
Sent: Saturday, May 09, 2015 12:00 AM
To: Zhoutianran; STUART VENTERS; [email-masked]
Cc: [email-masked]
Subject: RE: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

Terence, et al.,

Furthermore:

Regards,
Albrecht

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of Zhoutianran
Sent: Freitag, 8. Mai 2015 04:56
To: STUART VENTERS; [email-masked]
Cc: [email-masked]
Subject: Re: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

Best,
Terence

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of STUART VENTERS
Sent: Wednesday, May 06, 2015 11:19 PM
To: [email-masked]
Subject: Re: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

--------------

---

From: Xiayinben <[email-masked]>
Date: Fri, 15 May 2015 00:42:24 +0000

Hi Albrecht,

You are right, this draft is focus on the requirement that simplify to describe user's intent of manipulating network. 
I think a language, especially DSL(domain specific language), is user friendly way to describe user's intent. So we suggest to use a description language in this draft.
The example in this draft is using to illustrate user's intent rather than language design.

We have another draft is focus on the language design, https://tools.ietf.org/html/draft-xia-sdnrg-nemo-language-02. I hope you are interesting too. And we are looking forward to your comments. 
As you indicated, policy is in form of "if conditions then actions". It always be used in response to some change situation. But most time user has direct command to do something, e.g. provisioning a virtual network. So I think policy is a part of description language for user's intent, but it is not all.

Best regards,
Yinben 

-----邮件原件-----
发件人: sdn [mailto:[email-masked]] 代表 Schwarz, Albrecht (Albrecht)
发送时间: 2015年5月13日 21:02
收件人: Zhoutianran; STUART VENTERS; [email-masked]
抄送: [email-masked]
主题: Re: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

Hello Terence,

Languages for the description of (commmunication services) are of type "system design language" (using the notion of ITU-T).
(Z.119, 3.3  system design language: A formal notation that has a well-defined syntax and semantics that is used for some aspect of the engineering systems ranging from statements of requirements for procurement or in standards to the deployment of implemented systems or networks.)

Regards,
Albrecht

PS

PSS

-----Original Message-----
From: Zhoutianran [mailto:[email-masked]]
Sent: Dienstag, 12. Mai 2015 08:06
To: Schwarz, Albrecht (Albrecht); STUART VENTERS; [email-masked]
Cc: [email-masked]
Subject: RE: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

Hi Albrecht,

Best Regards,
Terence

-----Original Message-----
From: Schwarz, Albrecht (Albrecht) [mailto:[email-masked]]
Sent: Saturday, May 09, 2015 12:00 AM
To: Zhoutianran; STUART VENTERS; [email-masked]
Cc: [email-masked]
Subject: RE: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

Terence, et al.,

Furthermore:

Regards,
Albrecht

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of Zhoutianran
Sent: Freitag, 8. Mai 2015 04:56
To: STUART VENTERS; [email-masked]
Cc: [email-masked]
Subject: Re: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

Best,
Terence

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of STUART VENTERS
Sent: Wednesday, May 06, 2015 11:19 PM
To: [email-masked]
Subject: Re: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

--------------

---

From: Xiayinben <[email-masked]>
Date: Fri, 15 May 2015 00:52:22 +0000

Hi Albrecht,

After I send my response, I found Tianran also response you. 
I hope this will make you more interesting in this topic :-)

Best regards,
Yinben

-----邮件原件-----
发件人: Ibnemo [mailto:[email-masked]] 代表 Zhoutianran
发送时间: 2015年5月15日 0:30
收件人: Schwarz, Albrecht (Albrecht); STUART VENTERS; [email-masked]
抄送: [email-masked]
主题: Re: [Ibnemo] [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

Hi Albrecht,

Best,
Tianran

Hello Terence,

Regards,
Albrecht

PS

PSS

-----Original Message-----
From: Zhoutianran [mailto:[email-masked]]
Sent: Dienstag, 12. Mai 2015 08:06
To: Schwarz, Albrecht (Albrecht); STUART VENTERS; [email-masked]
Cc: [email-masked]
Subject: RE: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

Hi Albrecht,

Best Regards,
Terence

-----Original Message-----
From: Schwarz, Albrecht (Albrecht) [mailto:[email-masked]]
Sent: Saturday, May 09, 2015 12:00 AM
To: Zhoutianran; STUART VENTERS; [email-masked]
Cc: [email-masked]
Subject: RE: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

Terence, et al.,

Furthermore:

Regards,
Albrecht

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of Zhoutianran
Sent: Freitag, 8. Mai 2015 04:56
To: STUART VENTERS; [email-masked]
Cc: [email-masked]
Subject: Re: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

Best,
Terence

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of STUART VENTERS
Sent: Wednesday, May 06, 2015 11:19 PM
To: [email-masked]
Subject: Re: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

--------------

_______________________________________________
sdn mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/sdn
_______________________________________________
sdn mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/sdn
_______________________________________________
sdn mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/sdn
_______________________________________________
Ibnemo mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ibnemo

---

From: Xiayinben <[email-masked]>
Date: Thu, 21 May 2015 12:54:15 +0000

Hi Albrecht,

I think you are right. This draft should focus on the requirement and the information which need to describe a service request.
Because Intent is a new philosophy to design network interface. I think it need several drafts to discuss it from different points. Maybe in the future, there should be a working group to cover these topics. So we establish this mail list for detail technical discussion. 
https://www.ietf.org/mailman/listinfo/ibnemo

It seems you interested in this topic and you have lots of related experience as well. It is appreciated if you have any suggestion about the discussion points or how to structure the topics.

Best regards,
Yinben 

-----邮件原件-----
发件人: Ibnemo [mailto:[email-masked]] 代表 Schwarz, Albrecht (Albrecht)
发送时间: 2015年5月9日 0:00
收件人: Zhoutianran; STUART VENTERS; [email-masked]
抄送: [email-masked]
主题: Re: [Ibnemo] [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

Terence, et al.,

Furthermore:

Regards,
Albrecht

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of Zhoutianran
Sent: Freitag, 8. Mai 2015 04:56
To: STUART VENTERS; [email-masked]
Cc: [email-masked]
Subject: Re: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

Best,
Terence

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of STUART VENTERS
Sent: Wednesday, May 06, 2015 11:19 PM
To: [email-masked]
Subject: Re: [Sdn] I-D Action: draft-xia-sdnrg-service-description-language-02.txt

--------------