Subject: RE: [Seamoby] Dormant Mode Location Tracking by Mobility Protocol Issues

From: [email-masked]
Date: Thu, 28 Feb 2002 12:13:05 -0600

Bechet,
 
I understood that if IP Paging is an IP layer protocol then we have to define different protocols (simple IPv4, simple IPv6, mobile IPv4 and mobile IPv6 based IP Paging, although we should de-emphasize the need of paging in simple IP). But if we put the paging protocol as an application layer protocol, then to trigger paging for another application you need to define another paging application layer protocol. Is it what we want?
 
Best Regards,

Rene Purnadi 
Phone: +1 972.894.4897 
Mobile: +1 972.342.3503 
e-mail: [email-masked] 

-----Original Message-----
From: ext Behcet Sarikaya [mailto:[email-masked]]
Sent: Thursday, February 28, 2002 10:22 AM
To: [email-masked]
Subject: Re: [Seamoby] Dormant Mode Location Tracking by Mobility Protocol Issues

In case of SIP based paging, the MH does dormant mode registrations to the SIP servers. SIP servers take part in doing the paging (finding the MH) and then forward SIP Invite message.

The mechanism of paging as described in the paper I mentioned is very similar to  what we defined in draft-sarikaya or draft-guri.

The point here is that the trigger is SIP Invite message which means the application layer header should be processed in order to trigger the paging.

Therefore if you want to trigger paging for another application you need to define it in another application layer protocol.

However if paging is defined as IP layer protocol, the paging will be automatically triggered looking into IP header. This requires the paging infrastructure setup independent of any application, using paging protocol entities.

Note that similar arguments exist for Mobile IP. Terminal mobility can be handled at the application layer, like SIP based terminal mobility described in Henning's paper. Again what is done is in fact very similar to Mobile IP operation. 

These are very well known facts on layering, surprising how some find it confusing.

Rene,the issue here is, if IP Paging is an IP layer protocol then we have define for different protocols (simple IPv4 simple IPv6 mobile IPv4 and mobile IPv6 based IP Paging). All of these are independent of any application. This is the issue.

Regards,

[email-masked] wrote:

Hi Yoshi and Bechet,

I agree with Yoshi, IP Paging should be defined independent of any existing application layer protocol such as SIP. The packet containing the SIP Invite message could be just a trigger for the IP paging.

Best Regards,
Rene Purnadi
Phone: +1 972.894.4897
Mobile: +1 972.342.3503
e-mail:  [email-masked]

-----Original Message-----
From: ext Yoshihiro Ohba [ mailto:[email-masked]]
Sent: Wednesday, February 27, 2002 7:09 PM
To: Behcet Sarikaya
Cc: Yoshihiro Ohba;  [email-masked]
Subject: Re: [Seamoby] Dormant Mode Location Tracking by Mobility
Protocol Issues

On Wed, Feb 27, 2002 at 06:23:03PM -0600, Behcet Sarikaya wrote:

Hi Yoshi,
I just saw a paper entitled Application Layer Mobility Using SIP by
Schulzrinne in which as part of SIP which is an application layer
protocol a paging protocol is very shortly described. Paging is used to
alert the mobile host in dormant mode in order to forward SIP Invite
request.
You can certainly define such things for specific applications but then
for each application, another paging protocol will have to be defined.
In the same paper mobility is defined for SIP not using Mobile IP.

Maybe now you will be convinced where IP Paging should be placed in
layering.

Not yet.

As long as IP Paging is defined as a separate protocol which is
independent of any existing application layer protocol such as SIP, it
logically does not matter whichever layer it is defined and thus
defining IP paging in application layer is also valid in this regard.
There must be other factors to determine the layer where IP paging is
defined.

Yoshihiro Ohba

--behcet

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 28 Feb 2002 15:22:36 -0600

Rene,

[email-masked] wrote:

>Bechet,
> 
>I understood that if IP Paging is an IP layer protocol then we have to define different protocols (simple IPv4, simple IPv6, mobile IPv4 and mobile IPv6 based IP Paging, although we should de-emphasize the need of paging in simple IP). 
>
Agreed.

>But if we put the paging protocol as an application layer protocol, then to trigger paging for another application you need to define another paging application layer protocol. Is it what we want?
> 
>Best Regards,
>
>
>Rene Purnadi 
>Phone: +1 972.894.4897 
>Mobile: +1 972.342.3503 
Of course not.

--bechet

---

From: Yoshihiro Ohba <[email-masked]>
Date: Thu, 28 Feb 2002 17:02:07 -0500

> I understood that if IP Paging is an IP layer protocol then we have to define different protocols (simple IPv4, simple IPv6, mobile IPv4 and mobile IPv6 based IP Paging, although we should de-empha…

Are there any particular reason for de-emphasizing the need of DMHA
for simple-ip?  I think the reason for using the word "DMHA" instead
of "IP paging" is as a result of consideration of dormant simple-ip
hosts as well as dormant mobile hosts.  We should also consider 
simple-ip for the reason as I mentioned earlier.

> But if we put the paging protocol as an application layer protocol, then to trigger paging for another application you need to define another paging application layer protocol. Is it what we want?

I don't understand why we need another paging apllication layer protocol 
if we put the paging protocol as an application layer protocol.  

Yoshihiro Ohba