Subject: [Seamoby] Comment on CAR requirements

From: [email-masked]
Date: Thu, 14 Feb 2002 13:14:28 -0500

Hi all,

I've got a comment regarding requirement 3.9

Just for recalling:
---------
3.9. DEPENDENCE ON A MOBILITY MANAGEMENT PROTOCOL

CAR discovery MUST NOT depend on a particular mobility management
protocol. In other words, it MUST NOT utilize a feature which is unique
to a particular mobility management protocol. The output of CAR
discovery, however, MUST be usable by mobility management protocols. CAR
discovery MUST NOT deteriorate the performance of the underlying
mobility management protocol.
---------

In the second sentence, shouldn't it be '...it MUST NOT depend on a feature which is
unique...' rather than 'utilize'? Here's my thought:
Assuming a CAR solution that has an MIPV6 mode and a non-MIPV6 mode, and maybe a mixed
mode. The first one specifically utilizes MIPV6 if possible to implement CAR efficiently.
If the environment were non-MIPV6 (or we have a mixed environment in the sense
that some of the neighbors are MIPV6, the others are not), the non-MIPv6 or the mixed mode 
are used. This should be a viable, albeit probably rather complex, solution, shouldn't it?

However, the solution must not depend on this feature in the sense that it does not
work if the specific MM feature is not present, i.e., the other non-MIPV6 nodes are
simply not discovered. That's how I understood the dependence titel of this requirement. 

Any comments?

Dirk

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "James Kempf" <[email-masked]>
Date: Thu, 14 Feb 2002 11:16:41 -0800

Dirk,

> simply not discovered. That's how I understood the dependence titel of
this requirement.

Well, I suppose if you want to be precise, you have a point.

            jak