Subject: RE: [Seamoby] Deadline Approaching: WG Last Call for Paging Assessment Draft

From: [email-masked]
Date: Tue, 26 Feb 2002 19:42:41 -0600

I feel that using DMHA for packet filtering is an inappropriate use. This also requires that the Paging Function to determine different kinds of packets. A better way for packet filtering must be an application level functionality, we should use application (or services) level differentiation on what services are enabled when the device/host is in a certain mode (not necessarily dormant).  IMPP WG is working on presence services which will be more suitable for such differentiation.  The important requirement for DMHA is power saving (for power starving devices). Frequent mobility updates drains power and hence, DMHA.

The importance should be on mobillity. we should not support the simple-ip case just because it is easy.

Regards

-----Original Message-----
From: ext Yoshihiro Ohba [mailto:[email-masked]]
Sent: 26 February, 2002 7:24 PM
To: Sreemanthula Srinivas (NRC/Dallas)
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Seamoby] Deadline Approaching: WG Last Call for Paging Assessment Draft

DHMA for simple-ip is needed for office and home environments
especically for the purpose of filtering unimportant packets while a
host is dormant, and different filtering rule should be able to be
applied to different hosts.  I don't understand why we should not
support easier case (supporting DMHA for simple-ip hosts is much
easier than supporting DMHA for mobile hosts).

Yoshihiro Ohba

In-Reply-To: <[email-masked]>

On Tue, Feb 26, 2002 at 06:21:24PM -0600, [email-masked] wrote:
> I agree with Theo that no single draft qualifies as a base proposal on it's own. But, rewriting individual proposals and reevaluating will leave us again in the same situation as before, wasting valuable time.  Instead, we can speed up things by converging what we have and improvising on the common solution. 
> 
> I ask the WG to rethink if we actually need paging for simple-ip cases. I posed this question before, from lack of responses, I see that no one seems to have interest in it. Now, the WG should put more importance on the mobility requirement (4.8). 

> 
> With emphasis on mobility, draft-renker does not have a better solution than others. As a matter of fact (also as the  draft-renker evaluator), I can comment that it falls short of complete description of the protocol behaviour in the implicit (mipv6) mode. Therefore, the best approach would be to choose the strongest mobility based proposals and combine them into one single proposal. 
> 
> Thanks,
> Srini
> 
> -----Original Message-----
> From: ext Theo Pagtzis [mailto:[email-masked]]
> Sent: 26 February, 2002 4:41 PM
> To: Vinod Kumar Choyi
> Cc: Sreemanthula Srinivas (NRC/Dallas); [email-masked]
> Subject: Re: [Seamoby] Deadline Approaching: WG Last Call for Paging
> Assessment Draft
> 
> 
> Hello all,
> 
> May I suggest that I would find personally unfair to go ahead with a
> selection of a single solution since _none_ was satisfying in absolute
> terms specific marks required for a weighted consideration as an WG
> item. I personally stated the following in the evaluation team which I
> would just reiterate: at this stage no protocol must be selected amongst
> all. Having read all drafts I feel that none is fittest than another. I
> am also talking as an evaluator that has no interest in any of them in
> terms of selection. Right now the authors of the drafts needed to go
> back on their drawing board and consider the comments that the
> evaluation team gave (hence the output draft). The authors must rework
> their solutions in the light of these comments.
> 
> A last round of evaluation must then be carried out by the same team
> since it already has the initial view of the problem. A final decision
> must be taken past the last changes and amendments of the DHMA protocol
> solutions, which must not be disputed by anybody under objective
> criteria and no arguments against the evaluators that they missed this
> or did not see that. 
> 
> The results from the review would then come up as a revised draft and in
> public scrutiny to the interested individuals that must be considered
> objectively (no company hats) if we ever want to see something moving
> forward. If the results from the criteria pass a last call from the
> community then the chair will announce the protocol that dominates
> overall in marks. Then we proceed and take it further.
> 
> Alternatively the authors of the draft get together and they build a
> single protocol by unifying the concepts that the evaluation team found
> to stand out from each proposal. The authors converge and bring their
> elements together in a single solution that is decided if to be
> independent of any mobility protocol or not.
> 
> The chair declares a concensus on the matter, a single protocol is
> defined and considered an WG item. 
> 
> We can then proceed in peace and evolution of the DHMA solution.
> 
> Please consider..
> 
> 
> regards
> 
> Theo
> UCL/Mobile Systems
> 
> Vinod Kumar Choyi wrote:
> > 
> > Srinivas,
> > 
> > Mobile devices  (that do not have any home or do not use MIP)could
> > also use just Simple IP, but I agree with you that the emphasis should
> > be more on mobility.
> > 
> > regards
> > vinod
> > 
> > [email-masked] wrote:
> > 
> > > Bechet,
> > > You are stretching your interpretation of my mail and presenting as
> > > my views.
> > > 1. There may be a solution that fits all. I am not against it. But
> > > who wants to use simple-ip? "Independence to mobility protocol" was
> > > a key point in decision making, as indicated in the
> > > paging-assessment draft.  Paging protocol is most likely will always
> > > be used with mobile devices, hence the successful and wide
> > > acceptance of paging protocol depends on a solution that takes more
> > > of mobility into consideration. Sacrificing this point may well make
> > > the final paging protocol not so useful, at best.
> > > 2. I am not particularly inclined for HA based solutions. My point
> > > is, while defining a mobility based paging protocol we should not
> > > take a particular LMM method (for e.g. HMIPv6) as  solution, like
> > > draft-sarikaya. But instead a generalised LMM approach. HA based
> > > solution will also be needed for non-LMM cases.
> > > Srini
> > > -----Original Message-----
> > > From: e
> > > xt Behcet Sarikaya [mailto:[email-masked]]
> > > Sent: 25 February, 2002 9:32 AM
> > > To: [email-masked]
> > > Subject: Re: [Seamoby] Deadline Approaching: WG Last Call for Paging
> > > Assessment Draft
> > > Dear all,
> > >   Several mails have been sent over the weekend I'll try to give my
> > > views in one mail.
> > > Regarding Srinivas' email, my understanding is that he is against
> > > Alternative 1 (one size fits all solution) and he is for the
> > > Alternative
> > > 2. In that he is suggesting that we concentrate on Requirement 4.8
> > > rather than 4.7. As for the drafts, he seems to be inclined to home
> > > agent based architectures which is demonstrated in draft-renker.
> > > This is
> > > an architectural choice, I think that his choice of alternatives is
> > > clear.
> > >   Besides, I think that the chairs would like to choose draft/drafts
> > > a
> > > s
> > > soon as possible and ask people to submit their 01 drafts by March
> > > 1st
> > > and move on. We do not have a lot of time for doing this.
> > > Regarding Yoshi's email, I am quoting the abstract of RFC 3103:
> > >
> > >> This document presents a protocol with which to implement Realm
> > >>    Specific IP (RSIP).  The protocol defined herein allows
> > >> negotiation
> > >>    of resources between an RSIP host and gateway, so that the host
> > >> can
> > >>    lease some of the gateway's addressing parameters in order to
> > >>    establish a global network presence.  This protocol is designed
> > >> to
> > >>    operate on the application layer and to use its own TCP or UDP
> > >> port.
> > >>    In particular, the protocol allows a gateway to allocate
> > >> addressing
> > >>    and control parameters to a host such that a flow policy can be
> > >>    enforced at the gateway.
> > >>
> > > Yoshi, I think that the functionalities summarized above of RSIP
> > > have
> > > nothing to do with IP Paging. Can we define a port specific to  IP
> > > Paging , if yes then how does IP Paging capture all packets to the
> > > dormant hosts?
> > > Added to this, please see Pars' email,
> > >
> > >> This is serious, because "paging" which is intended for
> > >> optimizing bandwidth use, may become a bandwidth threat.
> > >> IP layer solutions may be necessary. This is, perhaps, one more
> > >> motivation for IP paging.
> > >>
> > > Let us get motivated for IP Paging.
> > > Regards,
> > > [email-masked] wrote:
> > >
> 
> _______________________________________________
> Seamoby mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/seamoby
> 

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: Yoshihiro Ohba <[email-masked]>
Date: Tue, 26 Feb 2002 22:56:23 -0500

Hello Srini,

You seem to misunderstand something.  What I'm talking about is packet
filtering for DMHA, which is completely different from "DHMA for
packet filtering." and from instant messaging.  The goal of packet
filtering for DMHA is definitely for power saving.

Yoshihiro Ohba

---

From: "James Kempf" <[email-masked]>
Date: Wed, 27 Feb 2002 08:44:47 -0800

I agree with Srini on this.

            jak

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, February 26, 2002 5:42 PM
Subject: RE: [Seamoby] Deadline Approaching: WG Last Call for Paging
Assessment Draft

> I feel that using DMHA for packet filtering is an inappropriate use.
This also requires that the Paging Function to determine different kinds
of packets. A better way for packet filtering must be an application
level functionality, we should use application (or services) level
differentiation on what services are enabled when the device/host is in
a certain mode (not necessarily dormant).  IMPP WG is working on
presence services which will be more suitable for such differentiation.
The important requirement for DMHA is power saving (for power starving
devices). Frequent mobility updates drains power and hence, DMHA.
Assessment Draft
> In-Reply-To:
<[email-masked]>
> > I agree with Theo that no single draft qualifies as a base proposal
on it's own. But, rewriting individual proposals and reevaluating will
leave us again in the same situation as before, wasting valuable time.
Instead, we can speed up things by converging what we have and
improvising on the common solution.
> >
> > I ask the WG to rethink if we actually need paging for simple-ip
cases. I posed this question before, from lack of responses, I see that
no one seems to have interest in it. Now, the WG should put more
importance on the mobility requirement (4.8).
>
> >
> > With emphasis on mobility, draft-renker does not have a better
solution than others. As a matter of fact (also as the  draft-renker
evaluator), I can comment that it falls short of complete description of
the protocol behaviour in the implicit (mipv6) mode. Therefore, the best
approach would be to choose the strongest mobility based proposals and
combine them into one single proposal.