Subject: RE: [Seamoby] Dormant Mode Location Tracking by Mobility Protocol Issues

From: "Pat R. Calhoun" <[email-masked]>
Date: Fri, 22 Feb 2002 18:46:44 -0800

>> Hope you agree with the above.
>
>Not yet.  I have a counter example.  Realm-Specific IP (RFC3103),
>which is a NAT technology, defines  an application layer protocol
>for controlling a NAT box, while actual data packet transfer through
>the  NAT box is version dependent.

RFC 3103 is an experimental protocol. Whether or not it sees the
light of day is unknown. Further, why are we worried about supporting
NAT?

PatC

---

From: Yoshihiro Ohba <[email-masked]>
Date: Fri, 22 Feb 2002 22:18:36 -0500

This is just for showing an example of a protocol that does not 
have separate specficications for IPv4 and IPv6.  
There is no other intention.  

Yoshihiro Ohba

On Fri, Feb 22, 2002 at 06:46:44PM -0800, Pat R. Calhoun wrote:
>  
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> -----BEGIN PGP SIGNATURE-----
> Version: PGPfreeware 7.0.3 for non-commercial use <http://www.pgp.com>
> 
> iQA/AwUBPHcCkzN1fXKoxmisEQL7LACgnUrBt4amoj9+xkm5pBtP3opVFT0AoOob
> Y9ZVkCIWwXX2X3qk0AsnWq19
> =3AiD
> -----END PGP SIGNATURE-----

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "James Kempf" <[email-masked]>
Date: Mon, 25 Feb 2002 08:38:54 -0800

Pat,

> light of day is unknown. Further, why are we worried about supporting

I believe that Yoshi was saying that RSIP is an example of a protocol
where the same protocol can run over both IPv4 and IPv6. If paging
could do this too, we would not need two version of the paging protocol.
I don't believe he was advocating supporting NAT.

W.r.t the point that came up in the original note about MIPv6 using
IP headers for BU/BAck, it is worthwhile investigating, but there
are some fairly severe implementation difficulties with using header
options.
For example, the HUT Linux implementation of MIPv6 does not
give application programs access to the BU/BAck information,
it is only accessable to the kernel. Erik Nordmark wrote a draft
a while back advocating getting rid of header options in MIPv6
for the Home Address Option and BU/BAck and instead using
Deering-Zill tunnels. Due to the maturity of MIPv6 implementations,
this is not possible, but his technical arguments were good, so
I think we should probably have equal or better technical arguments
if we want to use header options for paging.

            jak

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 25 Feb 2002 11:51:09 -0600

Jim,
  An IP level IP Paging protocol must be implemented as a kernel mode 
program like HUT Mipv6 implementation (I think now it is called MIPL). 
Sometimes user level implementations are also tried.
  In fact about a year ago we had tried to prototype an earlier version 
of draft-sarikaya extending MIPL. The (undergraduate) students had 
failed because MIPL at that time was not allowing sub-options to be 
defined with binding updates.
  MIPv4/v6 based IP Paging can easily be implemented extending present 
implementations, this was the conclusion of our project. In fact there 
are other prototyping efforts documented in literature.

  Hope this helps,

>if we want to use header options for paging.
behcet