Subject: RE: [Seamoby] Dormant Mode Location Tracking by Mobility Protocol Issues

From: [email-masked]
Date: Thu, 28 Feb 2002 17:11:57 -0600

>>Are there any particular reason for de-emphasizing the need of DMHA
for simple-ip?  I think the reason for using the word "DMHA" instead
of "IP paging" is as a result of consideration of dormant simple-ip
hosts as well as dormant mobile hosts.  We should also consider 
simple-ip for the reason as I mentioned earlier.

Yes. When we talk about about simple-ip, we mean static hosts that are plugged into the power source which don't have any mobility built in them. Therefore, they don't require any dormancy. Please remember the first requirement for DMHA is to save power for lean terminals running on limited power (mobile, ofcourse). Now, can you exactly tell why we need DMHA for simple-ip?

>>I don't understand why we need another paging apllication layer protocol 
if we put the paging protocol as an application layer protocol. 

If we leave the simple-ip out (as we should),  it is only natural that paging protocol makes as an extension to the existing mobility protocol(s).  As of now, the applications (or application servers) are not aware of the mobility of the hosts.  For the same reason, paging protocol must be independent of the application layers above. 

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: Yoshihiro Ohba <[email-masked]>
Date: Thu, 28 Feb 2002 19:30:24 -0500

> Yes. When we talk about about simple-ip, we mean static hosts that are plugged into the power source which don't have any mobility built in them. Therefore, they don't require any dormancy. Please…

Why do you exclude a simple-ip host that is not plugged into the power
source?

Moreover, why should we ignore power saving for plugged-in hosts?

DMHA for simple-ip is required for stationary dormant hosts not to 
spend power (battery or plugged-in power) for processing unimportant 
packets (thus filtering trigger packets is necessary for DMHA).

> If we leave the simple-ip out (as we should),  it is only natural that paging protocol makes as an extension to the existing mobility protocol(s).  As of now, the applications (or application serve…

Now one important requirement is going to be compromized, 
independence of any mobility management protocol.  I disagree.

Yoshihiro Ohba

---

From: Vinod Kumar Choyi <[email-masked]>
Date: Thu, 28 Feb 2002 20:32:24 -0600

Instead of the term Simple IP we could say: Hosts that do not use MIP,
they could be wireless or fixed. I do not think we should completely
ignore paging support for these hosts.
Having a design such that paging entities and their interactions are
within a local network (Foreign network takes care of paging when MN is
in a visited network and Home network takes care of paging when MN is at
home) could provide a solution for both MIP hosts and Simple IP hosts
(do not use MIP).
The MAIN difference (not the only difference) between Simple IP service
and MIP service is the involvement of Home Agent (Home network, AAAH
etc), so if we were to avoid anything to do with Home we could have a
BASE solution that supports both hosts. To me, that BASE solution should
be Home - Independent.
To have optimized solutions (whatever OPTIMIZED means), we would need to
use the base solution to come up with a solutions for Simple IP, MIPv4
and MIPv6.

regards
vinod