Subject: RE: [SeaMoby] Topic #2:Do we need a server for CARD

From: [email-masked]
Date: Wed, 12 Mar 2003 16:07:01 -0500

Hi James,

I'm surprised to suddenly see AP authentication in the scope of CAR discovery. Where does this change of
scope come from? If a network operator requires AP authentication for each AR, network management
tools can be used to download the list of APs to the AR. I don't see anything in the issue draft putting 
this on the table of CAR discovery (we would have called it CAR and local AP discovery then).

So if you want to address this, let's define MIB entries and push mechanisms to download said AP entries to 
the AR MIB, and we're done. 

Dirk

>-----Original Message-----
>From: ext James Kempf [mailto:[email-masked]]
>Sent: Wednesday, March 12, 2003 3:58 PM
>To: Chaskar Hemant (NRC/Boston); [email-masked]; [email-masked]
>Subject: Re: [SeaMoby] Topic #2:Do we need a server for CARD
>
>
>No disconnect.
>
>My point was, this is a deficiency with both drafts. It is an 
>issue we need to
>resolve before we can consider the design complete.
>
>            jak
>
>----- Original Message -----
>From: <[email-masked]>
>To: <[email-masked]>; <[email-masked]>; 
><[email-masked]>
>Sent: Wednesday, March 12, 2003 12:22 PM
>Subject: RE: [SeaMoby] Topic #2:Do we need a server for CARD
>
>
>> Hi:
>>
>> There seems to be some disconnect. The current DT draft does 
>NOT intend solve
>the problem of enabling AR to determine which APs are 
>authorized. APs are
>brought up/down and connected to/disconnected from AR. Some L2 
>layer mechanism
>between AR-AP enables AR to learn about new/removed AP. AR 
>reports that AP is
>up/down to CARD server and CARD server stores the mapping. In 
>other words, AR is
>in control of knowing what APs are attached to it and CARD 
>server relies on
>information provided by AR regarding this.
>>
>> Hemant
>>
>> -----Original Message-----
>> From: ext Eunsoo Shim [mailto:[email-masked]]
>> Sent: Wednesday, March 12, 2003 4:48 PM
>> To: James Kempf; [email-masked]
>> Subject: Re: [SeaMoby] Topic #2:Do we need a server for CARD
>>
>>
>>
>>
>> > The server will allow an AR to determine which APs are 
>authorized. The
>> dycard
>> > draft has nothing about this. This is an important 
>security measure,
>> though not
>> > directly related to exchanging the CAR information.
>> >
>> [eunsoo] The routing protocol (for the wired Internet) has a similar
>> problem. They want to know whether a router is authorized to 
>participate in
>> the route discovery. So for intra-domain routing protocols, 
>usually shared
>> secret is proposed. Also Dycard assumes it in the expression 
>that there
>> should be a security association between ARs. If we consider only
>> intra-domain communication between ARs, shared secret would 
>be sufficient
>> for authorization and message authentication. If you 
>consider central NMS
>> system that allows remote configuration of ARs, it would be 
>very easy to
>> configure the shared secret among ARs. If there is no such 
>thing, people do
>> the configuration by remotely logging into ARs. This one 
>time configuration
>> removes concerns about scalability and reliability. You 
>don't need a server
>> running up 24/7 for this authorization since you don't 
>expect a new AR that
>> often.
>>
>> Eunsoo
>>
>> _______________________________________________
>> Seamoby mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/seamoby
>>
>>
>
>_______________________________________________
>Seamoby mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/seamoby
>
_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "James Kempf" <[email-masked]>
Date: Wed, 12 Mar 2003 14:52:28 -0800

Dirk,

You're right. This is a significant gap in our requirements.

We will have to recall them from the IESG and include it. It is an unacceptable
security hole for there to be no requirement that APs be authorized. I'm
suprised Steve Bellovin didn't find this.

Thanx for pointing out this serious hole.

            jak

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>;
<[email-masked]>; <[email-masked]>
Sent: Wednesday, March 12, 2003 1:07 PM
Subject: RE: [SeaMoby] Topic #2:Do we need a server for CARD

---

From: "James Kempf" <[email-masked]>
Date: Wed, 12 Mar 2003 14:52:28 -0800

Dirk,

            jak