Subject: [Sedate] Let's keep things moving!

From: "Bron Gondwana" <[email-masked]>
Date: Sat, 11 Sep 2021 23:03:13 +1000

Hi all.

There's a specific request in this email: please reply with your opinions on whether you'd prefer to have a github issue tracker to track specific decisions, or separate email threads for each issue only, or something else entirely.  I'd like those replies (to this email) by Friday September 17th (this coming Friday), at which time we can go with whatever seems most popular, but get conversations moving on each of the topics one way or another!

But first...

*A couple of bits of news:*

The IAB met a couple of weeks ago, and Mark and I appeared as guests to discuss liaison with ISO.  You can read the minutes here:

https://www.iab.org/documents/minutes/minutes-2021/iab-minutes-2021-08-25/

The upshot is that the IAB will pursue a formal liaison.

Also: we have a session request in for IETF112.  It's for 1 hour.  That's probably either too much time or not enough!

Finally, CalConnect is meeting in October as well:

https://www.calconnect.org/events/calconnect-virtual-conference-autumn-2021

During which there will be a joint interim session for the JMAP and CALEXT working groups (of which I'm also a chair).  If there's interest in doing a joint SEDATE session I could ask for time for that during the week as well.

*Do we want a github issue tracker?**
*

Right now we're just discussing things on the list, but it would be easy to spin up issues on a github tracker and refer to them for tracking changes and decisions on specific issues.  I've used this successfully in other working groups.  The final discussion for each thing still happens on the list, but the issue tracker keeps them neatly separate.

*Speaking of which - what do we still need to do?**
*

I think this is the status.  Decisions that I'm aware are outstanding:
 * Will this document specify floating times (time in timezone, regardless of offset) or only times with an exact UTC offset?
   * Explicitly naming the different fields, and different formats, of date (see Neil Jenkins' email)
 * Explicit handling for when offset on the date, and offset expected by the named zone don't match.
 * Namespaces for extensions (see Ujjwal's email)
 * Assigning a co-editor
Anything I've missed?

... let's keep moving on this.

Cheers,

Bron.
**
--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: Justin Grant <[email-masked]>
Date: Sat, 18 Sep 2021 13:46:54 -0700

Thanks Bron for helping move things along!  Personally I prefer to use
GitHub issues because I find them easier to follow than
sometimes-multi-branched email threads, but I'm happy to abide by whatever
the group decides.

Cheers,
Justin Grant (Temporal)

On Sat, Sep 11, 2021 at 6:03 AM Bron Gondwana <[email-masked]>
wrote:

> Hi all.
>
> There's a specific request in this email: please reply with your opinions
> on whether you'd prefer to have a github issue tracker to track specific
> decisions, or separate email threads for each issue only, or something else
> entirely.  I'd like those replies (to this email) by Friday September 17th
> (this coming Friday), at which time we can go with whatever seems most
> popular, but get conversations moving on each of the topics one way or
> another!
>
> But first...
>
> The IAB met a couple of weeks ago, and Mark and I appeared as guests to
> discuss liaison with ISO.  You can read the minutes here:
>
> Also: we have a session request in for IETF112.  It's for 1 hour.  That's
> probably either too much time or not enough!
>
>
> During which there will be a joint interim session for the JMAP and CALEXT
> working groups (of which I'm also a chair).  If there's interest in doing a
> joint SEDATE session I could ask for time for that during the week as well.
>
> *Do we want a github issue tracker?*
>
> Right now we're just discussing things on the list, but it would be easy
> to spin up issues on a github tracker and refer to them for tracking
> changes and decisions on specific issues.  I've used this successfully in
> other working groups.  The final discussion for each thing still happens on
> the list, but the issue tracker keeps them neatly separate.
>
> *Speaking of which - what do we still need to do?*
>
>    - Will this document specify floating times (time in timezone,
>    regardless of offset) or only times with an exact UTC offset?
>    - Explicitly naming the different fields, and different formats, of
>       date (see Neil Jenkins' email)
>       - Explicit handling for when offset on the date, and offset
>    expected by the named zone don't match.
>    - Namespaces for extensions (see Ujjwal's email)
>    - Assigning a co-editor
>
> Anything I've missed?
>
> Sedate mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sedate
>

---

From: Shane Carr <[email-masked]>
Date: Sun, 19 Sep 2021 10:46:31 -0500

Thanks for the update!  +1 to GitHub.

On Sat, Sep 18, 2021 at 3:47 PM Justin Grant <
[email-masked]> wrote:

>> During which there will be a joint interim session for the JMAP and
>> CALEXT working groups (of which I'm also a chair).  If there's interest in
>> doing a joint SEDATE session I could ask for time for that during the week
>> as well.
>>