Subject: [sfc] Ping and traceroute in SFP

From: Greg Mirsky <[email-masked]>
Date: Mon, 13 Apr 2020 17:24:11 -0700

Dear All,
drat-ietf-sfc-oam-requirements suggests that ICMP "can be used for some of
the connectivity functions [ of SFC]". Indeed, ICMP can be used to ping an
SFF given its IP address is known to the sender. But I don't see that ICMP
can be used to trace an SFP. The draft suggests the following procedure:

the initiator could send OAM packets with sequentially incrementing the TTL
in the NSH to trace the SFP.

But I think that this approach would not work. Please consider what happens
when a packet gets to the control plane. The NSH is removed. As a result,
the ICMP packet with the IP destination address of the last SFF is
revealed. I think that the node will forward the packet instead of sending
the ICMP echo reply back to the sender.
It was the motivation for the work on SFC Echo Request/Reply, work that the
SFC WG hs adopted. The draft defines formats of SFC Echo Reply/Request and
mechanisms necessary to perform ping and trace functions on an SFP. The
draft has been stable and authors would appreciate WG Chairs consideration
for WFLC.

Regards,
Greg

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 13 Apr 2020 17:41:47 -0700

Dear All,
apologies, I've missed mentioning the draft that the authors would like to
be considered for the WGLC - draft-ietf-sfc-multi-layer-oam
<https://datatracker.ietf.org/doc/draft-ietf-sfc-multi-layer-oam/>.

Regards,
Greg

On Mon, Apr 13, 2020 at 5:24 PM Greg Mirsky <[email-masked]> wrote:

> the initiator could send OAM packets with sequentially incrementing the
> TTL in the NSH to trace the SFP.
>
> But I think that this approach would not work. Please consider what
> happens when a packet gets to the control plane. The NSH is removed. As a
> result, the ICMP packet with the IP destination address of the last SFF is
> It was the motivation for the work on SFC Echo Request/Reply, work that
> the SFC WG hs adopted. The draft defines formats of SFC Echo Reply/Request
> and mechanisms necessary to perform ping and trace functions on an SFP. The

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Tue, 14 Apr 2020 01:27:41 +0000

Hello, Greg,

To be clear, you are referring to a drat-ietf-sfc-oam-requirements draft. To my knowledge a draft with that filename does not exist; however, I believe you may be intending to refer to draft-ietf-sfc-oam-framework. Assuming that is the case:

There are many ways to intercept an exception packet and send it to the control plane. One example is setting the TTL in IP. Another is using RAO. Another is specific instructions on NSH TTL expiration. And many others. None of this is new.

Unfortunately, you are adding things that do not exist in draft-ietf-sfc-oam-framework… The text says:

Alternately, the initiator could send OAM packets with
   sequentially incrementing the TTL in the NSH to trace the SFP.

It does not say anything about ICMP echo replies. Or destination addresses for trace. Or…

I apologize for sounding like a broken record, but draft-ietf-sfc-oam-framework does not define solutions.

Now, if that is the justification for creating draft-ietf-sfc-multi-layer-oam, I strongly recommend that there is absolutely no need to create a full blown new protocol in paper, without implementation, copying MPLS LSP Ping. I’d recommend making existing protocols such as ICMP, BFD, S-BFD, etc., work, rather than over engineering in paper.

Best,

Carlos.

2020/04/13 午後8:24、Greg Mirsky <[email-masked]<mailto:[email-masked]>>のメール:

Dear All,
drat-ietf-sfc-oam-requirements suggests that ICMP "can be used for some of the connectivity functions [ of SFC]". Indeed, ICMP can be used to ping an SFF given its IP address is known to the sender. But I don't see that ICMP can be used to trace an SFP. The draft suggests the following procedure:
the initiator could send OAM packets with sequentially incrementing the TTL in the NSH to trace the SFP.
But I think that this approach would not work. Please consider what happens when a packet gets to the control plane. The NSH is removed.. As a result, the ICMP packet with the IP destination address of the last SFF is revealed. I think that the node will forward the packet instead of sending the ICMP echo reply back to the sender.
It was the motivation for the work on SFC Echo Request/Reply, work that the SFC WG hs adopted. The draft defines formats of SFC Echo Reply/Request and mechanisms necessary to perform ping and trace functions on an SFP. The draft has been stable and authors would appreciate WG Chairs consideration for WFLC.

Regards,
Greg

_______________________________________________
sfc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sfc

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 13 Apr 2020 19:18:02 -0700

Dear Carlos,
thank you for correcting the reference, I was sloppy. As for the quote,
I've found it in the section on ICMP and assumed that it is related to the
proposed procedure using ICMP in SFC OAM. Also, your suggestions are very
helpful and someone might start a new work based on an idea that you've
shared.

Regards,
Greg

On Mon, Apr 13, 2020 at 6:27 PM Carlos Pignataro (cpignata) <
[email-masked]> wrote:

> Hello, Greg,
>
> To be clear, you are referring to a drat-ietf-sfc-oam-requirements draft.
> To my knowledge a draft with that filename does not exist; however, I
> believe you may be intending to refer to draft-ietf-sfc-oam-framework.
> Assuming that is the case:
>
> There are many ways to intercept an exception packet and send it to the
> control plane. One example is setting the TTL in IP. Another is using RAO.
> Another is specific instructions on NSH TTL expiration. And many others.
> None of this is new.
>
> Now, if that is the justification for
> creating draft-ietf-sfc-multi-layer-oam, I strongly recommend that there is
> absolutely no need to create a full blown new protocol in paper,
> without implementation, copying MPLS LSP Ping. I’d recommend making
> existing protocols such as ICMP, BFD, S-BFD, etc., work, rather than over
> engineering in paper.
>
> Best,
>
> Carlos.
>
> 2020/04/13 午後8:24、Greg Mirsky <[email-masked]>のメール:
>
> Dear All,
> happens when a packet gets to the control plane. The NSH is removed.. As a
> [email-masked]