Subject: [shara] proposed update for SHARA BOF charter text

From: <[email-masked]>
Date: Tue, 3 Feb 2009 01:10:51 +0100

I have updated the charter text for the BOF proposal taking into account the comments received so far on the mailing list. I intend to upload the text to wiki within a day or so. Comments are welcome.
- Gabor

Sharing IPv4 Addresses (SHARA) BOF proposal:
-------------------------------------------------------

Background and Motivation:
-------------------------

When IPv6 was designed, the assumption was that the transition from IPv4 to IPv6 will occur way before the exhaustion of the available IPv4 address pool. The unexpected growth of the IPv4 Internet and the hesitation and technical difficulties to deploy IPv6 indicates that the transition may take much longer than originally anticipated.
It is expected that communication using IPv6 addresses will increase during the next few years to come at the expense of communication using IPv4 addresses. We should reach a safety point in the future, where the number of IPv4 public addresses in use at a given time begins decreasing. It is very likely that the IPv4 public address pool currently available at IANA will be exhausted before the internet reaches this safety point. This creates a need to prolong the lifetime of the available IPv4 addresses.

While IPv6 is the long-term solution, IPv4 connectivity needs to be provided for hosts and applications unable to utilize IPv6 and/or require NATless IPv4 connectivity. This can happen for example when:

    * a host is provided with IPv6 only connectivity by access network, but it is running (legacy) applications requiring NATless IPv4 connectivity
    * a distribution of NAT to edges instead of core is desired e.g. for better end-user control of NAT or for distribution of NAT function

In IETF multiple IPv6 transition solutions have been and are being worked on, including protocol translation that is worked on behave WG and Dual-Stack Lite that is worked on softwire WG. This BOF proposes new work on:

    * defining complementary, _not competing_, transition mechanism based on shared IPv4 addresses
    * documenting the deployment scenarios where usage of such addresses is envisioned and beneficial over other solutions being standardized
    * defining protocols for assigning and routing shared IPv4 addresses
    * documenting the benefits, drawbacks, dangers of using shared IPv4 addresses

Prior activity:
--------------

IPv6 transition mechanisms have a long history. Port-restricted IPv4 addresses as a solution approach have been discussed during 2008 at least in IETF#72, IETF#73, and to lesser extent in v4v6 interim meeting held in Montreal:

IETF#73

    * Softwires WG: https://www.ietf.org/proceedings/08nov/index.html
    * Behave WG: https://www.ietf.org/proceedings/08nov/index.html

IPv4-IPv6 Co-Existence Interim

    * http://trac.tools.ietf.org/area/int/trac/wiki/v4v6interim

IETF#72

    * intarea: https://www.ietf.org/proceedings/08jul/index.html
    * v6ops: https://www.ietf.org/proceedings/08jul/index.html

Proposed Work:
-------------

The proposed SHARA working group will focus on following topics relevant for shared IPv4 addresses:

    * Problem statement and requirements document: a document describing the problems caused by IPv4 address shortage and why sharing IPv4 addresses could be a solution for the problem; what requirements solutions using shared IP addresses need to fulfill

    * Document as many of the issues that shared IPv4 addresses create that can be identified by the community (e.g. blind attacks, ICMP handling, fragmentation, routing, tunneling, etc), develop solutions where possible; describe drawbacks and consequences. Analyze the behaviour of legacy applications that have some IPv4 NAT traversal capabilities, determine under what circumstances they could still work with shared IPv4 addresses.

    * Deployment scenarios: describe deployment scenarios where shared IPv4 addresses are applicable (e.g. point-to-point physical links, distributing Carrier Grade NAT, integration with Dual-Stack Lite, IP mobility protocols etc)

    * Shared address assignment: describe mechanisms for assigning shared IPv4 addresses for hosts

The BoF proposes to discuss the above items and gauge interest in forming a working Group. There is already work in progress addressing some of the identified problems, which is expected to be the starting point for the deliverables:

    * http://tools.ietf.org/internet-drafts/draft-levis-behave-ipv4-shortage-framework
    * http://tools.ietf.org/html/draft-ymbk-aplusp
    * http://tools.ietf.org/html/draft-boucadair-port-range
    * http://tools.ietf.org/html/draft-bajko-v6ops-port-restricted-ipaddr-assign
    * http://tools.ietf.org/html/draft-boucadair-dhc-port-range
    * http://tools.ietf.org/html/draft-boucadair-behave-bittorrent-portrange
    * http://tools.ietf.org/html/draft-arkko-townsley-coexistence
    * http://tools.ietf.org/html/draft-despres-sam

Approximate Timeline for Deliverables:
-------------------------------------

    * April 2009 WG approved by IESG
    * 2H09 Submit problem statement I-D to IESG
    * 1H10 Submit address assignment I-D to IESG
    * 2H10 Submit deployment scenarios I-D to IESG
    * 2H10 Recharter or close WG
_______________________________________________
shara mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/shara

---

From: <[email-masked]>
Date: Wed, 4 Feb 2009 02:44:42 +0100

http://trac.tools.ietf.org/bof/trac/wiki/WikiStart?version=330#Transport