Subject: [shara] comments about draft-bajko-pripaddrassign-00

From: Hui Deng <[email-masked]>
Date: Wed, 25 Feb 2009 20:37:37 +0800

Hello, Authors.

I read through the document
1) when some clients support option-pra, but others don't, will server
behavior section
describe this scenario?

2) how to handle lease life time of dhcp address

thanks

-Hui

---

From: <[email-masked]>
Date: Wed, 25 Feb 2009 13:56:59 +0100

Hi,

1) It should be described in 6.2 Server behaviour:
--

   If OPTION-IPv4-PRA is not present in DHCPDISCOVER, the server SHOULD

   allocate full unrestricted public or private [RFC1918] IPv4 address

   to the client, if available, by generating a DHCPOFFER as described

   in [RFC2131].

--
and forward.

So essentially the same DHCP server is allocating both full and port restricted IPv4 addresses, depending on host's support.

2) Excellent question. The lease time will have to be per port set instead of per IPv4 address as currently.
- For a client this does not make any difference when compared to full IPv4 address (client has to renew the address and when the lease ends, the IPv4 address expires whatever was the size of allocated port set)
- For the DHCP server this is clearly more complex, though. The DHCP server has to follow lease times per allocated port set. So if the server splits an IPv4 address into 10 sets, it has to have lease time follow-up for all those 10 sets. The clients will be varyingly renewing the port set they were allocated, and also individual port sets may be released/expired individually.

For me it looks the DHCP server needs two tables: one for managing full IPv4 addresses, and one for managing port-restricted IPv4 addresses. Maybe those could be combined as well if the full IPv4 address is just considered a port-restricted IPv4 address with single 64K port allocation. I.e. something like:
{ 10.0.0.1 - port set FULL }
{ 10.0.0.2 - port set partial-A }
{ 10.0.0.2 - port set partial-B }

I hope I find time to digg deeper into this before next IETF, but let's see. Anyhow, I believe the actual impact to lease time management on the server side depends on individual implementations.

I hope I answered your questions.

Best regards,

    Teemu

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Hui Deng
Sent: 25 February, 2009 14:38
To: [email-masked]
Subject: [shara] comments about draft-bajko-pripaddrassign-00

Hello, Authors.

I read through the document
1) when some clients support option-pra, but others don't, will server behavior section
describe this scenario?

thanks

-Hui

---

From: Hui Deng <[email-masked]>
Date: Thu, 26 Feb 2009 21:20:55 +0800

Hi, Teemu

It looks workable, but need to change a lot of thing.
thanks.

-Hui

2009/2/25 <[email-masked]>

> So essentially the same DHCP server is allocating both full and port
> restricted IPv4 addresses, depending on host's support.
>
> - For a client this does not make any difference when compared to full IPv4
> address (client has to renew the address and when the lease ends, the IPv4
> address expires whatever was the size of allocated port set)
> - For the DHCP server this is clearly more complex, though. The DHCP
> server has to follow lease times per allocated port set. So if the server
> splits an IPv4 address into 10 sets, it has to have lease time follow-up for
> all those 10 sets. The clients will be varyingly renewing the port set they
> were allocated, and also individual port sets may be released/expired
> individually.
>
> For me it looks the DHCP server needs two tables: one for managing full
> IPv4 addresses, and one for managing port-restricted IPv4 addresses. Maybe
> those could be combined as well if the full IPv4 address is just considered
> a port-restricted IPv4 address with single 64K port allocation. I.e.
> something like:
> I hope I find time to digg deeper into this before next IETF, but let's
> see. Anyhow, I believe the actual impact to lease time management on the
> server side depends on individual implementations.
>
>  ------------------------------
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *ext Hui Deng
> *Sent:* 25 February, 2009 14:38
> *To:* [email-masked]
> *Subject:* [shara] comments about draft-bajko-pripaddrassign-00
>
>   Hello, Authors.
>