Subject: [shara] Questions about draft-boucadair-port-range-01

From: Hui Deng <[email-masked]>
Date: Thu, 26 Feb 2009 21:19:37 +0800

Dear authors,

After reading the draft, I have two questions:
1) This draft doesn't describe the DNS work, what happen if the
correspondent node need
visit node behind the CPE?
2) Some application which couldn't be supported by ALG will not work in this
scenarios?

thanks

-Hui

---

From: <[email-masked]>
Date: Thu, 26 Feb 2009 14:37:59 +0100

Hi,

Port restricted addresses certainly provide less functionality than full IPv4 addresses.

My understanding is that 1) would probably work as currently with private IPv4 addresses and NATs: node behind CPE finds out what its external IPv4 address+port is (STUN, UPnP, NAT-PMP) and communicates that by some means to correspondent node (e.g. with SIP & ICE).

2) Applications requiring ALG would suffer. However, if the port restricted address is handled by the host instead of CPE, the application itself could be capable of directly utilizing port restricted addresses and thus get possibility for NATless communication.

My personal opinion is that application developers should not longer assume existence of ALGs, especially when number of NATs that would need to implement ALG are growing increasingly - I believe (e.g. my phone has a third-party NAT (JoikuSpot) that I use when I need to share the HSDPA connection to my laptop via WLAN - I doubt it has very large set of ALGs implemented..).

Best regards,

    Teemu

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Hui Deng
Sent: 26 February, 2009 15:20
To: [email-masked]
Subject: [shara] Questions about draft-boucadair-port-range-01

Dear authors,

After reading the draft, I have two questions:
1) This draft doesn't describe the DNS work, what happen if the correspondent node need
visit node behind the CPE?
2) Some application which couldn't be supported by ALG will not work in this scenarios?

thanks

-Hui