Subject: [shara] draft-thaler-port-restricted-ip-issues: Host Implementation Issues

From: <[email-masked]>
Date: Mon, 1 Mar 2010 11:35:55 +0100

Dear Dave,

In your draft, you wrote: "To actually apply a port restriction, host stack implementations
   would need to change.  Without such a change, a host may naturally
   attempt to use the IP address with arbitrary protocols and ports,
   which would be akin to address spoofing in a port-restricted IP
   address model."

For fixed networks, several scenarios for the deployment of port restriction may be considered. Host-based model is one flavour among others.
 
For the CPE-based model, port-restriction features are not required to be supported by the hosts behind the CPE since port-restriction are to be enforced in the CPE: No changes are required for the hosts in such scenario.

For the host-based model (e.g., mobile networks), I agree that port-restriction feature is required to be supported by the host. Some modifications are needed (FYI, port-restriction feature may be activated by entering two IPTABLES lines in Linux-based Oses.). These modifications are to be positioned against expected gains such as:

- Battery consumption for mobile devices because keepalive messages to maintain NAT entries are avoided (in NAT-based solutions, "Always-on" services would impact severely the battery consumption. Not to mention several layers of keepalive messages: e.g., IPsec, SIP )
- No need to embed ALG in intermediary nodes. 
- No need to embed NAT traversal technique in the host
- No latency due to retrieving the perceived IPv4 public address (to be assigned by the NAT)
- Session tracking issues: It is not required to maintain per-session tracking information (legal requirement)
- Etc.  

Cheers,
Med

*********************************
This message and any attachments (the "message") are confidential and intended solely for the addressees. 
Any unauthorised use or dissemination is prohibited.
Messages are susceptible to alteration. 
France Telecom Group shall not be liable for the message if altered, changed or falsified.
If you are not the intended addressee of this message, please cancel it immediately and inform the sender.
********************************

---

From: Masataka Ohta <[email-masked]>
Date: Mon, 01 Mar 2010 22:27:30 +0900

[email-masked] wrote:

>    would need to change.

It merely means PR-IP does require host stack changes.

All of the PR-IP proposals do require host stack changes. So?

							Masataka Ohta

---

From: <[email-masked]>
Date: Tue, 2 Mar 2010 07:41:44 +0100

Hi all,

I'd like to refocus I-D.thaler-port-restricted-ip-issues on the subject that was discussed in Hiroshima during the aplusp BoF.

Dave's draft is exclusively focussed on A+P directly applied to hosts, as clearly stated in the abstract:
"This document discusses issues with assigning an IP address to a host
interface such that the IP address may only be used with a restricted
set of ports."

Dave explicitly concludes that other A+P approaches (A+P in CPEs is the dominant one), are not covered by these issues:
"The primary cause of the issues unique to port-restricted IP addresses comes from assigning such an address to
a device's interface.  This concept does not occur in classic NAT.
...
It is possible that the same state benefits motivating the concept of port-
restricted IP addresses may be possible in other approaches that do
not involve assigning a port-restricted IP address to an interface, 
but this investigation is left to other documents"

If you go back to the introductory slides of the aplusp BoF, it is also clear that A+P directly in hosts was out of the scope:
"Host-based A+P brings additional complexity" in slide 5 of 01-agenda.ppt

So, from the strict aplusp BoF point of view, this draft brings no objection on continuing the A+P work at the IETF.

Regards,

Pierre

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de [email-masked]
Envoyé : lundi 1 mars 2010 11:36
À : [email-masked]
Cc : [email-masked]
Objet : [shara] draft-thaler-port-restricted-ip-issues: Host ImplementationIssues

Dear Dave,

 

Cheers,
Med

_______________________________________________
shara mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/shara

---

From: Dave Thaler <[email-masked]>
Date: Tue, 2 Mar 2010 17:08:56 +0000

See also the second paragraph of section 4.
Other sections (5, 6) also apply to a CPE-only model.
So it is incorrect to say that this draft raises no issues 
with such a model.

Classic NAT != the CPE model here.

-Dave

> -----Original Message-----
> From: [email-masked] [mailto:pierre.levis@orange-
> ftgroup.com]
> Sent: Monday, March 01, 2010 10:42 PM
> To: Dave Thaler; [email-masked]
> Cc: [email-masked]
> Subject: RE: [shara] draft-thaler-port-restricted-ip-issues: Host
> ImplementationIssues
> 
> Hi all,
> 
> I'd like to refocus I-D.thaler-port-restricted-ip-issues on the subject
> that was discussed in Hiroshima during the aplusp BoF.
> 
> Dave explicitly concludes that other A+P approaches (A+P in CPEs is the
> dominant one), are not covered by these issues:
> If you go back to the introductory slides of the aplusp BoF, it is also
> clear that A+P directly in hosts was out of the scope:
> So, from the strict aplusp BoF point of view, this draft brings no
> objection on continuing the A+P work at the IETF.
> 
> 
> 
> Regards,
> 
> Pierre
> 
> 
> 
> For fixed networks, several scenarios for the deployment of port
> restriction may be considered. Host-based model is one flavour among
> others.
> 
> For the CPE-based model, port-restriction features are not required to
> be supported by the hosts behind the CPE since port-restriction are to
> be enforced in the CPE: No changes are required for the hosts in such
> scenario.
> 
> For the host-based model (e.g., mobile networks), I agree that port-
> restriction feature is required to be supported by the host. Some
> modifications are needed (FYI, port-restriction feature may be
> activated by entering two IPTABLES lines in Linux-based Oses.). These
> modifications are to be positioned against expected gains such as:
> 
> - Battery consumption for mobile devices because keepalive messages to
> maintain NAT entries are avoided (in NAT-based solutions, "Always-on"
> services would impact severely the battery consumption. Not to mention
> several layers of keepalive messages: e.g., IPsec, SIP )

---

From: <[email-masked]>
Date: Wed, 3 Mar 2010 09:00:23 +0100

That's right, these are issues to tackle when considering a CPE-only A+P architecture deployment.
However, obviously, they are not part of the "drastic change to the IP model".

My conclusion, I guess, remains valid; 
"brings no objection to continue the A+P work" does not mean "brings no issues relevant to A+P" 

Pierre

-----Message d'origine-----
De : Dave Thaler [mailto:[email-masked]] 
Envoyé : mardi 2 mars 2010 18:09
À : LEVIS Pierre RD-BIZZ-CAE; [email-masked]
Cc : BOUCADAIR Mohamed NCPI-NAD-TIP
Objet : RE: [shara] draft-thaler-port-restricted-ip-issues: Host ImplementationIssues

-Dave

---

From: Masataka Ohta <[email-masked]>
Date: Wed, 03 Mar 2010 18:39:16 +0900

> That's right, these are issues to tackle when considering a CPE-only A+P architecture deployment.

Wrong.

Section 4 of the draft merely says port restricted IP (including
leagacy NAT) restricts port, which is no new.

Sections 5 is simply wrong w.r.t. ICMP. Ping (command on a PR-IP
end host is slightly modified, which is part of stack change) is
working from PR-IP/IP to PR-IP/IP, without changing IP/ICMP layer.

Rest of the section is on management issue if static port
assignment is used with port restricted IP (including
leagacy static NAT), which is no new. You can avoid them
if fully dynamic PR-IP is used, of course.

> "brings no objection to continue the A+P work" does not mean "brings no issues relevant to A+P" 

No. The conclusion is, PR-IP works as good as leagacy NAT and some
form of PR-IP is better than leagacy NAT.

						Masataka Ohta
> Envoy? : mardi 2 mars 2010 18:09
> ? : LEVIS Pierre RD-BIZZ-CAE; [email-masked]
>>Envoy? : lundi 1 mars 2010 11:36
>>? : [email-masked]
>>Cc : [email-masked]

---

From: <[email-masked]>
Date: Wed, 3 Mar 2010 10:49:17 +0100

Dear Dave, all,

The text you are referring to is:

- In some part no specific to A+P (e.g., Personnel issues)
- Speculating on issues: eg.; you mentioned "significant complexity" and "unknown
   (to existing personnel) failure modes". The text does not identify the "significant complexity" and speculates on potential failure modes.
- For receiving ICMP and like/device management issues: my answer is to encourage the use IPv6 for implementing those features. 

Cheers,
Med 

-----Message d'origine-----
De : Dave Thaler [mailto:[email-masked]] 
Envoyé : mardi 2 mars 2010 18:09
À : [email-masked]; [email-masked]
Cc : BOUCADAIR Mohamed NCPI/NAD/TIP
Objet : RE: [shara] draft-thaler-port-restricted-ip-issues: Host ImplementationIssues

-Dave

---

From: Dave Thaler <[email-masked]>
Date: Wed, 3 Mar 2010 18:15:00 +0000

The term A+P does not appear in the document.
The issues are with any proposal that uses port-restricted IP
addresses, even ones that claim to only apply to NATs.

On IPv6, the draft already states reachability over IPv6
may be present but cannot be used to determine liveness
of the IPv4 stack.

-Dave

> From: [email-masked]
> [mailto:[email-masked]]
> Sent: Wednesday, March 03, 2010 1:49 AM
> To: Dave Thaler; LEVIS Pierre RD-BIZZ; [email-masked]
>    (to existing personnel) failure modes". The text does not identify
> the "significant complexity" and speculates on potential failure modes.
> - For receiving ICMP and like/device management issues: my answer is to
> encourage the use IPv6 for implementing those features.
> 
> Cheers,
> Med
> 
> 
> > Dave's draft is exclusively focussed on A+P directly applied to
> hosts,
> > as clearly stated in the abstract:
> > "The primary cause of the issues unique to port-restricted IP
> addresses
> > comes from assigning such an address to
> > De : [email-masked] [mailto:[email-masked]] De la
> part
> > de [email-masked]
> > - No latency due to retrieving the perceived IPv4 public address (to
> be
> > assigned by the NAT)
> > If you are not the intended addressee of this message, please cancel
> it
> > immediately and inform the sender.
> > If you are not the intended addressee of this message, please cancel
> it
> > immediately and inform the sender.

---

From: <[email-masked]>
Date: Thu, 4 Mar 2010 08:14:20 +0100

Dear Dave,

Please see inline.

Cheers,
Med 

-----Message d'origine-----
De : Dave Thaler [mailto:[email-masked]] 
Envoyé : mercredi 3 mars 2010 19:15
À : BOUCADAIR Mohamed NCPI/NAD/TIP; LEVIS Pierre RD-BIZZ; [email-masked]
Objet : RE: [shara] draft-thaler-port-restricted-ip-issues: Host ImplementationIssues

Med: This issue in the specific to port-restricted IP, we have the same issue for DS-Lite (The SP does not assign IPv4 address to the CPE, only an IPv6 prefix is assigned. Nevertheless, IPv4 services are delivered over IPv6) Device management can be implemented over IPv6 or rely on a "Pull" model. IMHI, these are not ** blocking ** issues, but should be taken into account when building an architecture which relies on port-restricted @es. BTW, this issue is documented in http://tools.ietf.org/html/draft-ford-shared-addressing-issues-01#section-6 where we proposed the use of UDP Ping for instance.