Subject: [shim6] Meeting at IETF 76?

From: Geoff Huston <[email-masked]>
Date: Wed, 16 Sep 2009 13:43:59 +1000

Hi,

In July of this year the SHIM6 WG was rechartered by the IESG to work  
on:

- implementation and/or deployment experience
- socket api extensions
- the applicability draft (last known as draft-ietf-shim6- 
applicability-03)

Is there interest from WG members in meeting at IETF 76?

Please indicate your preference and if that's a yes please also  
indicate if you have some relevant material you'd like to present.

thanks,

     Geoff

The relevant except from the new SHIM6 charter is:

> The Shim6 working group is chartered to track the implementation and
> testing or deployment efforts. The group is also expected to shepherd
> to completion a few remaining informational documents that complement
> the existing protocol specifications.
>
> The specific work items of the group are:
>
> o Write an implementation and/or deployment experience report.
>
> o Specify socket API extensions. This API enables interactions between
> applications and the Shim6 layer for advanced locator management,
> and access to information about failure detection and path
> exploration. It also enables some applications to turn Shim6 off.
>
> o Complete the work on the applicability draft. This draft explains
> in detail in which types of networks Shim6 is applicable, and
> what its advantages and disadvantages are. The draft will also
> explain how firewalls are impacted by the use of Shim6. Finally,
> the draft will also explain how Shim6 can be used in situations
> where native IPv6 connectivity is not available, such as using
> Shim6 over 6to4.
>
> The group will also work in co-operation with the 6MAN working group
> as they continue their efforts in improving IPv6 address selection
> mechanisms.
>
> The group shall not work on extensions to the Shim6 protocol itself at
> this time. However, new work items can be added through rechartering
> as others get completed.

---

From: Geoff Huston <[email-masked]>
Date: Tue, 22 Sep 2009 19:46:46 +1000

Hi,

Its been almost a week and I have had no response to this call for  
interest.

I'd like to repeat this call - is there any interest in meeting at  
IETF 76 to consider how to progress on the revised charter?

thanks,

    Geoff

On 16/09/2009, at 1:43 PM, Geoff Huston wrote:

> Hi,
>
> In July of this year the SHIM6 WG was rechartered by the IESG to  
> work on:
>

---

From: Jari Arkko <[email-masked]>
Date: Tue, 22 Sep 2009 13:58:49 +0300

The API draft was updated in the summer. Perhaps the authors would like 
to comment on whether that warrants discussion in a room?

Jari

Geoff Huston wrote:
>> - the applicability draft (last known as 
>> draft-ietf-shim6-applicability-03)
>>

---

From: Shinta Sugimoto <[email-masked]>
Date: Wed, 23 Sep 2009 01:11:11 +0900

Hi Geoff and all,

I am sorry for the late response.

Yes, I (as an author of the API draft) have interest in the meeting,
and we are willing to bring revised API draft to the meeting to get
feedbacks from the WG members.

Regards,
Shinta

On Tue, 22 Sep 2009 13:58:49 +0300
Jari Arkko <[email-masked]> wrote:

> _______________________________________________
> shim6 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/shim6

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 23 Sep 2009 09:56:25 +1200

Geoff,

I kept quiet because at this particular moment in time I have nothing
to raise personally, but I would very much like to hear of progress
on all those three topics. Especially, even though we are not an Ops
Area WG, about practical experience. If there's none of that to report,
we may wonder about the value of additional work.

We could also consider discussing ongoing 6man work on address selection
mechanisms, looking for shim6 implications.

   Brian

On 2009-09-22 21:46, Geoff Huston wrote:
> I'd like to repeat this call - is there any interest in meeting at IETF
> 76 to consider how to progress on the revised charter?
> 
> 
> thanks,
> 
>    Geoff
> 
> 
>> In July of this year the SHIM6 WG was rechartered by the IESG to work on:
>>

---

From: Scott Brim <[email-masked]>
Date: Tue, 22 Sep 2009 18:02:40 -0400

> mechanisms, looking for shim6 implications.

What in that list requires a f2f meeting?

---

From: Geoff Huston <[email-masked]>
Date: Wed, 23 Sep 2009 10:24:36 +1000

> What in that list requires a f2f meeting?

Well the good thing about a f2f is that it has an explicit deadline  
that flushes out the "I'll do this someday" work and turns it into "I  
need to get it done by then" work.

Geoff

---

From: John Ronan <[email-masked]>
Date: Wed, 23 Sep 2009 02:46:29 +0100

On 23 Sep 2009, at 01:24, Geoff Huston wrote:

> that flushes out the "I'll do this someday" work and turns it into  
> "I need to get it done by then" work.
>
> Geoff
>
>

Hi,

Here in TSSG, we have been beating on Sébastien Barré's LinShim6  
implementation.

We have adopted the scenario outlined in

"A. de la Oliva, M. Bagnulo, A. Garcia-Martinez, I. Soto, Performance  
Analysis of the REAchability Protocol for IPv6 Multihoming,  
Conference on Next Generation Teletraffic and Wired/Wireless Advanced  
Networking (NEW2AN 2007), September 2007"

And are trying to keep it as close to this as possible.

I believe Sébastien is travelling at the moment (and may not be  
reading emails), but I would hope that TSSG would have something to  
report by then.

Regards
John
--
John Ronan <[email-masked]>, +353-51-302938
Telecommunications Software &  Systems Group,  http://www.tssg.org

---

From: Sébastien Barré <[email-masked]>
Date: Thu, 24 Sep 2009 14:29:01 +0200

Hi,

Unfortunately I will not be able to attend the next IETF meeting, 
because it is too close to my wedding.

However, I just submitted an updated version of my implementation report 
draft:
http://www.ietf.org/id/draft-barre-shim6-impl-03.txt

As geoff previously proposed, this can serve as a starting point for the 
WG draft on implementation report.
I think he suggested to include deployment experience as well in the 
draft. But before to change it, in particular change the structure of 
the draft, I would be grateful to get review comments from the working 
group on the existing text.

Probably then, based on the comments, I could propose a 04 version. That 
version could include for example text from John Ronan in the deployment 
experience part. I think that BT could also provide feedback, I will try 
to see if they want to be involved in that process.

Note that I am still working on the LinShim6 implementation, and latest 
versions (currently 0.9.1) can always be retrieved from 
http://inl.info.ucl.ac.be/LinShim6 .

Thanks thus for any comments to that draft,

Sébastien.

John Ronan a écrit :
> Analysis of the REAchability Protocol for IPv6 Multihoming, Conference 
> on Next Generation Teletraffic and Wired/Wireless Advanced Networking 
> (NEW2AN 2007), September 2007"
>

-- 
Sébastien Barré
Researcher,
CSE department, UCLouvain, Belgium
http://inl.info.ucl.ac.be/sbarre

---

From: Geoff Huston <[email-masked]>
Date: Fri, 25 Sep 2009 07:12:57 +1000

thank you very much for this update - and, of course,  
congratulations! :-)

   Geoff

On 24/09/2009, at 10:29 PM, Sébastien Barré wrote:

> However, I just submitted an updated version of my implementation  
> report draft:
> As geoff previously proposed, this can serve as a starting point for  
> the WG draft on implementation report.
> draft. But before to change it, in particular change the structure  
> of the draft, I would be grateful to get review comments from the  
> working group on the existing text.
>
> Probably then, based on the comments, I could propose a 04 version.  
> That version could include for example text from John Ronan in the  
> deployment experience part. I think that BT could also provide  
> feedback, I will try to see if they want to be involved in that  
> process.
>
> Note that I am still working on the LinShim6 implementation, and  
> latest versions (currently 0.9.1) can always be retrieved from http://inl.info.ucl.ac.be/LinShim6 
>  .
>
>>> Well the good thing about a f2f is that it has an explicit  
>>> deadline that flushes out the "I'll do this someday" work and  
>>> turns it into "I need to get it done by then" work.
>>>
>>> Geoff
>>>
>>>
>>
>>
>> Hi,
>>
>> "A. de la Oliva, M. Bagnulo, A. Garcia-Martinez, I. Soto,  
>> Performance Analysis of the REAchability Protocol for IPv6  
>> Multihoming, Conference on Next Generation Teletraffic and Wired/ 
>> Wireless Advanced Networking (NEW2AN 2007), September 2007"
>>