Subject: Re: [shim6] Meeting at IETF 76?

From: Brian E Carpenter <[email-masked]>
Date: Mon, 09 Nov 2009 20:39:54 +1300

>> On 16/09/2009, at 1:43 PM, Geoff Huston wrote:
>>
>>> Hi,
>>>
>>> In July of this year the SHIM6 WG was rechartered by the IESG to work on:
>>>
>>> - implementation and/or deployment experience
>>> - socket api extensions
>>> - the applicability draft (last known as
>>> draft-ietf-shim6-applicability-03)
>>>
>>> Is there interest from WG members in meeting at IETF 76?

So, we aren't meeting, but we have only heard recent news about
the socket API. Can we have some news about the applicability draft?

Does anybody have a summary of implementations that is fully
up to date? http://www.shim6.org/ hasn't been updated since the
RFCs were published a few months ago.

Is there somewhere we can collect information about experience?
Wiki or blog style would be fine.

   Brian

---

From: Sébastien Barré <[email-masked]>
Date: Mon, 09 Nov 2009 12:57:01 +0100

Hi,

> Wiki or blog style would be fine.
Maybe we should attach a wiki to shim6.org to enable discussion. 
Marcelo, would this be possible ?
For my side, as said previously, my implementation is available at 
http://inl.info.ucl.ac.be/LinShim6.
The latest version is quite stable and has almost all features specified 
in the RFC. The final goal is to submit it to the Linux mainline kernel 
(It is made of a kernel patch based on the xfrm architecture and a 
userspace daemon), when I have some time to deal with the review process.

Currently I have coupled Shim6 with MPTCP, which appears as a deployment 
scenario. If someone sets up a wiki, I may write some lines about that 
on the wiki.

regards,

Sébastien.
>    Brian
> _______________________________________________
> shim6 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/shim6
>   

-- 
Sébastien Barré
Researcher,
CSE department, UCLouvain, Belgium
http://inl.info.ucl.ac.be/sbarre

---

From: "Henderson, Thomas R" <[email-masked]>
Date: Tue, 10 Nov 2009 07:27:07 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> On Behalf Of Brian E Carpenter
> Sent: Sunday, November 08, 2009 11:40 PM
> To: [email-masked]
> Cc: Lindqvist Kurt Erik
> Subject: Re: [shim6] Meeting at IETF 76?
>
>

Wherever the implementation page ends up (shim6.org or elsewhere), please add a link to the OpenHIP shim6 implementation for Linux:
http://www.openhip.org/docs/shim6.html

Thanks,
Tom

---

From: marcelo bagnulo braun <[email-masked]>
Date: Mon, 23 Nov 2009 13:30:28 +0100

Hi,
i have updated the shim6.org web page, included the link to the open hip 
based implementation and updated the links to the rfcs.

I won't be able to include a wiki. If someone cares to do so, i cna put 
a link from there.

Regards, marcelo

Henderson, Thomas R escribió:
>>>>> In July of this year the SHIM6 WG was rechartered by the
>>>>>           
>> IESG to work on:
>>