Subject: [shim6] Working Group Last Call draft-ietf-shim6-applicability

From: Geoff Huston <[email-masked]>
Date: Fri, 1 Oct 2010 17:41:00 +1000

The WG chairs have received a Working Group Last Call request from the authors of draft-ietf-shim6-applicability. The intended status of this document is Informational. The document (and the draft history) is at http://tools.ietf.org/html/draft-ietf-shim6-applicability-07

The 2 week WG Last Call will end as of the close of business on Friday 15th October 2010.

As usual, please address all comments to the SHIM6 WG mailing list, and please be clear in your comments to this WG last call if you are supporting the document's submission to the IESG or if you are opposed, or if you are not expressing a view either way. 

(Some visible indication of support of this draft progressing to the IESG will improve its passage through the IESG review stages!)

Thanks,

Geoff

WG Co-Chair hat ON

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 05 Oct 2010 12:51:27 +1300

Hi,

I believe this draft is ready for the IESG. I've noted some minor
points below, which could be fixed now or later.

     Brian

Nits and editorial:
===================

>    This document may contain material from IETF Documents or IETF
>    Contributions published or made publicly available before November
>    10, 2008.  

Do we need this bit of legal junk? Unless there is specific old
material and its authors are not available to say "OK", there is
no need for this. So which old material written by who is included?

> Regarding to the outbound traffic to H, 

--> Regarding the outbound traffic to H,

> IPv4 addressed can be

--> IPv4 addresses can be

>    [RFC3704] proposes that non-PI addresses should ensure that each
>    packet is delivered to the provider related with the prefix of its
>    source address.  

This is very contorted English. Maybe:

   [RFC3704] requires that sites using non-PI addresses should ensure that each
   packet is delivered to the provider whose prefix matches its source address.

>   These routers maintain as many parallel routing tables
>    as valid source prefixes are, 

--> These routers maintain as many parallel routing tables
   as there are valid source prefixes,

>    It is worth to note that 

--> It is worth noting that

>   In particular, the use of HBA/CGA prevents on-path and
>    off-path attackers to introduce new locators in the locator set of a
>    Shim6 context, preventing redirection attacks [RFC4218]. 

--> In particular, the use of HBA/CGA prevents on-path and
   off-path attackers injecting new locators into the locator set of a
   Shim6 context, thus preventing redirection attacks [RFC4218].

  == Outdated reference: A later version (-02) exists of
     draft-nordmark-shim6-esd-01

---

From: Alberto García <[email-masked]>
Date: Wed, 6 Oct 2010 11:56:10 +0200

Hi
Thanks for your review! I include your comments for the next version of the
draft.

Comments inline:

|  -----Mensaje original-----
|  De: [email-masked] [mailto:[email-masked]] En nombre de
|  Brian E Carpenter
|  Enviado el: martes, 05 de octubre de 2010 1:51
|  Para: Geoff Huston
|  CC: [email-masked];
[email-masked];
|  shim6
|  Asunto: Re: [shim6] Working Group Last Call
draft-ietf-shim6-applicability
|  
|  Hi,
|  
|  I believe this draft is ready for the IESG. I've noted some minor
|  points below, which could be fixed now or later.
|  
|       Brian
|  
|  Nits and editorial:
|  ===================
|  
|  >    This document may contain material from IETF Documents or IETF
|  >    Contributions published or made publicly available before November
|  >    10, 2008.
|  
|  Do we need this bit of legal junk? Unless there is specific old
|  material and its authors are not available to say "OK", there is
|  no need for this. So which old material written by who is included?

Yes, we don't need this part. I change the ipr claim so that this does not
appear.

|  
|  > Regarding to the outbound traffic to H,
|  
|  --> Regarding the outbound traffic to H,
|  
|  > IPv4 addressed can be
|  
|  --> IPv4 addresses can be
|  
|  >    [RFC3704] proposes that non-PI addresses should ensure that each
|  >    packet is delivered to the provider related with the prefix of its
|  >    source address.
|  
|  This is very contorted English. Maybe:
|  
|     [RFC3704] requires that sites using non-PI addresses should ensure
that each
|     packet is delivered to the provider whose prefix matches its source
address.
|  
|  >   These routers maintain as many parallel routing tables
|  >    as valid source prefixes are,
|  
|  --> These routers maintain as many parallel routing tables
|     as there are valid source prefixes,
|  
|  >    It is worth to note that
|  
|  --> It is worth noting that
|  
|  >   In particular, the use of HBA/CGA prevents on-path and
|  >    off-path attackers to introduce new locators in the locator set of a
|  >    Shim6 context, preventing redirection attacks [RFC4218].
|  
|  --> In particular, the use of HBA/CGA prevents on-path and
|     off-path attackers injecting new locators into the locator set of a
|     Shim6 context, thus preventing redirection attacks [RFC4218].

Made all these changes, thanks again

|  
|    == Outdated reference: A later version (-02) exists of
|       draft-nordmark-shim6-esd-01

Umm. I have a problem with this. I had already noticed that the 'nits' shown
by the IETF tools show 
  == Outdated reference: A later version (-02) exists of
     draft-nordmark-shim6-esd-01 

However, when I look for the -02 document, I cannot find it. For example,
https://datatracker.ietf.org/doc/draft-nordmark-shim6-esd/ refers to version
-01
In tools.ietf.org, only -01 is available
(http://tools.ietf.org/id/draft-nordmark-shim6-esd-01.txt - if 02 is tried,
it is redirected to 01)
Google cannot find the document for me, too.
So, it is not clear to me whether I should use 01 or 02 in the citation.

Regards,
Alberto

|  
|  _______________________________________________
|  shim6 mailing list
|  [email-masked]
|  https://www.ietf.org/mailman/listinfo/shim6

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 07 Oct 2010 11:01:29 +1300

> So, it is not clear to me whether I should use 01 or 02 in the citation.

Wow! That looks like a bug in the database used by idnits, since there is
indeed no trace of a -02 version anywhere. Not your problem.

   Brian

---

From: Geoff Huston <[email-masked]>
Date: Tue, 26 Oct 2010 08:30:47 +1100

The authors have submitted a new version of the draft that addresses the comments received in the WG last Call.

I believe that we have a sufficient level of consensus here to direct this draft onward to the IESG

thanks all

  Geoff

On 01/10/2010, at 5:41 PM, Geoff Huston wrote:

> _______________________________________________
> shim6 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/shim6

--

Geoff Huston
Chief Scientist, APNIC

+61 7 3858 3100
[email-masked]