Subject: [sidr] WG LC for draft-ietf-sidr-signed-object-01

From: Sandra Murphy <[email-masked]>
Date: Fri, 5 Nov 2010 16:11:42 -0400 (EDT)

The authors of draft-ietf-sidr-signed-object-01 
(http://tools.ietf.org/html/draft-ietf-sidr-signed-object-01) have 
requested a working group last call.

The chairs ask the working group to consider this draft and decide if it 
is worthy of publication.

This draft has not been through a last call before and next week is the 
IETF week, so the last call will end on 26 November.

--Sandy

---

From: Sandra Murphy <[email-masked]>
Date: Fri, 5 Nov 2010 16:13:03 -0400 (EDT)

OOPS, forgot the obligatory:

--Sandy, wg homburg on

On Fri, 5 Nov 2010, Sandra Murphy wrote:

> (http://tools.ietf.org/html/draft-ietf-sidr-signed-object-01) have requested 
> a working group last call.
>
> The chairs ask the working group to consider this draft and decide if it is 
> worthy of publication.
>
> This draft has not been through a last call before and next week is the IETF 
> week, so the last call will end on 26 November.
>
> --Sandy
> _______________________________________________
> sidr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidr
>

---

From: Sean Turner <[email-masked]>
Date: Mon, 08 Nov 2010 13:28:54 +0800

> IETF week, so the last call will end on 26 November.

I have read this draft and support progressing it down the publication path.

spt

---

From: Sean Turner <[email-masked]>
Date: Mon, 08 Nov 2010 13:36:20 +0800

>> The chairs ask the working group to consider this draft and decide if
>> it is worthy of publication.
>>
>> This draft has not been through a last call before and next week is
>> the IETF week, so the last call will end on 26 November.

One minor nit: [I-D.sidr-rpki-algs] should point to 
draft-ietf-sidr-rpki-algs instead of draft-huston-sidr-rpki-algs.

spt

---

From: Geoff Huston <[email-masked]>
Date: Mon, 8 Nov 2010 23:10:30 +1100

On 06/11/2010, at 7:11 AM, Sandra Murphy wrote:

> The authors of draft-ietf-sidr-signed-object-01 (http://tools.ietf.org/html/draft-ietf-sidr-signed-object-01) have requested a working group last call.
> 
> The chairs ask the working group to consider this draft and decide if it is worthy of publication.
> 
> This draft has not been through a last call before and next week is the IETF week, so the last call will end on 26 November.
> 

I had a question about this draft that I posted to the SIDR WG mailing list on the 8th October. 

----------------
I am a little confused in reading section 4 of this draft.

The intro to this section states that:

 "Each RPKI signed object MUST be defined in an Internet standards
  track document based on this profile, by specifying the following
  data elements and validation procedure:"

My question is: Why is the Content-Type Attribute listed as a distinct
data element that requires specification? 

The relevant text (item 3) states that:

 "Content-Type Attribute:  The mandatory Content-Type Attribute
  MUST have its attrValues field set to the same OID as
  eContentType in item 1."

So I understand that in writing a document that uses a RPKI signed object I
have to define the eContentType, but I DO NOT need to also define the
Content-Type Attribute. If this is the case then why is this data element
listed in Section 4 of the draft as being a data element that MUST
be separately specified in the specific object specification?

regards,

 Geoff
-------------------

I have not seen a response posted to the SIDR WG that responds to this question. Accordingly, as it stands I do not support this draft going forward until this question is resolved, as the draft as it stands is not internally consistent, imho.

thanks,

  Geoff

---

From: Andrew Chi <[email-masked]>
Date: Mon, 08 Nov 2010 10:05:09 -0500

> I had a question about this draft that I posted to the SIDR WG mailing list on the 8th October.

Thanks for catching this, Geoff.  You are correct that since the 
eContentType OID MUST equal the Content-Type Attribute, a specific 
object specification only needs to specify one, not both.  That item 
will be removed.

-Andrew

---

From: Geoff Huston <[email-masked]>
Date: Tue, 9 Nov 2010 08:25:22 +1100

> Thanks for catching this, Geoff.  You are correct that since the eContentType OID MUST equal the Content-Type Attribute, a specific object specification only needs to specify one, not both.  That item will be removed.

On the understanding that this will be corrected before the document heads to the IESG, I withdraw my objection, and support this draft gong forward.

thanks,

   Geoff

---

From: Geoff Huston <[email-masked]>
Date: Thu, 18 Nov 2010 19:14:34 +1100

> This draft has not been through a last call before and next week is the IETF week, so the last call will end on 26 November.

I support this document advancing

  Geoff