Subject: [sidr] draft-ymbk-rpki-origin-ops-00

From: Randy Bush <[email-masked]>
Date: Mon, 08 Nov 2010 13:57:25 +0800

Subject: New Version Notification for draft-ymbk-rpki-origin-ops-00
From: IETF I-D Submission Tool <[email-masked]>
To: [email-masked]
Date: Sun, 7 Nov 2010 21:55:37 -0800 (PST)

A new version of I-D, draft-ymbk-rpki-origin-ops-00.txt has been successfully submitted by Randy Bush and posted to the IETF repository.

Filename:	 draft-ymbk-rpki-origin-ops
Revision:	 00
Title:		 RPKI-Based Origin Validation Operations
Creation_date:	 2010-11-08
WG ID:		 Independent Submission
Number_of_pages: 7

Abstract:
Deployment of the RPKI-based BGP origin validation has many
operational considerations.  This document attempts to collect and
present them.  It is expected to evolve as RPKI-based origin
validation is deployed and the dynamics are better understood.

The IETF Secretariat.

---

From: Roque Gagliano <[email-masked]>
Date: Tue, 16 Nov 2010 15:46:25 +0100

Hi Randy

I have a comment on section 5 of this draft based on our experience playing with this.

When you say:
 "  Announcements with invalid origins MAY be used, but SHOULD be less
   preferred than those with valid or unknown."
It would be worthy to write a note warning that invalid announcements which are more specific that an existing valid announcement SHOULD be discarded as they will always be preferred, independently of validation state of BGP attributes (longest prefix match).

Regards,

Roque

PS: we are working on code for this feature.

On Nov 8, 2010, at 6:57 AM, Randy Bush wrote:

> Date: November 8, 2010 6:55:37 AM GMT+01:00
> To: [email-masked]
> _______________________________________________
> sidr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidr

---

From: Randy Bush <[email-masked]>
Date: Tue, 16 Nov 2010 15:54:25 +0100

> It would be worthy to write a note warning that invalid announcements
> which are more specific that an existing valid announcement SHOULD be
> discarded

could you give an example in real cisco ios or junos cli?

randy

---

From: Roque Gagliano <[email-masked]>
Date: Tue, 16 Nov 2010 16:08:21 +0100

Hi Randy,

> could you give an example in real cisco ios or junos cli?

not yet. stay tuned.

r.

---

From: Randy Bush <[email-masked]>
Date: Tue, 16 Nov 2010 16:10:46 +0100

>> could you give an example in real cisco ios or junos cli?

my point was that lengh comparison is not supported in cli, and probebly
should not be.  making a career out of unneeded complexity is not a
helpful path.

randy