Subject: [sidr] a query to the wg regarding publication draft

From: "Murphy, Sandra" <[email-masked]>
Date: Fri, 8 Nov 2013 13:25:41 +0000

Rob posed a question to the room during the meeting on Tue (Nov 5) about the publication draft.  See slides at http://www.ietf.org/proceedings/88/slides/slides-88-sidr-1.pdf.

The question to the list is:

Should the protocol be trimmed -- take out all of the “control” operations, leaving just the <publish/> and <withdraw/> operations -- or should the "control" operations be an optional sub-protocol?

What say ye?

--Sandy

---

From: Stephen Kent <[email-masked]>
Date: Fri, 08 Nov 2013 13:00:52 -0500

I'm comfortable with whichever option Rob prefers, in his role as the 
protocol designer and
principal implementer.

Steve

On 11/8/13 8:25 AM, Murphy, Sandra wrote:
> _______________________________________________
> sidr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidr
>

---

From: Tim Bruijnzeels <[email-masked]>
Date: Fri, 8 Nov 2013 11:14:44 -0800

Hi,

My opinion below..

On Nov 8, 2013, at 5:25 AM, "Murphy, Sandra" <[email-masked]> wrote:

> Should the protocol be trimmed -- take out all of the “control” operations, leaving just the <publish/> and <withdraw/> operations --

I prefer this, in standards-track.

Small, to the point, and makes it feasible for other implementations and other documents to build on this.

> or should the "control" operations be an optional sub-protocol?

I am fine with this being described in another document. I don't understand it well enough to judge whether it's re-useable by other implementations so I am not sure about which track it should be in.