Subject: Re: [sidr] jabber scribe; minutes taker; slides from presenters

From: "Murphy, Sandra" <[email-masked]>
Date: Mon, 3 Mar 2014 15:09:25 +0000

No one has yet volunteered to be either jabber scribe or minutes taker.

The meeting can't proceed without those.

Please do consider.  The etherpad collaborative tool can make the minutes taking less painful but still needs one/two/many collaborators.

--Sandy

________________________________________
From: Murphy, Sandra
Sent: Wednesday, February 26, 2014 7:18 PM
To: [email-masked]
Subject: RE: jabber scribe; minutes taker; slides from presenters

And number your slides, too.  Please.

--Sandy, speaking as wg co-chair
________________________________________
From: Murphy, Sandra
Sent: Wednesday, February 26, 2014 6:39 PM
To: [email-masked]
Subject: jabber scribe; minutes taker; slides from presenters

It would be most helpful to have the roles of jabber scribe and minutes taker set before the meeting.  If you are willing, please do speak up.

We can't proceed with the discussions and presentations without a the jabber scribe and minutes taker identified.  So if you want the meeting to proceed, speak up or urge someone to speak up.

We are meeting first thing Tuesday morning.  Anyone presenting slides should get their slides to the chairs by end of the session time on Monday.  It would be very much appreciated by those who are participating remotely.

(Anyone hoping to be first has already lost - David got his in already.)

--Sandy, speaking as co-chair

---

From: Demian Rosenkranz <[email-masked]>
Date: Mon, 03 Mar 2014 17:08:13 +0100

Hello,

I have a question regarding the possibility of using mitm attacks to 
change repository contents/the validity of signed objects and router 
certificates.

Every CA instance has a corresponding CRL and Manifest. The CRL contains 
certificates which are revoked and the Manifest contains just Signed 
Objects.

Because of the rsync protocol, a mitm attack between RP and repository 
is possible. If the attacker withholds ...

... a signed object, the rp software would recognize it by checking the 
manifest.

... a EE certificate, the rp software would recognize it, because the 
corresponding signed object can't be validated.

... a manifest/crl, the rp sofware would recognize it, because every CA 
instance has to have a manifest and a crl.

... a CA certificate and all files underneath that certificate, the rp 
software WOULDN'T recognize anything. So the whole structure underneath 
that certificate would be invalid.

... a Router certificate, the RP WOULDN'T recognize it, because it isn't 
listet in any other file.

Regonize means recognizing the missing file, not necessarily the attack. 
It could also be a mistake/bug/etc.

Are the described cases right or did I miss something? Would be great to 
get feedback.

Kind regards

Demian Rosenkranz

---

From: Andrew Chi <[email-masked]>
Date: Mon, 3 Mar 2014 11:44:39 -0500

All of these are detectable.

> that certificate would be invalid.

CA certs are listed by the manifest that sits in the same publication point
(directory).  In addition, the cert's SIA contains a URI for all of the
"children."  If the CA cert were present but "all files underneath" were
missing, the RP software would at the very least log a failure to fetch the
child directory.

> listet in any other file.

A manifest will cover anything in the directory (except itself), so that
should include router certs.

---

From: Matthew Lepinski <[email-masked]>
Date: Mon, 3 Mar 2014 12:41:49 -0500

I can take notes to help produce the minutes for the SIDR meeting on Tuesday

On Mon, Mar 3, 2014 at 10:09 AM, Murphy, Sandra
<[email-masked]>wrote:

> Please do consider.  The etherpad collaborative tool can make the minutes
> taking less painful but still needs one/two/many collaborators.
>
> --Sandy
>
> It would be most helpful to have the roles of jabber scribe and minutes
> taker set before the meeting.  If you are willing, please do speak up.
>
> We can't proceed with the discussions and presentations without a the
> jabber scribe and minutes taker identified.  So if you want the meeting to
> proceed, speak up or urge someone to speak up.
>
> We are meeting first thing Tuesday morning.  Anyone presenting slides
> should get their slides to the chairs by end of the session time on Monday.
>  It would be very much appreciated by those who are participating remotely.
>
> _______________________________________________
> sidr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidr
>

---

From: "Murphy, Sandra" <[email-masked]>
Date: Mon, 3 Mar 2014 17:50:35 +0000

>certificates which are revoked and the Manifest contains just Signed

The manifest contains every signed object (except  itself) that the CS produces.  That includes subsidiary certs, CRLS, ROAs and any other signed object.  So the certs a CA issues are also the set of "signed objects" the manifest lists.

You are probably confused by RFC6486:

  fileList:
      This field is a sequence of FileAndHash objects.  There is one
      FileAndHash entry for each currently valid signed object that has
      been published by the authority (at this publication point).

And the fact that there's an RFC called "Signed Object Template …" (RFC 6488) which is currently used to define manifests and ROAs.

In RFC6486, "signed objects" means objects that have signatures related to the CA and are published by the CA,  That includes certs and CRLs.

But in RFC 6488, "signed objects" means a subset of those objects, those that are not subsidiary CA certificates or CRLs..

--Sandy
________________________________________
From: sidr [[email-masked]] on behalf of Demian Rosenkranz [[email-masked]]
Sent: Monday, March 03, 2014 11:08 AM
To: [email-masked]
Subject: [sidr]  Man-in-the-middle attack

Hello,

Kind regards

Demian Rosenkranz

---

From: Demian Rosenkranz <[email-masked]>
Date: Mon, 03 Mar 2014 19:11:25 +0100

Ok, so I misunderstood the RFC6486:

"A manifest is a signed object that enumerates all the signed objects
(files) in the repository publication point (directory) that are
associated with an authority responsible for publishing at that
publication point."

RFC6488:
"Other information assertions about
resources are expressed via digitally signed, non-X.509 data
structures that are referred to as "signed objects" in the RPKI
context."

So, in the first sentence, "signed object" means all files which were 
signed by the CA instance and not a RPKI signed object as in the second 
one?!

Thank you for your answers.

Kind regards

Demian

Am 03.03.2014 17:44, schrieb Andrew Chi:
> On Mon, Mar 3, 2014 at 11:08 AM, Demian Rosenkranz
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>
>     ... a CA certificate and all files underneath that certificate, the
>     rp software WOULDN'T recognize anything. So the whole structure
>     underneath that certificate would be invalid.
>
>
> CA certs are listed by the manifest that sits in the same publication
> point (directory).  In addition, the cert's SIA contains a URI for all
> of the "children."  If the CA cert were present but "all files
> underneath" were missing, the RP software would at the very least log a
> failure to fetch the child directory.
>
>
>     ... a Router certificate, the RP WOULDN'T recognize it, because it
>     isn't listet in any other file.
>
>

---

From: "Murphy, Sandra" <[email-masked]>
Date: Mon, 3 Mar 2014 19:30:03 +0000

Thank you very much Matt.

The rest of you are not off the hook.  We still need a jabber scribe.  And it would be really really good to have another minutes taker to provide coverage.

--Sandy

________________________________
From: Matthew Lepinski [[email-masked]]
Sent: Monday, March 03, 2014 12:41 PM
To: Murphy, Sandra
Cc: [email-masked]
Subject: Re: [sidr] jabber scribe; minutes taker; slides from presenters

On Mon, Mar 3, 2014 at 10:09 AM, Murphy, Sandra <[email-masked]<mailto:[email-masked]>> wrote:
No one has yet volunteered to be either jabber scribe or minutes taker.

--Sandy

________________________________________
From: Murphy, Sandra
Sent: Wednesday, February 26, 2014 7:18 PM
To: [email-masked]<mailto:[email-masked]>
Subject: RE: jabber scribe; minutes taker; slides from presenters

To: [email-masked]<mailto:[email-masked]>

_______________________________________________
sidr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sidr<https://urldefense.proofpoint.com/v1/url?u=https://www.ietf.org/mailman/listinfo/sidr&k=ppNirDwWpcp60F64Pj2f9Q%3D%3D%0A&r=1r2Unu%2Fc6gYAwDNJlKNsbPY52jaSAOPXvi3DGzGJXQo%3D%0A&m=h%2Bi9Q12EhdKe6M6wCoIQK6txiLsiVsbOQ7jbFFYsb2E%3D%0A&s=70333526f42d765d53da4427403e03d5ac4c0e66963f4cc3228d6457511403e5>