Subject: [sidr] Fw: New Version Notification for draft-sriram-route-leak-problem-definition-00.txt

From: "Sriram, Kotikalapudi" <[email-masked]>
Date: Tue, 28 Oct 2014 15:55:37 +0000

Several people at the microphone at the GROW WG meeting in Toronto had suggested that we split 
the earlier document draft-sriram-route-leak-protection-00 into two parts:
 
(1) route leaks definition, and 

(2) route leaks solution proposal.

The first one is expected to be taken up in GROW, and 
the path for the second one was suggested to be IDR --> SIDR.
Accordingly, we have split our earlier single draft into two, with substantial revisions.
This (notification below) is the first of the two drafts that deals with route leaks definition. 
Your comments are welcome.

Since several people already expressed interest at the GROW meeting in Toronto (see meeting minutes), 

http://www.ietf.org/proceedings/90/minutes/minutes-90-grow
  
we would like to request the GROW chairs to post a request for WG adoption
of this problem definition draft. 
Also, I will be happy to present a brief update on this new version in Honolulu, 
if the GROW WG chairs can allocate some time in the agenda. 
Thank you.

Sriram
________________________________________
From: [email-masked] <[email-masked]>
Sent: Monday, October 27, 2014 6:28 PM
To: Danny McPherson; Montgomery, Douglas; Eric Osterweil; Sriram, Kotikalapudi; 
Subject: New Version Notification for draft-sriram-route-leak-problem-definition-00.txt

A new version of I-D, draft-sriram-route-leak-problem-definition-00.txt
has been successfully submitted by Kotikalapudi Sriram and posted to the
IETF repository.

Name:           draft-sriram-route-leak-problem-definition
Revision:       00
Title:          Problem Definition and Classification of BGP Route Leaks
Document date:  2014-10-27
Group:          Individual Submission
Pages:          9
URL:            http://www.ietf.org/internet-drafts/draft-sriram-route-leak-problem-definition-00.txt
Status:         https://datatracker.ietf.org/doc/draft-sriram-route-leak-problem-definition/
Htmlized:       http://tools.ietf.org/html/draft-sriram-route-leak-problem-definition-00

Abstract:
   A systemic vulnerability of the Border Gateway Protocol routing
   system, known as 'route leaks', has received significant attention in
   recent years.  Frequent incidents that result in significant
   disruptions to Internet routing are labeled "route leaks", but to
   date we have lacked a common definition of the term.  In this
   document, we provide a working definition of route leaks, keeping in
   mind the real occurrences that have received significant attention.
   Further, we attempt to enumerate (though not exhaustively) different
   types of route leaks based on observed events on the Internet.  We
   aim to provide a taxonomy that covers several forms of route leaks
   that have been observed and are of concern to Internet user community
   as well as the network operator community.

---

From: "Sriram, Kotikalapudi" <[email-masked]>
Date: Tue, 28 Oct 2014 16:12:10 +0000

Following up on my preceding email, this (notification below) is the second part
(after the 1 to 2 split) that documents the “route leaks solution proposal”.
This work was presented at the GROW meeting in Toronto, and it was suggested
that the path of progress for this document (solution proposal) should be through IDR to SIDR. 
I will be happy to present this work in the IDR or the joint IDR-SIDR meeting in Honolulu.
The earlier comments on this work at the GROW meeting in Toronto can be found here: 

Further comments, suggestions are welcome.

Sriram     

________________________________________
From: [email-masked] <[email-masked]>
Sent: Monday, October 27, 2014 7:01 PM
To: Sriram, Kotikalapudi; Montgomery, Douglas; 
Subject: New Version Notification for draft-sriram-route-leak-detection-mitigation-00.txt

A new version of I-D, draft-sriram-route-leak-detection-mitigation-00.txt
has been successfully submitted by Kotikalapudi Sriram and posted to the
IETF repository.

Name:           draft-sriram-route-leak-detection-mitigation
Revision:       00
Title:          Methods for Detection and Mitigation of BGP Route Leaks
Document date:  2014-10-27
Group:          Individual Submission
Pages:          13
URL:            http://www.ietf.org/internet-drafts/draft-sriram-route-leak-detection-mitigation-00.txt
Status:         https://datatracker.ietf.org/doc/draft-sriram-route-leak-detection-mitigation/
Htmlized:       http://tools.ietf.org/html/draft-sriram-route-leak-detection-mitigation-00

Abstract:
   In [I-D.ietf-sriram-route-leak-problem-definition], the authors have
   provided a definition of the route leak problem, and also enumerated
   several types of route leaks.  In this document, we first examine
   which of those route-leak types are detected and mitigated by the
   existing BGPSEC protocol [I-D.ietf-sidr-bgpsec-protocol-09].  Where
   the current BGPSEC protocol doesn't offer a solution, this document
   suggests an enhancement that would extend the route-leak detection
   and mitigation capability of BGPSEC.  The solution can be implemented
   in BGP without necessarily tying it to BGPSEC.  Incorporating the
   solution in BGPSEC is one way of implementing it in a secure way.  We
   do not claim to have provided a solution for all possible types of
   route leaks, but the solution covers several, especially considering
   some significant route-leak attacks or occurrences that have been
   observed in recent years.  The document also includes a stopgap
   method for detection and mitigation of route leaks for the phase when
   BGPSEC (path validation) is not yet deployed but only origin
   validation is deployed.