Subject: [sidr] I-D Action: draft-ietf-sidr-delta-protocol-01.txt

From: [email-masked]
Date: Mon, 19 Oct 2015 09:22:05 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Secure Inter-Domain Routing Working Group of the IETF.

        Title           : RPKI Repository Delta Protocol
        Authors         : Tim Bruijnzeels
                          Oleg Muravskiy
                          Bryan Weber
                          Rob Austein
                          David Mandelberg
	Filename        : draft-ietf-sidr-delta-protocol-01.txt
	Pages           : 15
	Date            : 2015-10-19

Abstract:
   In the Resource Public Key Infrastructure (RPKI), certificate
   authorities publish certificates, including end entity certificates,
   and CRLs to repositories on repository servers.  Relying Parties (RP)
   retrieve the published information from the repository and MAY store
   it in a cache.  This document specifies a delta protocol which
   provides relying parties with a mechanism to query a repository for
   changes, thus enabling the RP to keep its state in sync with the
   repository.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-sidr-delta-protocol/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-sidr-delta-protocol-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-sidr-delta-protocol-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Tim Bruijnzeels <[email-masked]>
Date: Wed, 21 Oct 2015 15:32:35 +0200

Hi all,

Changes in this version:
= Now using https consistently to retrieve notification, snapshot and delta files
= Simplified xml examples
= Simplified text on cache concerns
   - Leaving some of the discussion out of the document - but welcome to discuss on list
   - Lowering max time to cache 'notification.xml' to one minute only
     (enough to reduce load, and helps RPs get things faster)
= For now.. removed the hashes (checksums) for delta and snapshot files
   - an adversary who can modify snapshot/deltas fetched with https, can also modify the notification file
   - but.. we may put it back if there are other uses (file corruption, somehow?)
= Improved readability (without changing protocol)

Questions and comments welcome.

There is time planned for an update on this in Yokohama. I was *not* planning to go into an overview of the protocol again, but please let me know if you would value if I did. If there is enough interest in this then I am happy to ask the chairs for a bit more time and go over this once more, but if not then I would rather save everyone some time and only focus on the bits that changed and keep it brief.

Thanks

Tim

> On 19 Oct 2015, at 18:22, [email-masked] wrote:
> 
> 
> _______________________________________________
> sidr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidr