Subject: Re: [sidr] WGLC on draft-ietf-sidr-bgpsec-algs-11 (ENDS 30-Oct-2015)

From: Samuel Weiler <[email-masked]>
Date: Mon, 26 Oct 2015 22:57:56 -0400 (EDT)

I have read the draft and have no objections to it going forward.

Suggestions:

Section 5 talks about some of the requirements for (future) algorithm and 
key size agility, but says "The recommended procedures to implement such a 
transition of key sizes and algorithms is not specified in this document." 
(sic)  I think it would be good to cite some discussion of that, e.g. 
section 6 of -protocol.  (I'm not saying that section 6 of -protocol is 
complete or great, but it may be the best set of words we have right now.)

Nail down the initial codepoint in the IANA registry (this doc is 
creating the registry, so we can be specific).  I suggest "1".

---

From: Sean Turner <[email-masked]>
Date: Thu, 29 Oct 2015 08:51:37 +0900

On Oct 27, 2015, at 11:57, Samuel Weiler <[email-masked]> wrote:
> Section 5 talks about some of the requirements for (future) algorithm and key size agility, but says "The recommended procedures to implement such a transition of key sizes and algorithms is not specified in this document." (sic)  I think it would be good to cite some discussion of that, e.g. section 6 of -protocol.  (I'm not saying that section 6 of -protocol is complete or great, but it may be the best set of words we have right now.)

Fair ‘nuff I’ll add “, see Section 6 in [ID.sidr-bgpsec-protocol] for more information."

> Nail down the initial codepoint in the IANA registry (this doc is creating the registry, so we can be specific).  I suggest "1”.

Do you think this is a blocking issue?

I’d prefer to have IANA make the allocation and stick it in the document when it’s approved.  YMMV on this but since the registry isn’t yet created I’d rather not set an example that others might follow of making up registry names and numbers in drafts that have not yet reached consensus.

To expand on this issue though should we also reserve the low value and the high value too?  i.e., 

OLD (please forgive the formatting):

       Digest        Signature     Algorithm Suite    Specification
      Algorithm      Algorithm       Identifier          Pointer
 +----------------------------------------------------------------+
 |   SHA-256   |   ECDSA P-256   |       TBD       |   RFC 5480   |
 +----------------------------------------------------------------+

NEW:

       Digest        Signature     Algorithm Suite    Specification
      Algorithm      Algorithm       Identifier          Pointer
 +----------------------------------------------------------------+
 |   Reserved   |   Reserved   |       0x0       |   This draft   |
 +----------------------------------------------------------------+
 |   SHA-256   |   ECDSA P-256   |       TBD       |   RFC 5480   |
 +----------------------------------------------------------------+
 |   Unassigned   |   Unassigned   |   TBD..0xF       |   This draft   |
 +----------------------------------------------------------------+
 |   Reserved   |   Reserved   |      0xF       |   This draft   |
 +----------------------------------------------------------------+

spt

PS I also got some other minor nits from David that I’ll incorporate in the next version that will pop out Sunday/Monday.