Subject: [sidr] Endianness of RTR

From: Alberto Leiva <[email-masked]>
Date: Thu, 9 Aug 2018 16:40:23 -0500

Hi

Please forgive me if this is a stupid question, but

What is the endianness of the RTR protocol? (RFCs 6810 and 8210)
And why does it seem like it's not specified in the RFCs?

Thanks
Alberto

---

From: "Jakob Heitz (jheitz)" <[email-masked]>
Date: Fri, 10 Aug 2018 18:12:15 +0000

It's actually a good question, because it highlights that we don't even think about this anymore.
Perhaps https://tools.ietf.org/html/draft-newman-network-byte-order-01
should be advanced to RFC.
A: Big Endian.

Regards,
Jakob.

-----Original Message-----
From: sidr <[email-masked]> On Behalf Of Alberto Leiva
Sent: Thursday, August 9, 2018 2:40 PM
To: [email-masked]
Subject: [sidr] Endianness of RTR

Hi

Thanks
Alberto

_______________________________________________
sidr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sidr

---

From: Alberto Leiva <[email-masked]>
Date: Fri, 10 Aug 2018 13:49:44 -0500

Thank you!

"Expires August 1999"
Oops.

Though the problem might be a tad more broad than just byte order. I
actually came up with another question since yesterday:
What is the unit of the "Length of Error Text" field from the Error
Report PDU? 8-bit bytes or code points? or perhaps graphemes?

---

From: Rob Austein <[email-masked]>
Date: Thu, 16 Aug 2018 00:17:52 -0400

> Report PDU? 8-bit bytes or code points? or perhaps graphemes?

Octets.