Subject: [sidr] [Technical Errata Reported] RFC6487 (6854)

From: RFC Errata System <[email-masked]>
Date: Wed, 16 Feb 2022 09:46:58 -0800 (PST)

The following errata report has been submitted for RFC6487,
"A Profile for X.509 PKIX Resource Certificates".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6854

--------------------------------------
Type: Technical
Reported by: Corey Bonnell <[email-masked]>

Section: 4.8.1

Original Text
-------------
   The Basic Constraints extension field is a critical extension in the
   resource certificate profile, and MUST be present when the subject is
   a CA, and MUST NOT be present otherwise.

   The issuer determines whether the "cA" boolean is set.

Corrected Text
--------------
   The Basic Constraints extension field is a critical extension in the
   resource certificate profile, and MUST be present when the subject is
   a CA, and MUST NOT be present otherwise.

   If this extension is present, then the "cA" field MUST be true.

Notes
-----
The original text is contradictory. If the basicConstraints extension is prohibited in end-entity certificates, then it follows that whenever the extension is present in a certificate, that certificate is a CA certificate. If the certificate is a CA certificate, then the "cA" boolean MUST be true in all cases. It is nonsensical to allow a "cA" field value of false.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6487 (draft-ietf-sidr-res-certs-22)
--------------------------------------
Title               : A Profile for X.509 PKIX Resource Certificates
Publication Date    : February 2012
Author(s)           : G. Huston, G. Michaelson, R. Loomans
Category            : PROPOSED STANDARD
Source              : Secure Inter-Domain Routing
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: Geoff Huston <[email-masked]>
Date: Wed, 16 Feb 2022 22:22:47 +0000

Frankly I am having some trouble in understanding what is going on here. 

The original says “You can issue anything you want. IF you want to issue a CA cert then you MUST use Basic Constraints and set the CA buit. If you want to issue a EE cert then you MUST omit Basic Constraints.”

What the document does not say is “And thats the range of choices available to you” Implicitly thats what this report is trying to add, and I’m not sure that the original RFC went that far to limit the issuer’s options in this manner.

I would argue that this is not an error in the original RFC. The reporter is trying to add to the original RFC, but doing so via an errata report seems to me to be inappropriate.

Therefore I tend toward rejecting this on the basis that the report is not a report of an error in the RFC.

Geoff

> On 17 Feb 2022, at 4:46 am, RFC Errata System <[email-masked]> wrote:
>

---

From: Corey Bonnell <[email-masked]>
Date: Wed, 16 Feb 2022 22:41:41 +0000

Geoff,
If the Basic Constraints extension is omitted then it is not possible to set the "cA" field to any value, as it is a field within the Basic Constraints extension.

The original language says, "The issuer determines whether the "cA" boolean is set.". We know from the current text that the Basic Constraints extension is prohibited in end-entity certificates. Therefore, the "cA" field does not exist in an end-entity certificate. As a result, the only possible value for "cA" in all cases where the field is present is "true", as that field may only exist in CA certificates. It is an RFC 5280 profile violation if a CA certificate contains a Basic Constraints extension with a "cA" field value of false.

Thanks,
Corey

-----Original Message-----
From: Geoff Huston <[email-masked]> 
Sent: Wednesday, February 16, 2022 5:23 PM
To: RFC Errata System <[email-masked]>
Cc: George Michaelson <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Chris Morrow <[email-masked]>; [email-masked]; Corey Bonnell <[email-masked]>; [email-masked]
Subject: Re: [Technical Errata Reported] RFC6487 (6854)

Geoff

> The following errata report has been submitted for RFC6487, "A Profile 
> for X.509 PKIX Resource Certificates".
> 
> use "Reply All" to discuss whether it should be verified or rejected. 
> When a decision is reached, the verifying party can log in to change 
> the status and edit the report, if necessary.
>