Subject: Re: [Sidrops] draft-sidrops-rpkimaxlen

From: "Jakob Heitz (jheitz)" <[email-masked]>
Date: Wed, 10 Mar 2021 13:07:53 +0000

I agree that a hijack is made easier when a ROA exists without a corresponding BGP advertisement.

Implementing DDOS and RTBH as indicated in the draft is difficult without the ROAs for the required BGP announcements. As indicated in the draft, creating and distributing the ROAs required for RTBH and DDOS scrubbers is time consuming.

Note that these ROAs are not required throughout the entire BGP space, the world.
These ROAs are only needed near the AS requiring these services, thus distributing them
around the entire world, just for some local RTBH implementation is disruptive to the
rest of the world.

To help with these "limited distribution ROAs" that are required quickly, and in
a smaller space than the entire BGP space, I propose to invent a new BGP address
family to publish them. Using BGP to publish a ROA enables fast distribution
and allows to limit the distribution to only those ASes that need it.

Anybody want to help me write a draft?

Regards,
Jakob.

---

From: Randy Bush <[email-masked]>
Date: Wed, 10 Mar 2021 06:04:32 -0800

> To help with these "limited distribution ROAs" that are required
> quickly, and in a smaller space than the entire BGP space, I propose
> to invent a new BGP address family to publish them.

this belongs in idr, not an ops group

randy

---

From: Ben Maddison <[email-masked]>
Date: Wed, 10 Mar 2021 16:18:45 +0200

Hi Jakob,

> Implementing DDOS and RTBH as indicated in the draft is difficult without the ROAs for the required BGP announcements. As indicated in the draft, creating and distributing the ROAs required for RTB…
The issues with DDoS mitigations and RTBH signals are very different.

The more-specific prefixes that you originate during DDoS mitigation
have to go everywhere (in the DFZ). Hence, so does the covering ROA.

That is not generally true of RTBH-signals, which are typically intended
for consumption within a local neighborhood.
That property makes dealing with RTBH amenable to solutions based on
local policy exceptions. At least until there is something better.

> around the entire world, just for some local RTBH implementation is disruptive to the
Agreed

> and allows to limit the distribution to only those ASes that need it.
This is exactly the kind of idea that I was talking about, when I said
out-of-scope! :-)

> Anybody want to help me write a draft?
Perhaps a conversation, then a draft?

Cheers,

Ben

---

From: Di Ma <[email-masked]>
Date: Thu, 11 Mar 2021 15:34:33 +0800

Jakob,

> 2021年3月10日 21:07，Jakob Heitz (jheitz) <jheitz=[email-masked]> 写道：
> 

As I am maintaining RPSTIR the RP Software, I have been working on a feedback mechanism to enable RP to learn from BGP announcements to establish local/neighbor view. In the context of RPKI, I see those ASes sharing the same one RP are local. 

I think your proposed "limited distribution ROAs”  is going to help create local/neighbor view. 

Granted, we may have the ROA validation by RP not the router itself and should work on the interface between them.

> Anybody want to help me write a draft?

Count me in if you think an RP implementor can help. 

Di

---

From: George Michaelson <[email-masked]>
Date: Fri, 12 Mar 2021 01:07:31 +1000

Is there a role for use of AS0 ROA, to "punch out" the elements
between /len and /maxlen, that are not "wanted" in routing?

Is there a role for short-life AS0 ROA, to mark the "emergency use"
more specifics, So they can come live on the time for the AS0 to die
out or be repudiated, but not have to be announced until needed?

(C/F Randy: George: stop inventing things we don't need) also (C/F
this may not actually be a new thought bubble)\

-G

On Thu, Mar 11, 2021 at 5:34 PM Di Ma <[email-masked]> wrote:
> _______________________________________________
> Sidrops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidrops

---

From: Di Ma <[email-masked]>
Date: Thu, 11 Mar 2021 23:15:19 +0800

Interesting.

AS0 ROA is yet another thing we can take into consideration.

Di

> 2021年3月11日 23:07，George Michaelson <[email-masked]> 写道：
>