Subject: [Sidrops] [WGLC] draft-ietf-sidrops-rpkimaxlen-08 - ends 25/October/2021

From: Keyur Patel <[email-masked]>
Date: Mon, 11 Oct 2021 23:18:54 +0000

Hi Folks:

A working group last call has been requested for draft-ietf-sidrops-rpkimaxlen-08, “The Use of Maxlength in the RPKI”. Please reply to the list with your comments. The WGLC will end on October 25th, 2021.

The draft can be found at: https://datatracker.ietf.org/doc/html/draft-ietf-sidrops-rpkimaxlen-08. Authors, please reply indicating whether you're aware of any relevant IPR that hasn't been disclosed.

Regards,
Nathalie, Chris & Keyur

---

From: Job Snijders <[email-masked]>
Date: Tue, 12 Oct 2021 15:02:26 +0000

Hi everyone,

I am not aware of any IPR in relationship to this document.

Kind regards,

Job

> _______________________________________________
> Sidrops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidrops

---

From: Ben Maddison <[email-masked]>
Date: Tue, 12 Oct 2021 18:23:57 +0200

Hi Keyur,

I am not aware of any undisclosed IPR relevant to this document.

Cheers,

Ben

---

From: Amreesh Phokeer <[email-masked]>
Date: Fri, 29 Oct 2021 11:13:47 +0400

Hello Chairs,

Apologies for my late comments. I have read the document and I believe
it highlights an important loophole which operators need to know about.

I would like the authors to address the following comments:

##Editorial

[Section 3]
at the time writing --> at the time of writing
[Section 5.1]
s/considerabley/considerably
[Section 5.1(2)]
the set IP prefixes --> the set of IP prefixes

##Substantial
1. The document does not provide any guidance on how to deal with currently
existing ROAs
with maxLength.

2. The "security considerations" section is missing, all major concerns
mentioned in the draft
should move this section. e.g. Though minimal ROAs provides certain level
of protection but
can not completely eradicate the impact of forged-origin subprefix hijack
even the subprefix
is already originated.

3. Another point that can go into the "Security considerations" section:

The creation of specific ROAs (minimal ROA) for DDoS mitigation has a
trade-off,
it is revealing important information on which prefixes are protected
against DDoS and
which ones are not. While this information can potentially be obtained from
Internet Routing Registries (IRRs), having them in RPKI provides a more
precise
source of information, which inherently introduces a new attack vector.

Regards,
Amreesh Phokeer

On Tue, Oct 12, 2021 at 3:19 AM Keyur Patel <[email-masked]> wrote:

> Hi Folks:
>
>
>
> A working group last call has been requested for
> draft-ietf-sidrops-rpkimaxlen-08, “The Use of Maxlength in the RPKI”.
> Please reply to the list with your comments. The WGLC will end on October
> 25th, 2021.
>
>
>
> The draft can be found at:
> https://datatracker.ietf.org/doc/html/draft-ietf-sidrops-rpkimaxlen-08.
> Authors, please reply indicating whether you're aware of any relevant IPR
> that hasn't been disclosed.
>
>
>
> Regards,
>
> Nathalie, Chris & Keyur
>
>
>
>

-- 
Amreesh Phokeer