Subject: [Sidrops] Some question about the ASPA PDU in draft-ymbk-8210bis

From: "shenming (A)" <[email-masked]>
Date: Thu, 28 Oct 2021 08:57:24 +0000

Dear authors,

According to the Section 3 of draft-ietf-sidrops-aspa-profile-06, the ASPA content has AFI info.
But the ASPA PDU defined in draft-ymbk-8210bis doesn't have AFI info.
The two infomation is inconsistent.
Perhaps is it the missing AFI information here?

Best regards,
Ming Shen

This e-mail and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!

---

From: Di Ma <[email-masked]>
Date: Thu, 28 Oct 2021 17:16:38 +0800

Ming,

draft-ymbk-8210bis does have AFI info as described in Section 5.12 (ASPA PDU) where the FLAG indicates AFI.

However, I think you are initiating a necessary discussion here.

Section 5.12 (ASPA PDU) dose not give a instance for ASN AFI and IPv4/IPv6 address FLAG seem not be in alignment with  in which IPv4=1 and IPv6=2

I am sorta confusing when we were working on its implementation.

The authors might as well say more about this. 

Di

 [IANA-AFI]  http://www.iana.org/assignments/address-family-numbers.

> 2021年10月28日 16:57，shenming (A) <[email-masked]> 写道：
> 
> Dear authors,
>  
> _______________________________________________
> Sidrops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidrops

---

From: Randy Bush <[email-masked]>
Date: Thu, 28 Oct 2021 08:04:18 -0700

you have sent a message to me which seems to contain a legal
warning on who can read it, or how it may be distributed, or
whether it may be archived, etc.

i do not accept such email.  my mail user agent detected a legal
notice when i was opening your mail, and automatically deleted it.
so do not expect further response.

yes, i know your mail environment automatically added the legal
notice.  well, my mail environment automatically detected it,
deleted it, and sent this message to you.  so don't expect a lot
of sympathy.

and if you choose to work for some enterprise clueless enough to
think that they can force this silliness on the world, use gmail,
hotmail, ...

randy
On Thu, 28 Oct 2021 01:57:24 -0700,
shenming (A) wrote:
> 
> [1  <text/plain; us-ascii (quoted-printable)>]
> Dear authors,
> 
> [2  <text/html; us-ascii (quoted-printable)>]