Subject: [Sidrops] Grammatical errors in ASPA doc

From: "Compton, Rich A" <[email-masked]>
Date: Fri, 19 Nov 2021 22:18:38 +0000

I was just reading through the “Verification of AS_PATH Using the Resource Certificate Public Key Infrastructure and Autonomous System Provider Authorization” doc (https://datatracker.ietf.org/doc/draft-ietf-sidrops-aspa-verification/) and I noticed the following grammatical errors:

In section 1 “While such an approach has reasonable computational cost, the two side adjacencies don't provide a way to automate anomaly detection without high adoption rate..” that last phrase should be “without a high adoption rate”.

In section 1 “ This procedures uses a shared signed database…” should be “This procedure uses” or if plural it should be “These procedures use”

In section 3 “ASPA is digitally signed object that bind…” should be “ASPA is a digitally signed object that binds”

In section 3 “For a selected Customer AS SHOULD exist only single ASPA…” should be “For a selected Customer AS SHOULD exist only a single ASPA”

In section 3 “In this document we will use ASPA(AS1, AFI, [AS2, ...]) as notation to represent ASPA object...” should be “In this document we will use ASPA(AS1, AFI, [AS2, ...]) as notation to represent an ASPA object”

In section 4 “The semantics of its use is defined in next section.” should be “The semantics of its use is defined in the next section.”

In section 4 “Since an AS1 may have different set of providers in different AFI…” should be “Since AS1 may have a different set of providers in a different AFI”

In section 5 “We will use index of AS_PATH segments…” should be “We will use an index of AS_PATH segments”

In section 5.2 “When route is received from provider…” should be “When a route is received from a provider”

In section 5.2 “If I_MIN doesn't exist put the length of AS_PATH in I_MIN variable…” should be “If I_MIN doesn't exist put the length of AS_PATH in the I_MIN variable”

In section 5.3 “A route received from a RS at IX has much in common with route received from a provider.” should be “A route received from a RS at IX has much in common with a route received from a provider.”

In section 5.3 “A valid route from RS contains Upflow fragment and MAY contain Downflow fragment that contains IX AS” should be “A valid route from RS contains an Upflow fragment and MAY contain a Downflow fragment that contains IX AS”

In section 5.3 “In this case, a route will have only Upflow segment,” should be “In this case, a route will have only an Upflow segment,”

In section 6 “Authorizaion” should be “Authorization”

In section 6 “By creating an ASPA with providers set of [0],” should be “By creating an ASPA with a providers set of [0],”

In section 9 “While it may happen in theory, it's doesn't seem to be a real scenario” should be “While it may happen in theory, it doesn't seem to be a real scenario”

In section 10 “The authors wish to thank authors of…” should be “The authors wish to thank the authors of”

In section 10 “The also authors wish to thank…” should be “The authors also wish to thank”

[signature_1005930358]

Rich Compton    |     Principal Eng     |    314.596.2828
8560 Upland Drive,   Suite B  |  Englewood, CO 80112
PGP Key<https://keys.openpgp.org/vks/v1/by-fingerprint/34796C9780F5A45110C2E757058D383616AF9497>

E-MAIL CONFIDENTIALITY NOTICE: 
The contents of this e-mail message and any attachments are intended solely for the addressee(s) and may contain confidential and/or legally privileged information. If you are not the intended recipient of this message or if this message has been addressed to you in error, please immediately alert the sender by reply e-mail and then delete this message and any attachments. If you are not the intended recipient, you are notified that any use, dissemination, distribution, copying, or storage of this message or any attachment is strictly prohibited.

---

From: "Sriram, Kotikalapudi (Fed)" <[email-masked]>
Date: Mon, 22 Nov 2021 14:52:32 +0000

Hi Rich,

We are awaiting the publication of version -09. Please see:
https://mailarchive.ietf.org/arch/msg/sidrops/spTmfVH-lIfGPnjFePOLcf8E6uk/

Alexander and I have been discussing -09 revisions for the algorithms. Your suggestions for the grammatical corrections are timely.

Regards,
Sriram