Subject: [Sidrops] ASPA human notation format needed?

From: Tim Bruijnzeels <[email-masked]>
Date: Mon, 8 Nov 2021 14:47:05 +0100

Hi,

The nice work done by Oliver and team triggered me to ask the
question whether there would be value in having a well defined
human notation for ASPA object content.

As I mentioned last Friday we have added experimental ASPA
support to the new Krill release candidate. As part of this
we also invented a human readable notation for use with the
CLI:

https://krill.docs.nlnetlabs.nl/en/prototype-aspa-support/manage-aspas.html#aspa-configuration-notation

TL;DR -> two examples:

AS65000 => AS65001, AS65002(v4), AS65003(v6)
AS65001 => <none>

So, note that we assumed that we would have an explicit empty
list, rather than AS0, which is described here using '<none>'.

So, to repeat the question:
Do we think there is value in defining a notation like this?

If so, this may help operators when they use different
implementation and/or components. I am open to change..

If not, then implementations can just use their local
ways to describe.

Thanks
Tim

---

From: Job Snijders <[email-masked]>
Date: Mon, 8 Nov 2021 20:52:18 +0100

Hi Tim, others,

I think you bring up a good idea.

Should you proceed to capture this idea in an internet-draft, I’d like to
offer a recommendation how to formalise the syntax: please use ABNF (
https://datatracker.ietf.org/doc/html/rfc5234) to describe the notation
format.

With some luck, such a human notation format becomes the de facto format
(or at least an inspiration) for multiple open source/commercial BGP
implementations when they consider the CLI/UI aspect of their respective
2021-2022 ASPA projects.

Indeed, down the road this might make life easier for future operators who
wish to statically configure ASPA entries on their BGP edge routers.

Kind regards,

Job

On Mon, 8 Nov 2021 at 14:47, Tim Bruijnzeels <[email-masked]> wrote:

> _______________________________________________
> Sidrops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidrops
>

---

From: Tim Bruijnzeels <[email-masked]>
Date: Wed, 10 Nov 2021 09:56:00 +0100

Hi Job,

My initial thought on this was that it could perhaps be included in one of the
current ASPA drafts. But then I thought again..

This should most likely be an INFORMATIONAL thing - as this is really just for
convenience and not critical. And putting this in a separate draft has the
advantage that it can be really small and focussed.

So I can draft something up - probably next week - and give people something
concrete to shoot at.

Related to this we could also define notations for other object types, but
I think it would be best to keep things separate if we do.

Tim

> On 8 Nov 2021, at 20:52, Job Snijders <job=[email-masked]> wrote:
> 
> Hi Tim, others,
> 
> Should you proceed to capture this idea in an internet-draft, I’d like to offer a recommendation how to formalise the syntax: please use ABNF (
> https://datatracker.ietf.org/doc/html/rfc5234) to describe the notation format.
> 
> With some luck, such a human notation format becomes the de facto format (or at least an inspiration) for multiple open source/commercial BGP implementations when they consider the CLI/UI aspect of their respective 2021-2022 ASPA projects.
> 
> Indeed, down the road this might make life easier for future operators who wish to statically configure ASPA entries on their BGP edge routers.
> 
> Kind regards,
> 
> Job
>

---

From: Job Snijders <[email-masked]>
Date: Wed, 10 Nov 2021 11:57:02 +0100

On Wed, Nov 10, 2021 at 09:56:00AM +0100, Tim Bruijnzeels wrote:
> This should most likely be an INFORMATIONAL thing - as this is really
> just for convenience and not critical. And putting this in a separate
> draft has the advantage that it can be really small and focussed.
> 

nice!

> I think it would be best to keep things separate if we do.

agreed.

Kind regards,

Job

---

From: "Borchert, Oliver (Fed)" <[email-masked]>
Date: Wed, 10 Nov 2021 12:45:14 +0000

Hi Tim,

I am all for it. Especially when it comes to defining experimentation, using 
a well-defined human notation allows us to create nice experimentation set 
independent of tools being used.

Oliver

-----------------------------------------------
Oliver Borchert, Computer Scientist
National Institute of Standards and Technology
(Office) +1.301.975.4856
(GVoice) +1.240.668.4117

On 11/8/21, 8:49 AM, "Sidrops on behalf of Tim Bruijnzeels" <[email-masked] on behalf of [email-masked]> wrote:

    Hi,

    https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fkrill.docs.nlnetlabs.nl%2Fen%2Fprototype-aspa-support%2Fmanage-aspas.html%23aspa-configuration-notation&amp;data=04%7C01%7Coliver.borchert%40nist.gov%7C32110e0386164d4bd97408d9a2be5192%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637719761477389617%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=MVwbu%2BdXvFmMlL6yHU0M2Rz38LztbW9zdLk%2F%2BTQhhAw%3D&amp;reserved=0

    TL;DR -> two examples:

    Thanks
    Tim
    _______________________________________________
    Sidrops mailing list
    [email-masked]
    https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsidrops&amp;data=04%7C01%7Coliver.borchert%40nist.gov%7C32110e0386164d4bd97408d9a2be5192%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637719761477399577%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=Sh0qGmxQqR3pBKdDrz1xCFAiuZJdrLxE80Lq%2BQHHpdg%3D&amp;reserved=0

---

From: "Borchert, Oliver (Fed)" <[email-masked]>
Date: Wed, 10 Nov 2021 12:46:10 +0000

+1

From: Sidrops <[email-masked]> on behalf of Job Snijders <job=[email-masked]>
Date: Monday, November 8, 2021 at 2:54 PM
To: Tim Bruijnzeels <[email-masked]>
Cc: SIDR Operations WG <[email-masked]>
Subject: Re: [Sidrops] ASPA human notation format needed?

Hi Tim, others,

Should you proceed to capture this idea in an internet-draft, I’d like to offer a recommendation how to formalise the syntax: please use ABNF (
https://datatracker.ietf.org/doc/html/rfc5234<https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Frfc5234&data=04%7C01%7Coliver.borchert%40nist.gov%7C51e074c68c3b495f0bd808d9a2f15c40%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637719980403963394%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=CXF8qDIcGRk8B%2FtNr%2B7nV9tdu7s76TDoT1oWSdW9%2BZk%3D&reserved=0>) to describe the notation format.

Kind regards,

Job

On Mon, 8 Nov 2021 at 14:47, Tim Bruijnzeels <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

https://krill.docs.nlnetlabs.nl/en/prototype-aspa-support/manage-aspas.html#aspa-configuration-notation<https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fkrill.docs.nlnetlabs.nl%2Fen%2Fprototype-aspa-support%2Fmanage-aspas.html%23aspa-configuration-notation&data=04%7C01%7Coliver.borchert%40nist.gov%7C51e074c68c3b495f0bd808d9a2f15c40%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637719980403973348%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=4twzGL94wM2fQnHDibxNnJGjmgBdVT%2F2oGCOOgS7lNg%3D&reserved=0>

TL;DR -> two examples:

Thanks
Tim
_______________________________________________
Sidrops mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sidrops<https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsidrops&data=04%7C01%7Coliver.borchert%40nist.gov%7C51e074c68c3b495f0bd808d9a2f15c40%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637719980403983307%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=NOm54P8KTPyd6JR0GhS9010gF%2BdHVBsHyM4jmMMMhXg%3D&reserved=0>