Subject: Re: [Sidrops] Closed -- [WGLC] draft-ietf-sidrops-8210bis-05 - Ends 31/January/2022

From: "Borchert, Oliver (Fed)" <[email-masked]>
Date: Wed, 2 Feb 2022 16:21:16 +0000

So far we did not have the time to update the implementation to the latest changes.

Said that I am sorry to miss this last call because I would have re-requested one more editorial change that I pointed out during the previous WLC. The issue is the Flags field, which is defined twice, Once “globally” in chapter 5.1 Fields of PDU which contains the explanation on what to do for the ROA and Key handling. Then one more time in chapter 5.12 ASPA PDU.

I mentioned that already in November or December that for completeness it would make sense to add the text from 5.12 into 5.1 as it is done with the other PDU’s.

Oliver

-----------------------------------------------
Oliver Borchert, Computer Scientist
National Institute of Standards and Technology
(Office) +1.301.975.4856
(GVoice) +1.240.668.4117

From: Sidrops <[email-masked]> on behalf of Job Snijders <job=[email-masked]>
Date: Monday, January 31, 2022 at 2:41 PM
To: Keyur Patel <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Sidrops] Closed -- [WGLC] draft-ietf-sidrops-8210bis-05 - Ends 31/January/2022

Hi all,

Are any implementation reports available? I think Oliver/NIST might have one, is there another?

It might be good to confirm this before forwarding to IESG.

Kind regards,

Job

On Mon, 31 Jan 2022 at 20:09, Keyur Patel <[email-masked]<mailto:[email-masked]>> wrote:
Hi Folks,

This working group last call is closed. At this point, the draft is ready to progress further. Accordingly we will prepare a report and forward it to IESG.

Regards,
Nathalie, Chris & Keyur

From: Keyur Patel <[email-masked]<mailto:[email-masked]>>
Date: Monday, January 17, 2022 at 2:29 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [WGLC] draft-ietf-sidrops-8210bis-05 - Ends 31/January/2022

Hi Folks:

A working group last call has been re-issued for draft-ietf-sidrops-8210bis-05, “The Resource Public Key Infrastructure (RPKI) to Router Protocol, Version 2”.  All the pending edits and discusses from the previous last call has been resolved. Please reply to the list with your comments. The WGLC will end on January 31st, 2022.

The draft can be found at https://datatracker.ietf.org/doc/html/draft-ietf-sidrops-8210bis<https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-sidrops-8210bis&data=04%7C01%7Coliver.borchert%40nist.gov%7Cbbd92e19dd5847a4a12c08d9e4f18bc0%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637792548796104431%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=QYXnRLeclkKsysHhNv7gTBgeIrakz6OkikhOYcCRyMk%3D&reserved=0>. Authors, please reply indicating whether you're aware of any relevant IPR that hasn't been disclosed.

Regards,

Nathalie, Chris & Keyur

_______________________________________________
Sidrops mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sidrops<https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsidrops&data=04%7C01%7Coliver.borchert%40nist.gov%7Cbbd92e19dd5847a4a12c08d9e4f18bc0%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637792548796260653%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=HUAw64QHlEkqDje3Xev6SHOnyhoqM%2B%2B2rbtggE3UXws%3D&reserved=0>

---

From: "Borchert, Oliver (Fed)" <[email-masked]>
Date: Wed, 2 Feb 2022 16:24:03 +0000

And I forgot, as Tim so nicely said, I too do not object against the overall content of this document.
Some sorting of the text to the proper chapters as mentioned below would have been nice though.

Oliver

From: Oliver Borchert <[email-masked]>
Date: Wednesday, February 2, 2022 at 11:21 AM
To: Job Snijders <job=[email-masked]>, Keyur Patel <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Oliver Borchert <[email-masked]>
Subject: Re: [Sidrops] Closed -- [WGLC] draft-ietf-sidrops-8210bis-05 - Ends 31/January/2022

Oliver

Hi all,

Kind regards,

Job

Regards,
Nathalie, Chris & Keyur

Hi Folks:

Regards,

Nathalie, Chris & Keyur

---

From: Randy Bush <[email-masked]>
Date: Wed, 02 Feb 2022 09:09:33 -0800

> I would have re-requested one more editorial change that I pointed out
> during the previous WLC. The issue is the Flags field, which is
> defined twice, Once “globally” in chapter 5.1 Fields of PDU which
> contains the explanation on what to do for the ROA and Key
> handling. Then one more time in chapter 5.12 ASPA PDU.
> 
> I mentioned that already in November or December that for completeness
> it would make sense to add the text from 5.12 into 5.1 as it is done
> with the other PDU’s.

easy hack with no semantic impact.  anybody object if i do it?  might
wait to see if there are other bugs.

randy

---

From: Randy Bush <[email-masked]>
Date: Mon, 14 Feb 2022 04:02:51 -0800

> Said that I am sorry to miss this last call because I would have
> re-requested one more editorial change that I pointed out during the
> previous WLC. The issue is the Flags field, which is defined twice,
> Once “globally” in chapter 5.1 Fields of PDU which contains the
> explanation on what to do for the ROA and Key handling. Then one more
> time in chapter 5.12 ASPA PDU.
> 

oliver

i went to hack this and found i did not understand exactly what it is
you want.

exactly what text from 5.12?

5.1 says

The lowest-order bit of the Flags field is 1 for an announcement and 0
for a withdrawal

5.12 says

       Bit     Bit Name
       ----    -------------------
        0      AFI (IPv4 == 0, IPv6 == 1)
        1      Announce == 1, Delete == 0
        2-7    Reserved, must be zero

is it that you want 5.1 to change to

The lowest-order bit of the Flags field is 0 for IPv4 and 1 for IPv6,
and the next lowest bit is 1 for an announcement and 0 for a withdrawal

randy