Subject: multiline quoted strings

From: "Nigel Swinson" <[email-masked]>
Date: Thu, 21 Dec 2000 15:38:55 -0000

2.4.2. Strings
  <snip>

  Non-printing characters such as tabs, CR and LF, and control characters are permitted in strings. NUL ASCII 0) is not allowed in strings.

Does this mean that you are allowed to have quoted strings that span more than one line (ie contain CRLF)?  I think that the spec says that you can, but it almost hints that you can't.  (If you see what I mean... )

While I'm here and on ths subject in the same section it says:
  Note that a hashed comment or whitespace may occur in between the "text:" and the CRLF, but not within the string itself. Bracketed comments are not allowed here.
Does this mean that you can't have a /**/ after "text:" and before the CRLF?  It would seem a little strange to allow only one commenting style here.  I know that allowing only #ed comments makes it much easier to parse, but then is it not just confusing to allow one commenting style and not the other here?  Why not just allow both or neither?  

Cheers

Nigel

---

From: "Nigel Swinson" <[email-masked]>
Date: Thu, 21 Dec 2000 16:05:34 -0000

I finally found my answer in the grammer section but given that we have called the strings "quoted strings" and "multiline strings" I think it should be made more explicit in section 2.4.2 that a "quoted string" may be multiline.

?

---

From: Tim Showalter <[email-masked]>
Date: 21 Dec 2000 12:56:43 -0800

"Nigel Swinson" <[email-masked]> writes:

> I finally found my answer in the grammer section but given that we
> have called the strings "quoted strings" and "multiline strings" I
> think it should be made more explicit in section 2.4.2 that a "quoted
> string" may be multiline.

I'll see what I can do.  The document is past last call, but this is a
minor editorial change.

Tim

---

From: [email-masked]
Date: Thu, 21 Dec 2000 13:35:31 -0700 (PDT)

> I'll see what I can do.  The document is past last call, but this is a

I see no problem with doing this during the final 48 hour review prior to RFC
publication. So if you make the change as author at that point as AD I'll
approve it.

				Ned