Subject: 5233 gotcha, perhaps

From: Arnt Gulbrandsen <[email-masked]>
Date: Wed, 14 May 2008 11:30:47 +0200

Maybe I'm just being dense. Does :all correspond to user@domain, or to 
userseparatordetail@domain?

Both seem to be desirable.

If the latter, then the fairly common idiom
    if envelope :is :all "[email-masked]" { ...
is not compatible with using subaddresses.

Hm.

Arnt

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Wed, 14 May 2008 13:03:12 +0200

Alexey Melnikov writes:
> If your system allow for subaddress, then yes, you need to test :user 
> and :domain separately.

A bit of a pain... I've seen more than one guide to writing sieve 
scripts with examples like
   if address :is :all "from" "[email-masked]" { ...
and I dislike it when examples don't apply to my code.

Arnt

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 14 May 2008 11:38:58 +0100

Hi Arnt,

> userseparatordetail@domain?

:all corresponds the whole email address as supplied, i.e. to either 
user@domain or user+detail@domain.