Subject: [sieve] Quesion about managesieve BNF

From: Simon Horman <[email-masked]>
Date: Sat, 27 Feb 2010 11:47:49 +1100

Hi,

I have two minor questions about inconsistencies
in the BNF in draft-ietf-sieve-managesieve-09 and the ACAP RFC 2244.

1. In draft-ietf-sieve-managesieve-09 there is

     QUOTED-CHAR           = SAFE-UTF8-CHAR / DQUOTE QUOTED-SPECIALS

   And in RFC 2244 there is

     QUOTED-CHAR           = SAFE-UTF8-CHAR / "\" QUOTED-SPECIALS

   Or in words, draft-ietf-sieve-managesieve-09 allows DQUOTE
   as an escape character whereas RFC 2244 allows "\" as an
   escape. RFC 2244 seems to make more sense to me. Is the
   change in draft-ietf-sieve-managesieve-09 intentional?

2. In draft-ietf-sieve-managesieve-09 there is

     SAFE-UTF8-CHAR        = SAFE-CHAR / UTF8-2 / UTF8-3 / UTF8-4
                             ;; <UTF8-2>, <UTF8-3> and <UTF8-4>
                             ;; are defined in [UTF-8]

   And in RFC 2244 there is

     SAFE-UTF8-CHAR        = SAFE-CHAR / UTF8-2 / UTF8-3 / UTF8-4 /
                          UTF8-5 / UTF8-6

   I am curious to know why this change was made.

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Sat, 27 Feb 2010 11:46:46 +0100

> in the BNF in draft-ietf-sieve-managesieve-09 and the ACAP RFC 2244.

Why do you compare those? What does ACAP have to do with Managesieve?

Arnt

---

From: Alexey Melnikov <[email-masked]>
Date: Sat, 27 Feb 2010 19:37:34 +0000

>Hi,
Hi Simon,

>   change in draft-ietf-sieve-managesieve-09 intentional?
Actually this is a bug I've introduced in 
draft-ietf-sieve-managesieve-07 and it will be fixed before publication 
of this document as an RFC.
So you should assume that RFC 2244 version is correct.

>   I am curious to know why this change was made.
The new ABNF matches what is in RFC 3629, which is newer than RFC 2244.
To give you a bit more details: Unicode codepoints are 24bits, so so far 
5 or 6 octet sequences are not possible.

---

From: Simon Horman <[email-masked]>
Date: Sun, 28 Feb 2010 19:56:31 +1100

On Sat, Feb 27, 2010 at 07:37:34PM +0000, Alexey Melnikov wrote:
> draft-ietf-sieve-managesieve-07 and it will be fixed before
> publication of this document as an RFC.

Thanks, will do.

> To give you a bit more details: Unicode codepoints are 24bits, so so
> far 5 or 6 octet sequences are not possible.

Ok, that makes sense. Thanks for the clarification.

---

From: Simon Horman <[email-masked]>
Date: Mon, 1 Mar 2010 09:17:25 +1100

> Why do you compare those? What does ACAP have to do with Managesieve?

Sorry that I wasn't clearer about the reason in my original message.
draft-ietf-sieve-managesieve-09 refers to ACAP as the basis of
its atom and string formats.

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Sun, 28 Feb 2010 23:25:33 +0100

> its atom and string formats.

Oh... I'd quite forgotten that. Thanks.

Arnt