Subject: Re: [sieve] [Technical Errata Reported] RFC6558 (5561)

From: Barry Leiba <[email-masked]>
Date: Sun, 25 Nov 2018 17:17:05 -0500

This is correct; the type should be changed to "Editorial" and the
report marked as "Verified".

Barry
On Sun, Nov 25, 2018 at 4:51 PM RFC Errata System
<[email-masked]> wrote:
>
> The following errata report has been submitted for RFC6558,
> "Sieve Extension for Converting Messages before Delivery".
>
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata/eid5561
>
> --------------------------------------
> Type: Technical
> Reported by: Thomas Schmid <[email-masked]>
>
> Section: 3.2
>
> Original Text
> -------------
>        require ["mime", "fileinto", "convert"];
>        if header :mime :anychild :contenttype
>                  "Content-Type" "image/tiff"
>        {
>         if (convert "image/tiff" "image/jpeg" ["pix-x=320","pix-y=240"])
>         {
>          fileinto "INBOX.pics";
>         }
>        }
>
> Corrected Text
> --------------
>        require ["mime", "fileinto", "convert"];
>        if header :mime :anychild :contenttype
>                  "Content-Type" "image/tiff"
>        {
>         if convert "image/tiff" "image/jpeg" ["pix-x=320","pix-y=240"]
>         {
>          fileinto "INBOX.pics";
>         }
>        }
>
> Notes
> -----
> the if condition is wrapped in parentheses which is invalid sieve syntax.
>
> According to RFC5288 a test has to start with and alpha numerical identifier.
>
> Which is not true in this case. Either the parentheses need to be removed or any "anyof" or "allof" needs to be added.
>
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party
> can log in to change the status and edit the report, if necessary.
>
> --------------------------------------
> RFC6558 (draft-ietf-sieve-convert-06)
> --------------------------------------
> Title               : Sieve Extension for Converting Messages before Delivery
> Publication Date    : March 2012
> Author(s)           : A. Melnikov, B. Leiba, K. Li
> Category            : PROPOSED STANDARD
> Source              : Sieve Mail Filtering Language
> Area                : Applications
> Stream              : IETF
> Verifying Party     : IESG

-- 
Barry
--
Barry Leiba  ([email-masked])
http://internetmessagingtechnology.org/

---

From: [email-masked]
Date: Sun, 25 Nov 2018 16:19:57 -0800 (PST)

Agreed.

				Ned

> _______________________________________________
> sieve mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sieve