Subject: M3UA-06: chapter 4.4.3 ASP Auditing

From: Schwarzbauer Hanns Juergen <[email-masked]>
Date: Wed, 4 Apr 2001 12:36:18 +0200

Folks,

	we would like to receive some feedback  regarding how the SG responds to a DAUD received from an ASP dependent on the availability/restricted/congestion route state.

	Due to M3UA draft (6) the SG respond with a
		DUNA (if the route is unavailable)
		DAVA (if the route is available/uncongested)
		SCON (if the route is available/congested)

	What would happen if the route is restricted ?
		If the route is restricted/uncongested, the SG may respond with a DRST.
		If the route is restricted/congested, the SG may respond with a SCON and a DRST.
	In case of a restricted/congested route the status will change to available (due to SCON) and than to restricted (due to DRST). 

	>>>This solution is not appropriate for a restricted/congested route
	>>>You need two messages to correctly describe the state after the auditing,
	>>>instead of only one.
	>>>Furthermore SCON messages could be sent unsolicited from the SG to the ASP 
	>>>thus bringing the route back from restriced even if it was not intended.

	What about a separate audit message for congestion states only:
		Use a DAUD to audit the availability/restricted state.
		Use a DCAU (new message Congestion Audit) to audit the congestion state.
		SG respond to a DAUD with a
			DUNA (if the route is unavailable)
			DAVA (if the route is available)
			DRST (if the route is restricted)
		SG respond to a DCAU with a
			SCON (if the route is congested)
			SCON with congestion level 0(if the route is uncongested)

HannsJuergen Schwarzbauer

SIEMENS AG
Information and Communication Networks
Wireline Network Communication
Carrier Switching Networks
ICN WN CS SEN 51

Tel:	+49 89 722 24236
Fax:	+49 89 722 48212
E-mail [email-masked]
> __________________________________
> Important Note: This e-mail  may contain trade secrets or privileged, undisclosed or otherwise confidential information. If you have received this e-mail in error, you are hereby notified that any review, copying or distribution of it is strictly prohibited. Please inform us immediately and destroy the original transmittal. Thank you for your cooperation.
> 
> 
> 
> 

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 4 Apr 2001 06:03:46 -0500

Schwarzbauer,

Why not:

        DUNA          (unavailable)
        DAVA          (available/uncongested)
        DRST          (restricted/uncongested)
        DAVA + SCON   (available/congested)
        DRST + SCON   (restriced/congested)

or even

        DUNA          (unavailable)
        DAVA + SCON-0 (available/uncongested)
        DRST + SCON-0 (restricted/uncongested)
        DAVA + SCON   (available/congested)
        DRST + SCON   (restriced/congested)

That will get rid of the problem of SCON indicating available without adding
a new audit message.

--Brian

On Wed, 04 Apr 2001, Schwarzbauer Hanns Juergen wrote:

> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to [email-masked]

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

---