Subject: Re: [M3UA Issue 1] Network Appearance Sematics / Format

From: [email-masked]
Date: Fri, 28 Sep 2001 09:16:23 -0400

Brian,

I have searched through m3ua v8 and cannot find any support for your 
assertion that "RK is not allowed to span NA".

Please tell us where this restriction appears in m3ua v8.

Barry Nagelberg

"Brian F. G. Bidulock" <[email-masked]>
09/27/01 06:25 PM
Please respond to sigtran

        To:     "sigtran" <[email-masked]>
        cc:     [email-masked]
        Subject:        Re: [M3UA Issue 1] Network Appearance Sematics / Format - POLL - POLL  - 
POLL

Lyndon,

Lyndon Ong wrote:                                          (Thu, 27 Sep 
2001 13:42:23)
> 
> --- "Brian F. G. Bidulock" <[email-masked]>
> wrote:
> > > Logically, you can argue that the NA and RC are
> > > semantically different, and that while you may
> > > choose to organize separate ASs for each NA, 
> > > there may be a reason to have one AS that
> > > spans multiple NAs, in which case RC = NA is
> > > not possible.
> > 
> > Wrong.  You cannot span multiple NAs with an AS.
> > You can always have RC = NA.  Period.
> > 
> 
> I think this is debatable.  There is always the
> case where no RK is defined at the ASP, there is
> only a single AS that handles all messages sent
> to it.

It has nothing to do with whether an RK exists at
the ASP or not.  There is a 1:1 relationship between
RC and RK and RK is not allowed to span NA.
Therefore, it is always possible to establish RKs so
that there is one RK per NA, and thus one RC value
per NA value.  That RC value can equal the NA value.
Plain and simple.

--brian

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: [email-masked]
Date: Fri, 28 Sep 2001 09:24:30 -0400

Brian,

I have also searched m3ua v8 and cannot find any support for your 
assertion that "SPMC cannot span NA".

Barry Nagelberg

09/27/01 10:02 PM

        cc: 

Lyndon,

2001 17:38:33)
> Hi Brian,
> > It is precisely so that one does not need to
> > configure an RK at the ASP that RC is sent.
> 
> Oh, I mean where there is only one AS at the ASP,
> so you need neither RK nor RC there.

If you don't use RCs for ASs (you have one big AS
at the ASP), use 'em for NAs.  That's the point
of RC = NA.

> 
> > > At a higher level, though, are we putting a
> > > definition ahead of a need here?
> > > If someone wants to handle multiple NAs
> > > within a single AS, is there a reason to
> > > restrict this from being done?
> > 
> > Yes.  Because an AS (MTP-User) is defined only for
> > a single NA even in the SS7 model.  There is no need
> > to permit things outside the SS7 model.
> 
> I think we're already somewhat outside the SS7
> model ;o)  It's not hard to envision someone
> wanting to do this without having to define
> multiple ASs.

There has been no need expressed for this.  The
WG discussion on RK [Issue 15] concluded that RK
cannot be allowed to span SPMC (because there is
no concerned point code in the SNMM messages).
Because SPMC cannot span NA, RK cannot span NA
either.

It is difficult to conceive of someone not wanting
to know which SPMCs which SNMMs apply to.

So, I'm sorry, it is always possible to assign RC = NA.

Think of it this way: NA only defines the numbering
space (and format) of the point code.  Because RK and
RC can be assigned on a numbering space basis, RC = NA
is always possible.

Letting RK's, RC's and AS's span NA makes no sense.
Set RC = NA and have one big AS demuxed on NA = RC if
you want to get ridiculous.

--brian

---

---

From: Greg Sidebottom <[email-masked]>
Date: Fri, 28 Sep 2001 13:06:50 -0400

Hi Barry,

It's not to be found explicitly in Issue 8, but this was concluded in a
recent thread and I have added it to v9.  The discussion was most recently
under the thread RE: [m3ua Issue #2] Add RC and/or NA in DATA Message.  See
the e-mail from Maria-Cruz on May 9th (among others).

Hope this helps,

  Greg

----- Original Message -----
From: <[email-masked]>
To: "sigtran" <[email-masked]>
Sent: Friday, September 28, 2001 9:16 AM
Subject: Re: [M3UA Issue 1] Network Appearance Sematics / Format

> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to
[email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 28 Sep 2001 13:36:51 -0500

Barry,

The defintitions from M3UAv7 are:

  Routing Key: A Routing Key describes a set of SS7 parameters and 
  parameter values that uniquely define the range of signalling traffic 
  to be handled by a particular Application Server. Parameters within the 
  Routing Key cannot extend across more than a single SS7 Destination 
  Point Code.

  Signalling Point Management Cluster (SPMC) - The complete set of 
  Application Servers represented to the SS7 network under one specific 
  SS7 Point Code of one specific Network Appearance.  SPMCs are used to 
  sum the availability/congestion/User_Part status of an SS7 
  destination point code that is distributed in the IP domain, for the 
  purpose of supporting MTP3 management procedures at an SG.  In some
  cases, the SG itself may also be a member of the SPMC.  In this case, 
  the SG availability/congestion/User_Part status must also be taken 
  into account when considering any supporting MTP3 management actions.  

These were changed in M3UAv8 to:

  Routing Key: A Routing Key describes a set of SS7 parameters and 
  parameter values that uniquely define the range of signalling traffic 
  to be handled by a particular Application Server. Parameters within the 
  Routing Key cannot extend across more than a single Signalling Point 
  Management Cluster.

  Signalling Point Management Cluster (SPMC) - The complete set of 
  Application Servers represented to the SS7 network under a single MTP 
  entity (Signalling Point).  SPMCs are used to aggregate the 
  availability, congestion, and user part status of an MTP entity 
  (Signalling Point) that is distributed in the IP domain, for the purpose 
  of supporting MTP3 management procedures towards the SS7 network.  In 
  some

The only reason for the change was to permit an SPMC to have multiple
point codes (alias point codes) in the same NA.

Neither RK nor SPMC span NA.

--brian

[email-masked] wrote:                (Fri, 28 Sep 2001 09:24:30)
> You are currently subscribed to sigtran as: [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---