Subject: protocol Ids and port Ids

From: neeraj gupta <[email-masked]>
Date: Fri, 21 Sep 2001 14:19:24 +0200

Hi,

SCTP upper layer(s) can recognize the application (IUA/M2UA/M3UA etc ) from the port
number - which  is unique to each UA.
Also we have protocol IS which is unique to each UA.

How is the protocol ID used ( such that port ID can not be used in such  a
situation )

Thanks

Neeraj Gupta

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Lyndon Ong <[email-masked]>
Date: Fri, 21 Sep 2001 08:46:43 -0700 (PDT)

Hi Neeraj,

The protocol ID in SCTP was added at the request of
some folks in the IESG who saw a potential need in
the future to separate the functions of the port
number and protocol identification.  It is a feature
that is hoped to be useful longer term.

For example, there may be situations where you do
not use the well-known ports (there's a discussion
on a different thread on this) but still want to
identify the protocol, e.g., for filtering purposes.
Then protocol ID would allow you to identify the
protocol being transported by SCTP.

Cheers,

Lyndon

--- neeraj gupta <[email-masked]> wrote:
> You are currently subscribed to sigtran as:
> [email-masked]
> To unsubscribe send a blank email to
[email-masked]

__________________________________________________
Terrorist Attacks on U.S. - How can you help?
Donate cash, emergency relief information
http://dailynews.yahoo.com/fc/US/Emergency_Information/

---