Subject: problem related to M2PA

From: [email-masked]
Date: Tue, 25 Sep 2001 09:32:31 +0530

hi,

    I've the following questions arising from test case of M2PA interop(B9).

    1. When M2PA gets remote processor outage , does M2PA itself ABORT link or
this is the work of MTP3 ?
   (As per my understanding this should be done by MTP3)

   and the second question is
   2. what to do with data message coming from MTP3 when LPO is set ?
     a. discard the message
     b.  reset LPO and send data to peer
     c.  send message to peer but don't reset LPO

regards
manish

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Vladi Arbetov <[email-masked]>
Date: Tue, 25 Sep 2001 17:32:13 +0200

Manish,

1. I don't think MTP3 or M2PA should ABORT the link when Remote
Processor Outage is received. RPO just indicates the peer status and
shouldn't affect the link itself. 

2. LPO indicates the unavailability of the upper layer to the M2PA
layer. Getting the message from the upper layer while LPO is abnormal
and I think can indicate its availability to M2PA. This can happen when
Local Processor Outage Recovered Request from the upper layer somehow
wasn't done properly. It means misfit the statuses of the M2PA and upper
layer.
  c) Sending the message to peer without LPO reset will cause just to
discarding the message later at the peer because the RPO status and
keeps the status misfit on.
  a) Discarding the message keeps the status misfit on and this will
cause to discard all follows messages.
  b) Reset LPO and send data to peer - corrects the status misfit and
doesn't cause to message lost. 
Option b) looks to me as a proper action. 

Correct me if I'm wrong.

Regards,
Vladi Arbetov

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Posted At: Tuesday, September 25, 2001 6:03 AM
> Posted To: sigtran
> Conversation: problem related to M2PA
> Subject: problem related to M2PA
> 
> 
> 
> 
> 
> hi,
> 

> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to 
> [email-masked]
> 

---

---

From: [email-masked]
Date: Wed, 26 Sep 2001 09:41:56 +0530

HI TOM,
can you tell us that we are in right direction or not.

regards
manish

Vladi Arbetov <[email-masked]> on 09/25/2001 10:02:13 PM

Please respond to [email-masked]

To:   "sigtran" <[email-masked]>
cc:    (bcc: Manish Sharma/HSS)

Subject:  RE: problem related to M2PA

Manish,

Correct me if I'm wrong.

Regards,
Vladi Arbetov

> [email-masked]

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to
[email-masked]

---