Subject: RE: Decision needed! [SUA Issue] SS7 Hop Counter

From: [email-masked]
Date: Mon, 3 Sep 2001 09:23:08 +0300

Hi Brian,

> I absolutely do not support the removal of the SS7 Hop Counter.
> It must be there as it needs to be exchanged in support of
> the optional parameter in CR and mandatory parameter in (XL)UDT(S).
> It is orthoginal to IP Hop Counter.

Good.  Then the text I have added for SS7 Hop Counter will stay.

John

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: [email-masked]
Date: Tue, 4 Sep 2001 09:48:17 -0400

John and others,

I do have a vested interest in this, but for what its worth I do not think
removal of the SUA Hop counter is a good idea.  Some carriers with SS7
networks that are only UDT(S) capable  wished that  the UDT message had
supported this capability from the initial SCCP specification.  Given that
SUA is a new protocol, I think backward compatibility problems could be
avoided by supporting the Hop Counter in SUA from the beginning.  Also, I
don't think the IP Hop Counter makes the SUA Hop counter less important.
In the case of the SUA Hop counter, if the Hop counter expires the peer SUA
could be informed of Hop Counter violation if return on error is requested
(assuming the SUA procedures are similar to SCCP).  The cumulative
information could be used for network personal to detect SCCP/SUA loops
which would not be possible form the IP Hop Counter.

Ray

"Brian F. G. Bidulock" <[email-masked]> on 08/31/2001 12:24:19 PM

Please respond to [email-masked]

To:   "sigtran" <[email-masked]>
cc:   [email-masked] (bcc: Ray P. Singh/Telcordia)
Subject:  Re: Decision needed! [SUA Issue] SS7 Hop Counter

John,

--brian

John Loughney wrote:                                         (Fri, 31 Aug
2001 16:43:45)
> Hi all,
>
> The IP header has a Hop Counter.  While I am not stating that these
> are interchangable, a point has been made that the SS7 Hop Counter
> is redundant.
>
> Additionally, if we are looking at a backhaul of SCCP-users, it is
> doubtful that there will be many hops in which the SS7 hop counter
> would be decremented.
>
> The discussion between Brian & Gery has moved the support of the
> SS7 Hop Counter to a weak MAY.
>
> I know Brian will support the removal of the SS7 Hop Counter
> Field.  Does anyone else think that there will be problems if
> SUA does not use this parameter?
>
> I am wavering on the support of this parameter.
>
> John
>
>
> ---
> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to
[email-masked]

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to
[email-masked]

---

---

From: [email-masked]
Date: Tue, 4 Sep 2001 17:00:49 +0300

Hi Ray,

> I do have a vested interest in this, but for what its worth I 
> do not think removal of the SUA Hop counter is a good idea.  

The WG has spoke & the SS7 Hop Counter will be supported
in SUA.

Thanks,
John

---