Subject: Interop Issue

From: [email-masked]
Date: Wed, 19 Sep 2001 11:34:26 +0530

Hi,

In case of Multiple SGPs/IPSPs on the same Host, we have
come across this Interop Issue which can cause major problems
as nothing concrete has been mentioned in the UA Drafts.

Consider the scenario where we have multiple SGPs/ IPSPs on a
single stack entity and one ASP/IPSP  that wants to connect to
both the SGPs on this Stack.

The following are the 2 possible scenarios

Scenario 1)
                          Single SG Stack Entity
                           +---------------+
                           |   +-------+   |
                           |   |       |   |
                         +-|---+ SGP1  |   |
                  Assoc 1| |   |       |   |
      +--------+ ________| |   +-------+   |
      |        |/          |               |
      |  ASP 1 +           |               |
      |        |\________  |               |
      +--------+         | |   +-------+   |
                  Assoc 2| |   |       |   |
                         +-|---+ SGP2  |   |
                           |   |       |   |
                           |   +-------+   |
                           +---------------+
Scenario 2)

                          Single SG Stack Entity
                           +---------------+
                           |   +-------+   |
                           |   |       |   |
      +--------+           | +-+ SGP1  |   |
      |        |  Assoc 1  | | |       |   |
      |        +__________ | | +-------+   |
      |        |          \| |             |
      |  ASP 1 |           +X              |
      |        +__________/| |             |
      |        |  Assoc 2  | |             |
      |        |           | |             |
      +--------+           | | +-------+   |
                           | | |       |   |
                           | +-+ SGP2  |   |
                           |   |       |   |
                           |   +-------+   |
                           +---------------+

Scenario 1)
As shown above either we allow different SGP on a single stack entity to have
different server ports (defying the well known port concept)..

Scenario 2)
Or else we have multiple ports from which the ASP initiates connections.
(Here we have an ASP/IPSP which has multiple SCTP endpoints). Here the ASP has
more than one Transport Address so that it can connect to different SGP all of
which
share the common SCTP Port.

These 2 models cannot Interop so  there must be a concencus on the approach
to be followed.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Another issue which comes up alongside is related to the client/server Model...
Can a  Signaling Point (SGP/ASP/IPSP) behave as a client and a server at the
same time?

This is possible if the Signaling Point is allowed to have more than one
Transport Address.
The SP can bind on a server port (maybe the well defined port) and use more
client
ports to connect to other SPs on their listening ports(well defined ports).
Is this sort of an implementation valid?

Regards
Anshoo.

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 19 Sep 2001 02:57:16 -0500

Anshoo,

Simply use dynamic (or different) port assignments on the ASP and
the well-known port on the SG.  The ASP gets a different SGP each time
it forms an association with the SG well-known port.  The ASP may even
identify itself to the SG with ASPId.

There is no difficulty here whatsoever.  Consider it like spawning
multiple HTTP servers which all listen on port 80.

--brian

[email-masked] wrote:                     (Wed, 19 Sep 2001 11:34:26)
-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Thu, 20 Sep 2001 15:19:50 +0530

Hi Brian,

This would require the ASP to have multiple transport
addresses whenever it wants to connect to multiple SGPs
on the same stack. If there are diffrent vendors at the ASP and
the SGP side and the ASP vendor choses to have a single Transport
Address for the ASP and the SG vendor also decides to do have
a single server address for the all the SGPs on the stack
then stacks from these two vendors can never Interop.
Moreover in a earlier thread on this list "Multiple SGPs per Host"
the discussion was more inclined towards having multiple server ports
for multiple SGPs on a single stack.
Our intention was to have a concencus on which way we should head.

Regards
Anshoo.

----- Original Message -----
From: "Brian F. G. Bidulock" <[email-masked]>
To: "sigtran" <[email-masked]>
Sent: Wednesday, September 19, 2001 1:27 PM
Subject: Re: Interop Issue

> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to
[email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 20 Sep 2001 06:15:10 -0500

Anshoo,

The ASP only needs to use different local port numbers when
connecting to single well-known SG port.  I suggest you take
a look at the way TCP/IP works.  There is no problem here.

--brian

[email-masked] wrote:                            (Thu, 20 Sep 2001 15:19:50)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Songling Yang <[email-masked]>
Date: Thu, 20 Sep 2001 09:58:30 -0400

Hi Brian,

In the "Terminology" section of M3UA draft it says "An ASP contains an SCTP
endpoint...". And my understanding of an SCTP Endp is that it's uniquely
identified by the local port number. So is it possible for one ASP to have
multiple local port numbers?

Thanks,

Songling Yang
SS8 Networks Inc. http://www.ss8networks.com
Tel: 613.592.2100 ext. 3269 
Fax: 613.592.9634

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Thursday, September 20, 2001 7:15 AM
To: sigtran
Subject: Re: Interop Issue

Anshoo,

--brian

[email-masked] wrote:                            (Thu, 20 Sep 2001
15:19:50)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to
[email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 20 Sep 2001 11:30:38 -0500

Songling,

Yes, that pretty much says that there is an ASP at one end of
every SCTP association.  That's all.  The statement was not
intended to restrict an ASPs full use of local port numbers.

--brian

Songling Yang wrote:                                     (Thu, 20 Sep 2001 09:58:30)
> 
>    Hi Brian,
>    
>    In the "Terminology" section of M3UA draft it says "An ASP contains an
>    SCTP endpoint...". And my understanding of an SCTP Endp is that it's
>    uniquely identified by the local port number. So is it possible for
>    one ASP to have multiple local port numbers?
>    
>    Thanks,
>    
>    Songling Yang
>    SS8 Networks Inc. [1]http://www.ss8networks.com
>    From: Brian F. G. Bidulock [[2]mailto:[email-masked]]
>    [3]http://www.openss7.org/
>    
>    ---
>    You are currently subscribed to sigtran as: [email-masked]
> References
>    1. http://www.ss8networks.com/
>    2. mailto:[email-masked]
>    3. http://www.openss7.org/

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Lyndon Ong <[email-masked]>
Date: Thu, 20 Sep 2001 09:46:48 -0700 (PDT)

We adopted the well-known port model with SCTP
since it was a proven model for internet applications.
It assumes that the server listens on one port
but that clients can choose from a range of port 
numbers when they start up an association, as 
Brian suggests, so that the combination of source
and destination IP addresses and port numbers 
uniquely identifies the association.

Cheers,

Lyndon

--- "Brian F. G. Bidulock" <[email-masked]>
wrote:
> >    [email-masked] wrote:                   
>         (Thu, 20 Sep
> >    2001 15:19:50)
> >    >
> >    > Hi Brian,
> >    >
> You are currently subscribed to sigtran as:
> [email-masked]

__________________________________________________
Terrorist Attacks on U.S. - How can you help?
Donate cash, emergency relief information
http://dailynews.yahoo.com/fc/US/Emergency_Information/

---

---

From: [email-masked]
Date: Fri, 21 Sep 2001 19:22:14 +0530

Hi Lyndon ,

Please consider the following example
At Host 1 M3UA stack is running as ASP ( as per SG- ASP model). There are 2
different users ( SCCP and ISUP) on this Host. These are named ASP1 and ASP2.
These two ASPs are acting as Server i.e they do not initiate connection setup
and SGPs need to initiate connection setup. There is a single SCTP server
running at Host1 (at M3UA IANA port 2905). At Host2 M3UA stack is running as SG
( as per ASP - SG Model). There are 2 signalling processes ( SGP1 and SGP2 )
present on this host and are serving this SG.
SGP1 wants to connect to ASP. From Host2 SCTP connection setup is initiated from
some local port . SCTP Connection is established. At this point M3UA has no
information to relate this new connection to either ASP1 or ASP2. Later ASP1
comes UP ( i.e. it is ready for processing Management messages). M3UA needs to
notify the same to SGs that this ASP serve, So M3UA stack needs a list of SCTP
connections this ASP has and need to send ASP-UP message on all those
connections.  How does he do that ? So the basic problem is when a new
connection comes up M3UA should be able to associate that new connection with a
unique ASP + SGP.  One simple option is to associate (using some static
configuration ) a unique SCTP transport Address to a unique  ASP/ SGP. So based
on the local and remote transport addresses of the new association, M3UA can
determine which ASP + SGP pair this new connection is for. By saying that each
signalling process ( ASP/ SGP/IPSP) is identified by an SCTP endpoint current
M3UA draft does seems to suggest the same.

If we apply single Server Port scenario ( where there is only one server running
at M3UA) to the case where both SGP1 and SGP2 connects to both ASP1 and ASP2, we
have 4 associations between M3UA at ASP (host1) and M3UA at SG( Host2) and the
only thing that is different is a local port number that is randomly selected at
SCTP on SG.  I think for this case to work some more support will be needed in
protocol, where each side that establishes the connection sends a message to
help other side identify for which ASP + SGP this new connection is for ..

The same case also applies IPSP - IPSP scenario, where there are multiple APSs
present on multiple M3UA stacks acting as IPSP nodes.

Best Regards,
-Sandeep

"Anshoo Sharma" <[email-masked]> on 09/21/2001 04:07:06 PM

To:   Sandeep Mahajan/HSS@HSS
cc:

Subject:  Fw: Interop Issue

----- Original Message -----
From: "Lyndon Ong" <[email-masked]>
To: "sigtran" <[email-masked]>
Sent: Thursday, September 20, 2001 10:16 PM
Subject: Re: Interop Issue

> > [email-masked]
> > [email-masked]

---

---

From: Lyndon Ong <[email-masked]>
Date: Fri, 21 Sep 2001 15:08:49 -0700 (PDT)

Sandeep,

I'm on thin ice here since I don't actually
implement SGs or ASs...

The examples in M3UA generally describe the
case where the SG is the server, in which case
well-known port seems to work - you can reach
any SGP, and the ASP having created the 
association controls what application is being
supported, e.g., ISUP or SCCP.

In your example, where the ASP-host is the
server and each ASP serves a different function,
a single well-known port (2905) would seem to be
insufficient to establish an association directed
towards a specific type of ASP.  In that case
you would not use the well-known port and have
to configure the SG with specific port numbers
assigned to the different ASPs.

The SGP could still use dynamic port assignment
if it's identity is unimportant, otherwise you
might have to configure specific port numbers
for the SGPs as well (sounds messy but doable).

I don't at this point see any protocol enhancements
that are needed, though.

Cheers,

Lyndon

--- [email-masked] wrote:
> > > Yes, that pretty much says that there is an ASP
> at
> > > one end of
> > > every SCTP association.  That's all.  The
> statement
> > > was not
> > > intended to restrict an ASPs full use of local
> port
> > > numbers.
> > >
> > > --brian
> > >
> > > Songling Yang wrote:
> > > >    In the "Terminology" section of M3UA draft
> it
> > > says "An ASP contains an
> > > >    SCTP endpoint...". And my understanding of
> an
> > > SCTP Endp is that it's
> > > >    uniquely identified by the local port
> number.
> > > So is it possible for
> > > >    The ASP only needs to use different local
> port
> > > numbers when
> > > >    a look at the way TCP/IP works.  There is
> no
> > > problem here.
> > > >
> > > >    --brian
> > > >
> > > >    > This would require the ASP to have
> multiple
> > > transport
> > > >    > Address for the ASP and the SG vendor
> also
> > > decides to do have
> > > >    > a single server address for the all the
> SGPs
> > > on the stack
> > > >    > then stacks from these two vendors can
> never
> > > Interop.
=== message truncated ===

__________________________________________________
Do You Yahoo!?
Get email alerts & NEW webcam video instant messaging with Yahoo! Messenger. http://im.yahoo.com

---

---

From: [email-masked]
Date: Mon, 24 Sep 2001 21:58:47 +0530

Hi Lyndon,

Which of the following two in your view is correct.
1) An SCTP association is  established between an ASP (M3UA stack at ASP Node)
and SGP (M3UA stack at SG Node)
 2) An SCTP association  is established between an ASP (Signalling Process at
ASP Node e.g. ISUP) and a SGP ( Signalling Process at SG Node, e.g. MTP3/NIF).

My understanding is that option 2) is correct and it is a bit misleading to say
SCTP port 2905 is M3UA stack's well known port, as it is SGP ( i.e. User of
M3UA) and not M3UA stack that is listening for new connections.

Please correct me ..

Best Regards,
-Sandeep

Lyndon Ong <[email-masked]> on 09/22/2001 04:38:49 AM

Please respond to [email-masked]

To:   "sigtran" <[email-masked]>
cc:    (bcc: Sandeep Mahajan/HSS)

Sandeep,

Cheers,

Lyndon

__________________________________________________
Do You Yahoo!?
Get email alerts & NEW webcam video instant messaging with Yahoo! Messenger.
http://im.yahoo.com

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to
[email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 24 Sep 2001 12:07:13 -0500

Sandeep,

Then I'm sure you would find it misleading to call port 80 HTTP's port.
Following by analogy to what your say here, it should be called the
HTTP-Server or httpd port.

I think the text is perfectly clear as it is.

--brian

[email-masked] wrote:                            (Mon, 24 Sep 2001 21:58:47)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Lyndon Ong <[email-masked]>
Date: Mon, 24 Sep 2001 10:17:48 -0700 (PDT)

Hi Sandeep,

I'm going to weasel out of your question
and just say that port 2905 is by convention
the port number that you would expect to send
M3UA traffic to and to listen on for M3UA 
traffic, unless otherwise configured.

I did not say that it was the M3UA stack's
port, that seems like an implementation
issue rather than protocol.

We should probably either try to make this thread
more productive or drop it.  Is there something
that you think needs to be documented?  

Cheers,

Lyndon

---