Subject: Re: M3UA 08 - ASP Auditing

From: fangjishang <[email-masked]>
Date: Mon, 17 Sep 2001 14:44:03 +0800

Hi 
Greg, Brain
I have a doubt back to the question "ASP Auiting:The order between SCON and DAVA(DRST)  in the case of a congested SS7 destination".

1. why SCON msg must send before DAVA(DRST)?
2. Can we send SCON msg after DAVA(DRST)? If no, what is different between them?

Thanks.

fang

----- Original Message ----- 
From: "Greg Sidebottom" <[email-masked]>
To: "sigtran" <[email-masked]>
Sent: Thursday, August 16, 2001 1:59 PM
Subject: Re: M3UA 08 - ASP Auditing

> Hi Rajiv, Brian
> 
> I think we need to add Brian's understanding re the order of the audit
> responses to the M3UA draft - there is no text about the order in Issue 8.
> I propose the following line in Section 4.3.3:
> 
> "In the case of a congested SS7 destination, the SCON MUST be sent before
> the DAVA or DRST message."
> 
> Rajiv, one more response below ...
> 
> ----- Original Message -----
> From: "Duhoon, Rajiv" <[email-masked]>
> To: "sigtran" <[email-masked]>
> Sent: Wednesday, August 15, 2001 11:38 PM
> Subject: RE: M3UA 08 - ASP Auditing
> 
> 
> > Thanks Brian. See my comments below:
> >
> > -Rajiv
> >
> >
> > Rajiv,
> >
> > This has been discussed much on the list already.
> >
> > Please see comments below...
> >
> > Duhoon, Rajiv wrote:                      (Wed, 15 Aug 2001 16:24:49)
> > > Hi Greg,
> > >
> > > In section 4.3.3 "ASP Auditing" it has been mentioned that
> > >
> > > "If the SS7 destination is available and congested, the SGP
> > > responds with an SCON message in addition to the DAVA message.
> > > If the destination is restricted and congested, the SGP responds
> > > with an SCON message in addition to the DRST."
> > >
> > > 1)
> > >
> > > I want to know that if the sequence of messages is defined in such
> > > cases or these messages can be sent from SGP in any order.
> > >
> > > I think that the sequence of these messages is important otherwise if a
> > > DAVA message is received after SCON message, then how an ASP will
> > > distinguish
> > > between DAVA received in case PC status is both "congested & available"
> > > and a DAVA received when PC status is "available" only.
> >
> > The SCON must come before the DAVA or the DRST, and must be
> > followed by a DAVA or DRST.
> >
> > >
> > > 2)
> > >
> > > Do we really need to send DAVA and SCON if destination is congested and
> > > available? Doesn't "congested" status of a PC at ASP itself implies that
> > > its congested but still available.
> >
> > The SCON must come before the DAVA or the DRST, and must be
> > followed by a DAVA or DRST.
> >
> > The DAVA comes after the SCON so the ASP knows to stop waiting
> > for a DRST.
> >
> > [Rajiv] I want to know why do we need to send DAVA at all, when PC is
> > in available & congested state, only SCON should be sufficient?
> > >
> 
> [Greg] The thread we had some time ago on this topic concluded that an SCON
> is not sufficient to say the PC is available - the PC could be also be in
> the restricted and congested state.
> 
> Thanks,
> 
>     Greg
> 
> 
> > > 3)
> > >
> > > Is SGP always supposed to send an SCON message with "zero" cogestion
> level
> > > in
> > > case a DPC is no more congested or it can also send a DAVA message in
> > > response
> > > of DAUD message ?
> >
> > Don't send a SCON if there is no congestion: just send DAVA
> > or DRST.  DAVA or DRST with no SCON indicates "no congestion"
> > response to DAUD.
> >
> > [Rajiv] I am little confused here. What I understand from above text
> > is if "congestion" is removed then only DAVA is sent. So here reception
> > of DAVA means no "congestion"
> >
> > In response of my query# 1 you have mentioned that if destination is
> > "congested & available" then SCON followed by DAVA is sent. In this
> > case even after receiving DAVA I am assuming that PC status is still
> > "congested".
> >
> > We don't have any means (e.g. any timer) to distinguish between
> > DAVA message received in two different scenarios.
> > &
> > Why do we need to send DAVA at all in case PC is "congested and
> > available". SCON message should be sufficient enough.
> >
> > Nevertheless, I see no reason why you shouldn't be able send
> > SCON(0) before DAVA if you really want.  It should not confuse
> > the ASP, as the ASP is prepared to receive SCON before DAVA or
> > DRST.
> >
> > --brian
> >
> > --
> 
> 
> 
> 
> ---
> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to [email-masked]
ÿÿØ¢æ«yË«éí—+.nÇ+‰·¶‹"‚ÚÚ«ÿ²(-©ÿj·!Š÷ÿ–+-³øžµÿè®èº{.nÇ+‰·¬zwZnV§‘éšŠ[h•æ¯{û"‚ÚÚŸþ:ÓžFþ\«ŠÏç¢»^–wÂŠä³÷(

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 17 Sep 2001 03:12:32 -0500

fang,

SCON must come before DAVA/DRST during auditing.

--brian

fangjishang wrote:                                    (Mon, 17 Sep 2001 14:44:03)
> ÿÿØ¢æ«yË«éí—+.nÇ+‰·¶‹"‚ÚÚ«ÿn'n–‡$ýÖ¥•«ÿëS¢éì¹»®&Þ±éÝi¹ZžG¦j)m¢Wš½ïìŠkjøçÝ|ùr®+ÿžŠízYÞ·
> +’ÏÜ

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]