Subject: Some general queries

From: [email-masked]
Date: Thu, 20 Sep 2001 15:27:15 +0500

Hi

   I have some basic queries regarding the architecture of the IP domain 
for SS7 and the functionting of M3UA in respect to that:
1) Can two physically different nodes in an IP Domain have the same 
point code? (I feel yes but i want the confirmation)
2) How is the routing done at the SGP on the basis of DPC and SSN? How 
will the SGP know the SSN? Does it need to go and parse the payload data 
for the SSN in case of data transfer messages? 
3) Are the SSN values present in all SCCP messages? My understanding 
says they are not there in all the messages. So how do we know the SSN 
value?
4) Can more than one routing Key format be supported by a SGP at the 
same time? What i mean to say is : Can one node register a routing key 
as DPC + SIO and another as DPC + SSN with the same SGP? 
{
If yes, then how will the SGP interpret a message which is coming from 
the SS7 - whether the routing context it needs to index into the Message 
distribution table should be found from DPC + SIO or DPC + SSN?
}

This  is a general query for all the routing keys which are based on a 
member which is ouside the routing label like DPC + CIC(how do we know 
the CIC?) etc.

Regards
Vaibhav

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 20 Sep 2001 05:42:07 -0500

Vaibhav,

[email-masked] wrote:                  (Thu, 20 Sep 2001 15:27:15)
> point code? (I feel yes but i want the confirmation)

Yes.

> for the SSN in case of data transfer messages? 

If you want to route on SSN, use SUA.

> says they are not there in all the messages. So how do we know the SSN 

SUA handles this well.  M3UA does not.

> as DPC + SIO and another as DPC + SSN with the same SGP? 

Again, SUA handles this (SSN) well, M3UA does not.

> distribution table should be found from DPC + SIO or DPC + SSN?

Even though M3UA does not explicitly support this, I would expect that
one would index on DPC + SIO==SCCP + SSN.

> member which is ouside the routing label like DPC + CIC(how do we know 

The CIC is known either by provisioning or by registration.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Thu, 20 Sep 2001 15:54:37 +0500

Hi Brian
   
    What i feel is that in case of M3UA the routing key should be never 
based on DPC + SSN as we will never know what is the SSN at the M3UA 
Level? The reason SUA handles it well is because it is supposed to 
interpret the message, so it can get the SSN value from the message but 
M3UA does not interpret the message. It only gets the routing lable and 
routes according to that. To make it short, what i want to say is that : 
Is it really necessary to mention DPC + SSN as one of the possibility 
for a routing key when we can't handle it well? Can't we remove it from 
the draft? 

Regards
Vaibhav 

----- Original Message -----
From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thursday, September 20, 2001 4:12 pm
Subject: Re: Some general queries

> Vaibhav,
> 
> [email-masked] wrote:                  (Thu, 20 Sep 2001 
> 15:27:15)> Hi
> > 
> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to leave-sigtran-
> [email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 20 Sep 2001 06:11:31 -0500

Vaibhav,

I understand that SSN *has* been removed from the RK in the REG REQ
and that it is mentioned only in passing in the text.  We had this
same discussion over a month ago.

--brian

[email-masked] wrote:                      (Thu, 20 Sep 2001 15:54:37)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Greg Sidebottom <[email-masked]>
Date: Thu, 20 Sep 2001 13:34:42 -0400

Hi Vaibhav,

   I can confirm that, in spite of my efforts, SSN is agreed to be removed
from the RK in Issue 9 - it is a closed issue (M3UA Issue #6).

Cheers,

  Greg
----- Original Message -----
From: "Brian F. G. Bidulock" <[email-masked]>
To: "sigtran" <[email-masked]>
Sent: Thursday, September 20, 2001 7:11 AM
Subject: Re: Some general queries

> [email-masked] wrote:                      (Thu, 20 Sep 2001
15:54:37)
> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to
[email-masked]

---