Subject: IUA link establishment

From: neeraj gupta <[email-masked]>
Date: Wed, 12 Sep 2001 11:35:00 +0200

Hi,

In IUA, if an association goes down, and then comes back up, should there be
establish_req sent
to re-establish the links also.  OR do we assume that the association went down but the
links are still
"established", therefore data transfer can be resumed.

Neeraj Gupta

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: [email-masked]
Date: Fri, 14 Sep 2001 16:13:42 +0530

Hi Neeraj,

The section 1.5.4 of the RFC says
"Likewise, if an SCTP association fails, the IUA layer on both the SG
   and ASP sides MAY generate Release primitives to take the data links
   out-of-service."

So,  the links would have to be re-established. Also, when the association goes
down, the ASP is also marked as "Down"
implying that it is not in a position to process any traffic.
By the time the ASP becomes active again, the status of the link at the SG may
no longer be establised.
So it may not be possible to resume data transfer unless  the link is also
released when the association goes down
and established again when the association comes up.

resume.

regards
harsh

neeraj gupta <[email-masked]> on 09/12/2001 03:05:00 PM

Please respond to [email-masked]

To:   "sigtran" <[email-masked]>
cc:    (bcc: Harsh Bhondwe/HSS)

Subject:  IUA link establishment

Hi,

In IUA, if an association goes down, and then comes back up, should there be
establish_req sent
to re-establish the links also.  OR do we assume that the association went down
but the
links are still
"established", therefore data transfer can be resumed.

Neeraj Gupta

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to
[email-masked]

---

---

From: Ken Morneault <[email-masked]>
Date: Fri, 14 Sep 2001 11:05:35 -0400

Neeraj,

I agree with Harsh that EST REQs should be sent (after ASP Active / 
ASP Active Ack exchange) in order to ensure the D channels are 
established.   

Regards,

Ken

At 04:13 PM 9/14/01 +0530, you wrote:

>You are currently subscribed to sigtran as: [email-masked]

---