Subject: RE: [M3UA Issue #1] NA definition

From: [email-masked]
Date: Mon, 3 Sep 2001 08:36:38 +0300

Hi Javier,

> Yes, we can clarify it in that way. How about:
> 
> Network Appearance: The Network Appearance is a local 
> reference (tipically an integer) that together with an SPC 
> uniquely identifies an SS7 node (Signaling Point Code) by 
> indicating the specific SS7 network it belongs to.[...]
> 
> I've just added "local" before "reference" to indicate that 
> SG can assign the NA independently of the rest of the nodes.

I think that is a good start, but "typically" is the correct
spelling :)

John

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Wed, 5 Sep 2001 18:13:24 +0200

Hi Brian,

This definition does NOT restrict NA haveing one value for one network in all situations. That is implementation dependant.

BR // Javier.

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Friday, August 31, 2001 9:36 PM
> To: sigtran
> Subject: Re: [M3UA Issue #1] NA definition
> Importance: High
> 
> 
> John,
> 
> I can accept an NA definition which does not restrict NA to having
> one value for one network in all situations.  The case in point is
> the multiple PC, multiple network attachment scenario.  This is not
> expected to be a common case, but if the NA definition allows the
> flexibility to assign multiple values of NA to one network where
> required, I don't see a problem.  I would see a problem with a
> definition which restricts NA to have one value and one value only.
> 
> --brian
> 
> On Fri, 31 Aug 2001, John Schantz wrote:
> 
> > It would not have to be but it does seem to make the most 
> sense if an SG (or
> > set of SGs) that are "STPing" the traffic to from the same 
> network to
> > multiple adjacent nodes.  This is especially helpful for 
> SNMM, it would
> > allow the SG(s) to broadcast SNMM to all adjacent nodes 
> (communicating with
> > the network) without needing to look up which value of NA 
> it is using for
> > each adjacent node.  This is also true for regular traffic, messages
> > received on routes to the network would only need one NA 
> and this NA is
> > passed onto the adjacent nodes without the need for looking 
> up a specific NA
> > per adjacent node.  You have to admit, the admin would be a 
> lot simpler.
> > 
> > John
> > 
> > > -----Original Message-----
> > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > Sent: Friday, August 31, 2001 11:18 AM
> > > To: sigtran
> > > Cc: [email-masked]; [email-masked]
> > > Subject: Re: [M3UA Issue #1] NA definition
> > > 
> > > 
> > > Javier,
> > > 
> > > Are you attempting to form the definition so as to 
> restrict NA to one
> > > value per network?
> > > 
> > > --brian
> > > 
> > > Javier Pastor-Balbas (ECE) wrote:                          
> > > (Fri, 31 Aug 2001 18:00:09)
> > > > Hi Brian 
> > > > 
> > > > It was explained in the mail:
> > > > 
> > > > "We proposed a modification to the definition since we 
> > > agree with Barry in
> > > > that the NA should refer to networks and no to specific 
> end nodes."
> > > > 
> > > > 
> > > > BR // Javier.
> > > > 
> > > 
> > > -- 
> > > Brian F. G. Bidulock
> > > [email-masked]
> > > http://www.openss7.org/
> > > 
> > > 
> > > ---
> > > You are currently subscribed to sigtran as: 
> [email-masked]
> > > To unsubscribe send a blank email to 
> > > [email-masked]
> > > 
> > 
> > 
> > ---
> > You are currently subscribed to sigtran as: [email-masked]
> > To unsubscribe send a blank email to 
> [email-masked]
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
> 
> ---
> You are currently subscribed to sigtran as: 
> [email-masked]
> To unsubscribe send a blank email to 
> [email-masked]
> 

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 5 Sep 2001 13:12:19 -0500

Javier,

On Wed, 05 Sep 2001, Javier Pastor-Balbas (ECE) wrote:

> Hi Brian,
> 
> This definition does NOT restrict NA having one value for one network in
> all situations. That is implementation dependant.

I suggest that you add the two sentences above as a clarification
to the definition.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: "Asveren, Tolga" <[email-masked]>
Date: Wed, 5 Sep 2001 13:27:27 -0500

Hi,

If RC is added to SSNM messages, is there a need to have different NA values in the same network?

    Tolga

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Wednesday, September 05, 2001 2:12 PM
To: sigtran
Subject: Re: [M3UA Issue #1] NA definition
Importance: High

Javier,

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 5 Sep 2001 13:33:55 -0500

Tolga,

> If RC is added to SSNM messages, is there a need to have different NA values

Probably not, but this thread was attempting to
redefine NA before the RC issue was resolved.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: "Schantz, John" <[email-masked]>
Date: Wed, 5 Sep 2001 11:56:03 -0700

Tolga,
	Depends on the nodes' involved and the administrative policies of
the network operator (nodes' owner).  I think it makes sense to have a
network owner/operator take charge and set a value for a set of SGs and
their end-nodes to use for each network "appearance".  The other extreme
case is where separate NA values would be defined for each SG--end-node
pairing.  This case seems like a lot of extra work for both the SGs and
end-points.

John

> From: Asveren, Tolga [mailto:[email-masked]]
> Sent: Wednesday, September 05, 2001 1:27 PM
> To: sigtran
> Subject: RE: [M3UA Issue #1] NA definition
> 
> 
> Hi,
> 
> You are currently subscribed to sigtran as: [email-masked]

---

---

From: "Asveren, Tolga" <[email-masked]>
Date: Wed, 5 Sep 2001 13:40:36 -0500

Hi,

Thats my point, first resolve the RC issue, according to its result fate of
NA can be decided.

   Tolga

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Wednesday, September 05, 2001 2:34 PM
To: sigtran
Subject: Re: [M3UA Issue #1] NA definition
Importance: High

Tolga,

On Wed, 05 Sep 2001, Asveren, Tolga wrote:

> Hi,
> 
> If RC is added to SSNM messages, is there a need to have different NA
values
> in the same network?

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 5 Sep 2001 15:46:33 -0500

Tolga,

I agree that RC should be resolved first.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Lyndon Ong <[email-masked]>
Date: Wed, 5 Sep 2001 14:39:15 -0700 (PDT)

?? RC has been agreed to be in the DATA and SNMM 
messages, does anyone still object to this?

L. Ong

--- "Brian F. G. Bidulock" <[email-masked]>
> > > > > [email-masked]
=== message truncated ===

__________________________________________________
Do You Yahoo!?
Get email alerts & NEW webcam video instant messaging with Yahoo! Messenger
http://im.yahoo.com

---

---

From: "Asveren, Tolga" <[email-masked]>
Date: Wed, 5 Sep 2001 19:38:18 -0500

Hi,

Just to make sure, it will be there in both directions (SG to ASP, ASP to SG), right?

  Tolga

-----Original Message-----
From: Lyndon Ong [mailto:[email-masked]]
Sent: Wednesday, September 05, 2001 5:39 PM
To: sigtran
Subject: Re: [M3UA Issue #1] NA definition

L. Ong

---

---

---

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Thu, 13 Sep 2001 16:34:31 +0200

Hi there, 

We have been working out a definition for NA. The starting point has been the last definition that was proposed in the mailing list. We have tried to make it simpler and shorter to avoid controversy as much as possible.

The definition could be:

Network Appearance - The Network Appearance is a local reference (typically an integer) that together with an SPC uniquely identifies an SS7 node by indicating the specific SS7 network it belongs to. It can be used to distinguish between signaling traffic associated with different networks being sent between the SG and the ASP over a common SCTP association. An example scenario is where an SG appears as an element in multiple separate national SS7 networks and the same SPC value may be reused in different networks. 

Cheers // Javier.

---