Subject: When is DUNA sent?

From: [email-masked]
Date: Fri, 21 Sep 2001 09:30:52 +0530

Hi
    Let us consider the configuration 

                      B
                  --   |   --
                --     |      --
            D         |         A
                --     |   
                  --   |   
                      C

QUESTION 1:

A is a node in the IP world ( an ASP ).
B and C are acting as 2 SGPs which are sitting on different hosts but come under a single SG.
D is a node in the SS7 network ( a SEP )

A is connected to B only. B and C are also interconnected i.e. there is a SGP to SGP protocol between B and C. 
D can be reached through both B and C. 

Whenever A wants to send some message to D, he will send it to B. B will in turn forward it to D. 
Now my question is : If the association between B and D goes down, will DUNA be sent to A ( though D can still be reached via B - C - D) or will the path now become A - B - C - D instead of the earlier A -B - D. 

Regards
Vaibhav
---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 20 Sep 2001 23:59:37 -0500

Vaibhav,

[email-masked] wrote:                      (Fri, 21 Sep 2001 09:30:52)
>    A is connected to B only. B and C are also interconnected i.e. there
>    is a SGP to SGP protocol between B and C.
>    
>    Now my question is : If the association between B and D goes down,

B and D don't have an association: D is in the SS7 world and B is an
SG.  Therefore B and D, I assume, have an SS7 link(set) between them.
I presume that you mean: "If the links between B and D go down..."

>    will DUNA be sent to A ( though D can still be reached via B - C - D)
>    or will the path now become A - B - C - D instead of the earlier A -B
>    - D.

It is the SG implementation's choice.  This is an implementation
question.

I would suggest that you form associations between A an C so that you
can better meet performance and reliability constraints, but it is
really up to the implementation.  There are no interoperability concerns
here.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Fri, 21 Sep 2001 10:52:48 +0530

Brian

> It is the SG implementation's choice.  This is an implementation

If we take it as an implementation choice and my implementation needs it,
then i have some questions:

a)At the SGP, are we allowed to process the messages (DATA I mean) which are
coming from an ASP?
b)If we are, then what is the use in the normal scenario? All MTP linksets
are fine and there is no need to do all this processing.
c) If we are not allowed, how can i pass the message from one SGP to another
without processing the message? It is only after all the processing that I
will get the DPC contained in the message and I will be able to know that
the MTP link to that DPC is down?
d) I hope the processing decision is also not an implementation issue :):)

Regards
Vaibhav

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 21 Sep 2001 00:31:18 -0500

Vaibhav,

[email-masked] wrote:                      (Fri, 21 Sep 2001 10:52:48)
> a) At the SGP, are we allowed to process the messages (DATA I mean) which
>    are coming from an ASP?

An SGP is always allowed to process messages coming to it.  Where did you
get the idea that it might not?

> b) If we are, then what is the use in the normal scenario? All MTP linksets

Huh? All what processing?

>    without processing the message? It is only after all the processing that
>    I will get the DPC contained in the message and I will be able to know
>    that the MTP link to that DPC is down?

Where did you get the idea that an SGP would not be permitted to process
any messages that it might want to?

> d) I hope the processing decision is also not an implementation issue :):)

It certainly is.  What processors or hosts or threads of execution a message
is passed to once it has arrived at an SGP is implementation specific.  M3UA
has enough to support the interesting configuration, including the one that
your present (which is rather odd).

In general there is no reason why A should not also have an association to C.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Fri, 21 Sep 2001 11:32:01 +0530

Brian
    My terminology certainly seems to be going the wrong way today. 
    
My question was : Is the M3UA Layer at the SGP allowed to look into the routing label and the payload data of the DATA message coming from a peer ASP( the data format is the same) or will it just pass it to the MTP 3 with the help of the interworking function. 

Regards
Vaibhav

---

---

From: "Srivats P." <[email-masked]>
Date: Fri, 21 Sep 2001 11:39:11 +0500

Vaibhav,

>My question was : Is the M3UA Layer at the SGP allowed to look into
>the routing label and the payload data of the DATA message coming from
>a peer ASP( the data format is the same) or will it just pass it to the MTP 3
>with the help of the interworking function. 

If the DATA message includes the RC, you don't need to look into the
routing label/payload data. If it doesn't you *do* need to look into the
routing label/payload data to perform reverse Routing Key Lookup to
get the RC.

The need for the RC is to ensure that the ASP is "active" for the AS (RC)
from which the message originated.

Hope that helps,

Srivats

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 21 Sep 2001 01:21:37 -0500

Vaibhav,

What the SGP does with a message after it receives it from the
ASP is its own business.  It can blindly forward it to the
MTP3 NIF, it can massage it, examine it, copy it to a log file,
whatever.  This is all implementation specific.

An implementation which has a distributed MTP will likely permit
you to pass from M3UA to MTP3 interface directly at B and the
distributed MTP will handle any movement of messages between
B and C.  A non-distributed MTP will run into difficulties.

It is way outside the scope of the draft to specify the SGP-to-SGP
protocol, even where it sits in the stack.

--brian

[email-masked] wrote:                      (Fri, 21 Sep 2001 11:32:01)
>    a peer ASP( the data format is the same) or will it just pass it to
>    the MTP 3 with the help of the interworking function.
>    
>    Regards
>    Vaibhav

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Verwimp Gery <[email-masked]>
Date: Fri, 21 Sep 2001 10:02:36 +0200

Vaibhav,

To answer your original question : does B send a DUNA ?

It's not an implementation option, and you don't require an additional
association between A and C (although it is a good idea to be more robust
against failure).

B does not send a DUNA, because it has an alternative route to D via C. It
might send a DRST though, if the path via C is only there for abnormal cases
(C-link procedures in MTP). A DUNA is only sent if no more routes towards D
are available to B.

Regards,

____________________________

Gery Verwimp
> SIEMENS ATEA
> ICN D CS D5
> Tel. : +32 14 25 3424
Fax : +32 14 25 3212
mailto:[email-masked]
____________________________________

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: vrijdag 21 september 2001 7:00
To: sigtran
Subject: Re: When is DUNA sent?

Vaibhav,

[email-masked] wrote:                      (Fri, 21 Sep 2001
09:30:52)

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to
[email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 21 Sep 2001 03:12:58 -0500

Gery,

Your remarks appear confused: there are no c-links in this example;
this is between SGP of the same SG--not between SG.

--brian

Verwimp Gery wrote:                                       (Fri, 21 Sep 2001 10:02:36)
> Fax: +32 14 25 3212
> You are currently subscribed to sigtran as: [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Verwimp Gery <[email-masked]>
Date: Fri, 21 Sep 2001 10:51:38 +0200

Brian,

I was just drawing a parallel with MTP3 C-links. Going via C is no optimal
route, at least not equivalent to the direct A-B-D and should be avoided.
Therefor it may be appropriate to send DRST, which is implementation
dependent I guess. But the question was : does SGP-B send a DUNA ? Just
because both SGP-B and -C belong to the same SG, they have to present a
consistent overall SG-view of the connectivity to SS7, right ? Therefor, I
think SGP-B MUST NOT send DUNA(D), because the SG has not lost connectivity
to D.

But I admit it's a strange config.

Gery Verwimp
Fax : +32 14 25 3212

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: vrijdag 21 september 2001 10:13
To: sigtran
Subject: Re: When is DUNA sent?

Gery,

--brian

Verwimp Gery wrote:                                       (Fri, 21 Sep 2001
10:02:36)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 21 Sep 2001 04:39:02 -0500

Verwimp,

Verwimp Gery wrote:                                       (Fri, 21 Sep 2001 10:51:38)
> think SGP-B MUST NOT send DUNA(D), because the SG has not lost connectivity

What is "connectivity"?  An SG implementation which chooses to not
route heavy traffic between B and C may very well send DUNA (and
the ASP will interpret this as SG-wide DUNA).  Whether it does or
not, and in reaction to which internal configuration changes is
SG-implementation specific.

> But I admit it's a strange config.

More interesting in the SGP paritioning case (where SGPs loose inter-SGP
communication).  This was already discussed at some length.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---