Subject: [M3UA Issue #3]: SG/SGP Management

From: Lyndon Ong <[email-masked]>
Date: Tue, 11 Sep 2001 14:25:57 -0700 (PDT)

Folks,

Turning to Issue #3, the issue as listed by Greg is

3) SSNM messages semantics at the SGP or SG level.    
    Status: Open

Options:  SSNM messages apply to each SGP (current) or
SG-wide 
(previous).
Or define an new SG-level message set (extension
draft?)

We need to get into more detail about what the issue
is and what changes are being proposed.

Comparing the text from v6 and v8, the main change 
was to change "SG" to "SGP" in several instances,
so can I assume that the proposal is to change this
back to "SG"?

Secondarily, there is also a proposal on the table to
add a notification from the SGP to the ASP that it is
no longer able to support an AS, so that it can 
"gracefully" go out of service.  This could be either
an ASPIA ACK or a NOTIFY message depending on 
people's preference.  In the email thread, as far
as I could tell there was some leaning for ASPIA
ACK, although IMHO NOTIFY seems like it might be
a better choice as it fits into the current definition
of "an autonomous indication of M3UA events to an
M3UA peer".

Comments, please.

Cheers,

L. Ong

__________________________________________________
Do You Yahoo!?
Get email alerts & NEW webcam video instant messaging with Yahoo! Messenger
http://im.yahoo.com

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Greg Sidebottom <[email-masked]>
Date: Thu, 13 Sep 2001 02:21:49 -0400

Hi Lyndon,

One response below,

----- Original Message -----
From: "Lyndon Ong" <[email-masked]>
To: "sigtran" <[email-masked]>
Sent: Tuesday, September 11, 2001 5:25 PM
Subject: [M3UA Issue #3]: SG/SGP Management

> of "an autonomous indication of M3UA events to an

Its probably not a big difference but I propose we go with ASPIA Ack.  As
Brian has pointed out, there is a precedent in the ASP Down procedures:

     " If the ASP receives an ASP Down Ack without having sent an ASP Down
message, the ASP should now consider itself as in the ASP-DOWN state.
If the ASP was previously in the ASP-ACTIVE or ASP-INACTIVE state, the
ASP should then initiate procedures to return itself to its previous
state."

I agree with Brian that it is consistent to add equivalent text for the ASP
Inactive procedure:

    " If the ASP receives an ASP Inactive Ack without having sent an ASP
Inactive
message, the ASP should now consider itself as in the ASP-INACTIVE state.
If the ASP was previously in the ASP-ACTIVE state, the ASP should then
initiate
procedures to return itself to its previous state. "

So this would cover the error case (an out-of-the-blue ASPIA Ack) and also
the "graceful" SGP-intiated shutdown.

Cheers,

    Greg

> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to
[email-masked]

---

---

From: "Gradischnig, Klaus" <[email-masked]>
Date: Wed, 19 Sep 2001 15:58:05 -0500

Lyndon,

SSNM messages should have SG wide significance.

Klaus

> -----Original Message-----
> From: Lyndon Ong [mailto:[email-masked]]
> Sent: September 11, 2001 5:26 PM
> To: sigtran
> You are currently subscribed to sigtran as: 
> [email-masked]

---