Subject: RE: M3UA: DATA message should never be sent on stream 0

From: Tim Vetter <[email-masked]>
Date: Thu, 27 Sep 2001 18:14:33 -0500

Brian,

I like your solution of adding this sentense to M3UA:
	DATA messages SHOULD be sent on a SCTP stream
	other than stream '0'.

I think response to maintenance events would be much faster
if DATA messages were not going over the same stream.  This
sentense also implies that implementations should support
more than just stream 0.

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Thursday, September 27, 2001 4:03 PM
To: Tim Vetter
Cc: Ken Morneau
Subject: Re: M3UA: DATA message should never be sent on stream 0

Tim,

I have no problem with a "SHOULD" there...  Something
like:

	DATA messages SHOULD be sent on a SCTP stream
	other than stream '0'.

I think that was pretty much assumed anyways.

However, what problems can this possibly cause for the
receiver?  UA receivers can easily demultiplex received
messages by message class and should not rely upon the
stream upon which the message was received to indicate
anything.

--brian

On Thu, 27 Sep 2001, Tim Vetter wrote:

> We have been doing some interop with M3UA.
> I would like to push for adding to the M3UA
> specification that DATA messages for M3UA
> should never be sent on stream 0.  It would
> seems that stream 0 should be reserved for
> management-type messages.
>

--
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Greg Sidebottom <[email-masked]>
Date: Fri, 28 Sep 2001 00:30:57 -0400

Tim, Brian,

   I agree - I 'd add that this should apply also to M2UA and SUA as well.
I suggest that an appropriate place is Section 4.1.1 end of 4th paragraph).

     "In addition, the message needs to be sent on the appropriate SCTP
      stream, again taking care to meet the message sequencing needs of
      the signalling application. DATA messages SHOULD be sent on an
      SCTP stream other than stream '0'."

Cheers,

   Greg Sidebottom

----- Original Message -----
From: "Tim Vetter" <[email-masked]>
To: "sigtran" <[email-masked]>
Sent: Thursday, September 27, 2001 7:14 PM
Subject: RE: M3UA: DATA message should never be sent on stream 0

Brian,

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Thursday, September 27, 2001 4:03 PM
To: Tim Vetter
Cc: Ken Morneau
Subject: Re: M3UA: DATA message should never be sent on stream 0

Tim,

--brian

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to
[email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 27 Sep 2001 23:59:34 -0500

Greg,

Sounds good.  Thanx.

--brian

Greg Sidebottom wrote:                                       (Fri, 28 Sep 2001 00:30:57)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Fri, 28 Sep 2001 10:47:23 +0300

Hi Greg,

>    I agree - I 'd add that this should apply also to M2UA and 
> SUA as well. I suggest that an appropriate place is Section 4.1.1 end of 
> 4th paragraph).
> 

That sounds good for SUA as well.

John

---