Subject: [SUA issue 15]: Segmentation/Reassembly/Sequencing part 5

From: [email-masked]
Date: Thu, 6 Sep 2001 12:03:37 +0300

Hi Sandeep,

> For this issue, SUA will make no requirements nor any
> restrictions.
> 
> Sandeep >> I think these two terms are conflicting. For 
> example if there is no restriction if a originating IPSP 
> can segment or not. It becomes a requirement on 
> the receiving IPSP side to support reassembly at least. So 
> responsibilities need to be assigned in this case.

I'd suggest that if the receiving side does not support
reassembly, then it can send an 'segmentation not 
supported' error.

John

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: [email-masked]
Date: Thu, 6 Sep 2001 16:35:06 +0530

Hi ,

Again moving some related text from other thread on the issue of allowing
originating IPSP to perform segmentation of CLDT message.

*****
Should SUA implementation perform and be allowed to perform segmentation be in
an IPSP case >
>> Benefits
An implementation may very well want to segment long CLDT into pieces for better
SCTP stream HOL blocking and IP fragmentation performance.
>> Issues
In a all IP network  SCTP should be best suited for segmentation/reassembly. IMO
segmentation by application for better SCTP stream HOL blocking and better IP
fragmentation performance is not a established fact and needs to be proved.

****
I agree with John's remarks here.  The draft should neither place requirements
nor restrictions in this regard.
*****

Sandeep >> Why do you want specification to be silent on this ? I think if there
are scenarios where one or the other option will be useful, these can be listed
and implementation be allowed to choose what suits them best. At the same time
implementation at other end need to be ready for whatever option is chosen by
first side. So I do not think it will not be enough to say SUA puts no
restriction and no requirement. More specifically saying if there is no
restriction for originating IPSP to allow/disallow segmentation; receiving IPSP
side will have to support reassembly. Are there compelling reasons to allow
originating IPSP side to perform segmentation ?

*****
Sandeep, I was really talking CO here.  In this case segmentation and reassembly
is required at the IPSP to support "streamed" connections.
*****

Can I say "SUA at originating IPSP node should not perform segmentation of CLDT
message" , hence there is no need for terminating IPSP to support reassembly of
CLDT messages.

Best Regards,
-Sandeep

[email-masked] on 09/06/2001 03:33:37 PM

Please respond to [email-masked]

To:   "sigtran" <[email-masked]>
cc:    (bcc: Sandeep Mahajan/HSS)

Subject:  [SUA issue 15]: Segmentation/Reassembly/Sequencing part 5

Hi Sandeep,

John

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to
[email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 6 Sep 2001 06:26:54 -0500

Sandeep,

> message" , hence there is no need for terminating IPSP to support reassembly of

I already said this in text in the last note to John on this thread.

Something like: The IPSP SHOULD NOT segment N-UNITDATA from the local user
into CLDT messages sent to the peer.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Thu, 6 Sep 2001 14:34:59 +0300

Hi Brian & Sandeep

> Sandeep, I was really talking CO here.  In this case 
> segmentation and reassembly is required at the IPSP to 
> support "streamed" connections.
> *****
> 
> Can I say "SUA at originating IPSP node should not perform 
> segmentation of CLDT message" , hence there is no need for 
> terminating IPSP to support reassembly of CLDT messages.

I think that the IPSP does not need to support segmenting,
but does need to support sequencing.  Correct?

John

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 6 Sep 2001 06:51:47 -0500

John,

> but does need to support sequencing.  Correct?

Correct for CL, incorrect for CO.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Thu, 6 Sep 2001 18:07:01 +0530

John ,

[email-masked] on 09/06/2001 06:04:59 PM

Subject:  RE: [SUA issue 15]: Segmentation/Reassembly/Sequencing part 5

Hi Brian & Sandeep

Sandeep >> Do you mean to say reassembly ?
Brian suggested following text
'The IPSP SHOULD NOT segment N-UNITDATA from the local user into CLDT messages
sent to the peer.'
So if originating side never segments, why should terminating side support
reassembly ? we can consider changing SHOULD to MUST to make it more clear.

John

---

---