Subject: [SUA] routing context in data message

From: Manish Rajpal <[email-masked]>
Date: Wed, 19 Sep 2001 13:48:17 +0530

hi
I have a question regarding the inclusion of list of Routing context in SUA
data messages as specified by draft 07. Why is it that we keep a list of RC
when we are sending data to just one. or is it that i am mistaken.

Another is regarding SSNM messages,
this is SCON message as shown in draft
       0                   1                   2                   3
       0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |         Tag = 0x0001          |             Length            |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |          Tag = 0x0006         |            Length             |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      /                       Routing Context                         /
      \                                                               \
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      /                     Destination Address                       /
      \                                                               \
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |         Tag = 0x000F          |             Length            |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |                       Congestion Level                        |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |         Tag = 0x0004          |             Length            |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      /                          Info String                          /
      \                                                               \
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

i wonder why we have two tags before RC and none preceding dest. addr?

regards
m@nish

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: [email-masked]
Date: Wed, 19 Sep 2001 11:31:33 +0300

Hi Manish,

> I have a question regarding the inclusion of list of Routing 
> context in SUA data messages as specified by draft 07. Why is it 
> that we keep a list of RC when we are sending data to just one,
> or is it that i am mistaken.

Routing Contexts can be considered as an index into a table of
Routing Keys.  When sending data, a node may have have signaling
connections to more than one peer, and needs to discriminate 
where to send the message to.  
 
> Another is regarding SSNM messages, this is SCON message as 
> shown in draft

That is a typo, it has been corrected. See below.

3.4.4 Network Congestion (SCON)

The SCON message can be sent from the SGP or relay node to all concerned
ASPs to indicate that the congestion level in the SS7 network to a specified
destination has changed.

    0                   1                   2                   3
   |         Tag = 0x0103          |             Length            | 

---

---

From: Lyndon Ong <[email-masked]>
Date: Wed, 19 Sep 2001 09:20:35 -0700 (PDT)

John,

I think maybe the question was why RC would ever
be a list of more than 1 in the Data message.
The format of the RC parameter allows it to be
a list of more than 1, but I imagine that it
would be limited to 1 value for Data messages,
but could be more than 1 value for management
messages.  Is that correct?

Cheers,

Lyndon

--- [email-masked] wrote:
>     0                   1                   2       
>            3
>    |         Tag = 0x0006          |           
> Length             |
>    /                       Routing Context          
>               /
>    \                                                
>               \
>    |         Tag = 0x0103          |            
> Length            | 
>    /                     Destination Address        
>               / 
>    \                                                
>               \ 
>    |         Tag = 0x000F          |            
> Length            |
>    |                       Congestion Level         
>               |
>    |         Tag = 0x0004          |            
> Length            |
>    /                          Info String           
>               /
>    \                                                
>               \
> 
> 
> ---
> You are currently subscribed to sigtran as:
> [email-masked]
> To unsubscribe send a blank email to
[email-masked]

__________________________________________________
Terrorist Attacks on U.S. - How can you help?
Donate cash, emergency relief information
http://dailynews.yahoo.com/fc/US/Emergency_Information/

---

---

From: [email-masked]
Date: Thu, 20 Sep 2001 12:27:57 +0300

Hi Lyndon,

> messages.  Is that correct?

Yes it is.  Thanks for clarifying the question.

John

---