Subject: [M3UA Issue 1] Network Appearance Sematics / Format - CLOSED

From: Greg Sidebottom <[email-masked]>
Date: Wed, 26 Sep 2001 14:34:54 -0400

The new NA definition from Javier in an e-mail of Sept 13th seems to be
accepted as no comments on list:

"Network Appearance - The Network Appearance is a local reference (typically
an integer) that together with an SPC uniquely identifies an SS7 node by
indicating the specific SS7 network it belongs to. It can be used to
distinguish between signalling traffic associated with different networks
being sent between the SG and the ASP over a common SCTP association. An
example scenario is where an SG appears as an element in multiple separate
national SS7 networks and the same SPC value may be reused in different
networks."

Cheers

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Asveren, Tolga" <[email-masked]>
Date: Wed, 26 Sep 2001 13:48:00 -0500

Greg,

What is meant exactly by "local reference"? Can the same network have different NA values to be used for SG1-ASP1  and SG2-ASP1 or not(I think yes)? I assume NA should have the be coordinated between ASP and SG, so is "local" the correct word?

   Tolga

> -----Original Message-----
> From: Greg Sidebottom [mailto:[email-masked]]
> Sent: Wednesday, September 26, 2001 2:35 PM
> To: sigtran
> Subject: [M3UA Issue 1] Network Appearance Sematics / Format - CLOSED
> 
> 
> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to 
> [email-masked]
> 

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 26 Sep 2001 14:02:51 -0500

Greg,

Whether it is acceptable or not depends on whether NA is ever
required to appear in DATA or SNMM.  If NA only appears in REG REQ,
its definition should not speak to separating signalling traffic
over a common assocation, but should speak to the role of
identifying point-code numbering spaces for registration requests.

Is the "specific SS7 network" only identified by NA "together with
an SPC"?  (SPC is not defined in the draft, but used twice here.)

It is quite unclear whether the definition points to point-code
numbering space or relaxes the definition to permit multiple NA
values within a single point code numbering space.

Where do we stand with NA in DATA and SNMM?  And, what impact would
this definition have on that?

--brian

Greg Sidebottom wrote:                            (Wed, 26 Sep 2001 14:34:54)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Greg Sidebottom <[email-masked]>
Date: Wed, 26 Sep 2001 15:26:06 -0400

Greetings Brian, Tolga

Fair questions - I'll let Javier respond as we agreed amongst ourselves that
he would handle this issue.  I put the mail out to test our assumption that
it was closed.  I see more discussion is required so it is therefore not yet
closed.

Cheers,

  Greg

----- Original Message -----
From: "Brian F. G. Bidulock" <[email-masked]>
To: "sigtran" <[email-masked]>
Sent: Wednesday, September 26, 2001 3:02 PM
Subject: Re: [M3UA Issue 1] Network Appearance Sematics / Format - CLOSED

---

---

From: "Schantz, John" <[email-masked]>
Date: Wed, 26 Sep 2001 12:53:13 -0700

Greg,

The definition is acceptable.

Other replies:

NA MUST appear in DATA and SNMM when multiple networks with different
address spaces are involved.  BUT this group has been through this
before and we don't need to do this discussion again.

SPC is Signalling Point Code.  It was already stated that telecom
standard terms could be used.

I think NA is an administrated value at least between an SG and an SEP.
The network administrator will probably use the same value for a pair of
SGs' network connections and the SEPs that receive the traffic.  It
would make an SG's life easier in identifying traffic if traffic had to
be forwarded from its "mate" SG via a "C-link" type of route.  Each
community of SGs and SEPs could use different NA values or the "home
network" administrator could define a single value for all communication
with the remote network.  BUT this is their call not ours.

John

> Sent: Wednesday, September 26, 2001 2:26 PM
> To: sigtran
> You are currently subscribed to sigtran as: [email-masked]

---

---

From: Lyndon Ong <[email-masked]>
Date: Wed, 26 Sep 2001 13:08:52 -0700 (PDT)

Folks,

I had proposed that NA would be required to appear
in DATA and SNMM when needed to distinguish between
network contexts at the SG, just as RC would be
required to appear in DATA and SNMM when needed 
to distinguish between routing contexts at the
ASP, and that seemed to be grudgingly acceptable
to everyone.  

Let's not go back on this.  I have no problem 
trying to refine the definition of NA to be clearer
on when it should be used, especially to keep the
administrative requirements limited as that was
a concern.

Thanks,

L. Ong

--- "Brian F. G. Bidulock" <[email-masked]>
wrote:
> You are currently subscribed to sigtran as:
> [email-masked]

__________________________________________________
Do You Yahoo!?
Get email alerts & NEW webcam video instant messaging with Yahoo! Messenger. http://im.yahoo.com

---

---

From: Lyndon Ong <[email-masked]>
Date: Wed, 26 Sep 2001 14:02:14 -0700 (PDT)

Brian,

The last discussions we had on the topic
(going back to Sept. 12 or so) were on the
administrative requirements to support NA
in addition to RC and concluded (IMO) that 
these were not unreasonable.

Regarding the poll, (now a bit dated), 
the issues have been (a) whether to add
RC to the DATA and SNMM messages, for which
there seems a clear consensus, and (b) whether
to also remove NA, which already appears in
the DATA and SNMM messages - there is no
consensus on (b).

So, for version 9 please consider this issue
CLOSED.  Let's see what we get in v9.  

Cheers,

L. Ong

wrote:
> Lyndon,
> 
> What made you think this issue was decided?
> 
> Poll Results:
> 
>     (a)                       (b)
>     RC only                   RC and NA
>     ------                    ------
>     Maria-Cruz                Ken
>     Brian                     John S.
>     Tolga                     Klaus
>     Javier                    Barry
>     Amish                     Andrew
>     Gery
>     ------                    ------
>       6                         5
> 
> Certainly this is not a basis for requiring NA
> in DATA and SNMM.  Maybe purely as an OPTION.
> 
> --brian
> 
> Lyndon Ong wrote:                              (Wed,
> 26 Sep 2001 13:08:52)
> > Folks,
> > 

---

---

From: Lyndon Ong <[email-masked]>
Date: Wed, 26 Sep 2001 15:15:06 -0700 (PDT)

Brian,

> Could you point to the thead?  The only thread that
> I see from that time is the Issue #2 thread that
> ended with my last note.  Aside from a few exchanges
> on Sept 11 and 12 the thread goes back to the
> beginning of the poll.
> 
> I think your memory is failing you... ;)

You could be right, I've deleted a good number of
messages from the oversupply here... At some point,
though, the discussion petered out without any
great objection to having both NA and RC being
sent whenever applicable.

> 
> You misrepresent the poll!  The above does not
> sound like the message below:  It was clearly
> only or both.

If the result had been more clear cut, i.e.,
strong consensus for RC only, there would be
justification to take out NA.  However, there
was no such consensus, only acceptance of putting
RC in but not relying on RC only.

> Not closed.  Including NA must be OPTIONAL as
> it is implied in RC.  And there are a good number
> of people supporting that view.

There are clearly a number of people preferring
RC.  Just as clearly a number of people preferring
NA, hence the need for a procedure that allows 
both to coexist.  I thought that interoperability
was a big concern of yours, otherwise we could 
make both NA and RC optional and rely on people
to configure their systems to interwork!

In any case, we need to get a v9 out, if people
don't like it we will (sigh!) continue to work
on this.

Cheers,

L. Ong

---

---

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Thu, 27 Sep 2001 12:10:08 +0200

Hi Tolga, 

A "local reference" means that NA can have no meaning outside the M3UA scope. It is only a tool to differenciate several traffics in the SS7 world. I assume in your question you are talking about two SGPs. My answer is that if you want to do things in an easy way, you should do it: having the same NA. But you don't have to do it. It is a "local" number in the sense that you elect the value. That also means that you can elect the same value as the NI parameter, or the same identification as the MTP-SAP. Who configures is who decides how to do it, and therefore, it can be cosidered to be local IMHO.

Cheers // Javier.

> From: Asveren, Tolga [mailto:[email-masked]]
> Sent: Wednesday, September 26, 2001 8:48 PM
> To: sigtran
> Subject: RE: [M3UA Issue 1] Network Appearance Sematics / Format -
> CLOSED
> 
> 
> Greg,
> 
> What is meant exactly by "local reference"? Can the same 
> network have different NA values to be used for SG1-ASP1  and 
> SG2-ASP1 or not(I think yes)? I assume NA should have the be 
> coordinated between ASP and SG, so is "local" the correct word?
> 
>    Tolga
> 
> [email-masked]

---

---

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Thu, 27 Sep 2001 12:22:16 +0200

Brian, 

I have a doubt. You want to solve first if we have to include NA and/or RC in DATA msgs, and afterthat, define NA and RC. My question is: how can anyone know if we have to include NA and/or RC inside the DATA msgs if we don't know what NA and RC are ???. Don't you think that it means building your house starting with the roof?

BTW, SPC has to be included in the Terminology chapter as Signaling Point Code. But I think that all the people that want to implement M3UA will perfectly know the meaning, or on the other hand they seem to have a problem...  ;-)

More answers below...

> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Wednesday, September 26, 2001 9:03 PM
> To: sigtran

The specific context where the SPC is in the SS7 network is identified by NA and the SS7 endpoint (SEP) is therefore identify by its SPC and its context (NA).

> values within a single point code numbering space.

Go to the part: "indicating the specific SS7 network it belongs to". Hence you can note a change back to previous M3UA versions....

> this definition have on that?

It would be nice to separate threads under different mail subjects ...  :-)

Cheers // Javier.

---

---

From: Amish Chana <[email-masked]>
Date: Thu, 27 Sep 2001 12:14:48 +0100

Hi Javier,

I think a better choice of words is necessary instead on "local reference." 
I suggest replacing the first sentance with the following:

"The Network Appearance together with an SPC uniquely identifies an SS7 node 
by indicating the SS7 network it references. The scope of the Network 
Appearance value is limited to the M3UA deployment in which it is used."

Amish

>A "local reference" means that NA can have no meaning outside the M3UA 
>scope. It is only a tool to differenciate several traffics in the SS7 
>world. I assume in your question you are talking about two SGPs. My answer 
>is that if you want to do things in an easy way, you should do it: having 
>the same NA. But you don't have to do it. It is a "local" number in the 
>sense that you elect the value. That also means that you can elect the same 
>value as the NI parameter, or the same identification as the MTP-SAP. Who 
>configures is who decides how to do it, and therefore, it can be cosidered 
>to be local IMHO.
>
>Cheers // Javier.
>

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp

---

---

From: "Asveren, Tolga" <[email-masked]>
Date: Thu, 27 Sep 2001 07:24:01 -0500

Hi,

If "local" means "local to M3UA", then it is fine, otherwise if it does mean local to ASP, it is not exactly true because it should be coordinated between ASP and SG.
I also agree that in most configurations, where one ASP is connected to multiple SGs, for the same network, the same NA value will be used. But this is not mandatory. So, in this case SPC+NA is not enough to identify uniquely a SS7 node, it should be SPC+NA+Association, because for the same network different NA values can be used with different SGs for one ASP.
In fact I am sure for everybody reading those e-mails, this things are clear but the definition should be clear enough to allow a newcomer person to understand it with as less ambiguity as possible. 

    Tolga

> From: Javier Pastor-Balbas (ECE)
> [mailto:[email-masked]]
> Sent: Thursday, September 27, 2001 6:10 AM
> To: sigtran
> A "local reference" means that NA can have no meaning outside 
> the M3UA scope. It is only a tool to differenciate several 
> traffics in the SS7 world. I assume in your question you are 
> talking about two SGPs. My answer is that if you want to do 
> things in an easy way, you should do it: having the same NA. 
> But you don't have to do it. It is a "local" number in the 
> sense that you elect the value. That also means that you can 
> elect the same value as the NI parameter, or the same 
> identification as the MTP-SAP. Who configures is who decides 
> how to do it, and therefore, it can be cosidered to be local IMHO.
> 
> Cheers // Javier.
> 

---

---

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Thu, 27 Sep 2001 15:27:10 +0200

Hi Tolga, Amish and others, 

Tolga, you are right, it has to be complete understable by a newcomer.

What about "M3UA local reference shared by SG and AS" ?? 

Amish, do you think this means the same as yours? I don't see the problem in "local reference", but perhaps it needed some more detail:
	- local reference inside M3UA
	- It is shared by SG and AS

Could be that clearer?

Cheers // Javier.

> Sent: Thursday, September 27, 2001 2:24 PM
> To: sigtran
> If "local" means "local to M3UA", then it is fine, otherwise 
> if it does mean local to ASP, it is not exactly true because 
> it should be coordinated between ASP and SG.
> I also agree that in most configurations, where one ASP is 
> connected to multiple SGs, for the same network, the same NA 
> value will be used. But this is not mandatory. So, in this 
> case SPC+NA is not enough to identify uniquely a SS7 node, it 
> should be SPC+NA+Association, because for the same network 
> different NA values can be used with different SGs for one ASP.
> In fact I am sure for everybody reading those e-mails, this 
> things are clear but the definition should be clear enough to 
> allow a newcomer person to understand it with as less 
> ambiguity as possible. 
> 
>     Tolga
> 
> [email-masked]

---

---

From: Amish Chana <[email-masked]>
Date: Thu, 27 Sep 2001 17:15:39 +0100

Hi Javier,

see below.

>Amish, do you think this means the same as yours? I don't see the problem 
>in "local reference", but perhaps it needed some more detail:

Yes. What does your definition look like now?

Amish

---