Subject: [SUA issue 15]: Segmentation/Reassembly/Sequencing - CLOSED

From: [email-masked]
Date: Fri, 7 Sep 2001 15:32:50 +0300

Hi all,

I have not seen any replies on this proposal - so I think that this is
sufficient.  If it is not, tell me now - or I will make this issues as
closed.

br,
John

-----Original Message-----
From: ext [email-masked] 
Sent: 06 September, 2001 15:57
To: sigtran
Subject: [SUA issue 15]: Segmentation/Reassembly/Sequencing - to close
or not to close?

Hi all,

So far, I have these changes marked for SUA.  Anything else needed for issue
15?

John

3.10.x Segmentation

   0                   1                   2                   3
   0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
  +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
  |         Tag = 0x010x          |             Length            |
  +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
  | first/remain  |             Segmentation Reference            |
  +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

The first/remaining segments field is formatted as follows :
bit 8 (MSB) : indicates whether this is the first segment (1) or not (0)

bits 1-7 : indicate the number of remaining segments, value between 0 and 15

The field would thus be coded 1000 0000 (first, no remaining segments) for a
non-segmented CLDT.

The segmentation reference field is a 3 byte integer, assigned by the ASP.

OPTIONAL for CLDT
====

4.1 SCCP - SUA Interworking at the SG

4.1.1 Connectionless Data

The SGP SHOULD NOT attempt to reassemble XL/UDT when it is
acting as an SG/STP.  The ASP SHOULD perform reassembly of
XL/UDT in this situation.
 
The SGP SHOULD segment CLDT into XL/UDT.  However, if the SG is
acting as an STP, the ASP SHOULD include the Segmentation
parameter and the ASP MAY segment CLDT.
 
Additionally, ASPs MAY segment CLDT messages, based upon knowledge of
segmentation size supported at the SG(s) to which the ASP has routes to.

The IPSP SHOULD NOT segment N-UNITDATA into CLDT.

4.1.2 Connection-Oriented Data

The SGP SHOULD NOT attempt to segment CODT into DT, particularly
for class 3. The ASP performs reassembly of CODT messages. The ASP 
SHOULD be responsible for segmenting data into CODT of the appropriate 
size for DT1/DT2.

The IPSP SHOULD NOT attempt to resegment, or reassemble, into CODT
data received from the local user in a N-DATA request primitive.

The IPSP SHOULD be responsible for any resegmentation or reassembly
which is required to indicate data received in CODT messages to the
local user in N-DATA indication primitives.

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to
[email-masked]

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 7 Sep 2001 13:00:41 -0500

John,

I think the proposal is fine.

--brian

John Loughney wrote:                                         (Fri, 07 Sep 2001 15:32:50)
> You are currently subscribed to sigtran as: [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---