Subject: Re: M2UA / M3UA / SUA: Sending Data Messages on Stream 0

From: Michael Tuexen <[email-masked]>
Date: Thu, 8 Nov 2001 07:58:31 +0100

Brian,

I can not find a description of this feature in the socket-api
draft. Could you give me a reference (subsection number) or
citing it?

Thanks for your help.
Best regards
Michael

On Thursday, November 8, 2001, at 03:07  Uhr, Brian F. G. Bidulock wrote:

> Michael,
>
> The ability to split off a stream of an association onto
> a separate socket file descriptor.
>
> --brian
>
> Michael Tuexen wrote:                                     (Thu, 08 Nov 
> 2001 02:30:32)
>> Dear Brian,
>>
>> what is the split-off capability of the socket draft for SCTP?
>>
>> Best regards
>> Michael
>>
>> On Wednesday, November 7, 2001, at 04:50  Uhr, Brian F. G. Bidulock
>> wrote:
>>
>>> Ken,
>>>
>>> As I recall the reason was that if an implementation wishes
>>> to split off a control process on stream 0 and split off
>>> data processes on other streams, the control process is
>>> simpler if it does not have to deal with data on stream 0.
>>>
>>> This would be consistent with the split-off capability of
>>> the sockets draft for SCTP.
>>>
>>> If there are indeed multiple streams established at SCTP
>>> association initilization, there should be no reason why
>>> an implementation must accept data on stream 0 and, indeed,
>>> there is an error message "Invalid Stream Identifier" which
>>> it appears can be used to reject a management message on
>>> other than stream 0, so why not a data message on stream 0
>>> if there is more than one stream in the association?
>>>
>>> Perhaps the SHOULD does not need to be changed to a MUST,
>>> but is needs to be made clear that an implementation can
>>> choose to send ERR("Invalid Stream Identifier") if it receives
>>> data on stream 0.
>>>
>>> Can we change the description of the error message:
>>>
>>> 	The "Invalid Stream Identifier" error is sent if a message is 
>>> received
>>> 	on an unexpected SCTP stream (e.g., a Management message was 
>>> received
>>> 	on a stream other than "0").
>>>
>>> to
>>>
>>> 	The "Invalid Stream Identifier" error is sent if a message is 
>>> received
>>> 	on an unexpected SCTP stream (e.g., a Management message was 
>>> received
>>> 	on a stream other than "0", or a Data message was received on stream
>>> 	"0").
>>>
>>> --brian
>>>
>>>
>>> Ken Morneault wrote:             (Tue, 06 Nov 2001 21:33:14)
>>>>
>>>>
>>>> John,
>>>>
>>>> There is no functional reason why "SHOULD" needs to be changed
>>>> to "MUST".
>>>>
>>>> I would keep the text the same.
>>>>
>>>> Ken
>>>>
>>>> At 09:55 AM 11/6/2001 +0200, you wrote:
>>>>> Hi all,
>>>>>
>>>>> There has been some comment on limiting the sending of
>>>>> data messages on Stream 0.
>>>>>
>>>>>>> "DATA messages SHOULD be sent on an SCTP  stream other than
>>>>>>>  stream '0'."
>>>>>>>
>>>>>>> This Should be changed to "DATA messages MUST be sent on an SCTP
>>>>>>> stream other than stream '0'."
>>>>>>
>>>>>> Sorry, I asked for this one too and was told that it was necessary
>>>>>> to leave it at SHOULD to allow the single-stream implementation.
>>>>>
>>>>> I think that this needs to be harmonized with all of the UAs.
>>>>> Ken & Greg, what do you think should be done with this?  Is
>>>>> SHOULD enough?
>>>>>
>>>>> John
>>>>>
>>>>>
>>>>> ---
>>>>> You are currently subscribed to sigtran as: [email-masked]
>>>>> To unsubscribe send a blank email to leave-
>>>>> [email-masked]
>>>>
>>>>
>>>>
>>>> ---
>>>> You are currently subscribed to sigtran as: [email-masked]
>>>> To unsubscribe send a blank email to leave-
>>>> [email-masked]
>>>
>>> --
>>> Brian F. G. Bidulock
>>> [email-masked]
>>> http://www.openss7.org/
>>>
>>>
>>> ---
>>> You are currently subscribed to sigtran as:
>>> [email-masked]
>>> To unsubscribe send a blank email to leave-
>>> [email-masked]
>>>
[email-masked]
>>
>>
>>
>> ---
>> You are currently subscribed to sigtran as: [email-masked]
>> To unsubscribe send a blank email to leave-
>> [email-masked]
>
> --
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
>
>
> ---
> You are currently subscribed to sigtran as: 
> [email-masked]
> To unsubscribe send a blank email to leave-
> [email-masked]

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 8 Nov 2001 08:01:55 +0100

This line ist different. i like the mail reflector!!!!!!!!!!!!!!!!!!!

Dear Brian,

I can not find a description of that feature in
draft-ietf-tsvwg-sctpsocket-01.txt. Could you please give
me a reference to the description or cite it?

Thank you in advance

Best regards
Michael

---