Subject: Re: [Tsvwg] RE: SCTP and fragmentation

From: Randall Stewart <[email-masked]>
Date: Tue, 13 Nov 2001 12:38:35 -0600

Lyndon:

I think the basic HOL issue can be summarized in a very
simple statement.

SCTP, in its current form, addresses HOL on the receiver
side. It does NOT address HOL issues on the sender
side (caused by the queuing effect of the sender).

And has you state (and Laurent as well) different 
applications will encounter different types of
sending side HOL based on the sizes and distributions
of the sends over the various streams. 

R

"Ong, Lyndon" wrote:
> 
> John,
> 
> It seems to me that it would be an overstatement to recommend
> that all applications above SCTP do their own fragmentation.
> Brian has pointed out an impact of fragmentation on the ability
> to use streams to bypass HOL blocking, but how significant this is
> seems very dependant on the particular application.
> 
> Cheers,
> 
> Lyndon
> 
> -------------------------------------------------------
> Should applications above SCTP do their own fragmentation
> because of this, or should applications rely on SCTP and/or
> IP functionality.
> 
> thanks,
> John
> 
> _______________________________________________
> tsvwg mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/tsvwg
> 
> _______________________________________________
> tsvwg mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/tsvwg

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Qiaobing Xie <[email-masked]>
Date: Tue, 13 Nov 2001 13:19:39 -0600

Lyndon,

I agree with you. 

Besides I think the whole SCTP stream usage discussion has been blown
out of proportion. I'd really like to ask people to think about some
basic questions, such as:

 - why do we want to do partial write to a message-oriented association?
   How often does this really become unavoidable?

 - If the app really wants to do partial write, what's wrong to let 
   it suffer from a little HOL blocking? (this is very reasonable to 
   prepare to pay a little extra cost for the extra convenience.)

 - If SCTP effectively alleviates HOL blocking 95% of the time, is it
   really NOT good enough for SIGTRAN? If so, then what is the reason 
   for SIGTRAN to require 100% HOL-blocking-free transport? We know 
   that it will not come free, what is (complexity) price SIGTRAN 
   willing to pay for that? and Why?

regards,
-Qiaobing

---