Subject: m3uav09 : ASPAC-ACK traffic mode

From: Tolga Asveren <[email-masked]>
Date: Fri, 2 Nov 2001 11:00:28 -0800 (PST)

Hi Greg, Javier and others,

First sorry for the empty messages I sent, just
because of mail-server :-)

It seems that using traffic mode in ASPAC-ACK message
as the traffic mode of the entity sending ASPAC-ACK
could be usefull. So, the ASPAC sending entity can
know this, whereas currently this should be configured
in a static way.

If this change is done, there won't be anymore a way
to confirm the traffic mode of the ASPAC sending
entity by the receiving entity but is this really
something usefull and needed?

With such a change in ASP/SG case, still traffic mode
of SGs should be congfigured statically but at least
SGPs will be able to inform about their traffic modes
by themselves.

Any other opinions , supporting/opposing ideas?

   Tolga

>
>
>
> Hi Brian,
>
> I think you are proposing to use traffic mode in
ASPAC-ACK to inform the
>       other party about the answering entities (SG
in ASP-SG mode and
>       passive IPSP in your proposal for IPSP model
). Regardless what the
>       conclusion for IPSP is going to be, I think
this could be usefull
>       also for ASP-SG case, so that SGP traffic mode
can be told by SG side
>       to ASPs.
That's what I was thinking.
>
> But for that a change is necessary on the draft.
Currently the optional
>       traffic mode parameter in ASPAC-ACK is a
reflection of traffic mode
>       (which is again optional) specified in ASPAC.
True.
> Was that what you have in mind or do I misinterpret
it?
Yes, I was thinking it might be changed also because
it would
be usefult to both SG/AS and IPSP cases.
Shall we propose it?
--brian

__________________________________________________
Do You Yahoo!?
Find a job, post your resume.
http://careers.yahoo.com

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Ken Morneault <[email-masked]>
Date: Mon, 05 Nov 2001 12:54:47 -0500

Tolga,

Pls see comments below.

Regards,

Ken

>Any other opinions , supporting/opposing ideas?

I can see how this could be useful for the IPSP
model, but how would the ASP (in ASP/SG model)
use the traffic mode of the SGP?  Do error
scenarios need to be defined if traffic mode is
invalid or unsupported?

>You are currently subscribed to sigtran as: [email-masked]

---

---

From: [email-masked]
Date: Mon, 5 Nov 2001 10:37:37 -0800

Ken,

Please see comments below.

   Tolga

> -----Original Message-----
> From:   Ken Morneault <[email-masked]>
> Sent:   Monday, November 05, 2001 1:20 PM
> To:     "sigtran" <[email-masked]>
> Cc:
> Subject:     Re: m3uav09 : ASPAC-ACK traffic mode
>
>  Tolga,
> Pls see comments below.
> Regards,
> Ken
[TOLGA] When there are more than one SGP available to send traffic to
(SG/ASP case)  , then we can loadshare or use them as active/standby (or
maybe even in broadcast mode). Currently I don't see a way, how this
information can be told by SGPs to ASPs. If traffic mode in ASPAC-ACK is
used for this purpose, we won't be limited to static configuration.
I think for the cases, where ASP does not like the traffic mode specified
in ASPAC-ACK (for some reason), ERROR message with diagnostic information
"Unsupported Traffic andling Mode" can be used

> >To unsubscribe send a blank email to
> [email-masked]
> ---
> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to
> [email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 5 Nov 2001 12:44:22 -0600

Ken,

Ken Morneault wrote:                                          (Mon, 05 Nov 2001 12:54:47)
> scenarios need to be defined if traffic mode is

In ASP/SG, the ASP always has the choice to do
ASPIA if it doesn't like the traffic mode.  I don't
think separate error cases are required.

--brian

> You are currently subscribed to sigtran as: [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 5 Nov 2001 13:07:51 -0600

tolga.asveren,

[email-masked] wrote:                        (Mon, 05 Nov 2001 10:37:37)
> "Unsupported Traffic andling Mode" can be used

SGPs are not used to receiving ERROR messages (they normally only
send them).  I think ASPIA without sending traffic would be a better
course of action  for the ASP.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Mon, 5 Nov 2001 11:20:14 -0800

Brian,

Was there a specific reason not to allow ERROR from ASP to SGP? Just
wondering, what the reason for this is or whether it could be usefull or
not to allow it. For example when ASP receives DATA with an invalid RC,
what should it do? Wouldn't it be better if it could send an ERROR to SGP?

      Tolga

> From:   "Brian F. G. Bidulock" <[email-masked]>
> Sent:   Monday, November 05, 2001 2:14 PM
> Cc:     [email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 5 Nov 2001 13:26:49 -0600

Tolga,

I don't recall any reason or intention for it.  It is just
that the procedures normally only describe ERROR being sent
in the SGP->ASP direction and normally in place of an Ack
message to a ASPSM/ASPTM from the ASP.

In the case you mention, something is seriously broken at
the SGP to send an invalid RC and the ASP could hardly trust
the RC labelling of any data from the SGP whether it turns
out to be valid or not.  Again, a better course of action
might be for the ASP to send ASPIA for the invalid RC, but
things are pretty hosed at this point...

--brian

[email-masked] wrote:                        (Mon, 05 Nov 2001 11:20:14)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Wed, 14 Nov 2001 10:12:00 -0800

Hi,

Any other opinions about changing the meaning of ASPAC-ACK traffic mode
parameter?

    Tolga

> Sent:   Monday, November 05, 2001 2:33 PM

---

---

From: Verwimp Gery <[email-masked]>
Date: Thu, 15 Nov 2001 09:09:34 +0100

Hi Tolga,

Well frankly I don't see much use for it. Besides, isn't traffic mode now a
RK parameter (i.e. part of configuration) ? So it could be deleted from the
ASPTM messages; there's also an issue (as came out during the SUA interop
test) what the reaction of the SG should be if 2 ASPs go active in
"override" mode ... seems to me the SG should already know which is the
dominant one based on config anyway.

____________________________

Gery Verwimp
> SIEMENS ATEA
> ICN D CS D5
> Tel. : +32 14 25 3424
Fax : +32 14 25 3212
mailto:[email-masked]
____________________________________

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: woensdag 14 november 2001 19:12
To: sigtran
Cc: [email-masked]
Subject: RE: Re: m3uav09 : ASPAC-ACK traffic mode

Hi,

    Tolga

> > > [email-masked]

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to
[email-masked]

---

---

From: Ken Morneault <[email-masked]>
Date: Thu, 15 Nov 2001 09:33:24 -0500

Gery,

Please see comment below.

Ken

>dominant one based on config anyway.

Most implementations will not have a "dominant" ASP.  The last ASP to go
Active should be the one that receives the traffic.  The other will be notified
with NTFY-Alternate ASP Override and will need to transition to Inactive.  This
is a scenario that could happen if ASPs lose communication with each other.

---

---

From: [email-masked]
Date: Thu, 15 Nov 2001 05:49:19 -0800

Hi Gery,

  Tolga

> From:   Verwimp Gery <[email-masked]>
> Sent:   Thursday, November 15, 2001 3:17 AM
[TOLGA] The proposal is to make use of traffic-mode parameter in ASPAC-ACK
message to tell about the traffic mode of SGPs, because currently the only
way to know about traffic mode of SGPs  on ASP side is through
configuration. In registeration we give the traffic mode of ASP. If traffic
mode is deleted from ASPAC message, maybe we still can keep it in ASPAC-ACK
for that purpose or maybe put traffic mode parameter to REG-RSP.
> dominant one based on config anyway.
[TOLGA] Probably there will be a thread related with this problem, but my
current opinion is, if ASPs really care which one should be the dominant
one, then they should coordinate sending ASPACs to SG among themselves.
From SG point of view, the one, which has sent the second ASPAC, is the
active one. Well, of course this has the problem that for a while -after
the first ASP has exchanged ASPAC/ASPAC-ACK, till the second (dominant one)
sends ASPAC, the secondary one will be primary one, which probably we don't
want. So, maybe the modes Override-Standby and Override-Active were not
useless and could have been used in such a case to tell to SG , which of
the ASPs is the primary one.

---

---

From: Tolga Asveren <[email-masked]>
Date: Thu, 15 Nov 2001 06:41:16 -0800 (PST)

resending.....

Hi Gery,

  Tolga

>  Hi Tolga,
> Well frankly I don't see much use for it. Besides,
isn't 
> traffic mode now a
> RK parameter (i.e. part of configuration) ? So it
could be 
> deleted from the
> ASPTM messages; there's also an issue (as came out
during the 
> SUA interop
[TOLGA] The proposal is to make use of traffic-mode
parameter in ASPAC-ACK message to tell about the
traffic mode of SGPs, because currently the only way
to know about traffic mode of SGPs  on ASP side is
through configuration. In registeration we give the
traffic mode of ASP. If traffic mode is deleted from
ASPAC message, maybe we still can keep it in ASPAC-ACK
for that purpose or maybe put traffic mode parameter
to REG-RSP.
> "override" mode ... seems to me the SG should
already know 
> which is the
[TOLGA] Probably there will be a thread related with
this problem, but my current opinion is, if ASPs
really care which one should be the dominant one, then
they should coordinate sending ASPACs to SG among
themselves. From SG point of view, the one, which has
sent the second ASPAC, is the active one. Well, of
course this has the problem that for a while -after
the first ASP has exchanged ASPAC/ASPAC-ACK, till the
second (dominant one) sends ASPAC-, the secondary one
will be active one, which probably we don't want. So,
maybe the modes Override-Standby and Override-Active
were not useless and could have been used in such a
case to tell to SG , which of the ASPs is the primary
one.
> Any other opinions about changing the meaning of
ASPAC-ACK 
> traffic mode
> > [email-masked] wrote:                      
 (Mon, 05
> > Nov 2001 11:20:14)
> > > Brian,
> > >
> > > Was there a specific reason not to allow ERROR
from ASP 
> to SGP? Just
> > > wondering, what the reason for this is or
whether it could
> > be usefull or
> > > not to allow it. For example when ASP receives
DATA with an
> > invalid RC,
> > > what should it do? Wouldn't it be better if it
could send
> > an ERROR to SGP?
> > > > [email-masked] wrote:                  
     (Mon, 05
> > > > Nov 2001 10:37:37)
> > > > > [TOLGA] When there are more than one SGP
available to send
> > > > traffic to
> > > > > (SG/ASP case)  , then we can loadshare or
use them as
> > > > active/standby (or
> > > > > maybe even in broadcast mode). Currently I
don't see a
> > way, how this
> > > > > information can be told by SGPs to ASPs. If
traffic mode in
> > > > ASPAC-ACK is
> > > > > used for this purpose, we won't be limited
to static
> > configuration.
> > > > > I think for the cases, where ASP does not
like the traffic
> > > > mode specified
> > > > > in ASPAC-ACK (for some reason), ERROR
message with
> > > > diagnostic information
> > > > SGPs are not used to receiving ERROR messages
(they 
> normally only
> > > > send them).  I think ASPIA without sending
traffic would
> > be a better
> > > > > > >You are currently subscribed to sigtran
as:
> > [email-masked]
> > > > > > ---
> > > > > > You are currently subscribed to sigtran
as:
> > [email-masked]

__________________________________________________
Do You Yahoo!?
Find the one for you at Yahoo! Personals
http://personals.yahoo.com

---

---

From: Verwimp Gery <[email-masked]>
Date: Thu, 15 Nov 2001 16:16:48 +0100

Hi Tolga, Ken,

Seems we need to think more about the role of REG and ASPTM procedures.
Meddling with configuration parameters in ASPTM Ack messages is hardly an
extendable approach.

I'd like to propose that any configuration-oriented stuff, i.e.
- (SS7) traffic definition (OPC etc.)
- traffic mode
- "assume active on restart"
- ...
is part of the REG procedures. No reason why an SGP couldn't send a REG REQ
to the ASPs.

For ASPTM, we have already active/inactive ("available/unavailable"), maybe
we need "congested" here as well ?

Gery Verwimp
Fax : +32 14 25 3212

-----Original Message-----
From: Ken Morneault [mailto:[email-masked]]
Sent: donderdag 15 november 2001 15:33
To: sigtran
Subject: RE: Re: m3uav09 : ASPAC-ACK traffic mode

Gery,

Ken

Most implementations will not have a "dominant" ASP.  The last ASP to go
Active should be the one that receives the traffic.  The other will be
notified
with NTFY-Alternate ASP Override and will need to transition to Inactive.
This
is a scenario that could happen if ASPs lose communication with each other.

---

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 15 Nov 2001 12:06:19 -0600

Gery,

Registration is an OPTIONAL procedure, configuration is not.

--brian

Verwimp Gery wrote:                                       (Thu, 15 Nov 2001 16:16:48)
> Fax: +32 14 25 3212
> >Fax: +32 14 25 3212

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Verwimp Gery <[email-masked]>
Date: Fri, 16 Nov 2001 09:12:02 +0100

Brian,

Yes, and when configuration information is to be exchanged between SPs, e.g.
traffic mode, please make use of the REG procedures. But keep it out of
ASPTM is my point.

--gery

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: donderdag 15 november 2001 19:06
To: Verwimp Gery
Cc: sigtran
Subject: Re: m3uav09 : ASPAC-ACK traffic mode

Gery,

--brian

Verwimp Gery wrote:                                       (Thu, 15 Nov 2001
16:16:48)

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 16 Nov 2001 02:42:59 -0600

Gery,

Are you saying that you would rather that an SGP TMT be returned
in a registration response rather than ASPTM and that TMT should
be removed from ASPTM?

The problem with this is that REG/DEREG as they stand are for
registering Routing Keys.  One cannot do anything with them
without registering a RK.  They are called RKMM (Routing Key
Management Messages).  If I have statically configured routing
keys, how do I do TMT on the fly?

--brian

Verwimp Gery wrote:                                       (Fri, 16 Nov 2001 09:12:02)
> You are currently subscribed to sigtran as: [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Verwimp Gery <[email-masked]>
Date: Fri, 16 Nov 2001 10:29:55 +0100

Brian,

IMO TMT is part of the RK, whether implicit based on config data on either
side or exchanged via the REG procedures. If you change TMT on the fly, you
basically have a different RK/RC. TMT shouldn't change because of traffic
load conditions, or ASPs going inactive.

What ASPTM currently lacks is a means of load control. At the moment it's
all or nothing (active/inactive), without an ASP having the possibility to
signal it wants less than it's proportional share of new calls e.g. I don't
think we should solve this by meddling with the TMT on the fly.

Do you have a scenario where we would want to go from loadsharing to
broadcast on the fly or whatever ?

Perhaps it would be interesting for an ASP to withdraw from active duty (and
become "backup") but without a means to phase-out existing calls (ASPTM
signalling "no new calls") a change of TMT will disrupt traffic
distribution.

Gery Verwimp
Fax : +32 14 25 3212

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: vrijdag 16 november 2001 9:43
To: sigtran
Cc: [email-masked]
Subject: Re: m3uav09 : ASPAC-ACK traffic mode

Gery,

--brian

Verwimp Gery wrote:                                       (Fri, 16 Nov 2001
09:12:02)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 16 Nov 2001 04:13:16 -0600

Gery,

Verwimp Gery wrote:                                       (Fri, 16 Nov 2001 10:29:55)
> broadcast on the fly or whatever ?

No, I don't really.  Changing load selection within a group, yes,
but not traffic mode, no.

> signalling "no new calls") a change of TMT will disrupt traffic

I think you have me convinced.  At least I got TMT from mandatory to
optional in ASPTM.  Want to remove it altogether?  Why not just add
TMT as an optional parameter in the REG RESP for indicating SGP TMT?

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Verwimp Gery <[email-masked]>
Date: Fri, 16 Nov 2001 12:49:13 +0100

Brian,

That would be a good start. However I'm still struggling with ASPTM between
SGs. See IPSP thread ...

Gery Verwimp
Fax : +32 14 25 3212

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: vrijdag 16 november 2001 11:13
To: sigtran
Cc: [email-masked]
Subject: Re: m3uav09 : ASPAC-ACK traffic mode

Gery,

10:29:55)

--brian

---