Subject: ASP in DOWN state

From: Vipin Gupta <[email-masked]>
Date: Wed, 21 Nov 2001 12:39:59 +0800

Please refer to M3UA Draft-09, section 4.3.1 which says that ASP in DOWN
state should  not be sent any messages other than Heartbeat.
This text should be modified to say that ASP in DOWN state can receive ASPSM
and MGMT (ERROR) messages also.

---Vipin

Software Engineer
Hughes Software Systems
[email-masked]
+91 124 6346666 (Ex. 3612)

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 21 Nov 2001 01:29:22 -0600

Vipin,

An ASP in the down state can receive whatever messages it wants.  The
spec says that messages are not to be sent (from an SG) to an ASP in
the DOWN state (as viewed from the SG).  Why should an SG ever send an
ASPSM or ERROR message to an ASP that it views to be in a DOWN state?

The only message I can think of that an SG needs to send to an ASP in
the DOWN state is ASPDN Ack (and optionally HEARTBEAT).

Could you explain?

--brian

Vipin Gupta wrote:                                          (Wed, 21 Nov 2001 12:39:59)
> You are currently subscribed to sigtran as: [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Vipin Gupta <[email-masked]>
Date: Wed, 21 Nov 2001 13:11:40 +0800

Brian

State diagrams in the Draft depict the state transitions of an ASP at an
SGP.
But ASPDN Ack/ASPUP Ack are also ASPSM messages.
Consider a case when an ASP sends an Invalid ASPUP message to the M3UA
at SGP, then SGP sends an Error Message to it (like invalid parameter etc).
In my opinion the text should be modified after considering such cases.

---Vipin

----- Original Message -----
From: "Brian F. G. Bidulock" <[email-masked]>
To: "sigtran" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, November 21, 2001 3:29 PM
Subject: Re: ASP in DOWN state

> > To unsubscribe send a blank email to
[email-masked]
>
> --
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
>
>
> ---
> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to
[email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 21 Nov 2001 02:21:47 -0600

Vipin,

Ok, so there is ASPDN Ack, ERROR and HEARTBEAT.  But certainly
the SG has the ASP in the INACTIVE state before sending ASPUP Ack.
If we add ASPDN Ack and ERROR to the text would that be ok?  (I
think ASPDN Ack is implied, because the SG couldn't have had the
ASP correctly in the DOWN state if it received an ASPDN.)

--brian

Vipin Gupta wrote:                                          (Wed, 21 Nov 2001 13:11:40)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Vipin Gupta <[email-masked]>
Date: Wed, 21 Nov 2001 14:13:34 +0800

Brian

I agree with you. This text will certainly make protocol more clear for the
implementers.

---Vipin

----- Original Message -----
From: "Brian F. G. Bidulock" <[email-masked]>
To: "sigtran" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, November 21, 2001 4:21 PM
Subject: Re: ASP in DOWN state

> > > Vipin Gupta wrote:                                          (Wed, 21
Nov
> > 2001 12:39:59)
> > > > This text should be modified to say that ASP in DOWN state can
receive
> > ASPSM

---

---

From: Greg Sidebottom <[email-masked]>
Date: Wed, 21 Nov 2001 04:59:38 -0500

Vipin, Brian

   I have added the clarification for Issue 10, which will be submitted
today.

Cheers,

  Greg
----- Original Message -----
From: "Vipin Gupta" <[email-masked]>
To: "sigtran" <[email-masked]>
Sent: Wednesday, November 21, 2001 1:13 AM
Subject: Re: ASP in DOWN state

> > > > > Please refer to M3UA Draft-09, section 4.3.1 which says that ASP
in
> DOWN

---