Subject: Re: M3UA v9 : SCON message handling

From: Greg Sidebottom <[email-masked]>
Date: Wed, 21 Nov 2001 13:38:13 -0500

Hi Karen,

     Just confirming that the paragraph was deleted for Issue 10.

Cheers,

  Greg
----- Original Message -----
From: <[email-masked]>
To: "sigtran" <[email-masked]>
Sent: Friday, November 02, 2001 8:30 AM
Subject: RE: M3UA v9 : SCON message handling

> Brian,
>
> As you say, we shouldn't repeat this, so I'd be happy if the following
> paragraph was removed from section 3.4.4: Signalling Congestion (SCON),
>
> " The Affected Point code parameter can be used to indicate congestion of
> multiple destinations or ranges of destinations. However, an SCON message
> MUST not be delayed to collect individual congested destinations into a
> single SCON message as any delay might affect the timing of congestion
> indications to the M3UA Users. One use for including a range of congested
> DPCs is when the SG supports an ANSI cluster route set to the SS 7 network
> that becomes congested due to outgoing link set congestion."
>
> As you've pointed out the Mask field definition is sufficient.
>
> Ok to take this paragraph out Greg?
>
> Regards,
>
> Karen
>
>
> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: 30 October 2001 10:13
> To: sigtran
> Subject: Re: M3UA v9 : SCON message handling
>
>
> Gerhard,
>
> [email-masked] wrote:                           (Tue, 30 Oct 2001
> 09:43:40)
>
> > ''The Affected Destination parameter can be used in case of a route set
> > congestion to indicate the congestion of a cluster or range of
> destinations
> > that are reached via that congested route set, e.g. when an ANSI cluster
> > route set to the SS 7 network becomes congested due to outgoing link set
> > congestion.''
>
> This text is acceptable, however, I would remove references to link sets
> and route sets which are not well defined in M3UA, and also imply
functions
> that are the responsibility of the NIF, as follows:
>
> > ''The Affected Destination parameter can be used -- ---- -- - ----- ---
> > ---------- to indicate the congestion of a cluster or range of
> destinations
> > ---- --- ------- --- ---- --------- ----- ---, e.g. when an ANSI cluster
> > ----- --- -- --- -- - ------- becomes congested --- -- -------- ---- ---
> > ----------.''
>
> or,
>
>     The Affected Destination parameter can be used to indicate
>     the congestion of a cluster or range of destinations, e.g.
>     when an ANSI cluster becomes congested.
>
> But, geee!  Now it looks like the definition of the parameter.  Yet
> the definition of the mask field says:
>
>     The Mask field can be used to identify a contiguous range of
>     Affected Destination Point Codes, independent of the point
>     code format.  Identifying a contiguous range of Affected DPCs
>     may be useful when reception of an MTP3 management message or
>     a linkset event simultaneously affects the availability status
>     of a series of destinations at an SG.
>
> So it seems that the existing definition of the Affected DPC mask
> field and this proposed replacement text are the same.  There is no
> need to say it twice.
>
> Please strike the original sentence.
>
> --brian
>
> --
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
>
>
> ---
> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to
> [email-masked]
>
>
> ---
> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to
[email-masked]

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Vipin Gupta <[email-masked]>
Date: Thu, 22 Nov 2001 09:54:38 +0800

Greg,

Does this mean that there will be only one Affected Destination TLV in the
SCON message. I think this should not be the case and support for multiple
Affected Destinations is still present.

---Vipin
Software Engineer
Hughes Software Systems
[email-masked]
+91 124 6346666 (Ex. 3612)

----- Original Message -----
From: "Greg Sidebottom" <[email-masked]>
To: "sigtran" <[email-masked]>
Sent: Thursday, November 22, 2001 2:38 AM
Subject: Re: M3UA v9 : SCON message handling

> You are currently subscribed to sigtran as: [email-masked]

---

---

From: Greg Sidebottom <[email-masked]>
Date: Wed, 21 Nov 2001 23:41:11 -0500

Hi Vipin,

Don't worry - Multiple Affected Destination TLVs in an SCON is unchanged.

The text change only removed a requirement stating that an implementation
MUST NOT delay an SCON to collect subsequent affected destinations.

Cheers,

   Greg

----- Original Message -----
From: "Vipin Gupta" <[email-masked]>
To: "sigtran" <[email-masked]>
Sent: Wednesday, November 21, 2001 8:54 PM
Subject: Re: M3UA v9 : SCON message handling

---