Subject: SUA Segmentation Clarification Required ??

From: [email-masked]
Date: Thu, 1 Nov 2001 17:44:58 +0530

Hi,
      the document <draft-ietf-sigtran-sua-08.txt>
section "4.7.1 Connectionless Data" says
"The SGP SHOULD segment CLDT into XL/UDT."

Do we interpret it as

"The SUA at the SGP SHOULD segment CLDT into XL/UDT."

OR

"The SCCP at the SGP SHOULD segment CLDT into XL/UDT."

Regards
Dipak

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: [email-masked]
Date: Thu, 1 Nov 2001 14:20:07 +0200

Hi Dipak,

> "The SCCP at the SGP SHOULD segment CLDT into XL/UDT."

Well, the technical answer is that SUA cannot force any
requirements on SCCP, so that the draft cannot require
SCCP to do anything.  From an implementation point of
view, if you can assure that SCCP always segments
XL/UDT at the SG, that will be sufficient.  If you 
cannot, then SUA should.

John

---

---

From: [email-masked]
Date: Thu, 1 Nov 2001 18:24:22 +0530

Hi john,
     I think lots of "SHOULD's" and "MAY's" in the draft
need to be clarified and changed to "MUST" or "MUST NOT",

best regards
dipak

[email-masked] on 11/01/2001 05:50:07 PM

Please respond to [email-masked]

To:   "sigtran" <[email-masked]>
cc:    (bcc: Dipak Aggarwal/HSS)

Subject:  RE: SUA Segmentation Clarification Required ??

Hi Dipak,

John

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to
[email-masked]

---

---

From: [email-masked]
Date: Thu, 1 Nov 2001 18:24:22 +0530

Hi john,

best regards
dipak

Hi Dipak,

John

---

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 2 Nov 2001 04:17:01 -0600

Dipak,

Which ones?

--brian

[email-masked] wrote:                          (Thu, 01 Nov 2001 18:24:22)
> You are currently subscribed to sigtran as: [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Fri, 2 Nov 2001 16:53:01 +0530

Hi Brian,

1) 1.5.4 SCTP Stream Mapping --> "SUA SHOULD use stream 0
     for SUA management messages".
This should be changed to "SUA MUST use stream 0
     for SUA management messages"

     3.9.12 Error Code : The "Invalid Stream Identifier" error would
          be sent if a message was received on an unexpected
          SCTP stream (e.g., a Management message   was
          received on a stream other than "0").

2) 3.10.1 SS7 Hop counter ---> "The value of the SS7 Hop Counter is
          decremented with each global title translation and
          should be in the range 15 to 1. "
This Should be changed to "The value of the SS7 Hop Counter is
          decremented with each global title translation and
          Must be in the range 15 to 1. "
     Refer Q.714 -> 2.8.6 Hop Counter Violation

3) 3.10.2.6 IP Addresses ----> "It should be noted
   that if the source address is in a certain IP version, the
   destination address should also be in the same IP version."

This Should be changed to "It should be noted
   that if the source address is in a certain IP version, the
   destination address MUST be in the same IP/Higher version"
     As IpV4 cannot understand IpV6 addresses.

4) 4.1.1 Receipt of Primitives from the SUA-User --> "DATA messages
          SHOULD be sent on an SCTP  stream other than
          stream '0'."
This Should be changed to "DATA messages
          MUST be sent on an SCTP  stream other than
          stream '0'."

Please clarify

Best Regards
Dipak

"Brian F. G. Bidulock" <[email-masked]> on 11/02/2001 03:47:01 PM

Subject:  Re: SUA Segmentation Clarification Required ??

Dipak,

Which ones?

--brian

[email-masked] wrote:                          (Thu, 01 Nov 2001
18:24:22)

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 2 Nov 2001 15:01:02 -0600

diaggarwal,

[email-masked] wrote:                          (Fri, 02 Nov 2001 16:53:01)
>           received on a stream other than "0").

I think we already caught that one.

>      Refer Q.714 -> 2.8.6 Hop Counter Violation

How about:
            decremented with each global title translation and
            is in the range 15 to 1. "

>      As IpV4 cannot understand IpV6 addresses.

I still disagree that IP addresses are of any use.

>           MUST be sent on an SCTP  stream other than

Sorry, I asked for this one too and was told that it was necessary
to leave it at SHOULD to allow the single-stream implementation.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Tue, 6 Nov 2001 10:12:56 +0530

Hi Brian,
     My Comments as enclosed by "DI>>"

Best regards
dipak

"Brian F. G. Bidulock" <[email-masked]> on 11/03/2001 02:31:02 AM

Please respond to [email-masked]

To:   Dipak Aggarwal/HSS@HSS
cc:   sigtran <[email-masked]>

diaggarwal,

[email-masked] wrote:                          (Fri, 02 Nov 2001
16:53:01)

How about:

DI>> No problems but as per SCCP there should be a HOP
Counter violation in case it reaches 0 , or maybe we get a
message with HOP counter greater than 15. I think that there should
be an error message added for that in addition to the MUST.

DI>> I think that in case the Routing is based on "Hostname",
Hostname can also refer to an Ip Address in Dotted form
"x.y.z.a". I Doubt that IpV4 can understand IpV6 addresses.

DI>> Thats a good thought. I believe that the draft should also
include a single line about "Single Stream implementation"

--brian

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 5 Nov 2001 22:49:49 -0600

diaggarwal,

[email-masked] wrote:                          (Tue, 06 Nov 2001 10:12:56)
> be an error message added for that in addition to the MUST.

What must?  Interworking SCCP Hop counter with SS7 is an implementation
detail.  This was already discussed in detail settled at last call.

> "x.y.z.a". I Doubt that IpV4 can understand IpV6 addresses.

SCCP cannot understand them at all and IPSP operation has not been
settled.  IPSP operation dos not include transfer/relay just yet,
and these are nothing more than place-markers for extension drafts.

> include a single line about "Single Stream implementation"

This has alredy been raised.

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Tue, 6 Nov 2001 09:56:20 +0200

Hi all,

> detail.  This was already discussed in detail settled at last call.

Agreed. This has been settled.

> and these are nothing more than place-markers for extension drafts.

Agreed.
 
best regards,
John

---

---

From: [email-masked]
Date: Tue, 6 Nov 2001 09:58:56 +0200

Hi Brian,

Agreed.
 
John

---