Subject: Message Retrieval (was: SCTP and fragmentation)

From: Andreas Jungmaier <[email-masked]>
Date: Thu, 15 Nov 2001 17:41:55 +0100

Hello,

Another fine (probably implementation dependent) question is how to 
organize retrieval of data. RFC2960 states (in the example API) that 
there could be the functions :
RECEIVE_UNACKED, RECEIVE_UNSENT, which should be fairly useful for
MTP adaptation layers. 

Any ideas or enlightenment as to how that works together with
long "messages" ? (actually, "message" seems to imply something
short, but let's assume for a moment 5 MB message for a moment, my assoc
breaks, and I want to retrieve about 3 MB of data in order to
send it via a second association).

Andreas

- -- 
- ------------------------------------------------------------------------
Dipl.-Ing. Andreas Jungmaier              |                         _
Computer Networking Technology Group      | ASCII ribbon campaign  ( )
University of Essen                       |  - against HTML email   X
http://www.exp-math.uni-essen.de/~ajung   |              & vcards  / \

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Randall Stewart <[email-masked]>
Date: Thu, 15 Nov 2001 10:09:30 -0600

Andreas:

I can only tell you how to do this with the socketapi draft :>

What we are doing is that:

IF the user is subscribed to data failure notifications
then we send each TSN up to the application with 
a state flag indicating if it was SENT or just QUEUED.

So basically the application will end up reading up
a large number of notifications with its 3M of data...

R

Andreas Jungmaier wrote:
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Hello,
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.0.6 (GNU/Linux)
> Comment: For info see http://www.gnupg.org
> 
> iD8DBQE78/BTXAsLBNOCSsARAlLgAKCGj8/4j7rLs12nF9TXh0Mlby2XwQCgo9Tc
> RnfMfsSpJLfPbFlirIcqIyE=
> =Mnwl
> -----END PGP SIGNATURE-----
> 
> _______________________________________________
> tsvwg mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/tsvwg

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)

---

---

From: Arun Prasad <[email-masked]>
Date: Sat, 17 Nov 2001 15:07:56 +0530

Hi Andreas,
    We are also in the process of thinking about this, I could pour some ways to
implement this, but not very sure....

* When a SACK is received for one of the Fragmented chunk, the chunk should
    not be freed until all of the fragmented chunks of the particular SSN is Acked...
    But the Cumulative Tsn is moved as usual.....
    So during the Retrieval,  the fragmented chunks are bundled and delivered to
    the ULP....

* When the message M is fragmented to M1,M2,M3... , M is stored in a Queue,
    and whenever all the fragmented chunks of M, are Acknowledged M is freed...
    So during the Retrieval, the messages in this Q are sent to the ULP...
    This method does have an overhead of storing the messages twice in the
     SCTP layer, but if the Fragmentable (HUGE) message are very rare, this
    procedure is ok.... This procedure can also be an optional one, where the
    Application above can choose to do this extra processing or not.

    Are the above methods sound reasonable.....

Thanks
-arun

Andreas Jungmaier wrote:

> You are currently subscribed to sigtran as: [email-masked]

---