Subject: RE: M2UA / M3UA / SUA: Sending Data Messages on Stream 0 (and MP2 A)

From: [email-masked]
Date: Wed, 7 Nov 2001 08:05:24 +0200

Hi Brian,

> As I recall the reason was that if an implementation wishes
> to split off a control process on stream 0 and split off
> data processes on other streams, the control process is
> simpler if it does not have to deal with data on stream 0.
> 
> This would be consistent with the split-off capability of
> the sockets draft for SCTP.
> 
> If there are indeed multiple streams established at SCTP
> association initilization, there should be no reason why
> an implementation must accept data on stream 0 and, indeed,
> there is an error message "Invalid Stream Identifier" which
> it appears can be used to reject a management message on
> other than stream 0, so why not a data message on stream 0
> if there is more than one stream in the association?
> 
> Perhaps the SHOULD does not need to be changed to a MUST,
> but is needs to be made clear that an implementation can
> choose to send ERR("Invalid Stream Identifier") if it receives
> data on stream 0.
> 
> Can we change the description of the error message:
> 
> 	The "Invalid Stream Identifier" error is sent if a 
> message is received 
> 	on an unexpected SCTP stream (e.g., a Management 
> message was received 
> 	on a stream other than "0").
> 
> to
> 
> 	The "Invalid Stream Identifier" error is sent if a 
> message is received 
> 	on an unexpected SCTP stream (e.g., a Management 
> message was received 
> 	on a stream other than "0", or a Data message was 
> received on stream
> 	"0").

This could be reasonable.

John

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Ken Morneault <[email-masked]>
Date: Wed, 07 Nov 2001 07:09:24 -0500

Brian,

This text change works for me.

Ken

At 08:05 AM 11/7/2001 +0200, you wrote:
>You are currently subscribed to sigtran as: [email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 7 Nov 2001 13:23:47 -0600

Ken,

I think we're finished on this minor point then.

--brian

Ken Morneault wrote: (Wed, 07 Nov 2001 07:09:24)
> You are currently subscribed to sigtran as: [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---