Subject: M3UA 09- MTP3 indication doubt

From: kamesh kaul <[email-masked]>
Date: Mon, 12 Nov 2001 20:04:51 -0800 (PST)

Hi
Please see my coments below:

I have a doubt regarding MTP3 indications at SG.

                                                      

                  SG                                  
                   
          -+---------------+                          
                   
           |               |                          
                   
           | +---------+   |               +---------+
                   
           | |  SGP1   +---+---------------+  ASP1   |
                   
           | |         +---+-----------+   |         |
                   
           | +---------+---+-------+   |   +---------+
                   
           |               |       |   |              
                   
           |               |       |   |              
                   
           | +---------+   |       |   |   +---------+
                   
           | |   SGP2  +---+----+  |   +---+  ASP2   |
                   
           | |         +---+----+--+-------|         |
                   
           | +---------+   |    |  |       +---------+
                   
           |               |    |  |                  
                   
           |               |    |  |                  
                   
           | +---------+   |    |  |       +---------+
                   
           | |  SGP3   |   |    |  +-------|  ASP3   |
                   
           | |         +---+-+  +----------|         |
                   
           | +---------+   | +-------------+---------+
                   
           |               |                          
                   
           |               |                          
                   
           +---------------+                          
                   
                               Fig 1                  

                
Referring to  fig 1 SGP 1 is connected to three ASP’s
(ASP1 , ASP2, ASP3) belonging to the same 
AS  , SGP2 is connected to two ASP’s (ASP2 , ASP3) and
SGP3 is connected to ASP3 .

Now whenever MTP3 pause or resume indication is
triggered at SGP1 corresponding DUNA or 
DAVA message is send to ASP1, ASP2 and ASP3
respectively that means DPC status is 
Synchronized at all the three ASP’s. In case pause or
resume indication is triggered at SGP3 , as SGP3
is only connected to ASP3, DUNA or DAVA message is
send to ASP3 only, which means that
DPC (DPC's) status is updated at ASP3 only, even
though ASP1 and ASP2 are communicating with same 
DPC (DPC's) via SGP1 or SGP2. Thus ASP1 and ASP3 sees
different view of SS7 network via same SG. 

Please comment.

Best regards
Kamesh

__________________________________________________
Do You Yahoo!?
Find the one for you at Yahoo! Personals
http://personals.yahoo.com

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 12 Nov 2001 22:42:57 -0600

Kamesh,

The spec says that if ASP3 receives an SNMM from any of the
the SGP that it may view the SNMM as applying to the entire
SG.  It does not say that SGP3 can only send SNMM to ASP3.

It is necessary in an SG for SGP1, SGP2 and SGP3 to all
have the same view of the SS7 network.  When SGP3 receives
an event that triggers, it needs to indicate the SNMM event
to SGP1 and SGP2 anyway (otherwise SGP1 and SGP2 will have
invalid routing tables).  When SGP3 indicates the event to
SGP1 and SGP2, SGP1 and SGP2 may each send SNMM to as many
ASPs as they want.  Even if ASP3 receives the same SNMM from
each SGP, each of them indicates the state of the SG.

You should really have AS in our diagram.  SNMM are only
really applicable to an AS and are not necessarily valid on
an entire-ASP basis.

In general, it is better to design an SG to send the
SNMM event to all AS (and not worry about which ASP handles
the event to each AS).  If all the ASPs in your example
serve the same AS, it is sufficient that SGP3 sends the SNMM
to ASP3 for the concerned AS.

Nevertheless, with a properly built SG, each SGP that is
capable of informing AS of an SNMM event must alse be informed
as a group when one SGP detects such an event.  Otherwise,
routing tables in the SGP will be out of sync and the SG
cannot perform its normal routing functions.

--brian

kamesh kaul wrote:                                         (Mon, 12 Nov 2001 20:04:51)
> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: "Zannin, Francois" <[email-masked]>
Date: Tue, 13 Nov 2001 14:03:53 -0000

Hi,

My understanding of the draft 9 on the SSNM event distribution from the
SG to the AS!

It is said in paragraph 3.4.1 that when a SSNM message is sent from a
SGP in the SG to all concerned ASPs.

What is the meaning of "concerned ASPs"? When a SG can deal with an AS
via one or several ASPs, is the SSNM received by all ASP "UP"?

It should be important to decide NOW if these SNNM are sent to ALL ASPs
"UP" connected to the SG or to only ONE ASP "UP" for the AS. The
handling of these SSNM can be handled and optimized in different way
depending on the NORMAL behavior of a M3UA network.

If ALL ASPs must receive these SSNM, we can consider that if one has not
received one of these messages, it is an error and a most costly (CPU,
inter-process messages) synchronization must be executed between all
ASPs. But under normal circumstances, only one ASP has to broadcast this
ss7 network knowledge to all the entities of the AS/ASP platform for a
SG but we are sure that every ASP is able to do it. 

If only ONE ASP receives these SSNM, we can consider that the normal
behavior of the ASPs for a concerned SG is to broadcast these messages
to all entities of the AS/ASP group. This is a ss7 like mode for the ss7
network destination availability. When an ASP receive a SSNM message, it
always broadcast it and NO excessive inter entity traffic is generated
on the platform.

Francois Z.

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Tuesday, November 13, 2001 5:43 AM
To: sigtran
Cc: [email-masked]
Subject: Re: M3UA 09- MTP3 indication doubt

Kamesh,

--brian

kamesh kaul wrote:                                         (Mon, 12 Nov
2001 20:04:51)
            
> Referring to  fig 1 SGP 1 is connected to three ASP's
> AS  , SGP2 is connected to two ASP's (ASP2 , ASP3) and
> Synchronized at all the three ASP's. In case pause or
> To unsubscribe send a blank email to
[email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to
[email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 13 Nov 2001 15:33:51 -0600

Francois,

How the SG goes about sending SNMM and what the ASP cares
to do with it is rather implementation dependent.  It is
sufficient that at least one ASP serving each concerned AS
receive the message.  This is already provided for in the
draft.

"Concerned" means the ASP that wants or needs to be informed
of the SNMM event.  An ASP without active AS does not want or
need to be informed of SNMM events.

--brian

Zannin, Francois wrote:                                   (Tue, 13 Nov 2001 14:03:53)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: "Zannin, Francois" <[email-masked]>
Date: Wed, 14 Nov 2001 11:35:13 -0600

Hello,

In another paragraph 4.5.1, it is said that the MTP-xxx indications 
are sent to the "concerned ASPs" dealing for the specified network. 
"In this way, ALL ASPs configured to send/receive traffic within a 
particular network appearance are informed".
"If the SGP operates within a single network appearance, then all 
ASPs are informed".

We can understand from these sentences that the normal behavior for 
a "SG" is to send these SSNM to all ASP "UP" for the concerned network!
 
In this way, the ASPs handling for these SSNM messages should easier 
and all not received SSNM on an ASP are considered as lost and then a 
more expensive processing should be started in order to re-synchronize 
the databases between ASPs. This example shows that a single word can 
hardly impact the implementation. 

-- Francois Z.

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Tuesday, November 13, 2001 10:34 PM
To: sigtran
Cc: [email-masked]
Subject: Re: M3UA 09- MTP3 indication doubt

Francois,

--brian

Zannin, Francois wrote:                                   (Tue, 13 Nov
2001 14:03:53)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 14 Nov 2001 16:30:14 -0600

Fracois,

There are no RFC keywords in the passages you quote.  The text
is discriptive only.  The concensus of the working group as
arrived on the MTP Restart thread and M3UA Issue discussion
was that SNMM are not set to inactive ASP (ASPs which are
inactive for the concerned AS).  The text passages you quote
do not reflect this concensus and should be struck.

--brian

Zannin, Francois wrote:                                   (Wed, 14 Nov 2001 11:35:13)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---