Subject: Re: [Tsvwg] Re: M2PA: User Level Acknowledgements

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 6 Nov 2001 06:16:33 -0600

Ivan,

This only says that if I choose to drop it (MAY) that I MUST still
send a SACK.  There is nothing in these words precluding an
implementation from Cum Acking the data while still advertising
a_rwnd = 0.

It that is what was intended, I suggest the following sentence
be added:

   The receiver MUST NOT cummulatively acknowledge any DATA
   (i.e., the receiver MUST NOT move the cumulative TSN ack
   point) while advertising an a_rwnd of zero.

Clear?

--brian

[email-masked] wrote:        (Tue, 06 Nov 2001 14:09:47)
> 	Brian, please, please, please, read what is written... Maybe you
> just have a problem to understand the difference between saving the TSN in
> your buffer (the MAY), and not acknowledge its receipt (the MUST)... I quote
> (again):
> 
> > > "
> > > Note: Anytime the receivers rwnd is 0, the receiver MAY drop
>                                                             ^^^^
> > > the DATA chunk without acknowledgment of the new DATA
>                    ^^^^^^^
> > > chunk (since it has no room to receive the data nor validate it).
> > > However the receiver MUST still send an acknowledgment showing
>                          ^^^^
> > > the new chunk as still missing with a r_wnd update following 
>                   ^^^^^^^^^^^^^^^^
> > > the delayed acknowledgment guidelines specified below.
> > > "
> 
> 	I don't know if it would be better for you something like:
> 
> Note: Anytime the receiver's rwnd is 0, the receiver MAY drop
> the DATA chunk (since it has no room to receive the data).
> However the receiver MUST still send an acknowledgement showing
> the new chunk as still missing with an a_rwnd update and following
> the delayed acknowledgement guidelines specified below.
> 
> 	Any better? (but is still says exactly the same as before)...
> 
> ... snip...
> 
> 	BR Iván Arias Rodríguez

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Randall Stewart <[email-masked]>
Date: Tue, 06 Nov 2001 06:44:04 -0600

Brian:

If the WG feels this is the right idea I have no problem to changing
this wording to:

"
Note: Anytime the receivers rwnd is 0, the receiver MUST drop

As Kachong said, this is a minor point. You should have specified
that is what you wanted in the first place... all you would
have had to do is quote the sentence and ask it to be changed
to a MUST... 

What does the rest of the working group feel? 

> implementation from Cum Acking the data while still advertising

I don't like the above since now you get the implementation 
lying about where the cum-ack is. This is much harder
to implement... if we go down this type of route then
I think we should just require the chunk to be dropped.

We might need to add some words about the fact that a probe
chunk SHOULD NOT cause any adjustment to the cwnd as would
a normal time-out. At least from what Kacheong said this is
how TCP works.. so we want to make SCTP similar here..

R

R

> _______________________________________________
> tsvwg mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/tsvwg

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)

---