Subject: M3UA : some confusions over SG

From: [email-masked]
Date: Thu, 1 Nov 2001 10:27:11 +0200

Hi,

I have some confusions, please correct me.

1>  In this scenario, is it possible  that SGP routes
 DATA from ASP1 to ASP2?
My answer is NO, ASP1 can deliver DATA to ASP2
 via IPSP/IPSP case. Why overlay such a function. 
But I am not sure.

  ********   SS7   *****************   IP   ********
  * SEP  *---------*      SGP      *--------* ASP  *
  ********         *****************        ********

  +------+         +---------------+        +------+
  | ISUP |         |     (NIF)     |        | ISUP |
  +------+         +------+ +------+        +------+
  | MTP3 |         | MTP3 | | M3UA |        | M3UA |
  +------|         +------+-+------+        +------+
  | MTP2 |         | MTP2 | | SCTP |        | SCTP |
  +------+         +------+ +------+        +------+
  |  L1  |         |  L1  | |  IP  |        |  IP  |
  +------+         +------+ +------+        +------+ 
      |_______________|         |______________|

2> In the following scenario, is it possible that SGP
 routes DATA from ASP1 to ASP2?
My answer is YES, but this is because of sccp's GT
 translation function of SGP, otherwise SGP only route DATA 
from IP domain to SS7 domain, or vice versa. 
I am not very sure of this either.

  ********   SS7   *****************   IP   ********
  * SEP  *---------*               *--------*      *
  *  or  *         *      SGP      *        * ASP  *
  * STP  *         *               *        *      *
  ********         *****************        ********

  +------+         +---------------+        +------+
  | SCCP-|         |     SCCP      |        | SCCP-|
  | User |         +---------------+        | User |
  +------+           |   _____   |          +------+
  | SCCP |           |  |     |  |          | SCCP |
  +------+         +------+-+------+        +------+
  | MTP3 |         | MTP3 | | M3UA |        | M3UA |
  +------|         +------+ +------+        +------+
  | MTP2 |         | MTP2 | | SCTP |        | SCTP |
  +------+         +------+ +------+        +------+
  |  L1  |         |  L1  | |  IP  |        |  IP  |
  +------+         +------+ +------+        +------+
      |_______________|         |______________|

Thanks and BR

Qun Qu

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 1 Nov 2001 02:57:02 -0600

Qun,

[email-masked] wrote:     (Thu, 01 Nov 2001 10:27:11)
>   * SEP  *---------*      SGP      *--------* ASP  *

My answer is YES.  In the following configuration, I don't
think that the SG/STP has a choice not to be able to
transfer messages between PC 10-10-10 and 20-20-20.  This
results in ASP to ASP data transfer via the SG.

                                ______                  
                               /      \                 
                         -----|  ASP1  |  AS PC=10-10-10
            ________    /      \______/                 
           |        |  /                                
     ______| STP/SG | /                                 
          /|        |/                                  
         / |30-30-30|\                                  
        /  |________| \                                 
       /        |      \        ______                  
      /         |       \      /      \                 
                |        -----|  ASP2  |  AS PC=20-20-20
                               \______/                 

>   * SEP  *---------*               *--------*      *

SCCP even requires that local SCCP users be able to transfer
messages between themselves via SCCP.  For SUA, this means
that this capability should be supported whether the SCCP
user is local to the SG or remoted to the ASP.  Again, the
answer is YES.  SUA ASPs can send data messages to each other
via the SG.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Fri, 2 Nov 2001 03:05:33 +0200

Hi, Brian,

Thanks for your answer.
But other questions...

In the case 1, if SG can route DATA from ASP1 to ASP2 (ASP1 and ASP2 
are both connected directly to SG), then we will never need IPSP to IPSP

case if there is a SG. In this scenario,  these two IPSPs can connect to
SG 
and actually act as ASPs.

Besides, per the M3UA v9's defination:
<snip> 1.2
Signalling Gateway - An SG is a signaling agent that receives/sends SCN 
native signaling at the edge of the IP network [1].

The above texts do not say SG can receive/send non-SCN native signalling
in the middle of the IP network. I think DATA sent from ASP1 to ASP2 via
SG
is not a SCN native signalling, and in this situation the SG does not
sit at the 
edge of the IP network, at least part of the SG sits in the middle of
the IP network.
Did I misunderstanding something? Please correct me.

Best Regards.

Qun Qu

-----Original Message-----
From: ext Brian F. G. Bidulock [mailto:[email-masked]]
Sent: 01. November 2001 16:57
To: sigtran
Subject: Re: M3UA : some confusions over SG

Qun,

                                ______                  
                               /      \                 

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to
[email-masked]

---