Subject: Re: [Tsvwg] SCTP applicability statement

From: Allison Mankin <[email-masked]>
Date: Sun, 04 Nov 2001 16:22:14 -0500

> Does SCTP support failover between multi-homed hosts?
> 
> 
> Is failover between multi-homed hosts within the scope of SCTP?

Brian,

SCTP's multi-homing has no relation to anything between*
hosts, only between interfaces of one host.  There might be
some kind of cluster that appears to its SCTP peer be one host 
with multiple interfaces, but it would not be within the scope
of SCTP to know about the cluster. 

In draft-ietf-aaa-transport-04.txt, section 3.2. there's a 
good discussion of failover/failback, which distinguishes
among:

- what a cluster does in its cluster OS or cluster communication
  system 
- what application-level watchdogs do, where the failover is among
  multiple potential peers (here AAA servers)
- what SCTP does

If all interfaces of an SCTP host are down, that's the second case.

Allison

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: RJ Atkinson <[email-masked]>
Date: Sun, 04 Nov 2001 16:32:40 -0500

At 15:58 04/11/01, Brian F. G. Bidulock wrote:
>But this is what SIGTRAN *has* done by havinng multiple ASPs and SGPs
>with loadsharing, broadcast and active/standby between ASPs and SGPs
>as members of the cluster.  This is also what rserpool does.  

I disagree with your assertion that defining how to build
a cluster computer is what has been done by those efforts.

Ran
[email-masked]

---