Subject: Re: dynamically changing routing key

From: veeraraghavan selvam <[email-masked]>
Date: Sat, 2 Feb 2002 08:10:51 -0800 (PST)

Brian,

      what will happen to the other ASP's which  have
      Registered for this RK .
      
      Whether the SG Has to send a Different RC for
      this new RK.

      Please correct me if iam wrong.

thanx,
selva

--- "Brian F. G. Bidulock" <[email-masked]>
wrote:
> Resend...
> 
> Narendar,
> 
> SUA-10 page 95:
> 
>   An ASP MAY modify an existing Routing Key by
> including a Routing Context
>   parameter in the REG REQ.  If the SGP determines
> that the Routing Context
>   applies to an existing Routing Key, the SG MAY
> adjust the existing Routing
>   Key parameter.  A Registration Response "Routing
> Context Registration
>   Refused" is returned if the SGP deos not accept
> the modification of the
>   Routing Key.
> 
> It is clearly permitted for SUA.  M3UA, OTOH, does
> not include this paragraph.
> 
> M3UA should include both the paragraph and the Error
> Code in support of
> managing ISUP CICs on an live platform.  Even TALI
> (RFC 3094) supports this.
> At present M3UA does not.
> 
> --brian
> 
> Narendar Goel wrote:                                
>     (Mon, 21 Jan 2002 08:48:59)
> > Hi ,
> >  Please clarify this issue.
> >  Is it possible to change the routing key for a AS
> dynamically?
> > On page 55 of SUA draft 10 error code "Routing Key
> Change Refused" is
> > defined. But no such error code is defined for
> M3UA. If this error code is
> > correct for SUA then in what situations SG can
> refuse routing key change? Is
> > it implementation dependent ?
> > 
> > Routing key change is required in some practical
> situation. For example AS
> > handling traffic for certain set of mobile
> subscribers(IMSIs represented by
> > GTT) may want to add or delete IMSIs at run time.
> > 
> >  Thanks,
> > 
> > Regards,
> > Narender
> > 
> > 
> > 
> > ---
> > You are currently subscribed to sigtran as:
> [email-masked]
> > To unsubscribe send a blank email to
> [email-masked]
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
> 
> ---
> You are currently subscribed to sigtran as:
> [email-masked]
> To unsubscribe send a blank email to
[email-masked]

__________________________________________________
Do You Yahoo!?
Great stuff seeking new owners in Yahoo! Auctions! 
http://auctions.yahoo.com

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 4 Feb 2002 03:40:52 -0600

Selva,

We discussed three possibilities here:

	1  SG changes RK just for ASP making change.
	2  SG changes RK for all ASPs
	3  SG rejects change.

I think 2 is the correct answer.  This may involve splitting
traffic flows that were previously conjoined, but them's the
breaks!

--brian

veeraraghavan selvam wrote:              (Sat, 02 Feb 2002 08:10:51)
> > [email-masked]
> > 
> > -- 
> > Brian F. G. Bidulock
> > [email-masked]
> > http://www.openss7.org/
> > 
> > 
> > ---
> [email-masked]
> 
> 
> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran