Subject: RE: [Sigtran] ASP Identifier

From: "Goel, Soni" <[email-masked]>
Date: Thu, 28 Feb 2002 15:44:57 -0800

Hi,

An ASP should be concerned with the traffic of an AS which it needs to
takeover because of a failed ASP. So it needs to know identity of the AS
only. There is no need of ASP Id in Notify message.

- Soni

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Thursday, February 28, 2002 2:34 PM
To: Goel, Soni
Cc: Sigtran (E-mail)
Subject: Re: [Sigtran] ASP Identifier

Soni,

RC is not in the ERR("ASP Failure") message.  It is an ASP which has
failed not an AS.

Also, consider 3 ASPs.

--brian

Goel, Soni wrote:                                           (Thu, 28 Feb
2002 12:09:53)
> Hi,
> 
> Why does ASP1 need to know the Id of ASP2 ? The Routing Context present in
> Notify message is sufficient to inform ASP1 that an ASP has failed in this
> RC.
> 
> - Soni
> 
> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Thursday, February 28, 2002 10:58 AM
> To: Goel, Soni
> Cc: Sigtran (E-mail)
> Subject: Re: [Sigtran] ASP Identifier
> 
> 
> Soni,
> 
> Goel, Soni wrote:                                           (Thu, 28 Feb
> 2002 10:44:44)
> > Hi,
> > 
> > I have query regarding the second purpose of ASP Id i.e. -
> > To identify to other ASPs connected to the same SGP which ASP has failed
> in
> > a NTFY("ASP Failure").
> > 
> > The draft states -
> > "A Notify message reflecting a change in the AS state MUST be sent to
all
> > ASPs in the AS, except those in the ASP-DOWN state, with appropriate
> Status
> > Information and any ASP Identifier of the failed ASP."
> > 
> > How ASP Id of a failed ASP can be used at other ASPs in case of AS state
> > change ? Why is it required at all in this Notify message ?
> 
> 
> As disussed before:  ASP1 needs to distinguish between
> the following two cases:
> 
> a) where the communcation with ASP2 fails but ASP2
> is still processing traffic.
> 
> 
>                         ________                  
>                        |        |                 
>                  ______|  ASP2  |                 
>                 |      |________|                 
>                 |           |                     
>                 |           |                     
>       _______   |           X                     
>      |       |__|                                 
>      |  SGP  |__            X                     
>      |_______|  |           |                     
>                 |       ____|___                  
>                 |______|        |                 
>                        |  ASP1  |                 
>                        |________|                 
> 
> 
> b) where ASP2 becomes isolated an cannot process
> traffic anymore.
> 
> 
> 
>                        XXXXXXXXXX                 
>                        X        X                 
>                  ______X  ASP2  X                 
>                 |      XXXXXXXXXX                 
>                 X           |                     
>                             |                     
>       _______   X           X                     
>      |       |__|                                 
>      |  SGP  |__            X                     
>      |_______|  |           |                     
>                 |       ____|___                  
>                 |______|        |                 
>                        |  ASP1  |                 
>                        |________|                 
> 
> 
> NTFY("ASP Failure") without an ASP Id does not tell
> the ASP receiving the failure which ASP failed.  To
> distinguish between the above two cases, the ASP needs
> to know the identify of the failed ASP.
> 
> --brian
> 
> > - Soni
> > 
> > -----Original Message-----
> > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > Sent: Wednesday, February 27, 2002 6:38 PM
> > To: Goel, Soni
> > Cc: Sigtran (E-mail)
> > Subject: Re: [Sigtran] ASP Identifier
> > 
> > 
> > Soni,
> > 
> > I think you'll agree that IPSP is not well spelt out in the drafts.
> > 
> > However, Please see comments below...
> > 
> > Goel, Soni wrote:                                           (Wed, 27 Feb
> > 2002 17:37:07)
> > > Hi,
> > > 
> > > The explanation seems to be okay. But I have a query  regarding ASP Id
> in
> > > IPSP scenario.
> > > For IPSPs in Single Ended mode, should both the IPSPs need to know the
> ASP
> > > Id of peer ?
> > > If yes, then how will it be possible as in this mode only one IPSP
sends
> > > ASPUP message ?
> > > If not, then take the following scenario -
> > > IPSP1                               IPSP2
> > IPSP3
> > > (PC=100)                            (PC=200)
> > > (PC=200)
> > > (AspId=1)                           (AspId=2)
> > > (AspId=3)
> > >    |--------ASPUP (AspId=1)------------>|
> |
> > >    |<------ASPUP ack--------------------|
> |
> > >    |<------NTFY (AS Inactive)-----------|
> |
> > >    |---------ASPUP
> (AspId=1)-------------------------------------------->|
> > >    |<--------ASPUP
> Ack---------------------------------------------------|
> > >    |---------ASPAC--------------------->|
> |
> > >    |<-------ASPAC Ack-------------------|
> |
> > >    |<-------NTFY (AS Active)------------|
> |
> > >    |=Association Failure IPSP1 to IPSP2=|
> |
> > >    |---------Notify (AS state change to
> AS-PENDING)--------------------->|
> > > 
> > > In the above scenario IPSP1 doesn't have ASPId of IPSP2, so if IPSP1
> will
> > be
> > > sending Notify on assoc failure, then it will not be able to send
AspId
> of
> > > IPSP2?
> > 
> > Why do you have both ISPSs sending NTFY in single-ended mode?  I thing
you
> > are confusing this with double-ended.  If only IPSP2 and IPSP3 in you
> > example
> > sends NTFY on association failure (as per the single-ended mode), there
is
> > no
> > problem.
> > 
> > --brian
> > 
> > > 
> > > - Soni
> > > 
> > > -----Original Message-----
> > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > Sent: Wednesday, February 27, 2002 1:50 PM
> > > To: Goel, Soni
> > > Cc: Sigtran (E-mail)
> > > Subject: Re: [Sigtran] ASP Identifier
> > > 
> > > 
> > > Soni,
> > > 
> > > Please see comments below...
> > > 
> > > Goel, Soni wrote:                                           (Wed, 27
Feb
> > > 2002 11:50:46)
> > > > Hi,
> > > > Please see my comments below.
> > > > - Soni
> > > > 
> > > > -----Original Message-----
> > > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > > Sent: Tuesday, February 26, 2002 6:03 PM
> > > > To: Goel, Soni
> > > > Cc: Sigtran (E-mail)
> > > > Subject: Re: [Sigtran] ASP Identifier
> > > > 
> > > > 
> > > > Soni,
> > > > 
> > > > An ASP Identifier is used for two things: (1) to identify
> > > > an ASP when connecting to an SGP when no other mechanism
> > > > (e.g, IP address and port number) can distinguish between
> > > > ASPs; and, 
> > > > 
> > > > [Soni] Does it mean multiple ASPs having same IP address and same
port
> > > > number ? That is something wierd.
> > > 
> > > No.  It means multiple ASPs having the same IP address and
> > > different point numbers, but the port numbwer are dynamically
> > > assigned by the ASPa and the SGP cannot use port number to
> > > distinguish between the ASPs.
> > > 
> > > This is a very common arrangement for both TCP and SCTP.  The
> > > SGP is listening on the well-known port number (2905) and the
> > > ASP connects with a dynamically assigned port number.
> > > 
> > > For example, when you browse the web, you connect to the server
> > > on port 80, but your computer dynamically assigns a port number
> > > to the connection.
> > > 
> > > The same is true for SCTP.  When multiple ASP processes on a
> > > host connect to the SGP port number 2905, it is quite normal
> > > to dynamically assign ASP port numbers to each process.  Thus
> > > there can be two ASPs connecting to the SGP from the same host,
> > > but the SGP cannot distinguish between them.  To accomplish
> > > this the ASP sends the ASP Id in these circumstances to permit
> > > the SGP to distinguish between the ASPs.
> > > 
> > > > 
> > > > (2) to identify to other ASPs connected to the
> > > > same SGP which ASP has failed in a NTFY("ASP Failure").
> > > > 
> > > > To serve both purposes, the ASP Id of an ASP must uniquely
> > > > identify the ASP to an SGP.  So, it could be provisioned on
> > > > as much as a per ASP/SGP relation: that is, on an SCTP
> > > > association basis.
> > > > 
> > > > What makes you think it must be unique to an AS?  It does
> > > > not appear with RC in any messages...
> > > > 
> > > > [Soni] Because M3UA draft states the following -
> > > > "The optional ASP Identifier parameter contains a unique value that
is
> 
> > > > locally significant among the ASPs that support an AS."
> > > 
> > > ASPs that do not support an AS are not very useful ASPs. :)
> > > 
> > > It is significant to a group of ASPs because when the an
> > > ASP receives an ASP Id in NTFY("ASP Failure") it needs to be
> > > able to determine to which ASP the NTFY pertains.  This, however,
> > > can still be accomplished with an ASP Identifier which is unique
> > > to the SGP/ASP relation (SCTP association) because the ASP knows
> > > on which association the NTFY was received.
> > > 
> > > In general this is accomplished at the SGP. That is, each ASP
> > > connecting to the SGP must have a unique ASP Id (either in the
> > > ASPUP or from local determination based on IP addresses and
> > > stuff).  The connection ASP should also know the identifier of
> > > other ASPs connecting to the same SGP in which it is interested.
> > > When the SGP sends the NTFY, it uniquely identifies the ASP
> > > to which SGP/ASP communication has failed to the other connected
> > > ASPs.
> > > 
> > > It is rather very simple.  Is it clear to you now?
> > > 
> > > --brian
> > > 
> > > -- 
> > > Brian F. G. Bidulock
> > > [email-masked]
> > > http://www.openss7.org/
> > 
> > -- 
> > Brian F. G. Bidulock
> > [email-masked]
> > http://www.openss7.org/
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 28 Feb 2002 18:34:25 -0600

Soni,

It is necessary because to know which traffic to take over for the
AS, it needs to know the identity of the ASP.  ASP Id is required
when available in the Notify message.

--brian

Goel, Soni wrote:                                           (Thu, 28 Feb 2002 15:44:57)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/