Subject: [Sigtran] How should an AS be viewed ?

From: "Duhoon, Rajiv" <[email-masked]>
Date: Mon, 25 Feb 2002 17:15:02 -0800

Hi All,

If an ASP  have an  ISUP user and two  SGPs SGP1 and SGP2
as shown in the diagram wants to send ISUP traffic to
this ASP then  which of the following AS view is
correct as per M3UA Draft ?

Following configurations has been defined as per M3UA Draft stating
that each RK is 1:1 mapped with AS, each RK is 1:1 mapped with RC
& therefore AS is also 1:1 mapped with RC.

----------------------------------------------------------------------
View 1:
ASP serving two independent AS (AS1 & AS2) for same routing key at two
SGPs:

Routing Key (RK1)   -  DPC = 300, OPC = *, SIO = ISUP, CIC = *

At SGP1
AS1 --map to --> RK1 --map to --> RC1

At SGP2
AS2 ---map to --> RK1 ----> RC2

ASP1 goes active for both of these SGP(s) by generating two
independent ASP ACTIVE messages with RC1 & RC2 as routing context
parameter.

           PC = 100            
     +-------------+  
     |       +---+ | 
     | SGP1  |AS1 ||--------+           +-------------+
     |       +---+ |        |           |             | 
     +-------------+        |-----------|  ASP1       |
                            |           |             |
                            |           +-------------+  
                            |                 PC = 300
     +-------------+        |
     |       +---+ |        |
     | SGP1  |AS2| |--------+      
     |       +---+ |
     +-------------+  
          PC = 200

-------------------------------------------------------------------------

Routing Key (RK1)   -  DPC = 300, OPC = *, SIO = ISUP, CIC = *

View 2:
ASP serving single AS for a single routing key at both the SGPs

Routing Key (RK1)   -  DPC = 300, OPC = *, SIO = ISUP, CIC = 100 - 200

At SGP1
AS1 -- map to --> RK1 -- map to --> RC1

At SGP2
AS1 --- map to --> RK1 -- map to --> RC1

ASP1 goes active for both of these SGP(s) be generating two independent 
ASP ACTIVE messages with same Routing Context RC1 as routing context
parameter

           PC = 100            
     +-------------+  
     |       +---+ | 
     | SGP1  |AS1| |--------+          +-------------+
     |       +---+ |        |           |+---+        | 
     +-------------+        |-----------||AS1|  ASP1  |
                            |           |+---+        |
                            |           +-------------+  
                            |                 PC = 300
     +-------------+        |
     |       +---+ |        |
     | SGP1  |AS1| |--------+      
     |       +---+ |
     +-------------+  
          PC = 200
----------------------------------------------------------------------------
----

With in a network for one routing key (e.g RK1 defined above) served by an
ASP, is
allowed to have  multiple independent AS defined on different SGP(s) as in
View 1 or all 
the SGPs should have a common view of a single AS served by ASP as defined
in View 2.

In my opinion  1:1 mapping or RK:AS, RK:RC, AS:RC should be true at SGP as
in view 1
and not as in view 2. SGP should be allowed to define independent AS for
there routing
needs.

Thanks,
Rajiv

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 26 Feb 2002 03:19:43 -0600

Rajiv,

If SGP1 and SGP2 belong to different SGs there is no requirement
to coordinate the RC values between SGs and View 1 is permitted.
If SGP1 and SGP2 belong to the same SG, there was a requirement
in the spec which says that these SGP "SHOULD" coordinate RC
values across SGP belonging to the same SG and View 2 is required.

Even if the SGP do not belong to the same SG, if the SGs are
acting as mated STPs, one would expect View 2 to prevail although
it is not required by the spec.

Do these SGP belong to the same SG?

--brian

Duhoon, Rajiv wrote:                                      (Mon, 25 Feb 2002 17:15:02)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/