Subject: RE: [Sigtran] Adding more lines to M2UA and M3UA for TTC PRI bits

From: "Otsuka.Hiroshi" <[email-masked]>
Date: Fri, 1 Feb 2002 20:10:49 +0900

Dear Brian,

The PRI bits are located 6th and 7th bits (G and H bits) of LI octet which
defined in TTC Q.703 (you can also refer to ITU-T Q.703 that PRI uses two
spare bits between LI and SIO of ITU-T).   So I believe if it copied to M2UA
PDU, the PRI bits should locate on 6th and 7th bits of LI octet.

It may be strange that the only MP description has an example.  But the 
TTC Q.704 defines the PRI priority as;

	H G	Priority		Integer
	1 1	High		3
	1 0			2
	0 1			1
	0 0	Low		0

So when the PRI bits are copied to MP from LI, the 6th and 7th bit in LI
must
be swapped in MP octet.   So I think it would be nice to give additional
comment 
like;

		     0  1  2  3  4  5 6  7 
		    +-+-+-+-+-+-+-+-+
MP for TTC PRI =   | 0 0  0  0  0 0| H| G|
		    +-+-+-+-+-+-+-+-+

Or do you think this is too much?

Best regards,
Hiroshi Otsuka

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Friday, February 01, 2002 3:56 AM
To: Otsuka.Hiroshi
Cc: [email-masked]
Subject: Re: [Sigtran] Adding more lines to M2UA and M3UA for TTC PRI
bits

Otsuka,

A few comments below...

Otsuka.Hiroshi wrote:                              (Thu, 31 Jan 2002
19:16:35)
> Dear Lyndon, Greg and Ken,
> 
> We (TTC) have been interested in adding some comments related 
> to PRI on current M2UA and M3UA drafts, to make sure that the
> everybody has the same idea for the location of PRI bits.   We think
> people can understand how the PRI bits should be placed in M2UA
> and M3UA from the drafts.   But we would like to add a few more 
> comments in each drafts to give more clear understanding of PRI.
> Since we asked to include the TTC spec. to M2UA and M3UA in 
> 2000, we believe it is our responsibility to give clear explanation to 
> avoid any confusion.   So please consider to add following lines to 
> current M2UA and M3UA drafts.
> 
> M2UA:
> We would like to make sure the location of PRI bits in LI octet for
> M2UA PDU.   I believe the LI octet appears twice in this draft (Section
> 3.3.1.1 Data and Section 3.3.1.11 Retrieval Indication).   We would like
> to insert following lines after the sentence of "The Japanese TTC 
> variant uses the spare bits of the LI octet for priority. "
> in Section 3.3.1.1 Data (Page 19) of m2ua-13.txt.
>
----------------------------------------------------------------------------
> -----------
> The format of LI octet is;
> 
>     0               
>     0 1 2 3 4 5 6 7 
>    +-+-+-+-+-+-+-+-+
>    |   spare   |PRI| (followed by SIO, SIF) 
>    +-+-+-+-+-+-+-+-+
>
----------------------------------------------------------------------------
> -----------

Actually, I think that the LI octet (as present in the SS7 message)
looks like this:

      0
      0 1 2 3 4 5 6 7
     +-+-+-+-+-+-+-+-+
     |PRI|  ignored  |
     +-+-+-+-+-+-+-+-+

If the first byte of the message is not to be formatted the same
as it appears in the SS7 message, it should be separated into it's
own TLV parameter.

> 
> M3UA:
> The existing MP explanation will be good enough to give understanding
> of how the PRI bits are placed in MP field.   But we appreciate if 
> following lines can be added after the sentences of MP description
> (Page 31) of Section 3.3.1 Payload Data Message in m3ua-11.txt.
>
----------------------------------------------------------------------------
> -----------
> For example, the MP field for TTC-style would be;
> 
>     0 1 2 3 4 5 6 7 
>    +-+-+-+-+-+-+-+-+
>    |0 0 0 0 0 0|PRI| 
>    +-+-+-+-+-+-+-+-+
>
----------------------------------------------------------------------------
> -----------

This is the same as for other protocol variants supporting message
priorities where the octet can take on the valies 0, 1, 2, 3.  IMHO
there is no need to separate out a TTC format here.

> 
> Also we believe it will be nice to have following TTC document in the 
> references of M2UA and M3UA, to provide the reference of PRI;
>
----------------------------------------------------------------------------
> -----------
> [x] Telecommunication Technology Committee (TTC) Standard JT-Q704,
>     'Message Transfer Part Signaling Network Functions', 
>     April 28, 1992.  
>
----------------------------------------------------------------------------
> -----------

I agree that it would be useful to add the reference.

--brian

> 
> We believe these additional lines will not give any changes to the 
> contents of M2UA and M3UA, but it will give more description of PRI
> location.   We also believe it will be nice to have similar level of 
> description among M2UA, M2PA and M3UA.
> 
> Again we appreciate if you consider to add above lines to these drafts.   
> If you have any difficulties or comments, please let me know.
> 
> Best regards,
> Hiroshi Otsuka
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 1 Feb 2002 10:40:48 -0600

Otsuka,

I think you will find that ITU-T number bits like this:

   7 6 5 4 3 2 1 0
  +-+-+-+-+-+-+-+-+
  |H|G|F|E|D|C|B|A|
  +-+-+-+-+-+-+-+-+

but IETF numbers the same bits like this:

   0 1 2 3 4 5 6 7
  +-+-+-+-+-+-+-+-+
  |H|G|F|E|D|C|B|A|
  +-+-+-+-+-+-+-+-+

That would mean that bits H and G corresponds to bits 0 and 1 and
the LI octet looks like this:

   0 1 2 3 4 5 6 7
  +-+-+-+-+-+-+-+-+
  |PRI|    LI     |
  +-+-+-+-+-+-+-+-+

It would be best to leave the LI octet as it appears "on the line".
I think that you have the bit order reversed.

--brian

Otsuka.Hiroshi wrote:                              (Fri, 01 Feb 2002 20:10:49)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/