Subject: [Sigtran] RE: [Tsvwg] Re: SCTP multihoming issues draft

From: Coene Lode <[email-masked]>
Date: Fri, 8 Feb 2002 16:50:01 +0100

Sorry, Pekka, Forgot to reply on one of your points.

> > Well, actually that section probably has not taken consideration at 
> > all of single-homed NATs (which in turn is not something 
> that comes to 
> > mind at once when talking about a NAT). 
> >
> > This is needed because single-homed _SCTP_ works together 
> with NATs nicely 
> > (because no multiple IP addresses are carried inside the 
> SCTP packets in the 
> > association setup phase), but multi-homed SCTP carries 
> these IP addresses 
> > inside the INIT and INIT ACK chunks, so something needs to 
> be tweaked in
> > that case.
> 
> If you use IP+SCTP, NAT still has to support rewriting the 
> port numbers 
> and IP numbers.  Therefore I gather NAT will have to be 
> modified anyway 
> cope with the fact.  This will probably include going into 
> INIT/INIT ACK 
> chunks, no?  
> 
you are 100% right. The NAT boxes has to look in the INIT/INIT ACK.(and
probably do some stuff) 

Yours sicnerly,
Lode Coene

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Coene Lode <[email-masked]>
Date: Tue, 12 Feb 2002 12:18:04 +0100

Hello Pekka,

Sorry for the delay(some minor internal system failures:-) 

> -----Original Message-----
> From: Pekka Savola [mailto:[email-masked]]
> Sent: vrijdag 8 februari 2002 16:01
> To: Coene Lode
> Cc: Andreas Jungmayer (E-mail); Transport Area wg (E-mail); SIGTRAN
> (E-mail); [email-masked]'
> Subject: [Sigtran] RE: SCTP multihoming issues draft
> 
> > > ==> on a generic note: it seems to me there is a need for routing
> > > tables on hosts only if one wants to optimize the paths: 
> one is used
> > > by default, and if it fails, just (try to) switch to the next one,
> > > right?
> > > 
> > 
> > See previous remark on routing tables.
> 
> See my reply to Andreas. (note to others: multi6 was stripped 
> from Cc:).
> 
> In short, routing table is naturally required, but the draft 
> talks about 
> the need to "download" a fuller table from edge routers on 
> hosts.  IMO 
> this is unnecessary.

the text is indeed too broad(my fault). It should be saying something
about"distributing some prefixes from the edge routers to the host". That is
far nearer to the truth.
But my favourite solution to this should be something that does NOT need "a
download" or "receiving some prefixes"(in general any solution needing to
bugger the adjacend routers) on the host. As such Randy's BSD implementation
is clearly good step in that direction.(as I could infer from his
explanation, correct me if I am wrong)

yours sincerly,
Lode

> 
> -- 
> Pekka Savola                 "Tell me of difficulties surmounted,
> Netcore Oy                   not those you stumble over and fall"
> Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords
> 
> 
> 
>