Subject: [Sigtran] ASP_INACT STATE

From: Jacques Rajchgod <[email-masked]>
Date: Fri, 01 Feb 2002 16:02:08 -0600

Ref: M3UA-09, Section 4.3.4.5, page 79:

Not sure how to interpret INACT:

1) The ASP is UP and exchanging data. It is in ACTIVE state. Now it wishes
to stop receiving data, so it sends an ASPIA and drops to ASP_INACTIVE
state.
2) The ASP is DOWN and receives an ASPUP request. It transitions to
ASP_INACTIVE state.

Both cases are referred-to as being in the ASP_INACTIVE state.
The problem:

The sections states that in the INACT state, a SG or ASP must still ACK an
ASPIA request, but I am not sure whether the doc means to say that in
relation to case "1" or "2". I tend to think that the doc means to say Case
"1", rather than case "2".

Please kindly advise.
Jacques Rajchgod
MCI Worldcom
Next Generation System Evaluation
Tel: [972] 729-7180
E-mail: [email-masked]

---

From: Ken Morneault <[email-masked]>
Date: Fri, 01 Feb 2002 19:46:53 -0500

Jacques,

Regardless of how the ASP transitioned to the INACTIVE state, when
it sends a ASPIA, the SG MUST still ACK the it.  

Hope this helps.

Regards,

Ken

At 04:02 PM 2/1/2002 -0600, you wrote:
>1) The ASP is UP and exchanging data. It is in ACTIVE state. Now it wishes to stop receiving data, so it sends an ASPIA and drops to ASP_INACTIVE state.
>2) The ASP is DOWN and receives an ASPUP request. It transitions to ASP_INACTIVE state.
> 
>The sections states that in the INACT state, a SG or ASP must still ACK an ASPIA request, but I am not sure whether the doc means to say that in relation to case "1" or "2". I tend to think that the doc means to say Case "1", rather than case "2".
> 
>Please kindly advise.
>
>Jacques Rajchgod
>MCI Worldcom

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran