Subject: [Sigtran] M3UA plugtest - Day 2 summary

From: Ken Morneault <[email-masked]>
Date: Wed, 27 Feb 2002 02:58:46 -0500

The following issues were raised today:

1)  another request that IPSP be discussed and a one exchange
method (single or double) selected

2)  Question about the following flow:

         ASP                                    SG
                 ---- REG (RKx)---------------->
                 <------- REG RSP (RC1)-----

                 ---- ASP Active (RC1)------->
                 <----ASP Active Ack----------

                 ---- REG (RKx)---------------->

SG receives a REG for a Routing Key that
was previously registered and is now Active.
What should SG do?  

- Send REG RSP with Error and keep ASP
active for this RK/RC, or

-  Send REG RSP with Error but change
ASP to inactive for this RK/RC, or

-  Send REG RSP with no Error and keep
ASP active for this RK/RC

3)  REG msg only has Service Indicator.  There
is interest in also allowing Network Indicator
(i.e. change Service Indicator field to SIO or
add NI parameter to message).

4)  Desire for more text on how ASP ID is 
supposed to be used

5)  Question about why multiple DPCs are allowed
in REG msg.  Why have multiple DPCs in a
single Routing Key?   It was noted that multiple
DPCs would be advantageous for the alias PC case.

6)  At last Interop, an question was raised about
accepting a parameter length of 4 for INFO and
DIAG.  Suggestion:  INFO and DIAG parameters
with length 4 would be accepted.

7)  Question about the following scenario:

        ASP                                    SG
                 ---- Inac (RC1)---------------->
                 <------- Inac Ack (RC1)-----

                 ----------- Dereg (RC1)------->
                 <----Dereg Rsp -----------------

                 ---- Inac (RC1)---------------->

What should SG do?  General consensus was
the following:

If the RK was registered and dynamically added 
to SG, respond with Error.  If RK was registered
but already statically defined at SG, respond
with Inactive Ack.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 27 Feb 2002 04:16:32 -0600

Ken,

Please see comments below...

Ken Morneault wrote:                                          (Wed, 27 Feb 2002 02:58:46)
> was previously registered and is now Active.

This first one, for reasons already discussed
on the list.

> add NI parameter to message).

If NI is added, NA should be removed. ;)

NI is implied by the NA parameter which can be
placed in the REG msg.  There is no need for
the SS7 link-specific NI field in the REG msg.

> 4)  Desire for more text on how ASP ID is 

What more can be said?

> DPCs would be advantageous for the alias PC case.

REG has multiple PCs for the alias PC case.

> but already statically defined at SG, respond

Should always be ASPIA Ack.  The ASP should be
able to determine the reponse of the SG in these
situations without having to peer into the innards
of the SG or keep track of ancient history.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/