Subject: RE: [Sigtran] ASP Identifier

From: "Goel, Soni" <[email-masked]>
Date: Thu, 28 Feb 2002 16:52:20 -0800

Hi,

Why will an ASP need to know the identity of another ASP to decide which
traffic it wants to take over ? After the ASP receives the identity of
Application Servers, it becomes a local decision at ASP to determine which
AS it wants to be active for.
Moreover, once an ASP becomes active for an AS in Override mode, it has to
handle all the AS traffic. And if the AS is in Loadshare mode then it is the
SGP which decides the traffic distribution based on the Loadshare algorithm.

- Soni

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Thursday, February 28, 2002 4:34 PM
To: Goel, Soni
Cc: Sigtran (E-mail)
Subject: Re: [Sigtran] ASP Identifier

Soni,

It is necessary because to know which traffic to take over for the
AS, it needs to know the identity of the ASP.  ASP Id is required
when available in the Notify message.

--brian

Goel, Soni wrote:                                           (Thu, 28 Feb
2002 15:44:57)
> 
> Hi,
> 
> An ASP should be concerned with the traffic of an AS which it needs to
> takeover because of a failed ASP. So it needs to know identity of the AS
> only. There is no need of ASP Id in Notify message.
> 
> - Soni
> 
> 
> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Thursday, February 28, 2002 2:34 PM
> To: Goel, Soni
> Cc: Sigtran (E-mail)
> Subject: Re: [Sigtran] ASP Identifier
> 
> 
> Soni,
> 
> RC is not in the ERR("ASP Failure") message.  It is an ASP which has
> failed not an AS.
> 
> Also, consider 3 ASPs.
> 
> --brian
> 
> Goel, Soni wrote:                                           (Thu, 28 Feb
> 2002 12:09:53)
> > Hi,
> > 
> > Why does ASP1 need to know the Id of ASP2 ? The Routing Context present
in
> > Notify message is sufficient to inform ASP1 that an ASP has failed in
this
> > RC.
> > 
> > - Soni
> > 
> > -----Original Message-----
> > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > Sent: Thursday, February 28, 2002 10:58 AM
> > To: Goel, Soni
> > Cc: Sigtran (E-mail)
> > Subject: Re: [Sigtran] ASP Identifier
> > 
> > 
> > Soni,
> > 
> > Goel, Soni wrote:                                           (Thu, 28 Feb
> > 2002 10:44:44)
> > > Hi,
> > > 
> > > I have query regarding the second purpose of ASP Id i.e. -
> > > To identify to other ASPs connected to the same SGP which ASP has
failed
> > in
> > > a NTFY("ASP Failure").
> > > 
> > > The draft states -
> > > "A Notify message reflecting a change in the AS state MUST be sent to
> all
> > > ASPs in the AS, except those in the ASP-DOWN state, with appropriate
> > Status
> > > Information and any ASP Identifier of the failed ASP."
> > > 
> > > How ASP Id of a failed ASP can be used at other ASPs in case of AS
state
> > > change ? Why is it required at all in this Notify message ?
> > 
> > 
> > As disussed before:  ASP1 needs to distinguish between
> > the following two cases:
> > 
> > a) where the communcation with ASP2 fails but ASP2
> > is still processing traffic.
> > 
> > 
> >                         ________                  
> >                        |        |                 
> >                  ______|  ASP2  |                 
> >                 |      |________|                 
> >                 |           |                     
> >                 |           |                     
> >       _______   |           X                     
> >      |       |__|                                 
> >      |  SGP  |__            X                     
> >      |_______|  |           |                     
> >                 |       ____|___                  
> >                 |______|        |                 
> >                        |  ASP1  |                 
> >                        |________|                 
> > 
> > 
> > b) where ASP2 becomes isolated an cannot process
> > traffic anymore.
> > 
> > 
> > 
> >                        XXXXXXXXXX                 
> >                        X        X                 
> >                  ______X  ASP2  X                 
> >                 |      XXXXXXXXXX                 
> >                 X           |                     
> >                             |                     
> >       _______   X           X                     
> >      |       |__|                                 
> >      |  SGP  |__            X                     
> >      |_______|  |           |                     
> >                 |       ____|___                  
> >                 |______|        |                 
> >                        |  ASP1  |                 
> >                        |________|                 
> > 
> > 
> > NTFY("ASP Failure") without an ASP Id does not tell
> > the ASP receiving the failure which ASP failed.  To
> > distinguish between the above two cases, the ASP needs
> > to know the identify of the failed ASP.
> > 
> > --brian
> > 
> > > - Soni
> > > 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 28 Feb 2002 20:05:21 -0600

Soni,

Goel, Soni wrote:                                           (Thu, 28 Feb 2002 16:52:20)
> AS it wants to be active for.

RC is not part of the ERR("ASP Failure") message.  The ASP does not receive
the identify of the AS.  If the ASP failure does not change the overall state
of the AS (e.g. loadshare with ASPs > n), the ASP will not receive AS
notification either.  This still means that some AS are running "vulnerable".
If the ASP has the identify of the failed ASP, it can determine for which AS
it is sparing the other ASP and become active for those AS before things
become critical.  Unfortunately, the SG does not notify when the AS only has
`n' processors, just when it has `n-1'.

Thus, ASP Id in ASP Failure is necessary.

> SGP which decides the traffic distribution based on the Loadshare algorithm.

But you forget, as above, that the ASPs are still responsible for determining
how many ASPs are serving a loadshare AS.

Also, in broadcast mode, the ASPs determine which traffic distribution they
are serving, not the SG.  So, broadcast mode is another example of where an
ASP needs to know the identify of the failed ASP to determine the traffic that
it needs to assume.

Thus, ASP Id in ASP Failure is again necessary.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/