Subject: [Sigtran] Who checks for the limit?

From: "vaibhav_madan" <[email-masked]>
Date: Tue, 12 Feb 2002 10:13:24 +0530

Hi

      In the M3UA Draft - 12, Page 7

The M3UA layer does not impose a 272-octet signalling information field 
(SIF) length limit as specified by the SS7 MTP Level 2 protocol [7,8,9].  
Larger information blocks can be accommodated directly by M3UA/SCTP, 
without the need for an upper layer segmentation/reassembly procedure as 
specified in recent SCCP or ISUP versions.  However, in the context of 
an SG, the maximum 272-octet block size must be followed when 
interworking to a SS7 network that does not support the transfer of 
larger information blocks to the final destination.  This avoids 
potential ISUP or SCCP fragmentation requirements at the SGPs.  The 
provisioning and configuration of the SS7 network determines the 
restriction placed on the maximum block size.  Some configurations 
(e.g., Broadband MTP [21]) may permit larger block sizes.

Who places the restrictions(on an ASP) if the SG is a part of a MTP-3 network which has maximum packet size as 172 octet? Is the restriction a config parameter of the M3UA User or M3UA has to put a check or SCTP does it? 

What will happen if the M3UA User(at an ASP) gives packets bigger than 272 octets(in case of restriction at SG)? Will M3UA reject it or will  it pass it to the SGP?

Regards

Vaibhav
Get Your Private, Free E-mail from Indiatimes at  http://email.indiatimes.com
Buy Music, Video, CD-ROM, Audio-Books and Music Accessories from http://www.planetm.co.in

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 11 Feb 2002 23:22:44 -0600

Vaibhav,

IMO it is the responsibility of the SGP to enforce SS7 network
interworking restrictions in backhaul scenarios.  This is no
different than the MTP enforcing the same restriction to its
users.  If an SGP gets a message which breaks this restriction,
an error message should be returned (e.g., Error("Protocol Error")).

In the point-to-point scenario, there is no such restriction.

--brian

vaibhav_madan wrote:                     (Tue, 12 Feb 2002 10:13:24)
>    Who places the restrictions(on an ASP) if the SG is a part of a MTP-3
>    network which has maximum packet size as 172 octet? Is the restriction
>    a config parameter of the M3UA User or M3UA has to put a check or SCTP
>    does it?
>    
>    What will happen if the M3UA User(at an ASP) gives packets bigger than
>    272 octets(in case of restriction at SG)? Will M3UA reject it or will
>    it pass it to the SGP?
>    
>    Regards
>    
>    Vaibhav

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran