Subject: [Sigtran] Regarding DATA messages in IUA

From: "Sundaresan M" <[email-masked]>
Date: Mon, 11 Feb 2002 16:37:30 +0530

BlankHi all,

I am having a query on IUA protocol implementation. I am following the
RFC3057.

In IUA, when MGC wishes the D-channel to be inservice it sends ESTABLISH
Request Message. SG replies MGC with a ESTABLISH confirm message.

Typically we have DATA Request from MGC to SG and Data Indication from SG to
MGC. I think these two messages are sent between MGC and SG whenever the
Protocol traffic data is waiting at their ends and NOT on REQUEST and REPLY
basis.

Meaning the Q.931 data is sent from MGC to SG in DATA INDICATION message and
Q.931 data is sent from SG to MGC in Data Request autonomously.

Is my assumption right?

Best Regards,

Sundar.

Perfection is achieved, not when there is nothing more to add, but when
there is nothing left to take away.

********************
Sundaresan.M.G
Senior Software Engineer
SIGTRAN-TE, GNNettest
Future Software
Voice : 4330550 @ 328
********************

---

From: "Subhodeep Sarkar" <[email-masked]>
Date: Mon, 11 Feb 2002 17:56:24 +0530

Hi,

Indication and request is in terms of user and provider i.e. if Q.931(user) sends a DATA message down to IUA (provider) it's a DATA Request by Q.931, but the same message in the peer Q.931 will be  treated as a DATA Indication.

Cheers,

Subhodeep

Subhodeep Sarkar 
Wipro Technologies 
Voice Over IP Solutions 
Ph : +91-(0)80-8411990 x 1251 

[email-masked] wrote: 

BODY {
	BACKGROUND-COLOR: #fffbf0; COLOR: #000000; FONT-FAMILY: Times New Roman; FONT-SIZE: 11pt; MARGIN-LEFT: 25px; MARGIN-TOP: 25px
}
P.msoNormal {
	COLOR: #ffffcc; FONT-FAMILY: Helvetica, "Times New Roman"; FONT-SIZE: pt; MARGIN-LEFT: 0px; MARGIN-TOP: 0px
}
LI.msoNormal {
	COLOR: #ffffcc; FONT-FAMILY: Helvetica, "Times New Roman"; FONT-SIZE: pt; MARGIN-LEFT: 0px; MARGIN-TOP: 0px
}

Hi all,

I am having a query on IUA protocol implementation. I am following the RFC3057.

In IUA, when MGC wishes the D-channel to be inservice it sends ESTABLISH Request Message. SG replies MGC with a ESTABLISH confirm message. 

Typically we have DATA Request from MGC to SG and Data Indication from SG to MGC. I think these two messages are sent between MGC and SG whenever the Protocol traffic data is waiting at their ends and NOT on REQUEST and REPLY basis. 

Meaning the Q.931 data is sent from MGC to SG in DATA INDICATION message and Q.931 data is sent from SG to MGC in Data Request autonomously. 

Is my assumption right?

Best Regards,

Sundar.

Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away.

******************** 
Sundaresan.M.G 
Senior Software Engineer 
SIGTRAN-TE, GNNettest 
Future Software 
Voice : C30550 @ 328 
******************** 

Get Your Private, Free E-mail from Indiatimes at  http://email.indiatimes.com
Buy Music, Video, CD-ROM, Audio-Books and Music Accessories from http://www.planetm.co.in

---

From: "Subhodeep Sarkar" <[email-masked]>
Date: Wed, 13 Feb 2002 08:52:55 +0530

Hi Sundar,

The first view is correct i.e. both MGC and SG can send/receive DATA Request/Indication. The test specification only considered the case where the call is getng originated from MGC side so it's a DATA Request for the SG from MGC. But when a call originates from the SG side, it will send a DATA Request for MGC.

Cheers,

Subhodeep

Subhodeep Sarkar 
Wipro Technologies 
Voice Over IP Solutions 

Hi Subhodeep,
 
I have 2 different views on this Data Handling when talking in terms of MGC and SG.
They are:
 
1) Both MGC and SG can send Data Request and can expect for a Data indication in reply.
 
2) MGC always sends Data Request and SG always send Data Indication when transfering data.
 
Which of these views is correct. I am wrong please do correct me with little more explanations.
 
I had refferred to the following Test spec for my IUA implementation:
http://www.alternic.org/drafts/drafts-j-k/draft-jimenez-morneault-iua-test-spec-00.txt
According to this Test spec, MGC(ASP) always sends Data Request to SG and to reply on that DATA Indication is sent by the SG to MGC(ASP)
 
Thanks in advance,
 
Best Regards,
Sundar.

-----Original Message-----
From: Subhodeep Sarkar [mailto:[email-masked]]
Sent: Monday, 11 February 02 5:55 PM
To: [email-masked]
Subject: Re: [Sigtran] Regarding DATA messages in IUA

Hi,

Indication and request is in terms of user and provider i.e. if Q.931(user) sends a DATA message down to IUA (provider) it's a DATA Request by Q.931, but the same message in the peer Q.931 will be  treated as a ÚTA Indication.

Cheers,

Subhodeep

Subhodeep Sarkar 
Wipro Technologies 
Voice Over IP Solutions 

BODY {
	BACKGROUND-COLOR: #fffbf0; COLOR: #000000; FONT-FAMILY: Times New Roman; FONT-SIZE: 11pt; MARGIN-LEFT: 25px; MARGIN-TOP: 25px
}
P.msoNormal {
	COLOR: #ffffcc; FONT-FAMILY: Helvetica, "Times New Roman"; MARGIN-LEFT: 0px; MARGIN-TOP: 0px
}
LI.msoNormal {
	COLOR: #ffffcc; FONT-FAMILY: Helvetica, "Times New Roman"; MARGIN-LEFT: 0px; MARGIN-TOP: 0px
}

Hi all,

Is my assumption right?

Best Regards,

Sundar.

******************** 
Sundaresan.M.G 
Senior Software Engineer 
SIGTRAN-TE, GNNettest 
Future Software 
Voice : Ã0550 @ 328 
********************

---

From: "Subhodeep Sarkar" <[email-masked]>
Date: Wed, 13 Feb 2002 10:52:51 +0530

Hi Sundar,

My previous explaination was wrong - infact the second one in correct MGC to SG is request and SG to MGC in indication. The reason is even when the call is getting originated at the SG side from PBX to SG it's a DATA Request but the Q.921 at the SG will send it as a DATA indication to peer Q.931. 

Cheers,

Subhodeep
"Subhodeep Sarkar" wrote: 

Hi Sundar,

Cheers,

Subhodeep

Hi Subhodeep,

 

 
Thanks in advance,
 
Best Regards,
Sundar.

-----Original Message-----
From: Subhodeep Sarkar [mailto:[email-masked]]
Sent: Monday, 11 February 02 5:55 PM
To: [email-masked]
Subject: Re: [Sigtran] Regarding DATA messages in IUA

Hi,

Cheers,

Subhodeep

BODY {

Hi all,

Is my assumption right?

Best Regards,

Sundar.

******************** 
Sundaresan.M.G 
Senior Software Engineer 
SIGTRAN-TE, GNNettest 
Future Software 
Voice : Ã0550 @ 328 
********************