Subject: [Sigtran] M3UA congestion monitoring between a SG and an AS

From: "Zannin, Francois" <[email-masked]>
Date: Tue, 12 Feb 2002 10:17:33 +0100

Hi,

I have an issue about the congestion handling in M3ua between the ASp and the SGp when congestion occurs on the AS(p).
It is said that an ASP can send a SCON to a SGP or another IPSP when a local congestion occurs. 
If we use the multi level of congestion between the ASp and the SGp, what message can be used to monitor the level of congestion in the ASp from the SGp or remote IPSp. An ASp can send the DAUD SSMN to a SGp but there is no matching message from the SGp to the ASP.

If a multi level congestion (National option) is detected in an ASp, a SCON is sent from the Asp to a SGp that sends a TFC to the ss7 Concerned SP. This SP trigs the RCT procedure to monitor the state of the affected DPC, but because the SGP cannot send this message to the ASP, it must keep locally the state of congestion of the AS, state that can only be updated by the ASp. If the SCON indicating "No Congestion" is lost between the ASp and the SGP, the AS will stay congested forever in the SG!

Is there a procedure that can be used from a SGp to monitor the state of congestion of an AS, something equivalent to the DAUD that can only be used from ASp to SGp?

Francois Zannin.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 12 Feb 2002 09:08:17 -0600

Francois,

This mechanism is implementation dependent even in ANSI/ITU specs
and optional.

--brian

Zannin, Francois wrote:                    (Tue, 12 Feb 2002 10:17:33)
> Hi,
> 
> I have an issue about the congestion handling in M3ua between the ASp and
> the SGp when congestion occurs on the AS(p).

> If we use the multi level of congestion between the ASp and the SGp, what
> message can be used to monitor the level of congestion in the ASp from the
> SGp or remote IPSp. An ASp can send the DAUD SSMN to a SGp but there is no
> matching message from the SGp to the ASP.

> 
> If a multi level congestion (National option) is detected in an ASp, a SCON
> is sent from the Asp to a SGp that sends a TFC to the ss7 Concerned SP. This
> SP trigs the RCT procedure to monitor the state of the affected DPC, but
> because the SGP cannot send this message to the ASP, it must keep locally
> the state of congestion of the AS, state that can only be updated by the
> ASp. If the SCON indicating "No Congestion" is lost between the ASp and the
> SGP, the AS will stay congested forever in the SG!

> 
> Is there a procedure that can be used from a SGp to monitor the state of
> congestion of an AS, something equivalent to the DAUD that can only be used
> from ASp to SGp?

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/