Subject: RE: [Sigtran] How should an AS be viewed ?

From: "Vats, Umesh" <[email-masked]>
Date: Tue, 26 Feb 2002 10:26:52 -0800

Hi  Brian

You said that in M3UA specs, requiremenst is there
that "RC should be co-ordinated between SGPs of
the same SG". Can you please point to the section where
this is mentioned ?

If the RC is co-ordinated between SGPs of an SG, it means 
each SGP of an SG knows about the RCs and corresponding RKs 
registered with other SGPs of the SG. So, should
ASP  register RK with only a single SGP of an SG ?

thanks
Umesh

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Tuesday, February 26, 2002 1:20 AM
To: Duhoon, Rajiv
Cc: [email-masked]'
Subject: Re: [Sigtran] How should an AS be viewed ?

Rajiv,

If SGP1 and SGP2 belong to different SGs there is no requirement
to coordinate the RC values between SGs and View 1 is permitted.
If SGP1 and SGP2 belong to the same SG, there was a requirement
in the spec which says that these SGP "SHOULD" coordinate RC
values across SGP belonging to the same SG and View 2 is required.

Even if the SGP do not belong to the same SG, if the SGs are
acting as mated STPs, one would expect View 2 to prevail although
it is not required by the spec.

Do these SGP belong to the same SG?

--brian

Duhoon, Rajiv wrote:                                      (Mon, 25 Feb 2002
17:15:02)
> Hi All,
> 
> If an ASP  have an  ISUP user and two  SGPs SGP1 and SGP2
> as shown in the diagram wants to send ISUP traffic to
> this ASP then  which of the following AS view is
> correct as per M3UA Draft ?
> 
> Following configurations has been defined as per M3UA Draft stating
> that each RK is 1:1 mapped with AS, each RK is 1:1 mapped with RC
> & therefore AS is also 1:1 mapped with RC.
> 
> 
> ----------------------------------------------------------------------
> View 1:
> ASP serving two independent AS (AS1 & AS2) for same routing key at two
> SGPs:
> 
> Routing Key (RK1)   -  DPC = 300, OPC = *, SIO = ISUP, CIC = *
> 
> At SGP1
> AS1 --map to --> RK1 --map to --> RC1
> 
> At SGP2
> AS2 ---map to --> RK1 ----> RC2
> 
> ASP1 goes active for both of these SGP(s) by generating two
> independent ASP ACTIVE messages with RC1 & RC2 as routing context
> parameter.
> 
>            PC = 100            
>      +-------------+  
>      |       +---+ | 
>      | SGP1  |AS1 ||--------+           +-------------+
>      |       +---+ |        |           |             | 
>      +-------------+        |-----------|  ASP1       |
>                             |           |             |
>                             |           +-------------+  
>                             |                 PC = 300
>      +-------------+        |
>      |       +---+ |        |
>      | SGP1  |AS2| |--------+      
>      |       +---+ |
>      +-------------+  
>           PC = 200
> 
> -------------------------------------------------------------------------
> 
> Routing Key (RK1)   -  DPC = 300, OPC = *, SIO = ISUP, CIC = *
> 
> View 2:
> ASP serving single AS for a single routing key at both the SGPs
> 
> Routing Key (RK1)   -  DPC = 300, OPC = *, SIO = ISUP, CIC = 100 - 200
> 
> At SGP1
> AS1 -- map to --> RK1 -- map to --> RC1
> 
> At SGP2
> AS1 --- map to --> RK1 -- map to --> RC1
> 
> ASP1 goes active for both of these SGP(s) be generating two independent 
> ASP ACTIVE messages with same Routing Context RC1 as routing context
> parameter
> 
> 
>            PC = 100            
>      +-------------+  
>      |       +---+ | 
>      | SGP1  |AS1| |--------+          +-------------+
>      |       +---+ |        |           |+---+        | 
>      +-------------+        |-----------||AS1|  ASP1  |
>                             |           |+---+        |
>                             |           +-------------+  
>                             |                 PC = 300
>      +-------------+        |
>      |       +---+ |        |
>      | SGP1  |AS1| |--------+      
>      |       +---+ |
>      +-------------+  
>           PC = 200
>
----------------------------------------------------------------------------
> ----
> 
> With in a network for one routing key (e.g RK1 defined above) served by an
> ASP, is
> allowed to have  multiple independent AS defined on different SGP(s) as in
> View 1 or all 
> the SGPs should have a common view of a single AS served by ASP as defined
> in View 2.
> 
> In my opinion  1:1 mapping or RK:AS, RK:RC, AS:RC should be true at SGP as
> in view 1
> and not as in view 2. SGP should be allowed to define independent AS for
> there routing
> needs.
> 
> Thanks,
> Rajiv
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 26 Feb 2002 13:37:06 -0600

Umesh,

I actually said that it "was" in the draft.  The only mention
I see after a quick scan is in section 1.4.1:

| Where an SG contains more than one SGP, the MTP3 routeset, SPMC and 
| remote AS/ASP states of each SGP SHOULD be coordinated across all the 
| SGPs.  Rerouting of traffic between the SGPs MAY also be supported.

and 

| Where a particular AS can be reached via more than one SGP, the 
| corresponding Routing Keys in the SGPs should be identical.  (Note: 
| It is possible for the SGP Routing Key configuration data to be 
| temporarily out-of-sync during configuration updates).

Really, it is an operational consideration.

--brian

Vats, Umesh wrote:                                          (Tue, 26 Feb 2002 10:26:52)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/