Subject: [Sigtran] ASP Identifier

From: "Goel, Soni" <[email-masked]>
Date: Tue, 26 Feb 2002 16:50:43 -0800

Hi,

What is the scope of uniqueness of ASP Id? Should it be unique per AS or for
the whole network ?

- Soni

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 26 Feb 2002 20:02:37 -0600

Soni,

An ASP Identifier is used for two things: (1) to identify
an ASP when connecting to an SGP when no other mechanism
(e.g, IP address and port number) can distinguish between
ASPs; and, (2) to identify to other ASPs connected to the
same SGP which ASP has failed in a NTFY("ASP Failure").

To serve both purposes, the ASP Id of an ASP must uniquely
identify the ASP to an SGP.  So, it could be provisioned on
as much as a per ASP/SGP relation: that is, on an SCTP
association basis.

What makes you think it must be unique to an AS?  It does
not appear with RC in any messages...

--brian

Goel, Soni wrote:                                           (Tue, 26 Feb 2002 16:50:43)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/