Subject: [Sigtran] reg req

From: "Nahar,virendra" <[email-masked]>
Date: Fri, 15 Feb 2002 00:04:03 +0530

At SG side if u get a Reg Request from an ASP which is already ACTIVE
for this AS .
which action  should be the action taken ..options are !!
(a) Discard the request & send an  error message with cause unexpected
message.
(b) Send the Registration response with RC & result as successful & mark
the ASP in inactive state.
(c) Send a positive Reg Response & do not change the state of ASP.
(d) Send a negative Reg Response with code error unknown
(e) Define a new error code for this case .

        Pls clarify this condition

Thanks
Nahar

--
Virendra Nahar
HCL-Technologies Ltd
Networking Systems Lab
51, Jawaharlal Nehru Road
Guindy Industrial Estate,
Ekkatuthangal,
Chennai - 600 097.
Phone Off : +91 44 233 4174 or +91 44 233 4181(extn:261,218)
mailto:[email-masked]
############################################################
"He who has a why for life can put with any how."
                             Frederick Nietzsche
############################################################

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 14 Feb 2002 12:57:40 -0600

Nahar,virendra,

Nahar,virendra wrote:                              (Fri, 15 Feb 2002 00:04:03)
>         Pls clarify this condition

I would say (f) send a negative Reg Response with error code
"Cannot Support Unique Routing".

If you are considering the case where the ASP crashes and comes back up,
the ASP should have sent ASP UP resulting in deregistration of all routing
keys and deactivation of all AS.  So the only time that an ASP would send
such a thing is if the ASP is confused, perhaps about the state of an AS
under its control.  There is not much one can do here: the ASP is broken.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/