Subject: RE: [Sigtran] (M2PA) Please add a Network Appearance parameter to the M2PA protocol

From: "Bep Verberk" <[email-masked]>
Date: Tue, 28 May 2002 15:26:24 -0400

This is getting at the heart of my question to Brian about the
value of using M3UA for SG-SG versus just m2pa.

This a valid plus for M3UA, that is, you can send traffic
for more than one network over the same association.
Although I still believe  this is a minor plus.

Of course Jeff points out that he doesn't like/need some
of the other aspects of m3ua for SG-SG.

So it becomes a trade off Jeff.
You need to either 
1. use muliple m2pa associations -  each
carrying traffic for different networks
(I don't think this is so bad)

2. Use m3ua 

3. Do something proprietary like you are proposing. If you
do this please share your ideas with us :)

Bep 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, May 28, 2002 3:05 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [Sigtran] (M2PA) Please add a Network Appearance 
> parameter
> to the M2PA protocol
> 
> 
> 
> Hello Brian,
> 
> >M3UA SG-SG has Network Appearance.
> >Use it instead of mangling M2PA.
> 
> Bummer of an answer. 'mangling'?
> 
> So the goal of M2PA is to offer nothing more, or less, than 
> that provided
> by MTP2?
> 
> I know this discussion is not going anywhere, but.....
> 
> I happen to have a MTP3 layer that is aware of multiple ITU-N 
> networks.
> I need a means to convey that information across B,C,D 
> SS7-over-IP links.
> You argue that this functionality is L3-based and does not 
> belong in L2
> (M2PA).
> Unfortunately, the MTP3 message payload is fixed. The M2PA message
> payload is not yet fixed, but strictly defines the mapping of 
> MSUs. The
> M2PA protocol is not very extensible, except in terms of new 
> message types.
> 
> M3UA SG-SG is not a good choice for my implementation:
> 1) I have no need for routing key registration or of 
> application servers.
> 2) I have no need for elaborate conversions of SS7 SNMs and MSUs.
> 3) I have no need to use multiple SCTP streams for user data.
> 
> So I am left with adding a custom message type to M2PA or 
> using reserved
> bits.
> Okee dokee.
> 
> Regards,
> 
> Jeff
> 
> 
> 
>

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 28 May 2002 15:42:30 -0400

RE: [Sigtran] (M2PA) Please add a Network Appearance parameter to the M2PA
protocolBep,

But similarly you can also not answer the question, why one should use M2PA
instead of M3UA SG-SG? ;-)
Why to try simulate links in IP domain? Why try to put another protocol
(M2PA) there for relaying?
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of
Bep Verberk
  Sent: Tuesday, May 28, 2002 3:26 PM
  To: [email-masked]'; [email-masked]
  Cc: [email-masked]
  Subject: RE: [Sigtran] (M2PA) Please add a Network Appearance parameter to
the M2PA protocol

  2. Use m3ua

  Bep