Subject: RE: [Sigtran] Problem with dynamic Registration In IPSP scenario

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Tue, 28 May 2002 14:39:33 +0200

Hi Brian, 

Comments below...

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Tuesday, May 28, 2002 1:47 PM
> To: Javier Pastor-Balbas (ECE)
> Cc: [email-masked]'; [email-masked]
> Subject: Re: [Sigtran] Problem with dynamic Registration In IPSP
> scenario
> 
> 
> Javier,
> 
> I thought that it was clearly understood that the RFC only covers
> point-to-point IPSP behavior and does not support relaying.

Yes.
  
> In the case
> of point-to-point IPSP, each IPSP has one SPMC.  

It is nothing said about this restriction in the current text.

> As such, a 
> routing key
> of OPC-DPC-xxx is the only routing key supported for IPSP 
> regardless of
> single or double anything.  Because SI or CIC is the same for both
> peers, one routing key is simply OPC-DPC-SI/CIC and the other is
> DPC-OPC-SI/CIC.  

This seems to be your new thought, but nothing of this has been said till now. 

I also agree it is the only way to work with SE and dynamic registration... but I don't like too much changing the way of doing things... In ASP-SGP each ASP registers itself in the remote node as belonging to one AS. My thought is that things should work the same in here. RK and RC define an AS but not a communication.

> So what needs to be registered in any case?  
> An SI?  A
> CIC range?  The OPC/DPCs are statically provisioned.  SI and CIC are
> both symmetrical.  Where did you get the idea that two registrations
> were required?  A double ended approach just generates two 
> registrations
> and two RCs where one will do.
> 

A double exchange works completely in the same way as ASP does in ASP-SGP communication when registering an AS. ASes get registered one to one.

For N RKs per IPSP the number of REG-REQ needed to get a fully meshed communication is:

	- DE -> 2N
	- SE -> N*N  (taking into account this new proposal)

But anyway, if the OPCs/DPCs are statically provisioned, what do we need dynamic registration in SE for ?? :-/  I don't want to use RCs just for fun...  

Cheers // Javier.

> --brian
> 
> Javier Pastor-Balbas (ECE) wrote:                          
> (Tue, 28 May 2002 12:34:35)
> > Hi Akhtar, 
> > 
> > When we were discussing about the Single Exchange some time 
> ago, Brian was
> > in favour of having a unique RC for Single Exchange. This 
> unique Routing
> > Context should be previously negociated between both peers 
> and use it as a
> > representant of two RK. This is what is shown in the RFC: 
> One RC that
> > contains the information of the two RK. Nothing about 
> registration was
> > mentioned since the RC value should be negotiated before 
> the communication ,
> > and therefore static configuration could be just OK.
> > 
> > I would say that Dynamic Registration is not allowed in 
> Single Exchange
> > based on the previous paragraph. If you want to have 
> Dynamic Registration,
> > we can use the Double exchange where you just allow the 
> other peer to send
> > messages to you as you do in the ASP-SGP case.
> > 
> > From my point of view, your way of registering could be the 
> only way of
> > allowing this dynamic registration. But I don't like it too 
> much since I
> > think that each ASP/IPSP should be responsible of its own 
> registration. By
> > using your approach is one side who registers two RK at 
> once. This is a
> > different behavior of what is explain in the RFC. And 
> moreover the number of
> > registrations should grow exponentially as the number of RK per IPSP
> > increases.
> > 
> > I would simply state that use Double Exchange whenever you 
> want to use the
> > Dynamic Registration approach.
> > 
> > 
> > Cheers // Javier. 
> > 
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]]
> > > Sent: Tuesday, May 28, 2002 7:17 AM
> > > To: [email-masked]
> > > Subject: [Sigtran] Problem with dynamic Registration In 
> IPSP scenario
> > > 
> > > 
> > > 
> > > 
> > > Hi,
> > > 
> > > 1)  Does Dynamic Registration in IPSP-IPSP communication 
> > > require a single
> > >       exchange or a double exchange?
> > > 
> > > 2)  In case of single exchange , I have a problem as stated below.
> > >       For example in case shown below , where both peer 
> > > support single exchange
> > > , and
> > >       we dynamically register a Routing Key (DPC only from 
> > > IPSP B to IPSP A).
> > >       After sending an ACTIVE from IPSP B to IPSP A , both 
> > > ends can transfer
> > > traffic ,
> > >       Now IPSP B can accept traffic for PC X, but for what PC 
> > > will IPSP A
> > > receive traffic.
> > >          ________                                 ________
> > >         |                   |                              |  
> > >                  |
> > >         |   IPSP A  |---------------------- |   IPSP B  |
> > >         |________|                              |________ |
> > > 
> > >                                   REG REQ (SINGLE exchange) 
> > > RK = DPC only (value
> > > X )
> > >                              <---------------------
> > >                                   REG RSP
> > >                               ---------------------->
> > >                                   ACTIVE (Single exchange)
> > >                              <----------------------
> > >                                   Active ACK
> > >                               ----------------------->
> > >                                    DATA  for PC X ( Now both 
> > > sides can send data
> > > )
> > >                               ----------------------->
> > >                                     DATA     (but for which 
> > > PC will IPSP A
> > > receive data)
> > >                                 <-----------------------
> > > 
> > > [but the same can be done in double exchange when both IPSP A 
> > > & B exchange
> > > Routing Keys]
> > > How can the same be achieved in case of single exchange?
> > > 
> > > 3) The scenario shown above can be achieved with single 
> > > exchange if we use the
> > > Routing key
> > >      DPC+OPC , so does that mean that there some restriction 
> > > on the type of
> > > Routing keys to be
> > >      used for Dynamic Registration in IPSP -IPSP scenario? Is 
> > > Routing Key DPC
> > > only not valid in
> > >      this case ?
> > > 
> > > Regards
> > > -Akhtar
> > > 
> > > 
> > > 
> > > DISCLAIMER: This message is proprietary to Hughes Software Systems
> > > Limited (HSS) and is intended solely for the use of the individual
> > > to whom it is addressed. It may contain  privileged or 
> confidential
> > > information  and should not be circulated or used for any 
> > > purpose other
> > > than for what it is intended. If you have received this 
> > > message in error,
> > > please notify the originator immediately. If you are not 
> the intended
> > > recipient, you are notified that you are strictly prohibited 
> > > from using,
> > > copying, altering, or disclosing the contents of this 
> > > message. HSS accepts
> > > no responsibility for loss or damage arising from the use of 
> > > the information
> > > transmitted by this email including damage from virus.
> > > 
> > > 
> > > 
> > > _______________________________________________
> > > Sigtran mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > 
> > 
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 28 May 2002 09:03:31 -0400

Hi Javier,

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Javier Pastor-Balbas (ECE)
> Sent: Tuesday, May 28, 2002 8:40 AM
> To: [email-masked]'; Javier Pastor-Balbas (ECE)
> Subject: RE: [Sigtran] Problem with dynamic Registration In IPSP
> scenario
>
>
> Hi Brian,
>
> Comments below...
>
> I also agree it is the only way to work with SE and dynamic
> registration... but I don't like too much changing the way of
> doing things... In ASP-SGP each ASP registers itself in the
> remote node as belonging to one AS. My thought is that things
> should work the same in here. RK and RC define an AS but not a
> communication.
[TOLGA] This approach (remote RKs/local RKs) is nothing else than two
client/server relationships brought together (ASPF+SGPF). In my opinion a
real peer-to-peer relationship on ASP level (in fact it is better speaking
of ASP-ASP instead of IPSP) should work with single-exchange. That is my
main argument against what is tried to be said in the M3UA draft. Javier, I
really think you should prepare this "IPSP overview document" so that we can
discuss about it. What stands in the current draft is totally
ununderstandable, the only reason we have some discussions about it is,
because we were involved in the initial discussions.
> A double exchange works completely in the same way as ASP does in
> ASP-SGP communication when registering an AS. ASes get registered
> one to one.
[TOLGA] Also everything else works the same way like in ASP/SGP case. I
think that is the reason why "double exchange" approach is nothing else than
ASPF+SGPF. I hope people soon will see that this is nothing new and
something already possible with defined ASP/SGP relationship.
> But anyway, if the OPCs/DPCs are statically provisioned, what do
> we need dynamic registration in SE for ?? :-/  I don't want to
> use RCs just for fun...
[TOLGA] If I were you, I wouldn't agree with this, because if one is happy
with PC granularity, then SG-SG is a much more clean and a real peer-to-peer
solution :-)

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 28 May 2002 09:13:08 -0500

Javier,

Please see comments below...

Javier Pastor-Balbas (ECE) wrote:                          (Tue, 28 May 2002 14:39:33)
> It is nothing said about this restriction in the current text.

I view this restriction and the point-to-point restriction as
the same.  Point-to-point is SEP to SEP.  An SEP is an SPMC.
An IPSP as an SEP is an SPMC.

So it is in the current text: by saying point-to-point.

> This seems to be your new thought, but nothing of this has been said till now. 

There are entire ladders on this topic streching back over the last year.

> 
> I also agree it is the only way to work with SE and dynamic registration...
> but I don't like too much changing the way of doing things... In ASP-SGP
> each ASP registers itself in the remote node as belonging to one AS. My
> thought is that things should work the same in here. RK and RC define an AS
> but not a communication.
> 
> A double exchange works completely in the same way as ASP does in ASP-SGP
> communication when registering an AS. ASes get registered one to one.

I agree with Tolga: this is ASPF+SGPF not IPSP.

> 	- SE -> N*N  (taking into account this new proposal)

Correction: SE -> N

> 
> 
> But anyway, if the OPCs/DPCs are statically provisioned, what do we need
> dynamic registration in SE for ?? :-/  I don't want to use RCs just for
> fun...  

Then don't use two where one with do.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/