Subject: RE: [Sigtran] IPSP vs AS (was RE: sg-sg communication)

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 31 May 2002 10:43:37 -0400

Javier,

>
> I still don't understand why you say
> 	- SE -> ASP-ASP
> 	- DE -> AS-AS
[TOLGA] What I say is just the opposite : DE is ASP-ASP and SE is AS-AS.
For AS-AS:
The RK defines the traffic ranges at both ends.

For ASP-ASP:
The RK defines the traffic range just at one end.

In my opinion that is the real thing, we should decide, the scope of RK.
Otherwise it is not just the issue of sending one or two ASPUPs.

> Could you please explain it?  :-)
>
> For me both are AS-AS and none of them is ASP-ASP as they are
> IPSP-IPSP....  :-/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Fri, 31 May 2002 16:19:57 +0200

Tolga, 

For me both are AS-AS and none of them is ASP-ASP as they are IPSP-IPSP....  :-/

Thanks // Javier.

> -----Original Message-----
> From: Tolga Asveren [mailto:[email-masked]]
> Sent: Friday, May 31, 2002 4:25 PM
> To: [email-masked]
> Subject: RE: [Sigtran] IPSP vs AS (was RE: sg-sg communication)
> 
> 
> Brian,
> 
> > -----Original Message-----
> > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > Sent: Friday, May 31, 2002 10:04 AM
> > To: Tolga Asveren
> > Cc: [email-masked]
> > Subject: Re: [Sigtran] IPSP vs AS (was RE: sg-sg communication)
> > Importance: High
> >
> >
> > Tolga,
> >
> > Your mis-counting routing keys for the DE case again.  
> There is no reason
> > to use wildcarded RKs for the DE example and non-wildcarded 
> RKs for the
> > SE example.  In fact, as IPSP is point to point and statically
> > provisioned,
> > DE has 8 routing keys:
> >
> > At IPSP1          RK1: OPC=1-1-1 DPC=3-3-3
> >                   RK2: OPC=1-1-1 DPC=4-4-4
> >                   RK2: OPC=2-2-2 DPC=3-3-3
> >                   RK2: OPC=2-2-2 DPC=4-4-4
> >
> > At IPSP2          RK1: OPC=3-3-3 DPC=1-1-1
> >                   RK2: OPC=3-3-3 DPC=2-2-2
> >                   RK2: OPC=4-4-4 DPC=1-1-1
> >                   RK2: OPC=4-4-4 DPC=2-2-2
> [TOLGA] Why do we need OPC for DE case? For DE it is true 
> that one needs to
> enter 8 RKs (because each RK will be configured at both 
> IPSPs), but there
> will be 4 different types of RK for the configuration I draw. 
> The reason why
> one might use "wildcarded" RKs in DE is, because RKs have 
> meaning only for
> one end, for SE, it has meaning for both ends, so both ends should be
> specified. In my opinion, this is really ASP-ASP vs. AS-AS 
> and I think we
> should choose one of those approaches.
> >
> > When you compare apples to apples (instead of oranges) DE 
> always has twice
> > the number of RKs (and RC values) as SE.
> >
> > Thus the waste.
> >
> > --brian
> >
> > Tolga Asveren wrote:                             (Fri, 31 May
> > 2002 09:32:08)
> > > Javier,
> > >
> > >
> > > You can have your view that AS corresponds to something
> > physical, for me it
> > > is just a traffic range. In the past, there were a lot of
> > comments saying
> > > that definition of AS in M3UA draft is misleading because it
> > might give the
> > > impression that it is something physical. In my view, it is
> > strange to think
> > > that AS is talking to SG. Peer of an AS can be only another AS
> > or a layer4
> > > entity(ISUP/SCCP) in SS7 domain (in fact one call call them
> > also AS in the
> > > context of this discussion) ASP just serves AS and 
> transfers a specific
> > > traffic range.
> > >
> > > > > There is a
> > > > > huge difference between those two approaches. Basically this
> > > > > is the main
> > > > > difference between "double-ended" and "single-ended"
> > > > > approaches, it is not
> > > > > just whetehr ASPUP (or ASPAC) is sent from one side or from
> > two sides.
> > > >
> > > > How can AS-AS vs ASP-ASP explain the difference between SE
> > and DE? :-/.
> > > [TOLGA] Double ended approach : ASP-ASP
> > > There are local and remote RKs. A RK defines a traffic range
> > just on one end
> > >
> > >  AS1: DPC=1-1-1              AS3: DPC=3-3-3
> > >  AS2: DPC=2-2-2              AS4: DPC=4-4-4
> > >  +---------+                 +---------+
> > >  |         |                 |         |
> > >  |         |                 |         |
> > >  |IPSP1    |                 |         |
> > >  |         +-----------------+IPSP2    |
> > >  |         |                 |         |
> > >  |         |                 |         |
> > >  +---------+                 +---------+
> > > There will be 4 RKs. RK1: DPC=1-1-1 local to IPSP1 and 
> remote to IPSP2
> > >                      RK2: DPC=2-2-2 local to IPSP1 and 
> remote to IPSP2
> > >                      RK3: DPC=3-3-3 local to IPSP2 and 
> remote to IPSP1
> > >                      RK4: DPC=4-4-4 local to IPSP2 and 
> remote to IPSP1
> > >                      (Those 4 RKs will be defined at both 
> of the IPSPs)
> > > In this approach, it is obvious that 2 ASPACs are 
> necessary (and not to
> > > break symmetry 2 ASPUPs are also making sense, which will
> > enable to model
> > > this as SGPF+ASPF) Because for RK1/RK2 IPSP1 behaves like 
> ASP and IPSP2
> > > behaves like SGP and for RK3/RK4 it is the opposite. That is
> > the reason, why
> > > I am saying, this is nothing else than SGPF+ASPF. One of 
> course does not
> > > need the MTP3 related interworking etc... of SGPs, but those
> > are not part of
> > > the protocol. The protocol defines just the state 
> machines and messaging
> > > between M3UA entities.
> > >
> > > Single-ended approach: AS-AS
> > > There is only one type of RK (unlike ASP-ASP case where we have
> > local and
> > > remote RKs). A RK defines a traffic range in both ends.
> > > There will be 8 RKs: RKs at IPSP1
> > >                      RK1: DPC=1-1-1 OPC=3-3-3
> > >                      RK2: DPC=1-1-1 OPC=4-4-4
> > >                      RK3: DPC=2-2-2 OPC=3-3-3
> > >                      RK4: DPC=2-2-2 OPC=4-4-4
> > >
> > >                      RKs at IPSP2
> > >                      RK5: DPC=3-3-3 OPC=1-1-1
> > >                      RK6: DPC=3-3-3 OPC=2-2-2
> > >                      RK7: DPC=4-4-4 OPC=1-1-1
> > >                      RK8: DPC=4-4-4 OPC=2-2-2
> > >
> > > (In fact one can think that there are only 4 RKs, because
> > RK1/RK5, RK2/RK6,
> > > RK3/RK7, RK4/RK8 are symmetrical)
> > > With this approach, one ASPAC is enough to activate the 
> traffic in both
> > > directions. Probably, it makes sense to give the same RC values
> > to symmetric
> > > RKs at both IPSP.
> > >
> > >
> > --
> > Brian F. G. Bidulock
> > [email-masked]
> > http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 31 May 2002 11:12:55 -0400

To show the difference between different RK approaches for IPSP let's
consider the follwoing example:
(I believe this will also clarify why I refer to one of them as AS-AS and
the other one ASP-ASP)

ASP-ASP (DE):
==============

  AS1: DPC=1-1-1              AS2: DPC=2-2-2 SIO=3

  +---------+               +---------+
  |         |               |         |
  |         |               |         |
  |         |               |         |
  | IPSP1   |               | IPSP2   |
  |         +---------------+         |
  |         |               |         |
  |         +--------+      |         |
  +---------+        |      +---------+
                     |
                     |
                     |        AS3: DPC=2-2-2 SIO=5
                     |      +---------+
                     |      |         |
                     |      |         |
                     |      |         |
                     |      | IPSP3   |
                     +------+         |
                            |         |
                            |         |
                            +---------+

Here symmetry is not needed for AS traffic ranges.

RKs at IPSP1:
   RK1: DPC=1-1-1  (local)
   RK2: DPC=2-2-2 SIO=3 (remote)
   RK3: DPC=2-2-2 SIO=5 (remote)

RKs at IPSP2:
   RK4: DPC=2-2-2 SIO=3 (local)
   RK5: DPC=1-1-1 (remote)

RKs at IPSP3:
   RK6: DPC=2-2-2 SIO=5 (local)
   RK7: DPC=1-1-1 (remote)

Here, RK defines, which traffic range ASP can accept, hence ASP-ASP.

AS-AS (SE):
============

 AS1: DPC=1-1-1 SIO=3
 AS2: DPC=1-1-1 SIO=5           AS3: DPC=2-2-2 SIO=3

 +---------+                    +---------+
 |         |                    |         |
 |         |                    |         |
 |         |                    |         |
 |         +--------------------+         |
 | IPSP1   |                    |  IPSP2  |
 |         +-----------+        |         |
 |         |           |        |         |
 +---------+           |        +---------+
                       |
                       |
                       |
                       |        AS4: DPC=2-2-2 SIO=5
                       |
                       |        +---------+
                       |        |         |
                       |        |         |
                       |        |         |
                       |        |         |
                       +--------+ IPSP3   |
                                |         |
                                |         |
                                +---------+

Here symmetry is needed, because it is AS-AS communication.

RKs at IPSP1:
       RK1: DPC=1-1-1 OPC=2-2-2 SIO=3
       RK2: DPC=1-1-1 OPC=2-2-2 SIO=5

RKs at IPSP2:
       RK3: DPC=2-2-2 OPC=1-1-1 SIO=3 (or maybe just DPC=2-2-2 OPC=1-1-1 for
this configuration)

RKs at IPSP3:
       RK4: DPC=2-2-2 OPC=1-1-1 SIO=5 (or maybe just DPC=2-2-2 OPC=1-1-1 for
this configuration)

Here the RK really defines, which two AS is communicating, hence AS-AS.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 31 May 2002 10:17:07 -0500

Tolga,

Tolga Asveren wrote:                             (Fri, 31 May 2002 11:12:55)
> (I believe this will also clarify why I refer to one of them as AS-AS and

And interestingly SE has half the routing
keys as DE in this example too.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 31 May 2002 11:32:45 -0400

Brian,

In my opinion, the problem is, that there is no consensus, who the peers are
in this point-to-point communication, AS or ASP?

   Tolga

> Sent: Friday, May 31, 2002 11:17 AM
> To: Tolga Asveren
> Cc: [email-masked]
> 2002 11:12:55)