Subject: RE: [Sigtran] document status

From: "Tolga Asveren" <[email-masked]>
Date: Wed, 22 May 2002 08:53:14 -0400

HannsJuergen,

> -----Original Message-----
> From: Schwarzbauer Hanns Juergen
> [mailto:[email-masked]]
> Sent: Wednesday, May 22, 2002 2:42 AM
> To: 'Tolga Asveren'
> Subject: RE: [Sigtran] document status
>
>
> dear all,
>
> sorry to jump into this discussion.
>
> That's again a new figure (perhaps I overlooked it in the mails
> exchanged yesterday) but I still have only a vague understanding
> what the SG-SG draft is heading for. Just stating ">I think, this
> figure shows well, what you can do, once SG-SG communication is
> there" is not sufficient. This sentence opens up a plethora of
> wishes and imaginations and everybody can claim afterwards: "the
> inclusion of that very feature was my basic understanding".
[TOLGA] Although there might be open points in the details, it is clear what
the draft is intended for : defining communication between two SGs. You add
this to what was already described in the M3UA draft for ASP-SGP
communication and then everyhting I draw in my figure is possible. In my
opinion, there is nothing ununderstandable in this figure. What would you
like to see as additional explanation?
>
> The whole discussion from the last days should be summarized in a
> second version, as the first version no longer reflects our
> current discussions!
> I seriously doubt that a decision about rising this draft as a
> work item could be taken now. I definitly would like to see more
> substance and more participation in the discussion (we are not
> all laid off, but...)
[TOLGA] Sorry but if the number of actively interested people about M3UA is
3-4, then the decision should be taken based on their opinions. Nobody is
preventing anybody to express their opinions. But I am also against to wait
1 year for comments.
>
>
> greetings
>
> HannsJuergen
>
> >-----Original Message-----
> >From: Tolga Asveren [mailto:[email-masked]]
> >Sent: Tuesday, May 21, 2002 7:38 PM
> >To: [email-masked]
> >Subject: RE: [Sigtran] document status
> >
> >
> >Reshma,
> >
> >
> >> -----Original Message-----
> >> From: reshma [mailto:[email-masked]]
> >> Sent: Tuesday, May 21, 2002 1:11 PM
> >> To: Tolga Asveren; [email-masked]
> >> Subject: Re: [Sigtran] document status
> >>
> >>
> >> Hi Tolga ,
> >>
> >>
> >> > > [Reshma] That is SG acting as STP ?
> >> > [TOLGA] Yes, and it can communicate to other IP-STPs, this
> >is in fact,
> >> what
> >> > SG-SG draft defines.
> >> >
> >>
> >> [Reshma] Okay that was my understanding from the draft
> >initially.And the
> >> only reason i could think this was needed was for Reliability and for
> >> Switching between two SGs (IP-STPs) whenever needed. But i
> >am still not
> >> clear about
> >> how this can increase inter-IP communication capabilities of
> >M3UA peers ?
> >> Can u help me in this..?
> >SG-SG communication defines a peer-to-peer relationship
> >between SGs (which
> >are M3UA entities). So, they can communicate among themselves.
> >I will redraw
> >one of the figures from a previous message:
> >
> >
> >                           -----
> >                        ///     \\\
> >                      ||           |
> >                      | ASP cloud3  |
> >                      ||           |
> >                        \\\     ///
> >                           --+--
> >                             |
> >                             |
> >                             |
> >                             |
> >                             |
> >                       +-----+----+
> >                       |          |
> >                       | SGPF3    |
> >                       |          |
> >                       +---+---+--+
> >                           |   |
> >                           |   |          +----------+
> >                           |   |          | ASP2     |
> >                           |   |          |          |
> >                           |   |          +----+-----+
> >        +----------+       |   |               |
> >        | User P.  |       |   |               |
> >        |  NIF/LM  |       |   |               |
> >        +----------+       |   |          +----+-----+
> >        |          +-------+   +----------+          |
> >        | SGPF1    +----------------------+ SGPF2    |
> >        |          |                      |          |
> >        +----------+                      +----------+
> >        | MTP3  1  |                      | MTP3  2  |
> >        +----+-----+                      +-----+----+
> >             |                                  |
> >             |                                  |
> >             |                                  |
> >             |                                  |
> >             |                                  |
> >             |                                  |
> >             |                                  |
> >        +----+-----+                      +-----+----+
> >        |          |                      |          |
> >        | STP1     |                      | STP2     |
> >        |          |                      |          |
> >        +----------+                      +----------+
> >
> >I think, this figure shows well, what you can do, once SG-SG
> >communication
> >is there.
> >SG-SG communication brings also relaying functionality. This
> >is important to
> >relay between SS7 nodes and also to have configurable systems
> >in IP domain.
> >As I stated previously in one of my messages, if you have n
> >nodes, and if
> >you change the RK in one of them, do you want to change the
> >RKs in all of
> >the other n-1 nodes or only in a few concentration nodes
> >(especially when
> >there are multiple operators present)?
> >
> >
> >
> >
> >
> >
> >_______________________________________________
> >Sigtran mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/sigtran
> >

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "reshma" <[email-masked]>
Date: Wed, 22 May 2002 18:31:28 +0530

Hi Tolga,

    Some more doubts...

> like to see as additional explanation?

[Reshma] Okay now i add the SG-SG communication to my current M3ua
implementation ,then as u say i should be able to do IPSP-IPSP communication
from this  right ? B'coz u said this will allow inter IP communication.

Thanks,
reshma

---

From: "Tolga Asveren" <[email-masked]>
Date: Wed, 22 May 2002 09:14:52 -0400

Reshma,

> Sent: Wednesday, May 22, 2002 9:01 AM
[TOLGA] You will have a way to let two M3UA entities communicate to each
other in IP domain. But personally I wouldn't call this IPSP. In my opinion,
it is another story and we will discuss it more, when the documant for it is
ready.

---

From: "reshma" <[email-masked]>
Date: Wed, 22 May 2002 18:45:43 +0530

Hi Tolga,

> it is another story and we will discuss it more, when the documant for it
is
[Reshma]    What do you mean by m3ua entities here? is it only SG ? or SGP
and ASP?
I thought IPSP is also a m3ua entity :-(  .Is there any separate
draft/document
coming out for IPSP in near future ?

---

From: "Tolga Asveren" <[email-masked]>
Date: Wed, 22 May 2002 09:47:08 -0400

Reshma,

> Sent: Wednesday, May 22, 2002 9:16 AM
> > it is another story and we will discuss it more, when the
> documant for it
> is
> > ready.
[TOLGA] As indicated in the figure, there is a peer-to-peer relationship
between SGs. But also user applications (directly on top of SGPF, or on a
ASPF) can also communicate to each other by staying totally in IP domain.
Personally, I don't think it is properly defined , what an IPSP is. As far
as I know, currently there is no plan for a new draft for it but Javier will
prepare a document, which collects information about IPSP to create a base
for discussions.

---

From: "reshma" <[email-masked]>
Date: Mon, 27 May 2002 20:27:06 +0530

Hi Tolga,

> prepare a document, which collects information about IPSP to create a base
[Reshma] I feel as per the figure two IP nodes can communicate (if  SG-SG
communication draft is implemented ) only through SG which will act as relay
point .Or is there any other configuration also?

Thanks,
Reshma

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 27 May 2002 12:28:55 -0500

reshma,

reshma wrote:                                              (Mon, 27 May 2002 20:27:06)
> point .Or is there any other configuration also?

Also as end-node.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/