Subject: RE: [Sigtran] SUA: GTT function placement

From: "Lamberton, Marc" <[email-masked]>
Date: Thu, 2 May 2002 16:00:24 +0200

Brian,

I agree that GTT is not required in the ASP if the two SG's are equivallent (as a mated STP pair). 

It may also happen that the SG's are regionally located. In that case, when an AS starts a transaction to a SEP, it is desirable to select the SG which is closer to the SEP in order to maximise the path on the IP network (the goal of sigtran is to use IP bandwidth rather than SS7, isn't it ? ;o) For this purpose, GTT rules in the ASP could help to perform this kind of "least cost routing" to select the best available SG which can reach a given PC/SSN. 

Marc

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Thursday, May 02, 2002 12:06 PM
To: Lamberton, Marc
Cc: [email-masked]
Subject: Re: [Sigtran] SUA: GTT function placement

Marc,

GTT is not required in the ASP to perform SG selection, just as it is not
required in an SEP to perform STP selection.  SCCP does not keep track of
the availability of remote subsystems on a per-route (per-STP) basis.  It
is both appropriate and adequate for the ASP to loadshare outgoing requests
with GT only over the available SGs, just as an SEP does to the GTT function
in a mated STP pair.

--brian

Lamberton, Marc wrote:                                 (Thu, 02 May 2002 11:00:44)
> Hi all,
> 
> In the SUA draft the GT Translation function is positioned in the "SG as
> relay-point". This is clear for inbound messages coming from the SS7 network
> with "route on GT" in their called address. 
> 
> For outbound messages (from AS/ASP to SS7) it might be possible to perform
> the GTT either in the SG or in the ASP. In a multiple SG's configuration, it
> seems that GTT is required in the ASP to perform SG selection; if the ASP is
> connected to multiple SG's; the ASP can store the availability of remote
> PC/SSN thru each SG, and then use this information to perform SG selection.
> For outbound messages with "route on GT" in the called address, the ASP must
> perform the GTT to derive a PC, and then select a SG capable to reach that
> PC. 
> 
> If the ASP performs a GTT on outbound messages, it would be nice to add the
> derived PC into the SUA message called address, and then the SGP uses that
> PC for the MTP3 DPC. Can we assume that a SGP receiving a message from an
> ASP with a called address containing [RI="route on GT" , a GT, and a PC]
> will not perform its own GTT and will use that DPC value for the MTP3 header
> ?
> 
> Do you foresee any other issues or advantages to do the GTT in the ASP as
> well ?
> 
> Marc Lamberton
> Compaq TPU
> [email-masked]
> Tel. (33)4 9295 5598
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 2 May 2002 09:19:14 -0500

Marc,

Lamberton, Marc wrote:                                 (Thu, 02 May 2002 16:00:24)
> It may also happen that the SG's are regionally located. In that case, when
> an AS starts a transaction to a SEP, it is desirable to select the SG which
> is closer to the SEP in order to maximise the path on the IP network (the
> goal of sigtran is to use IP bandwidth rather than SS7, isn't it ? ;o) For
> this purpose, GTT rules in the ASP could help to perform this kind of "least
> cost routing" to select the best available SG which can reach a given
> PC/SSN. 

If you take this approach, your ASP will not only be an SUA IPSP, it must also
be an M3UA IPSP.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/