Subject: RE: [Sigtran] RE: sg-sg communication

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Thu, 30 May 2002 17:40:52 +0200

Hi Tolga, 

A small addition...

> -----Original Message-----
> From: Tolga Asveren [mailto:[email-masked]]
> Sent: Thursday, May 30, 2002 5:47 PM
> To: [email-masked]
> Subject: RE: [Sigtran] RE: sg-sg communication
> 
> 
> Reshma,
> 
> > -----Original Message-----
> > From: reshma [mailto:[email-masked]]
> > Sent: Thursday, May 30, 2002 11:34 AM
> > To: Tolga Asveren; [email-masked]
> > Subject: Re: [Sigtran] RE: sg-sg communication
> >
> >
> > Hi Tolga,
> >
> >
> > > > > > > > Hi  Tolga,
> > > > > > > >
> > > > > > > >     Thanks for your reply some more doubts :-(
> > > > > > > >
> > > > > > > > > >  [Reshma] Okay now its clear. But how does SG1
> > knows whether
> > > > > > > > the data is
> > > > > > > > > > from SG2 or from ASPs? Depending on which 
> he might have to
> > > > > > > > act as relay
> > > > > > > > > > point or a normal SG?
> > > > > > > > > [TOLGA] With the same method, it can know, whether a
> > > > > message is
> > > > > > > > from ASP1
> > > > > > > > or
> > > > > > > > > ASP2, this is implemention dependent (but 
> most probably
> > > > > > > based on the
> > > > > > > > source
> > > > > > > > > address of the SCTP message)
> > > > > > > >
> > > > > > > > [Reshma] As per M3UA draft , m3ua can act as an 
> SGP,ASP,IPSP.
> > > > > > > > When it acts its an IPSP the peer is always assumed
> > to be IPSP.
> > > > > > > [TOLGA] No, IPSP will behaeve as ASP against SGPs.
> > > > > >
> > > > > > This is not true. IPSP has a specific behavior as 
> Reshma says.
> > > > > > And if we consider SE even the State Machine changes...  :-)
> > > > > [TOLGA] I disagree with this. In my opinion, IPSP needs to
> > > > > behaeve as ASP
> > > > > against SGPs.
> > > >
> > > > If you are handling received ASPUP or ASPAC, you are not acting
> > > > as an ASP. IPSP acts different to an ASP.
> > > [TOLGA] This is what it does against another IPSP (and still
> > there are so
> > > many issues to discuss there). Well, maybe it is better 
> to put ASPF+SGPF
> > in
> > > a box, so that ASPF can communicate with any SGP without 
> problems ;-)
> >
> > [Reshma] Your answer is  not convincing :-( .
> > How can it behave as both ASP and IPSP?
> [TOLGA] How it behaves as both IPSP and ASP is to be seen. 
> That was the
> reason, why I am always telling, it is better to speak of ASP-ASP
> communication instead of IPSP-IPSP. 

There was some time when IPSP communication was tried to be called ASP-ASP communication. I think of them as the same thing...

Cheers // Javier.

> An IPSP which can't speak 
> to SGPs is not
> very usefull because can't talk to nodes in SS7 domain, and 
> also can't make
> use of SG-SG communication.
> >

> >
> > Thanks,
> > Reshma
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 30 May 2002 11:00:14 -0500

Javier,

Javier Pastor-Balbas (ECE) wrote:                          (Thu, 30 May 2002 17:40:52)
> 
> There was some time when IPSP communication was tried to be called ASP-ASP
> communication. I think of them as the same thing...

But you said that the state machines in the IPSP were different from an ASP,
and combining somehow the subset of ASPF and SGPF necessary.  So how can
IPSP now be ASP-ASP communication?  It is just double criss-crossed ASP-SGP
communication where each IPSP is acting both as ASP and as SGP.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/