Subject: [Sigtran] SUA: application redundancy in the IP network

From: "Zannin, Francois" <[email-masked]>
Date: Thu, 2 May 2002 15:57:29 +0200

Hi,

Some remarks about the reliability of SUA services in a ss7 network!

When an AS is connected to several SG that belong to the same ss7 
network, and this AS, declared with the same PC on all SG, becomes 
inactive from one SG; this SG sends a SSP to the concerned SEP 
indicating that the AS (PC/SSN) is prohibited.
Then when the SEP receive this SSP, it considers that the service 
in not available while it is still available from another SG!
A solution should be to send the SSM only if no PC is specified 
for the AS. 

This is a behavior for SUA, if a service can be accessed via several 
SG, the service MUST be seen with different PC and the traffic routing 
MUST use a ss7 GT translation and THIS GT translation only on the 
TCAP BEGIN messages to have the benefit of the redundancy. Unless the 
ss7 SEP application chose itself the PC of the service to use! 

Isn't it restrictive in a ss7 point of view?

Francois Z.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 2 May 2002 09:17:50 -0500

Zannin,,

Zannin, Francois wrote:                                   (Thu, 02 May 2002 15:57:29)
> indicating that the AS (PC/SSN) is prohibited.

Why would you do that?

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 2 May 2002 12:11:37 -0400

Brian,

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Brian F. G. Bidulock
> Sent: Thursday, May 02, 2002 10:18 AM
> To: Zannin, Francois
> Cc: [email-masked]
> Subject: Re: [Sigtran] SUA: application redundancy in the IP network
> 
> 
> Zannin,,
> 
[TOLGA] What else should happen to make SG send SSP to the concerned SEP?

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 2 May 2002 12:02:45 -0500

Tolga,

There can only be two cases here:  either the SG's have the SCCP
relay function or they do not.  If the SG's have the SCCP relay
function, they are acting as STP and should coordinate with each
other before declaring routes or subsystems unavailble.  If they
are not acting as STPs, then they are acting as a single SEP/STP
and must coordinate between them.

Don't you see?  One SG has no business sending SSP if it can
access the subsystem via it's mate.  If it cannot access the
subsystem via its mate, then it is isolated and is correct to
send SSP.  If the SGs are not acting as STPs, then they
represent disjoint routes to different partitions of the SS7
network and can correctly send SSP.

So, where the SG's have separate point code, what you have
either looks like this:

Case A)

          _____             _______ 
         /     \           |       |
        |  SEP  |__________|  SG1  |____
        |       |          |       |    \
         \_____/           |_______|     \      _______
                                          \____|       |
                                               |  ASP  |
                                           ____|       |
          _____             _______       /    |_______|
         /     \           |       |     /
        |  SEP  |__________|  SG2  |___ /
        |       |          |       |
         \_____/           |_______|

Or like this:

Case B)
          _____             _______ 
         /     \           |       |
        |  SEP  |__________|  SG1  |____
        |       |  \      /|  STP  |    \
         \_____/    \    / |_______|     \      _______
                     \  /      |          \____|       |
                      \/       |               |  ASP  |
                      /\       |           ____|       |
          _____      /  \   ___|___       /    |_______|
         /     \    /    \ |       |     /
        |  SEP  |__/______\|  SG2  |___ /
        |       |          |  STP  |
         \_____/           |_______|

In Case A), it is perfectly correct for SG2 to send SSP to the
SEP when it cannot communicate to the ASP.

In Case B), why would SG2 send SSP  to any SEP just because it
cannot communicate directly with the ASP?  It still has
connectivity via SG1 (its mate).

--brian

Tolga Asveren wrote:                                        (Thu, 02 May 2002 12:11:37)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/