Subject: RE: [Sigtran] RE: sg-sg communication

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Thu, 30 May 2002 18:19:12 +0200

Hi Brian, 

From the RFC you get that an IPSP is essencially an ASP with some added features. When an AS is talking with another AS you will use the IPSP communication that allows also to receive messages than in the SG-AS communication an AS can not receive. In fact, as defined you can think that M3UA is a set of protocols that include AS-SG, AS-AS and possibly SG-SG communications, all of them using basically the same set of messages. A node implementing an AS, which you can see as an SPC, is transporting the signaling information to a SG or to another AS depending on the destination is in the SS7 network or in the IP network. In either case the node will use the right protocol: AS-AS (=IPSP communication) or AS-SG. You have as many state machines as M3UA connections to remote nodes you have, in the same way as in every protocol, but with the particularity that the state machine slighty varies depending the type of the destination node (AS or SG). 

Cheers // Javier. 

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Thursday, May 30, 2002 6:00 PM
> To: Javier Pastor-Balbas (ECE)
> Cc: 'Tolga Asveren'; [email-masked]
> Subject: Re: [Sigtran] RE: sg-sg communication
> 
> 
> Javier,
> 
> Javier Pastor-Balbas (ECE) wrote:                          
> (Thu, 30 May 2002 17:40:52)
> > 
> > There was some time when IPSP communication was tried to be 
> called ASP-ASP
> > communication. I think of them as the same thing...
> 
> But you said that the state machines in the IPSP were 
> different from an ASP,
> and combining somehow the subset of ASPF and SGPF necessary.  
> So how can
> IPSP now be ASP-ASP communication?  It is just double 
> criss-crossed ASP-SGP
> communication where each IPSP is acting both as ASP and as SGP.
> 
> --brian
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 30 May 2002 12:26:24 -0500

Javier,

But it is more that just the protocol: you said that the state machines
differ between an IPSP and an ASP.  One would need two sets of state
machines and then have just an IPSP and an ASP in the same box:
requiring and interworking function between them.  Did you not say that
the IPSP state machines were different than an ASP?

--brian

Javier Pastor-Balbas (ECE) wrote:                          (Thu, 30 May 2002 18:19:12)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/