Subject: RE: [Sigtran] m3ua:SG-SG document status

From: "Bep Verberk" <[email-masked]>
Date: Tue, 28 May 2002 13:38:35 -0400

I want to be convinced :)
But you are not succeeding. See below again.

Bep

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Tuesday, May 28, 2002 1:25 PM
> To: Verberk, Bep [CAR:7M00:EXCH]
> Cc: [email-masked]
> Subject: Re: [Sigtran] m3ua:SG-SG document status
> 
> 
> Bep,
> 
> Bep Verberk wrote:                                            
> (Tue, 28 May 2002 13:08:32)
> > 
> >    Thanks,
> >    see below.
> >    
> >    > -----Original Message-----
> >    > From: Brian F. G. Bidulock [[1]mailto:[email-masked]]
> >    > Sent: Tuesday, May 28, 2002 12:50 PM
> >    > To: Verberk, Bep [CAR:7M00:EXCH]
> >    > Cc: 'Tolga Asveren'; [email-masked]
> >    > Subject: Re: [Sigtran] m3ua:SG-SG document status
> >    >
> >    >
> >    > Bep,
> >    >
> >    > Bep Verberk wrote:
> >    > (Tue, 28 May 2002 12:23:07)
> >    > >
> >    > >    Tolga,
> >    > >    well you never answered one of my questions :)
> >    > >
> >    > >    What is the advantages of your SG-SG proposal over
> >    > >    simply using m2pa between 2 SGs.
> >    >
> >    > Multiple streams, routes, and routesets over a single 
> association.
> >    > (M2PA can only support 1 link, not even a linkset).
> >    
> >    [BEP] 1 m2pa association can carry traffic for multiple 
> routesets,
> >    just as one link can. If you want 2 for redundancy - no biggy.
> >    What do you mean by multiple steams ? exactly what 
> advantage does this
> >    give ?
> 
> Read the SCTP applicability statement.  Multiple streams 
> allows SCTP to
> address head-of-line blocking issues: the reason SCTP was 
> developed in the
> first place to address SIGTRAN applications.
> 
[BEP] That's what I thought, and you get the benefits of SCTP 
using m2pa. So at this point I consider the above arguments refuted.

> >    >
> >    > >    I'm not against proceeding with the draft - but I don't
> >    > >    see why anyone would use it - hopefully your answer to the
> >    > >    above question will help me understand.
> >    >
> >    > To understand the limitations of M2PA, you need only 
> realize that
> >    > it is exactly one link per association.  It requires a fully
> >    > functional
> >    > SS7 MTP Level 3 layer to make it work.  SG-SG does 
> not.  Also, SG-SG
> >    > is not restricted to M3PA, it could to SPA, ISPA, TPA.
> >    
> >    [BEP] SGs have a fully functional MTP3. The SG-SG draft adds
> >    complications to try to mimick MTP3 behavior that is already
> >    painstakingly defined as MTP3 and available at the SG.
> 
> And now wonderfully available between SGs over IP.  Which was 
> kinda the
> intention of SIGTRAN: to carry SS7 over IP, not to force peer-to-peer
> communication via the SS7 network.

[BEP] Not quite "wonderfully available" yet. 
M2PA/SCTP is indeed SS7 over IP.
So I don't understand this argument.

> 
> >    
> >    >
> >    > Let me ask you the question: what are the advantages 
> of M3UA?  Why
> >    not
> >    > just use M2UA?
> >    
> >    [BEP] I would use M3UA instead of M2UA because I want to mimimize
> >    the SS7 transport related functions on my ASPs (ie 
> ISUP+m3ua versus
> >    ISUP+mtp3+m2ua). I want the SG to take care of MTP3 for me.
> 
> We want to use M3PA instead of M2PA so that the IP network is 
> not treated
> like some kind of wire (which it isn't).

[BEP] Don't understand your point here. I assume you are implying that
by treating IP "like some kind of wire" I loose the inherent benfits of IP.
What I am asking for are the specific benfits I'm losing by using SG-SG m2pa

versus SG-SG M3UA. 

> --brian
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 28 May 2002 13:57:38 -0400

RE: [Sigtran] m3ua:SG-SG document statusBep,

One can think M3UA SG-SG communication as M3PA. If I use M2PA instead of
M3PA, what is the benefit of it?
Is there a need to simulate SS7 links in IP domain?

   Tolga
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of
Bep Verberk
  Sent: Tuesday, May 28, 2002 1:39 PM
  To: [email-masked]'
  Cc: [email-masked]
  Subject: RE: [Sigtran] m3ua:SG-SG document status

  Bep

  [BEP] Don't understand your point here. I assume you are implying that
  by treating IP "like some kind of wire" I loose the inherent benfits of
IP.
  What I am asking for are the specific benfits I'm losing by using SG-SG
m2pa
  versus SG-SG M3UA.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 28 May 2002 13:18:41 -0500

Bep,

Bep Verberk wrote:                                            (Tue, 28 May 2002 13:38:35)
>    > >    > From: Brian F. G. Bidulock
>    [[1][2]mailto:[email-masked]]

No you do not.  M2PA uses one stream and one stream only for data.  M2PA
is subject to HOL blocking, whereas M3PA is not.  M3PA could theoretically
have 65,535 independent streams making one retransmitted message only block
2^-16 of the traffic.  For M2PA 100% of the traffic is blocked waiting for
a retransmitted packet.

>    So I don't understand this argument.

M2PA is traditional SS7 over IP treated like a wire.  With a single stream
it is no better than MTP3b/SSCOP-MCE.

>    by treating IP "like some kind of wire" I loose the inherent benfits

On the contrary, you loose the benefits of the wire: fixed and available
bandwidth, fixed delay, fixed error rates.  Don't expect M2PA to follow
Q.703 or SSCOP queueing principles (guaranteed bit rates) or delay
characteristics.  MTP3 which runs fine with these wire guarantees can be
disasterous without them.

>    What I am asking for are the specific benfits I'm losing by using

Multiple streams, low HOL blocking, failover based on SCTP rather than MTP3
better performance and SG-SG procedures for a non-wire environment.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran