Subject: [Sigtran] SUA: GTT function placement

From: "Lamberton, Marc" <[email-masked]>
Date: Thu, 2 May 2002 11:00:44 +0200

Hi all,

In the SUA draft the GT Translation function is positioned in the "SG as relay-point". This is clear for inbound messages coming from the SS7 network with "route on GT" in their called address. 

For outbound messages (from AS/ASP to SS7) it might be possible to perform the GTT either in the SG or in the ASP. In a multiple SG's configuration, it seems that GTT is required in the ASP to perform SG selection; if the ASP is connected to multiple SG's; the ASP can store the availability of remote PC/SSN thru each SG, and then use this information to perform SG selection. For outbound messages with "route on GT" in the called address, the ASP must perform the GTT to derive a PC, and then select a SG capable to reach that PC. 

If the ASP performs a GTT on outbound messages, it would be nice to add the derived PC into the SUA message called address, and then the SGP uses that PC for the MTP3 DPC. Can we assume that a SGP receiving a message from an ASP with a called address containing [RI="route on GT" , a GT, and a PC] will not perform its own GTT and will use that DPC value for the MTP3 header ?

Do you foresee any other issues or advantages to do the GTT in the ASP as well ?

Marc Lamberton
Compaq TPU
[email-masked]
Tel. (33)4 9295 5598

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 2 May 2002 05:05:45 -0500

Marc,

GTT is not required in the ASP to perform SG selection, just as it is not
required in an SEP to perform STP selection.  SCCP does not keep track of
the availability of remote subsystems on a per-route (per-STP) basis.  It
is both appropriate and adequate for the ASP to loadshare outgoing requests
with GT only over the available SGs, just as an SEP does to the GTT function
in a mated STP pair.

--brian

Lamberton, Marc wrote:                                 (Thu, 02 May 2002 11:00:44)
> Hi all,
> 
> In the SUA draft the GT Translation function is positioned in the "SG as
> relay-point". This is clear for inbound messages coming from the SS7 network
> with "route on GT" in their called address. 
> 
> For outbound messages (from AS/ASP to SS7) it might be possible to perform
> the GTT either in the SG or in the ASP. In a multiple SG's configuration, it
> seems that GTT is required in the ASP to perform SG selection; if the ASP is
> connected to multiple SG's; the ASP can store the availability of remote
> PC/SSN thru each SG, and then use this information to perform SG selection.
> For outbound messages with "route on GT" in the called address, the ASP must
> perform the GTT to derive a PC, and then select a SG capable to reach that
> PC. 
> 
> If the ASP performs a GTT on outbound messages, it would be nice to add the
> derived PC into the SUA message called address, and then the SGP uses that
> PC for the MTP3 DPC. Can we assume that a SGP receiving a message from an
> ASP with a called address containing [RI="route on GT" , a GT, and a PC]
> will not perform its own GTT and will use that DPC value for the MTP3 header
> ?
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/