Subject: RE: [Sigtran] IPSP vs AS (was RE: sg-sg communication)

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Fri, 31 May 2002 17:33:56 +0200

Hi Tolga, 

See below...

> -----Original Message-----
> From: Tolga Asveren [mailto:[email-masked]]
> Sent: Friday, May 31, 2002 5:33 PM
> To: [email-masked]
> Subject: RE: [Sigtran] IPSP vs AS (was RE: sg-sg communication)
> 
> 
> Brian,
> 
> In my opinion, the problem is, that there is no consensus, 
> who the peers are
> in this point-to-point communication, AS or ASP?
> 

There is no ASP in IPSP communication. The AS is served by an IPSP instead of by an ASP. IPSP communication tries to put in contact two SS7 applications in the IP domain. And the communications are between those applications. M3UA works in IPSP mode and not in ASP mode, which is only to talk to a SG.
 
Cheers // Javier.

>    Tolga
> 
> > -----Original Message-----
> > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > Sent: Friday, May 31, 2002 11:17 AM
> > To: Tolga Asveren
> > Cc: [email-masked]
> > Subject: Re: [Sigtran] IPSP vs AS (was RE: sg-sg communication)
> > Importance: High
> >
> >
> > Tolga,
> >
> > Tolga Asveren wrote:                             (Fri, 31 May
> > 2002 11:12:55)
> > > To show the difference between different RK approaches 
> for IPSP let's
> > > consider the follwoing example:
> > > (I believe this will also clarify why I refer to one of them as
> > AS-AS and
> > > the other one ASP-ASP)
> > >
> > > ASP-ASP (DE):
> > > ==============
> > >
> > >   AS1: DPC=1-1-1              AS2: DPC=2-2-2 SIO=3
> > >
> > >   +---------+               +---------+
> > >   |         |               |         |
> > >   |         |               |         |
> > >   |         |               |         |
> > >   | IPSP1   |               | IPSP2   |
> > >   |         +---------------+         |
> > >   |         |               |         |
> > >   |         +--------+      |         |
> > >   +---------+        |      +---------+
> > >                      |
> > >                      |
> > >                      |        AS3: DPC=2-2-2 SIO=5
> > >                      |      +---------+
> > >                      |      |         |
> > >                      |      |         |
> > >                      |      |         |
> > >                      |      | IPSP3   |
> > >                      +------+         |
> > >                             |         |
> > >                             |         |
> > >                             +---------+
> > >
> > > Here symmetry is not needed for AS traffic ranges.
> > >
> > > RKs at IPSP1:
> > >    RK1: DPC=1-1-1  (local)
> > >    RK2: DPC=2-2-2 SIO=3 (remote)
> > >    RK3: DPC=2-2-2 SIO=5 (remote)
> > >
> > > RKs at IPSP2:
> > >    RK4: DPC=2-2-2 SIO=3 (local)
> > >    RK5: DPC=1-1-1 (remote)
> > >
> > > RKs at IPSP3:
> > >    RK6: DPC=2-2-2 SIO=5 (local)
> > >    RK7: DPC=1-1-1 (remote)
> > >
> > >
> > > Here, RK defines, which traffic range ASP can accept, 
> hence ASP-ASP.
> > >
> > >
> > > AS-AS (SE):
> > > ============
> > >
> > >  AS1: DPC=1-1-1 SIO=3
> > >  AS2: DPC=1-1-1 SIO=5           AS3: DPC=2-2-2 SIO=3
> > >
> > >  +---------+                    +---------+
> > >  |         |                    |         |
> > >  |         |                    |         |
> > >  |         |                    |         |
> > >  |         +--------------------+         |
> > >  | IPSP1   |                    |  IPSP2  |
> > >  |         +-----------+        |         |
> > >  |         |           |        |         |
> > >  +---------+           |        +---------+
> > >                        |
> > >                        |
> > >                        |
> > >                        |        AS4: DPC=2-2-2 SIO=5
> > >                        |
> > >                        |        +---------+
> > >                        |        |         |
> > >                        |        |         |
> > >                        |        |         |
> > >                        |        |         |
> > >                        +--------+ IPSP3   |
> > >                                 |         |
> > >                                 |         |
> > >                                 +---------+
> > >
> > > Here symmetry is needed, because it is AS-AS communication.
> > >
> > > RKs at IPSP1:
> > >        RK1: DPC=1-1-1 OPC=2-2-2 SIO=3
> > >        RK2: DPC=1-1-1 OPC=2-2-2 SIO=5
> > >
> > > RKs at IPSP2:
> > >        RK3: DPC=2-2-2 OPC=1-1-1 SIO=3 (or maybe just DPC=2-2-2
> > OPC=1-1-1 for
> > > this configuration)
> > >
> > > RKs at IPSP3:
> > >        RK4: DPC=2-2-2 OPC=1-1-1 SIO=5 (or maybe just DPC=2-2-2
> > OPC=1-1-1 for
> > > this configuration)
> > >
> > > Here the RK really defines, which two AS is 
> communicating, hence AS-AS.
> >
> > And interestingly SE has half the routing
> > keys as DE in this example too.
> >
> > --brian
> >
> > --
> > Brian F. G. Bidulock
> > [email-masked]
> > http://www.openss7.org/
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 31 May 2002 11:52:21 -0400

Javier,

For me conceptually IPSP-IPSP is ASP-ASP. You can reword the question , who
are the endpoints, AS or IPSP?

  Tolga

> From: Javier Pastor-Balbas (ECE)
> [mailto:[email-masked]]
> Sent: Friday, May 31, 2002 11:34 AM
> To: 'Tolga Asveren'; [email-masked]
> There is no ASP in IPSP communication. The AS is served by an
> IPSP instead of by an ASP. IPSP communication tries to put in
> contact two SS7 applications in the IP domain. And the
> communications are between those applications. M3UA works in IPSP
> mode and not in ASP mode, which is only to talk to a SG.
>
> Cheers // Javier.
>
>
> >    Tolga
> >