Subject: [Sigtran] (M3UA SG-SG) Why no FSN/BSN optional parameters or ACK message in support of change-over?

From: [email-masked]
Date: Wed, 29 May 2002 14:38:04 -0400

Hello All,

I note with interest the support for the changeover procedure in the
M3UA SG-SG draft.

I am curious how this can work properly without there being FSN/BSN
optional
parameters for use in transfer messages and without a new ACK message
(for conveying BSN in the absence of outbound transfer messages). Where is
the FSN value for the COR/CORA coming from? Is M3PA supposed to maintain
sequence numbers and manage acknowledgements, or is it depending on SCTP
to do so? If SCTP is doing the job, how are the various problems identified
in the M2PA discussions being addressed by M3PA?

I am also curious as to how multiple SCTP streams can be supported without
a stream ID being associated with the sequence number. Is it a requirement
that each signaling link have only one SCTP stream for transfer messages?
If not, then perhaps in addition to a SLC field, there should be a stream
ID field. Perhaps COR/CORA could be changed to include a list of stream IDs
and FSNs instead of just one pair. And while I'm at it, I repeat my concern
that the FSN be at least 24 bits.

Regards,

Jeff

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Wed, 29 May 2002 15:00:40 -0400

Jeffrey,

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> [email-masked]
> Sent: Wednesday, May 29, 2002 2:38 PM
> To: [email-masked]
> Subject: [Sigtran] (M3UA SG-SG) Why no FSN/BSN optional parameters or
> ACK message in supportof change-over?
>
>
> Hello All,
>
[TOLGA] COR/CORA is not needed for messages between SG/ASP or SG/SG
(basically not for SCTP association) It is only for the case, where COO/COA
etc... needs to be relayed. For example:
  +-------+              +-------+
  |       |              |       |
  | STP1  +------X-------+ STP2  |
  |       |              |       |
  +--+----+              +---+---+
     |                       |
     |                       |
     |                       |
     |                       |
     |                       |
     |                       |
     |        +-------+      |
     |        |       |      |
     +--------+ STP3  +------+
              |       |
              +-------+

In such a scenario, COO would be relayed over STP3 to STP2 (and also COA
backwards). Now just replace the TDM interface between STP3 and STP2 with
IP:

 +-------+              +-------+
 |       |              |       |
 | STP1  +------X-------+ SG2   |
 |       |              |       |
 +--+----+              +---+---+
    |                       |
    |                       |
    |                       |
    |                       | <===== SCTP association
    |                       |
    |                       |
    |        +-------+      |
    |        |       |      |
    +--------+   SG3 +------+
             |       |
             +-------+

Now, in such a case, how can we relay COO/COA if we don't have corresponding
messages? So, FSN/BSN in COR/CORA is coming from COO/COA.

> that the FSN be at least 24 bits.
[TOLGA] I didn't forget your comment for 24 bit :-)