Subject: RE: [Sigtran] (M2PA) Please add a Network Appearance parameter to the M2PA protocol

From: "Bep Verberk" <[email-masked]>
Date: Tue, 28 May 2002 16:56:05 -0400

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Tuesday, May 28, 2002 4:40 PM
> To: Verberk, Bep [CAR:7M00:EXCH]
> Cc: 'Tolga Asveren'; [email-masked]
> Subject: Re: [Sigtran] (M2PA) Please add a Network Appearance 
> parameter
> to the M2PA protocol
> 
> 
> Bep,
> 
> Where were you when 3GPP was picking their transport?  

[BEP] I think that's when I was consumed by playing QUAKE on-line. :)

I believe the reason the 3G folks didn't go further with m2pa
was that they did not want to implement MTP3. All their boxes
talk point-to-point ss7 with no signaling network management
functions - essentially a bunch of F-links.

I don't think they really want m3ua either, nor should they
use a SGP-ASP protocol. They need a point to point
IPSP - IPSP protocol based on SUA or TUA.

> Also, the SG-SG
> approach (and remember it is applicable to SUA SG-SG and TUA SG-SG)
> is not so different than Q.2150.1 and Q.2150.3.  I wonder why SG11 and
> SG13 didn't go with M2PA ;)  Really, the need is for adapting these
> upper layer protocols to use a IP-based transport rather than 
> attempting
> to make an IP network behave like TDM on a wire on ATM in a VC.
> 
> --brian
> 
> 
> Bep Verberk wrote:                                            
> (Tue, 28 May 2002 15:56:53)
> > 
> >    -----Original Message-----
> >    From: Tolga Asveren [[1]mailto:[email-masked]]
> >    Sent: Tuesday, May 28, 2002 3:43 PM
> >    To: [email-masked]
> >    Subject: RE: [Sigtran] (M2PA) Please add a Network Appearance
> >    parameter to the M2PA protocol
> >    
> >    > Bep,
> >    >
> >    > But similarly you can also not answer the question, 
> why one should
> >    use M2PA > instead of M3UA SG-SG? ;-)
> >    
> >    [BEP] But I asked you first ;)
> >    Jeff was kind enough to come forth with the multiple 
> networks reason.
> >    This is an advantage of m3ua over m2pa for SG-SG.
> >    
> >    The advantages of m2pa over m3ua for SG-SG are:
> >    - m2pa (altghough not yet an RFC) is fairly well defined
> >    - MTP3 is, as we're all aware, well defined, thus we 
> have "running
> >    code" from many differnet sources that demonstrate that 
> this works
> >    very nicely.
> >    
> >    - m3ua SG-SG requires we replicate many mtp3 functions (eg
> >    ChangeOver, MTP Restart), invent new
> >    messages (ie CORA, COR, TAL, CGT ) that are essentially 
> the same as
> >    existing
> >    MTP3 messages.
> >    
> >    It just seems to me that you are reinventing MTP3 with 
> new messages
> >    , with the only advantage over MTP3/M2PA being
> >    the ability to send messages for more than 1 network 
> over the same
> >    association.
> >    
> >    > Why to try simulate links in IP domain? Why try to put another
> >    protocol (M2PA) > there for relaying?
> >    
> >    -----Original Message-----
> >    From: [email-masked] [[2]mailto:[email-masked]]On
> >    Behalf Of Bep Verberk
> >    Sent: Tuesday, May 28, 2002 3:26 PM
> >    To: [email-masked]'; [email-masked]
> >    Cc: [email-masked]
> >    Subject: RE: [Sigtran] (M2PA) Please add a Network Appearance
> >    parameter to the M2PA protocol
> >    
> >    This is getting at the heart of my question to Brian about the
> >    value of using M3UA for SG-SG versus just m2pa.
> >    This a valid plus for M3UA, that is, you can send traffic
> >    for more than one network over the same association.
> >    Although I still believe  this is a minor plus.
> >    Of course Jeff points out that he doesn't like/need some
> >    of the other aspects of m3ua for SG-SG.
> >    So it becomes a trade off Jeff.
> >    You need to either
> >    1. use muliple m2pa associations -  each
> >    carrying traffic for different networks
> >    (I don't think this is so bad)
> >    2. Use m3ua
> >    3. Do something proprietary like you are proposing. If you
> >    do this please share your ideas with us :)
> >    Bep
> >    
> >    > -----Original Message-----
> >    > From: [email-masked]
> >    [[3]mailto:[email-masked]]
> >    > Sent: Tuesday, May 28, 2002 3:05 PM
> >    > To: [email-masked]
> >    > Cc: [email-masked]
> >    > Subject: Re: [Sigtran] (M2PA) Please add a Network Appearance
> >    > parameter
> >    > to the M2PA protocol
> >    >
> >    >
> >    >
> >    > Hello Brian,
> >    >
> >    > >M3UA SG-SG has Network Appearance.
> >    > >Use it instead of mangling M2PA.
> >    >
> >    > Bummer of an answer. 'mangling'?
> >    >
> >    > So the goal of M2PA is to offer nothing more, or less, than
> >    > that provided
> >    > by MTP2?
> >    >
> >    > I know this discussion is not going anywhere, but.....
> >    >
> >    > I happen to have a MTP3 layer that is aware of multiple ITU-N
> >    > networks.
> >    > I need a means to convey that information across B,C,D
> >    > SS7-over-IP links.
> >    > You argue that this functionality is L3-based and does not
> >    > belong in L2
> >    > (M2PA).
> >    > Unfortunately, the MTP3 message payload is fixed. The 
> M2PA message
> >    > payload is not yet fixed, but strictly defines the mapping of
> >    > MSUs. The
> >    > M2PA protocol is not very extensible, except in terms of new
> >    > message types.
> >    >
> >    > M3UA SG-SG is not a good choice for my implementation:
> >    > 1) I have no need for routing key registration or of
> >    > application servers.
> >    > 2) I have no need for elaborate conversions of SS7 
> SNMs and MSUs.
> >    > 3) I have no need to use multiple SCTP streams for user data.
> >    >
> >    > So I am left with adding a custom message type to M2PA or
> >    > using reserved
> >    > bits.
> >    > Okee dokee.
> >    >
> >    > Regards,
> >    >
> >    > Jeff
> >    >
> >    >
> >    >
> >    >
> > 
> > References
> > 
> >    1. mailto:[email-masked]
> >    2. mailto:[email-masked]
> >    3. mailto:[email-masked]
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
>

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 28 May 2002 18:05:10 -0400

RE: [Sigtran] (M2PA) Please add a Network Appearance parameter to the M2PA
protocolBep,
  -----Original Message-----
  From: Bep Verberk [mailto:[email-masked]]
  Sent: Tuesday, May 28, 2002 4:56 PM
  To: [email-masked]'
  Cc: 'Tolga Asveren'; [email-masked]
  Subject: RE: [Sigtran] (M2PA) Please add a Network Appearance parameter to
the M2PA protocol

  [TOLGA] Why do you think, a properly defined M3UA IPSP won't serve the
same purpose?

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 28 May 2002 17:21:09 -0500

Tolga,

Tolga Asveren wrote:                                        (Tue, 28 May 2002 18:05:10)
>      > From: Brian F. G. Bidulock [[1]mailto:[email-masked]]
>      [TOLGA] Why do you think, a properly defined M3UA IPSP won't serve
>      the same purpose?

Point Code exahustion: but M3UA is what it is.  I have never seen the
need for SUA: SCTP already provides all of the NSD services directly.
Thus the Q.2150.3.

--brian

>      > >    From: Tolga Asveren [[1][2]mailto:[email-masked]]
>      > >    From: [email-masked]
>      [[2][3]mailto:[email-masked]]On
>      > >    Behalf Of Bep Verberk
>      > >    [[3][4]mailto:[email-masked]]
>      > >    1. [5]mailto:[email-masked]
>      > >    2. [6]mailto:[email-masked]
>      > >    3. [7]mailto:[email-masked]
>      >
>      > --
>      > Brian F. G. Bidulock
>      > [email-masked]
>      > [8]http://www.openss7.org/
>      >
> 
> References
> 
>    1. mailto:[email-masked]
>    2. mailto:[email-masked]
>    3. mailto:[email-masked]
>    4. mailto:[email-masked]
>    5. mailto:[email-masked]
>    6. mailto:[email-masked]
>    7. mailto:[email-masked]
>    8. http://www.openss7.org/

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran