Subject: [Sigtran] M2PA:Questions on sequence number

From: Lisa Gorgone <[email-masked]>
Date: Fri, 24 May 2002 16:21:57 +0200

Hi all,
We have some questions about M2PA:

1)About BSNR, Q703 states:
"If any two backward sequence number values in three consecutively
received message signal units or fill-in signal units are not the same
as
the previous one or any of the forward sequence number values of the
signal units in the retrasmission buffer at the time that they are
received,
then level 3 is informed that the link is faulty."
Does this apply also to M2PA or BSNR is used just to acknowledge the
MSU (ie the link is never failed when the BSNR is wrong)?

2)The Forward Sequence Number Received  is used to check the correct
sequence of frames. If the FSNR is out of order which actions should be
taken?
Since the probability of this event is very low, the link could be
immediately failed.

3) In MTP2  not more than 127 MSU may be available for retransmission.
The size of RTB is based on this requirement.
In M2PA:
- the Sequence number fields are 24 bits
- it does not run a T7 timer (excessive delay of acknowledgement)
Then it could be useful to define a window size of maximum number of MSU

not yet  acknowledged in order to dimension the RTB.

Thanks in advance
Lisa & Aldo

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 24 May 2002 10:31:02 -0500

Lisa,

Please see comments below...

Lisa Gorgone wrote:                                          (Fri, 24 May 2002 16:21:57)
> "If any two backward sequence number values in three consecutively received
> message signal units or fill-in signal units are not the same as the
> previous one or any of the forward sequence number values of the signal
> units in the retrasmission buffer at the time that they are received,
> Does this apply also to M2PA or BSNR is used just to acknowledge the MSU (ie
> the link is never failed when the BSNR is wrong)?

I take the same approach as abnormal BSNR in Q.703.  I believe it is the
rational approach and should be included in the draft.

> Since the probability of this event is very low, the link could be

I take the same approach as abnormal FSNR in Q.703.  I believe it is the
rational approach and should be included in the draft.

> 
> 3) In MTP2  not more than 127 MSU may be available for retransmission.  The
> size of RTB is based on this requirement.
>
> In M2PA:
> Then it could be useful to define a window size of maximum number of MSU not
> yet  acknowledged in order to dimension the RTB.

Q.703 Annex A and Q.2210 both allow larger windows than traditional Q.703.
I agree that M2PA implementations should run a T7 timer.  I do.  I believe its
is the rational approach to run a T7 timer and should be included in the draft.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Lisa Gorgone <[email-masked]>
Date: Mon, 27 May 2002 15:21:23 +0200

> rational approach and should be included in the draft.

In Q.703 a wrong FSNR invokes retransmission by inverting BIB.
Do you think that Fib, Bib and Retransmission should be added
to the draft?
Thanks and Regards
Lisa & Aldo

---

From: Jacob Heitz <[email-masked]>
Date: Mon, 27 May 2002 10:12:26 -0700

> Do you think that Fib, Bib and Retransmission should be added

SCTP ensures in order and reliable delivery, using retransmission.
Why duplicate this function in M2PA ?

-- 
// Jacob Heitz. Tel:510-747-2917

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 27 May 2002 12:32:24 -0500

Lisa,

I considered that.  However, if you put FIB and BIB in, then you don't
need M2PA anymore: the old Bressler IP SS7 link draft will do.

--brian

Lisa Gorgone wrote:                                          (Mon, 27 May 2002 15:21:23)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 27 May 2002 12:35:23 -0500

Lisa,

What I really meant here was that if I receive some number
of abnormal FSNs, I put the link out of service.  Negative
acknowledgements are not provided for in M2PA at this time.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/