Subject: RE: [Sigtran] SUA: GTT function placement

From: "Bouckaert, Philippe" <[email-masked]>
Date: Fri, 3 May 2002 10:46:58 +0200

Brian,

my comments in the text,
Regards,
Philippe

		-----Original Message-----
		From: Brian F. G. Bidulock [mailto:[email-masked]]
		Sent: Friday, May 03, 2002 10:16 AM
		To: Bouckaert, Philippe
		Cc: Garnero, Pierre; [email-masked]
		Subject: Re: [Sigtran] SUA: GTT function placement

		Phillipe,

		Bouckaert, Philippe wrote:                             (Fri, 03 May 2002 10:00:18)

		--x--snip--x--
		> > > 
		> > > There is no need.  The ASP can send the message to the SG and it
		> > > will receive CLDR indicating the routing failure if it has return
		> > > on error set.  This will result in a N-NOTICE.  This is no different
		> > > than if the GTT was local.  If local GTT results in an inaccessible
		> > > point code or subsystem, the message will be discarded unless return
		> > > on error is set.  The same end occurs:  the AS gets N-NOTICE.  There
		> > > is no need to do this on the ASP as the SG is in a better position
		> > > to properly return the CLDR.  As this gets translated into the
		> > > appropriate TCAP procedure, the TCAP user does not care that the
		> > > GTT function is at the SG.  The same is true for CO on CORE.  The
		> > > SG would return COREF.
		> 
		> ******
		> It is different than if the GTT was local. If the GTT is local, the GTT
		> tables may be udpated, and if the ASP is connected to two or more SGs, the
		> right SG can be selected according the pc/ssn state. 

		If you have multiple SG acting as STP/SCCP-Relay it is the same.  If you do
		not have multiple SG acting as STP/SCCP-Relay, you don not have an SG at
		all, you have several SGP which must coordinate between themselves.

I agree, in the case of STP/SCCP-Relay, it will be the same. In this case, in fact, the ASP will not receive the CLDR, coming  only from one SG.
If not, and if the translation is done in the AS, you could have several independant SGs. Perhaps strange, but possible. 
Also if a first translation is done in the AS, the SG could be selected according some critiria, like the region. More flexible..
But as Pierre said, it is implementation dependant.   
 
		>
		> If you apply only loadsharing between 2 SGs, half of the traffic will be
		> lost.

		Two SGs acting as STP/SCCP-Relay can route traffic to each other.  No
		traffic is lost.

--brian

> *******

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 3 May 2002 05:36:01 -0500

Phillipe,

Bouckaert, Philippe wrote:                             (Fri, 03 May 2002 10:46:58)
[snip]
> I agree, in the case of STP/SCCP-Relay, it will be the same. In this case,
> in fact, the ASP will not receive the CLDR, coming  only from one SG.
>
> If not, and if the translation is done in the AS, you could have several
> independant SGs. Perhaps strange, but possible. 
>
> Also if a first translation is done in the AS, the SG could be selected
> according some critiria, like the region. More flexible..
>

If you attach to independent SG then your point code appears in multiple
networks and both MTP routing as well as SCCP routing would be required
at the ASP.  This is really an IPSP arrangement.  If you wish to use this
type of configuration, M3UA-IPSP would be a better choice than SUA, as you
are really looking to decide SG based on MTP route status, not remote
subsystem status.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/