Subject: RE: [Sigtran] (M2PA) Please add a Network Appearance parameter to the M2PA protocol

From: "Bep Verberk" <[email-masked]>
Date: Tue, 28 May 2002 15:56:53 -0400

-----Original Message-----
From: Tolga Asveren [mailto:[email-masked]]
Sent: Tuesday, May 28, 2002 3:43 PM
To: [email-masked]
Subject: RE: [Sigtran] (M2PA) Please add a Network Appearance parameter to
the M2PA protocol

> Bep,
>  
> But similarly you can also not answer the question, why one should use
M2PA > instead of M3UA SG-SG? ;-)

[BEP] But I asked you first ;) 
Jeff was kind enough to come forth with the multiple networks reason.
This is an advantage of m3ua over m2pa for SG-SG.

The advantages of m2pa over m3ua for SG-SG are:
- m2pa (altghough not yet an RFC) is fairly well defined
- MTP3 is, as we're all aware, well defined, thus we have "running code"
from many differnet sources that demonstrate that this works very nicely.
- m3ua SG-SG requires we replicate many mtp3 functions (eg
ChangeOver, MTP Restart), invent new
messages (ie CORA, COR, TAL, CGT ) that are essentially the same as existing
MTP3 messages.

It just seems to me that you are reinventing MTP3 with new messages
, with the only advantage over MTP3/M2PA being
the ability to send messages for more than 1 network over the same
association.

> Why to try simulate links in IP domain? Why try to put another protocol
(M2PA) > there for relaying?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Bep
Verberk
Sent: Tuesday, May 28, 2002 3:26 PM
To: [email-masked]'; [email-masked]
Cc: [email-masked]
Subject: RE: [Sigtran] (M2PA) Please add a Network Appearance parameter to
the M2PA protocol

This is getting at the heart of my question to Brian about the 
value of using M3UA for SG-SG versus just m2pa. 
This a valid plus for M3UA, that is, you can send traffic 
for more than one network over the same association. 
Although I still believe  this is a minor plus. 
Of course Jeff points out that he doesn't like/need some 
of the other aspects of m3ua for SG-SG. 
So it becomes a trade off Jeff. 
You need to either 
1. use muliple m2pa associations -  each 
carrying traffic for different networks 
(I don't think this is so bad) 
2. Use m3ua 
3. Do something proprietary like you are proposing. If you 
do this please share your ideas with us :) 
Bep 

> -----Original Message----- 
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Tuesday, May 28, 2002 3:05 PM 
> To: [email-masked] 
> Cc: [email-masked] 
> Subject: Re: [Sigtran] (M2PA) Please add a Network Appearance 
> parameter 
> to the M2PA protocol 
> 
> 
> 
> Hello Brian, 
> 
> >M3UA SG-SG has Network Appearance. 
> >Use it instead of mangling M2PA. 
> 
> Bummer of an answer. 'mangling'? 
> 
> So the goal of M2PA is to offer nothing more, or less, than 
> that provided 
> by MTP2? 
> 
> I know this discussion is not going anywhere, but..... 
> 
> I happen to have a MTP3 layer that is aware of multiple ITU-N 
> networks. 
> I need a means to convey that information across B,C,D 
> SS7-over-IP links. 
> You argue that this functionality is L3-based and does not 
> belong in L2 
> (M2PA). 
> Unfortunately, the MTP3 message payload is fixed. The M2PA message 
> payload is not yet fixed, but strictly defines the mapping of 
> MSUs. The 
> M2PA protocol is not very extensible, except in terms of new 
> message types. 
> 
> M3UA SG-SG is not a good choice for my implementation: 
> 1) I have no need for routing key registration or of 
> application servers. 
> 2) I have no need for elaborate conversions of SS7 SNMs and MSUs. 
> 3) I have no need to use multiple SCTP streams for user data. 
> 
> So I am left with adding a custom message type to M2PA or 
> using reserved 
> bits. 
> Okee dokee. 
> 
> Regards, 
> 
> Jeff 
> 
> 
> 
>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 28 May 2002 15:40:00 -0500

Bep,

Where were you when 3GPP was picking their transport?  Also, the SG-SG
approach (and remember it is applicable to SUA SG-SG and TUA SG-SG)
is not so different than Q.2150.1 and Q.2150.3.  I wonder why SG11 and
SG13 didn't go with M2PA ;)  Really, the need is for adapting these
upper layer protocols to use a IP-based transport rather than attempting
to make an IP network behave like TDM on a wire on ATM in a VC.

--brian

Bep Verberk wrote:                                            (Tue, 28 May 2002 15:56:53)
>    From: Tolga Asveren [[1]mailto:[email-masked]]
>    Subject: RE: [Sigtran] (M2PA) Please add a Network Appearance
>    parameter to the M2PA protocol
>    
>    > Bep,
>    >
>    > But similarly you can also not answer the question, why one should
>    use M2PA > instead of M3UA SG-SG? ;-)
>    
>    - MTP3 is, as we're all aware, well defined, thus we have "running
>    code" from many differnet sources that demonstrate that this works
>    very nicely.
>    
>    > Why to try simulate links in IP domain? Why try to put another
>    protocol (M2PA) > there for relaying?
>    
>    From: [email-masked] [[2]mailto:[email-masked]]On
>    Behalf Of Bep Verberk
>    Subject: RE: [Sigtran] (M2PA) Please add a Network Appearance
>    parameter to the M2PA protocol
>    
>    > From: [email-masked]
>    [[3]mailto:[email-masked]]
> References
>    1. mailto:[email-masked]
>    2. mailto:[email-masked]
>    3. mailto:[email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 28 May 2002 16:49:22 -0400

RE: [Sigtran] (M2PA) Please add a Network Appearance parameter to the M2PA
protocolBep,
  -----Original Message-----
  From: Bep Verberk [mailto:[email-masked]]
  Sent: Tuesday, May 28, 2002 3:57 PM
  To: 'Tolga Asveren'; [email-masked]
  Subject: RE: [Sigtran] (M2PA) Please add a Network Appearance parameter to
the M2PA protocol

  -----Original Message-----
  From: Tolga Asveren [mailto:[email-masked]]
  Sent: Tuesday, May 28, 2002 3:43 PM
  To: [email-masked]
  Subject: RE: [Sigtran] (M2PA) Please add a Network Appearance parameter to
the M2PA protocol

  [TOLGA] You should also consider that it is an extension to existing M3UA
draft. It enables you to do more than what was already defined there. Also,
I think if you consider, how well it is defined etc..., then basically we
can't introduce anything new to any protocol, because it will decrease the
stability.

  - m3ua SG-SG requires we replicate many mtp3 functions (eg
  ChangeOver, MTP Restart), invent new
  messages (ie CORA, COR, TAL, CGT ) that are essentially the same as
existing
  MTP3 messages.

  [TOLGA] So, similarly TFP = DUNA , TFA = DAVA etc..., it seems you don't
want any SSNM at all :-) In fact, it is easy to get rid of TAL. CORA and COR
are needed for a very special case, if people don't want to cover this case,
there is no need for them. For SGP/ASP case, one has already the combined
MTP3/SGPF functionality, SG-SG is only a natural extension of this. In M2PA
you have links in IP domain, with M3PA, only routes, which to me makes more
sense.

   [TOLGA] Most of SSNM already covers those messages.

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of
Bep Verberk
  Sent: Tuesday, May 28, 2002 3:26 PM
  To: [email-masked]'; [email-masked]
  Cc: [email-masked]
  Subject: RE: [Sigtran] (M2PA) Please add a Network Appearance parameter to
the M2PA protocol