Subject: [Sigtran] M3UA implementors guide -- Semi-optional parameters

From: "Schantz, John" <[email-masked]>
Date: Wed, 22 May 2002 15:29:41 -0500

I have been off doing other things and I decided to see what was new.

I noticed that section "3.6 Semi-Optional RC Parameter" left out "NA".  The same arguments for RC also apply to NA.  If an association is to carry traffic from more than one network (e.g., 2 national ITU networks where SS7 PCs are not unique, or an ANSI and an ITU network where the PC format and message format are different), then the NA is required.

You can easily change the section title to remove "RC" and change NA's designation from "optional" to "semi-optional".

John S.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Wed, 22 May 2002 17:43:51 -0400

Correct me if I am wrong but I thought 3.6 was added to IG, to prevent a
confusion because of

3.3.1
Routing Context   Optional

and

Page29:
Routing Context:
......
Where multiple Routing Keys and Routing Contexts are used across a common
association, the Routing Context MUST be sent to identify the traffic flow,
......

In the current draft, a MUST does not exist for Netwok Appearence. So,
should it be still considered as semi-optional?

   Tolga

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Schantz, John
> Sent: Wednesday, May 22, 2002 4:30 PM
> To: [email-masked]; [email-masked]; [email-masked];
> Javier Pastor-Balbas (ECE)
> Subject: [Sigtran] M3UA implementors guide -- Semi-optional parameters
>
>
> I noticed that section "3.6 Semi-Optional RC Parameter" left out
> "NA".  The same arguments for RC also apply to NA.  If an
> association is to carry traffic from more than one network (e.g.,
> 2 national ITU networks where SS7 PCs are not unique, or an ANSI
> and an ITU network where the PC format and message format are
> different), then the NA is required.
>
> You can easily change the section title to remove "RC" and change
> NA's designation from "optional" to "semi-optional".
>
> John S.
>
>