Subject: RE: [Sigtran] m3ua:ipspcomm document

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Tue, 28 May 2002 17:53:04 +0200

Hi Tolga, 

Comments below...

> -----Original Message-----
> From: Tolga Asveren [mailto:[email-masked]]
> Sent: Tuesday, May 28, 2002 5:44 PM
> To: [email-masked]
> Subject: RE: [Sigtran] m3ua:ipspcomm document
> 
> 
> Hi Javier,
> 
> > -----Original Message-----
> > From: Javier Pastor-Balbas (ECE)
> > [mailto:[email-masked]]
> > Sent: Tuesday, May 28, 2002 11:25 AM
> > To: 'Tolga Asveren'; [email-masked]
> > Subject: RE: [Sigtran] m3ua:ipspcomm document
> >
> >
> > Hi Tolga,
> >
> > Comments below...
> >
> > > -----Original Message-----
> > > From: Tolga Asveren [mailto:[email-masked]]
> > > Sent: Tuesday, May 28, 2002 4:19 PM
> > > To: [email-masked]
> > > Subject: RE: [Sigtran] m3ua:ipspcomm document
> > >
> > >
> > > Just a small clarification below.....
> > >
> > > > -----Original Message-----
> > > > From: [email-masked]
> > > [mailto:[email-masked]]On Behalf Of
> > > > Tolga Asveren
> > > >
> > > Sent: Tuesday, May 28, 2002 10:11 AM
> > > > To: [email-masked]
> > > > Subject: [Sigtran] m3ua:ipspcomm document
> > > >
> > > >
> > > > Javier,
> > > >
> > > > Now the document is there and so I can officially ask my
> > > questions :-) :
> > > >
> > > > 1- What is the difference between double message exchange (2
> > > > ASPUP, 2 ASPAC
> > > > etc..) approach and combining ASPF and SGPF together?
> > > >
> >
> > The difference is the concept itself. You don't have two
> > entities, you just have one. This entity is like a ASP with the
> > possibility of routing to an IP endpoint. The reason to send two
> > messages is to follow the current draft. Those messages are sent
> > by AS activating and deactivating it. There is a 1:1:1
> > relationship between AS:RK:RC. RK and RC implies only one AS and
> > not the complete path...
> [TOLGA] Sorry, but there is no difference at all. It is exactly
> cross-connected ASPF/SGPF case. It is also not peer to peer but 2
> client-server relationships. I am also against following the 
> current draft
> for IPSP case, because there was never a consensus about it in the WG.

I think that you mean there was never a consensus about the two exchange modes for IPSPs. That was the reason why we included both of them. IPSP is included from the earliest versions. It is nothing we included by our own...

It is not necessarily ASPF/SGPF. You can ask all the people that were at the Plugtest, how many of them modeled it as ASPF/SGPF. At least we didn't need it. It is a simply extension of an ASP (as the IPSP definition says).

> >
> >
> >
> > > > 2- Can those two approaches really interwork? How?
> > > [TOLGA] those approaches = single and double message exchange
> > > approaches
> >
> > Yes, they can interwork. I'm writing the text at this moment...  :-)
> [TOLGA] I think this is the new way of working in this WG. Without
> discussing and having consensus on the group , just writing drafts and
> documents -like it was done for IPSP in M3UA draft-.

IETF is a document driven forum. I just think it is more valuable work like this instead of going around the same mails and questions several times. It is also easy explain things that are complex using a document instead a bunch of mails.

Cheers // Javier.

> >
> > > >
> > > >
> > > >    Tolga
> > > >
> > > >
> > > >
> > > >
> > > >
> > > >
> > > > _______________________________________________
> > > > Sigtran mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > >
> > > _______________________________________________
> > > Sigtran mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/sigtran
> > >
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 28 May 2002 12:11:45 -0400

Hi Javier,

> I think that you mean there was never a consensus about the two
> exchange modes for IPSPs. That was the reason why we included
> both of them. IPSP is included from the earliest versions. It is
> nothing we included by our own...
>
> It is not necessarily ASPF/SGPF. You can ask all the people that
> were at the Plugtest, how many of them modeled it as ASPF/SGPF.
> At least we didn't need it. It is a simply extension of an ASP
> (as the IPSP definition says).
[TOLGA] My opinion is, it is irrelevant how people have implemented it,
important point is the defined functionality by the protocol.
Considering that our goal is to define IPSP mode, which couldn't be done for
M3UA because of time limitations, my proposal is, to remove "double ended"
approach, because it is not a peer-to-peer solution. (In fact I think
ASP-ASP isa more proper name but naming is not deadly important).
> IETF is a document driven forum. I just think it is more valuable
> work like this instead of going around the same mails and
> questions several times. It is also easy explain things that are
> complex using a document instead a bunch of mails.
[TOLGA] My point is, before finishing discussions on the current document,
it is not very usefull to write some extensions to it, we even don't know,
what the result of discussions about it is going to be.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 28 May 2002 11:45:12 -0500

Javier,

Please see comments below...

Javier Pastor-Balbas (ECE) wrote:                          (Tue, 28 May 2002 17:53:04)
> I think that you mean there was never a consensus about the two exchange
> modes for IPSPs. That was the reason why we included both of them. IPSP is
> included from the earliest versions. It is nothing we included by our own...
> 
> It is not necessarily ASPF/SGPF. You can ask all the people that were at the
> Plugtest, how many of them modeled it as ASPF/SGPF. At least we didn't need
> it. It is a simply extension of an ASP (as the IPSP definition says).

No, the IPSP definition says that the IPSP acts like an SG when responding to
another IPSP acting like an AS.  In fact, the draft you submitted has more
SG functionality in the IPSP than AS functionality (it has routing keys, it
distributes messages based on routing key, it accepts registrations, it has
an MTP3 which talks to the corresponding MTP3-User in the other IPSP, and on,
and on).

I agree with Tolga, it has been exactly described as criss-cross ASPF/SGPF,
regardless of what people did at the non-IETF function.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/