Subject: RE: [Sigtran] document status

From: "Ong, Lyndon" <[email-masked]>
Date: Tue, 14 May 2002 09:13:42 -0700

Hi Tolga,

There is currently no plan for a session, it depends on 
whether people would like a session and have some need for
this.  Any input would be welcome.

Cheers,

Lyndon

-----Original Message-----
From: Tolga Asveren [mailto:[email-masked]]
Sent: Monday, May 13, 2002 2:53 PM
To: [email-masked]
Subject: RE: [Sigtran] document status

Lyndon,

What about IETF meeting in Yokohoma, will there be a SIGTRAN session?

   Tolga

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Ong, Lyndon
> Sent: Monday, May 13, 2002 5:34 PM
> To: [email-masked]'
> Subject: [Sigtran] document status
> 
> 
> Hi Folks,
> 
> I was asked by our A-Ds for a document status update, this is 
> what I found:
> 
> draft-ietf-sigtran-m2ua-15.txt	In RFC editor's queue
> draft-ietf-sigtran-m3ua-12.txt	In RFC editor's queue
> draft-ietf-sigtran-sctp-mib-07.txt	Waiting on A-D comments
> draft-ietf-sigtran-sua-13.txt		Waiting on IESG review
> draft-ietf-sigtran-signalling-over-sctp-applic-05.txt
>   still draft, expect to complete before Yokohama
> draft-ietf-sigtran-m2pa-04.txt
>   still draft, expect to complete before Yokohama (no major issues)
> draft-ietf-sigtran-m3ua-mib-03.txt
>   still draft, waiting on incorporation of comments from Shaun Routhier
> draft-ietf-sigtran-v5ua-02.txt
>   still draft, expect to do WG LC soon
> draft-ietf-sigtran-dua-02.txt
>   resolving A-D issue with IANA requirements (believe that the issue
>   is just the determination of the SCTP Payload Protocol ID)
> draft-ietf-sigtran-m3ua-implementors-guide-00.txt
>   initial draft, expect to complete after November bakeoff
> draft-ietf-sigtran-iua-imp-guide-00.txt
>   initial draft, expect to complete after November bakeoff
> 
> There are apparently some concerns with the security section of 
> SUA that are
> holding this up,
> I will try to find out further information.  The SCTP MIB is waiting on
> comments from the OAM
> A-Ds.  DUA should be reissued soon with changes to the IANA section, and
> resubmitted to
> IESG for review.
> 
> We need to do WG Last Call for V5UA, I'd like to start this on 
> Wednesday if
> there are no 
> objections.  We can then do WG Last Call on M2PA after this, if we have
> resolved any 
> remaining issues.
> 
> Finally, Tolga has asked that we make the SG-SG document a working group
> document,
> I would like to get comments on this.
> 
> Cheers,
> 
> L. Ong
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "vaibhav_madan" <[email-masked]>
Date: Tue, 14 May 2002 19:49:17 +0530

Hi

     I also agree with Tolga that we should make SG-SG communication a part of the working group. As is the present case, already a lot of work has been done on the document and it will definitely give a better overview to people going for the implementation of M3UA(as the draft addresses issues specifically for M3UA).

Regards

Vaibhav

"Ong, Lyndon" wrote:

Hi Folks,

I was asked by our A-Ds for a document status update, this is what I found:

There are apparently some concerns with the security section of SUA that are
holding this up,
I will try to find out further information. The SCTP MIB is waiting on
comments from the OAM
A-Ds. DUA should be reissued soon with changes to the IANA section, and
resubmitted to
IESG for review.

We need to do WG Last Call for V5UA, I'd like to start this on Wednesday if
there are no 
objections. We can then do WG Last Call on M2PA after this, if we have
resolved any 
remaining issues.

Cheers,

L. Ong

Get Your Private, Free E-mail from Indiatimes at  http://email.indiatimes.com
Buy Music, Video, CD-ROM, Audio-Books and Music Accessories from http://www.planetm.co.in

---

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Fri, 17 May 2002 18:18:48 +0200

Hi Tolga, 

> Sent: Friday, May 17, 2002 6:06 PM
> To: [email-masked]
> Javier,
> > From: Javier Pastor-Balbas (ECE)
> > [mailto:[email-masked]]
> > Sent: Friday, May 17, 2002 9:07 AM
> > To: 'Ong, Lyndon'; 'Tolga Asveren'; [email-masked]
> > Hi Lyndon/Tolga,
> > I didn't answer before because I thought my view was clear
> > enough, but anyway I'll do it now. :-)
> >
> > I agree on having this SG-SG communication draft. I support it,
> > and I will help to this to become reality. I haven't still had
> > time to read it, but I'll do it during next week and I'll send my
> > comments.
> >
> > On the other hand, I don't think we need to define a new IPSP
> > communication. IPSP communication is already defined in the RFC
> > and we don't have to change it for the moment. It is true that it
> > has some holes in the design, and those are what we should fix to
> > finish the RFC in a good way. Regarding this, I plan to realise a
> > new draft that collects how IPSP communication works. It's
> > nothing new but I see the need to have it to work from a 
> clear baseline.
> [TOLGA] I hope you finish it soon so that we can continue 
> with the new stuff
> ;) I assume you will continue with the approach, which is 
> making use of ASPF
> and SGPF. 

Well, it is never said in the RFC that IPSP is a combination of ASPF and SGPF ;-). What it is said is that: "[...] only the SGP/ASP case is described but the SGP side of the procedures also apply to an IPSP sending traffic to an AS consisting of a set of remote IPSPs."

And also in the definition it says that an "IPSP is essentially the same as an ASP".

Anyway, let's wait for the document before start discussing...  :-)

> And just my 2 cents for the double-ended approach, 
> single-ended
> approach debate. If the strategy is to see IPSP as a 
> logically combined
> ASP/SGP, then I think it is obvious that it should be 
> double-ended approach.
> Otherwise state machines should be changed and it won't be 
> anymore reusing
> existing functionalities.

This is one of the debates I try to trigger...  :-D. But this time we have more time to reach a conclusion....

Cheers // Javier.

> >
> > I don't think either that focusing on new works ,without
> > finishing the ones that are going on, is the best option. I 
> would propose:
> > 	1- finish the M3UA as it is first. This means finish the
> > implementor's guide with the hole the current v12 has.
> > 	2- work in SG-SG
> > 	3- More improvements if needed
> >
> > Focusing on other issues will delay the end of the current 
> ones...  :-/
> >
> > Cheers // Javier.
> >
> >
> > > From: Ong, Lyndon [mailto:[email-masked]]
> > > Sent: Friday, May 17, 2002 1:32 AM
> > > To: 'Tolga Asveren'; [email-masked]
> > > If there is no discussion, I guess I will take that as no 
> opposition.
> > > However, I want to give people a chance to look over the document,
> > > especially if they were not part of the small group discussion.
> > >
> > > For example, does this fulfill what people were looking for in
> > > IPSP-to-IPSP transport?  Is the model of SG-to-SG communication
> > > over an IP network clear to people?  Are there any concerns with
> > > the addition of new messages and parameters?
> > >
> > > I agree, if people have issues these should be put on the table.
> > >
> > > Cheers,
> > >
> > > Lyndon
> > >
> > > Sent: Thursday, May 16, 2002 6:17 AM
> > > To: [email-masked]
> > > Considering the low amount of interest during the last few
> > > months on the WG,
> > > I  think it might be a little bit too optimistic to get a lot
> > > of feedback on
> > > this issue (till now one person has stated support and nobody
> > > objected).
> > >
> > > My goal is not to try to impose some ideas but trying to get
> > > a solution for
> > > a missing piece in the protocol (as most of the people can
> > > remember, before
> > > starting to work on the draft, I asked interested people for
> > > help, we formed
> > > a 10-12 people group and the draft shows the result of those
> > > discussions).
> > > If there are people objecting, I very much would like to get
> > > their arguments
> > > and their proposed solutions so that we can see how to proceed.
> > >
> > >     Cheers,
> > >     Tolga
> > >