Subject: RE: [Sigtran] m3ua: ipspcomm

From: "Schantz, John" <[email-masked]>
Date: Wed, 29 May 2002 10:00:07 -0500

Hi Guys,

I assume that you are talking about whether both ends send ASP UP and ASP Active (and of course the ACKs).  I was looking at the RFC recently and there were a number of conclusions I go from it.

	1) There is no indication or way to indicate what one of the sides of the association is going to do - single or double handshake.
	2) At minimum, the single handshake must be supported.
	3) If one side wants to do the double handshake, then the other side must provide "courtesy" ACKs to the ASP UP and ASP ACTIVE.
	4) Even in the single handshake case, who starts it?

At first I was going to say is that we only need the single handshake.  But if you don't want to configure which side starts!  Then a combination of the two should solve the "glare" condition.

If one of the sides receives an ASP UP before it has sent one, then a single handshake should be used with the "receiving" side just ACKing the other side that was first to send the ASP UP.

If one of the sides receives an ASP UP after it has already sent one, then a double handshake should be used.  It would be easier to do this than to figure out who should be the initiator and responder.

If you MUST only have one, then give the SCTP initiator side the M3UA initiation responsibility too.

John

> -----Original Message-----
> From: Javier Pastor-Balbas (ECE)
> [mailto:[email-masked]]
> Sent: Wednesday, May 29, 2002 8:08 AM
> To: 'Tolga Asveren'; [email-masked]
> Subject: RE: [Sigtran] m3ua: ipspcomm
> 
> 
> Hi Tolga, 
> 
> If this is what people think and Lyndon agrees, I have no problem  :-)
> 
> Do any people want both approaches??
> 
> Cheers // Javier.
> 
> > -----Original Message-----
> > From: Tolga Asveren [mailto:[email-masked]]
> > Sent: Wednesday, May 29, 2002 2:42 PM
> > To: [email-masked]
> > Subject: [Sigtran] m3ua: ipspcomm
> > 
> > 
> > Javier,
> > 
> > What is the reason to continue with two approaches? I think, 
> > first of all,
> > we should decide, whether this is really we want or not and 
> > if we want to go
> > with one of them, we should choose which one. "Double" and 
> > "single" ended
> > approaches are representing two different philosophies.
> > 
> >    Tolga
> > 
> > 
> > 
> > 
> > 
> > 
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> > 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Wed, 29 May 2002 11:24:34 -0400

John,

But apart from traffic initiation, there are also other aspects of this
issue, at least in my mind.
"Double ended" approach assumes RKs have meaning only in one direction, i.e.
one has local and remote RKs. For "single ended" the RK has meaning for both
AS on each side.
(This is more or less the point, where we have stopped in the intiial IPSP
discussions) That is the reason, why I was saying, those are representing
two different ways of doing things. In my opinion, if one chooses one of
those two methods, then agreeing on how traffic should be started shouldn't
be a major task.

   Tolga

> From: Schantz, John [mailto:[email-masked]]
> Sent: Wednesday, May 29, 2002 11:00 AM
> To: Javier Pastor-Balbas (ECE); Tolga Asveren; [email-masked]
> I assume that you are talking about whether both ends send ASP UP
> and ASP Active (and of course the ACKs).  I was looking at the
> RFC recently and there were a number of conclusions I go from it.
>
> 	1) There is no indication or way to indicate what one of
> the sides of the association is going to do - single or double handshake.
> 	3) If one side wants to do the double handshake, then the
> other side must provide "courtesy" ACKs to the ASP UP and ASP ACTIVE.
> At first I was going to say is that we only need the single
> handshake.  But if you don't want to configure which side starts!
>  Then a combination of the two should solve the "glare" condition.
>
> If one of the sides receives an ASP UP before it has sent one,
> then a single handshake should be used with the "receiving" side
> just ACKing the other side that was first to send the ASP UP.
>
> If one of the sides receives an ASP UP after it has already sent
> one, then a double handshake should be used.  It would be easier
> to do this than to figure out who should be the initiator and responder.
>