Subject: [Sigtran] SG-SG : starting traffic

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 30 May 2002 11:22:55 -0400

Brian,

>>I would rather get rid of TAL.  There is no reason why an SG can't use
>>ASPUP/DN, ASPAC/IA and DAUD for MTP3 restart in a similar fashion to
>>M3UA.  The only minor difference is that MTP3 restart should be handled
>>by a peer-to-peer arrangement rather than a MTP3/MTP3-User arrangement.
[TOLGA] I also want to get rid of TAL. But why just SSNM is not enough? If
possible, I would like to use just SSNM for SG-SG communication. My proposal
is, after SCTP association is established:
a) Either each SG announces available/restricted PC list to its peer
b) or each SG asks with DAUD for the PCs it is interested in to its peer

So again no TAL. The only reason, we have TAL is, because SGs were
announcing unavailable/restricted PCs and everyhting else was considered as
available, so, we needed a message to mark end of this announcement.
>>That is:
>>
>>	SG goes ASPUP.
>>
>>	SG does not require MTP3 restart if it has not isolated from
>>	the SS7 or IP networks.
>>
>>	SG needs to assume that all destinations are available at the
>>	beginning of the procedure (rather than unavailable as in the
>>	backhaul case).
>>
>>	SG requests update of routes by issuing DAUD to peer.  Peer
>>	responds with only unavailable (DUNA) destinations.  (Note
>>	that routes cannot be congested when no traffic is flowing
>>	to them).
>>
>>	After a time equivalent to T19, T20, T21, the SG starts traffic
>>	with ASPAC.
[TOLGA] Why do we need the timers and ASPAC?
>>
>>The difference here is that DAUD is issued before ASPAC (instead of
>>after in the backhaul case), destinations are assumed available and
>>uncongested (instead of unavailable as in the backhaul case).
>>
>>Voila.  No TAL.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "reshma" <[email-masked]>
Date: Thu, 30 May 2002 20:55:42 +0530

Hi Tolga/Javier,

> b) or each SG asks with DAUD for the PCs it is interested in to its peer

[Reshma] Why cant we have same mechanism for IPSP-IPSP also?
As+ there is no real need for ACTIVE /UP messages there also.

Thanks,
Reshma

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 30 May 2002 12:02:14 -0400

Brian,

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Thursday, May 30, 2002 11:37 AM
> To: Tolga Asveren
> Cc: [email-masked]
> Subject: Re: [Sigtran] SG-SG : starting traffic
>
>
> Tolga,
>
> Tolga Asveren wrote:                                        (Thu,
> 30 May 2002 11:22:55)
> > Brian,
> >
> Because it may take some nodes longer to restart and the peer needs some
> way of knowing that restarting traffic to the restarting node is now
> permitted.  Otherwise, an adjacent SG could start full traffic before a
> retarting node is capable of handling such traffic.  ASPTM is a natural
> for this.  The ASPUP is so that the SG has some sort of equivalent to an
> "In Service at Level 2" indication to begin restart preocedures.
> Otherwise
> its initial DAUD might go into a black hole, it would assume that it had
> received all updates within the time interval and it would restart traffic
> to a dead peer.
[TOLGA] I understand those concerns. But if DAVA is sent only, after traffic
for a PC can be really handled, wouldn't this solve the problem? For MTP3
Restart case, timers you mentioned will be of course there, but in MTP3
itself, and if there is no interaction with peers in SS7 domain, probably
those are not needed. When there is MTP3, like MTP3 informs user parts about
availability of PC, it can also inform SGPF logic.
> --brian
> --
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 30 May 2002 11:05:02 -0500

Tolga,

Tolga Asveren wrote:                                        (Thu, 30 May 2002 12:02:14)
> availability of PC, it can also inform SGPF logic.

The problem with DAVA is the same as in the SS7 network: if an SG must
indicate the availability of ALL its routesets, that may take a couple of
minutes.  If an SG indicates just the unavailable routesets, it may take no
time at all (if all routesets are available as is normally the case).

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 30 May 2002 10:37:16 -0500

Tolga,

Tolga Asveren wrote:                                        (Thu, 30 May 2002 11:22:55)

"In Service at Level 2" indication to begin restart preocedures.  Otherwise

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 30 May 2002 12:31:49 -0500

Tolga,

Tolga Asveren wrote:                                        (Thu, 30 May 2002 13:27:33)
> > Sent: Thursday, May 30, 2002 12:05 PM
> > To: Tolga Asveren
> > Cc: [email-masked]
> > 30 May 2002 12:02:14)
> [TOLGA] I also agree with this point, that was the reason, why we wanted to
> announce unavailable/restricted PCs after SCTP association establishment.
> So, correct me if I am wrong, you propose we replace TAL with ASPUP?
> Although it would be more elegant to solve the problem within SSNM, using
> ASPUP would have the advantage of not introducing a new message.

Not ASPUP: ASPAC.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 30 May 2002 13:27:33 -0400

Brian,

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 30 May 2002 13:50:12 -0400

Brian,

> Sent: Thursday, May 30, 2002 1:32 PM
> To: Tolga Asveren
> Cc: [email-masked]
> 30 May 2002 13:27:33)
[TOLGA] But why with ASPAC? Do we need to send ASPAC for all of the
available PC? Why not assume that all of them are available, announce
unavailable/restricted ones with SSNM after SCTP association is established
and end mark the end of this announcement with ASPUP (instead of TAL)?

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 30 May 2002 13:03:44 -0500

Tolga,

Tolga Asveren wrote:                                        (Thu, 30 May 2002 13:50:12)
> and end mark the end of this announcement with ASPUP (instead of TAL)?

I was thinking ASPAC with no RC.  It would be peculiar to send SNMM before
ASPUP, because they are not acknowledged: ASPUP is.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 30 May 2002 19:51:25 -0400

Brian,

> ASPUP, because they are not acknowledged: ASPUP is.
[TOLGA] My idea was, if SG is not ready to receive SSNM, then it won't
establish SCTP association(and it will reject if the peer SG tries to
initiate it) Well, but with a similar logic one could ask why ASPUP is
necessary for regular ASP/SGP case. So, if we have it for ASP/SGP , it makes
also sense to have it for SG-SG case.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 30 May 2002 19:21:59 -0500

Tolga,

Tolga Asveren wrote:                                        (Thu, 30 May 2002 19:51:25)
> also sense to have it for SG-SG case.

We had it for the regular ASP/SGP case because SCTP and the UA are usually
conceived as separate pieces.  Although SCTP is there and the association
is up, the UA could have crashed or failed to load.  ASPUP/ACK verifies that
UAs at both ends are alive and well before starting other exchanges.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 31 May 2002 10:10:07 -0400

Brian,

> Sent: Thursday, May 30, 2002 8:22 PM
> To: Tolga Asveren
> Cc: [email-masked]
> 30 May 2002 19:51:25)
[TOLGA[ O.K. I agree this is a cleaner solution, although in my opinion, it
is not very likely that SCTP/M3UA are not interworking very closly to
start/accept SCTP associations.