Subject: RE: [Sigtran] RE: sg-sg communication

From: "Bep Verberk" <[email-masked]>
Date: Thu, 30 May 2002 11:45:51 -0400

Folks,
it seems alot of our problems with making progress on these discussions
is notions of what an ASP , SGP, IPSP is.

If we all agree on the 2 objectives for Tolga's SG-SG
proposal can we discuss instead on how to do this without
worrying too much about what IPSP,ASP,SGP is currently defined
or, not defined as etc.

Does anyone disagree with the objectives ??

My suggestion would be to focus on Figure 1 first (ie
ASP <-> SG <-> SG <-> ASP  (Damm< I used the dreaded terms)

and secondly on Figure 2
SS7 node <-> SG <-> SG <-> SS7 node
(because I think this is more complex)

Bep

> -----Original Message-----
> From: Tolga Asveren [mailto:[email-masked]]
> Sent: Thursday, May 30, 2002 11:47 AM
> To: [email-masked]
> Subject: RE: [Sigtran] RE: sg-sg communication
> 
> 
> Reshma,
> 
> > -----Original Message-----
> > From: reshma [mailto:[email-masked]]
> > Sent: Thursday, May 30, 2002 11:34 AM
> > To: Tolga Asveren; [email-masked]
> > Subject: Re: [Sigtran] RE: sg-sg communication
> >
> >
> > Hi Tolga,
> >
> >
> > > > > > > > Hi  Tolga,
> > > > > > > >
> > > > > > > >     Thanks for your reply some more doubts :-(
> > > > > > > >
> > > > > > > > > >  [Reshma] Okay now its clear. But how does SG1
> > knows whether
> > > > > > > > the data is
> > > > > > > > > > from SG2 or from ASPs? Depending on which 
> he might have to
> > > > > > > > act as relay
> > > > > > > > > > point or a normal SG?
> > > > > > > > > [TOLGA] With the same method, it can know, whether a
> > > > > message is
> > > > > > > > from ASP1
> > > > > > > > or
> > > > > > > > > ASP2, this is implemention dependent (but 
> most probably
> > > > > > > based on the
> > > > > > > > source
> > > > > > > > > address of the SCTP message)
> > > > > > > >
> > > > > > > > [Reshma] As per M3UA draft , m3ua can act as an 
> SGP,ASP,IPSP.
> > > > > > > > When it acts its an IPSP the peer is always assumed
> > to be IPSP.
> > > > > > > [TOLGA] No, IPSP will behaeve as ASP against SGPs.
> > > > > >
> > > > > > This is not true. IPSP has a specific behavior as 
> Reshma says.
> > > > > > And if we consider SE even the State Machine changes...  :-)
> > > > > [TOLGA] I disagree with this. In my opinion, IPSP needs to
> > > > > behaeve as ASP
> > > > > against SGPs.
> > > >
> > > > If you are handling received ASPUP or ASPAC, you are not acting
> > > > as an ASP. IPSP acts different to an ASP.
> > > [TOLGA] This is what it does against another IPSP (and still
> > there are so
> > > many issues to discuss there). Well, maybe it is better 
> to put ASPF+SGPF
> > in
> > > a box, so that ASPF can communicate with any SGP without 
> problems ;-)
> >
> > [Reshma] Your answer is  not convincing :-( .
> > How can it behave as both ASP and IPSP?
> [TOLGA] How it behaves as both IPSP and ASP is to be seen. 
> That was the
> reason, why I am always telling, it is better to speak of ASP-ASP
> communication instead of IPSP-IPSP. An IPSP which can't speak 
> to SGPs is not
> very usefull because can't talk to nodes in SS7 domain, and 
> also can't make
> use of SG-SG communication.
> >
> >
> > Thanks,
> > Reshma
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 30 May 2002 11:01:52 -0500

Bep,

Bep Verberk wrote:                                            (Thu, 30 May 2002 11:45:51)
>    is notions of what an ASP , SGP, IPSP is.

We know full well what an ASP and SGP are.  It is only IPSP that
is poorly defined.

>    (because I think this is more complex)

Sure: what are you interested in discussing?

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "reshma" <[email-masked]>
Date: Thu, 30 May 2002 21:38:42 +0530

Hi Tolga/Brian

    Is there any other configuration wherein SG-SG communication is used
other than the below mentioned ones and combination of 1 and 2?

Thanks,
Reshma

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 30 May 2002 11:43:02 -0500

Reshma,

SG-SG communication does not restrict other
relationships of the SGs involved.  SGs could
be also communicating with some future protocol
as well (such as when IPSPs might be ever able
to talk to SGs).

--brian

reshma wrote:                                (Thu, 30 May 2002 21:38:42)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/