Subject: RE: [Sigtran] IPSP vs AS (was RE: sg-sg communication)

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Fri, 31 May 2002 17:48:57 +0200

Hi Brian, 

See comments below...

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Friday, May 31, 2002 5:42 PM
> To: Javier Pastor-Balbas (ECE)
> Cc: Tolga Asveren; [email-masked]
> Subject: Re: [Sigtran] IPSP vs AS (was RE: sg-sg communication)
> Importance: High
> 
> 
> Javier,
> 
> Javier Pastor-Balbas (ECE) wrote:               (Fri, 31 May 
> 2002 17:30:27)
> > Brian, 
> > 
> > In DE you need to correlate local with remote RK to consider the
> > communication establish or not. I'm talking of communication in both
> > direction since having one direction active has no use for me.
> 
> Two routing keys, one in provisioned in each node, registered in
> each node.
> 
For static configuration both provisioned in both nodes. It can be provisioned as only one, as in SE.

> > 
> > SE also needs to have this correspondence and it must be 
> placed in both
> > nodes since the relation origin-destination is also needed. 
> You never have
> > one one direction active here.
> 
> One routing key, provisioned in one node, registered in the 
> other node.
> 
Or statically provisioned in both nodes.

> 
> So, what was the point of DE?
> 

I think the main point was keeping the State Machine and that having independent activation: instead of having activation per communication , having an activation per AS as in AS-SG communication.

Cheers // Javier.

> --brian
> 
> > 
> > 
> > Cheers // Javier. 
> > 
> > > -----Original Message-----
> > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > Sent: Friday, May 31, 2002 5:27 PM
> > > To: Javier Pastor-Balbas (ECE)
> > > Cc: Tolga Asveren; [email-masked]
> > > Subject: Re: [Sigtran] IPSP vs AS (was RE: sg-sg communication)
> > > Importance: High
> > > 
> > > 
> > > Javier,
> > > 
> > > Ok. But I still come up with twice as many routing keys as DE
> > > requires 2 RKs to define a single full-duplex traffic flow,
> > > SE only requires 1 RK to define the same.  
> > > And what whas the
> > > point in DE of the waste and administrative nightmare of
> > > assigning to RK/RCs to represent one traffic flow?
> > > 
> > > --brian
> > > 
> > > 
> > > Javier Pastor-Balbas (ECE) wrote:               (Fri, 31 May 
> > > 2002 17:15:33)
> > > > Brian, 
> > > > 
> > > > You are right. Then apply the same for DE  :-)
> > > > 
> > > > > -----Original Message-----
> > > > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > > > Sent: Friday, May 31, 2002 5:12 PM
> > > > > To: Javier Pastor-Balbas (ECE)
> > > > > Cc: Tolga Asveren; [email-masked]
> > > > > Subject: Re: [Sigtran] IPSP vs AS (was RE: sg-sg 
> communication)
> > > > > Importance: High
> > > > > 
> > > > > 
> > > > > Javier,
> > > > > 
> > > > > Section 3.6.1 Registration Request (REG REQ)
> > > > > 
> > > > > "Note: The Destination Point Code, Service Indicators, 
> > > > > Originating Point
> > > > > Code List and Circui Range List parameters MAY be repeated as 
> > > > > a grouping
> > > > > within the Routing Key parameter, in the structure 
> shown above."
> > > > > 
> > > > > --brian
> > > > > 
> > > > > Javier Pastor-Balbas (ECE) wrote:               (Fri, 31 May 
> > > > > 2002 16:46:46)
> > > > > > Brian, 
> > > > > > 
> > > > > > You'll need to define a new parameter to include two 
> > > > > OPC/DPCs in your
> > > > > > explanation of SE. It seems that SE have some privileges in 
> > > > > nere... Why
> > > > > > don't you do the same for DE? In any case it is not 
> > > > > compatible with the
> > > > > > current RFC: just one OPC or/and DPC per RK.
> > > > > > 
> > > > > > Cheers // Javier.
> > > > > 
> > > > > -- 
> > > > > Brian F. G. Bidulock
> > > > > [email-masked]
> > > > > http://www.openss7.org/
> > > > > 
> > > 
> > > -- 
> > > Brian F. G. Bidulock
> > > [email-masked]
> > > http://www.openss7.org/
> > > 
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 31 May 2002 11:04:35 -0500

Javier,

Javier Pastor-Balbas (ECE) wrote:               (Fri, 31 May 2002 17:48:57)
> provisioned as only one, as in SE.

No it cannot: because *-*-*/1-1-1, 1-1-1/*-*-* reduces to *-*-*.
Try a real example.  Each IPSP needs two RKs (two RCs) per traffic
flow, whether they be static or dynamic configuration.

> 
> > > 
> > > SE also needs to have this correspondence and it must be placed in both
> > > nodes since the relation origin-destination is also needed.  You never
> > > have one one direction active here.
> > 
> > One routing key, provisioned in one node, registered in the other node.
> > 

The RK need only be provisioned in one node. The RC in both.

> I think the main point was keeping the State Machine and that having
> independent activation: instead of having activation per communication ,
> having an activation per AS as in AS-SG communication.

What does that acheive?

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 31 May 2002 12:11:36 -0400

Javier,

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Javier Pastor-Balbas (ECE)
> Sent: Friday, May 31, 2002 11:49 AM
> To: [email-masked]'; Javier Pastor-Balbas (ECE)
> Subject: RE: [Sigtran] IPSP vs AS (was RE: sg-sg communication)
>
>
> Hi Brian,
>
> See comments below...
>
> I think the main point was keeping the State Machine and that
> having independent activation: instead of having activation per
> communication , having an activation per AS as in AS-SG communication.
[TOLGA] The main point was to make it similar to ASP/SGP communication, so
that one can reuse them and model it as ASPF+SGPF. For ASP/SGP case the
peers are ASP and SGP(or SG, because SG is just the name for a group of
SGPs) not AS and SG.
Whether to have criss-crossed ASPF/SGPF relationships make sense or not is a
different story. But during the initial discussions, that was the idea but
we had to stop them because of time limitations.

---

From: "reshma" <[email-masked]>
Date: Fri, 31 May 2002 21:45:10 +0530

Hi Javier.,

[Reshma] If we follow DE only statemachine will reamain the same but rest
all will change . Also there is no point in IPSP becoming active when the
peer
is not ready to process the traffic right?

Thanks,
reshma