Subject: RE: [Sigtran] IPSP vs AS (was RE: sg-sg communication)

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Fri, 31 May 2002 18:14:04 +0200

Tolga, 

See comments below...

> -----Original Message-----
> From: Tolga Asveren [mailto:[email-masked]]
> Sent: Friday, May 31, 2002 6:12 PM
> To: [email-masked]
> Subject: RE: [Sigtran] IPSP vs AS (was RE: sg-sg communication)
> 
> 
> Javier,
> 
> > -----Original Message-----
> > From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> > Javier Pastor-Balbas (ECE)
> > Sent: Friday, May 31, 2002 11:49 AM
> > To: [email-masked]'; Javier Pastor-Balbas (ECE)
> > Cc: Tolga Asveren; [email-masked]
> > Subject: RE: [Sigtran] IPSP vs AS (was RE: sg-sg communication)
> >
> >
> > Hi Brian,
> >
> > See comments below...
> >
> > > -----Original Message-----
> > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > Sent: Friday, May 31, 2002 5:42 PM
> > > To: Javier Pastor-Balbas (ECE)
> > > Cc: Tolga Asveren; [email-masked]
> > > Subject: Re: [Sigtran] IPSP vs AS (was RE: sg-sg communication)
> > > Importance: High
> > >
> > >
> > > Javier,
> > >
> > > Javier Pastor-Balbas (ECE) wrote:               (Fri, 31 May
> > > 2002 17:30:27)
> > > > Brian,
> > > >
> > > > In DE you need to correlate local with remote RK to consider the
> > > > communication establish or not. I'm talking of 
> communication in both
> > > > direction since having one direction active has no use for me.
> > >
> > > Two routing keys, one in provisioned in each node, registered in
> > > each node.
> > >
> > For static configuration both provisioned in both nodes. It can
> > be provisioned as only one, as in SE.
> >
> > > >
> > > > SE also needs to have this correspondence and it must be
> > > placed in both
> > > > nodes since the relation origin-destination is also needed.
> > > You never have
> > > > one one direction active here.
> > >
> > > One routing key, provisioned in one node, registered in the
> > > other node.
> > >
> > Or statically provisioned in both nodes.
> >
> > >
> > > So, what was the point of DE?
> > >
> >
> > I think the main point was keeping the State Machine and that
> > having independent activation: instead of having activation per
> > communication , having an activation per AS as in AS-SG 
> communication.
> [TOLGA] The main point was to make it similar to ASP/SGP 
> communication, so
> that one can reuse them and model it as ASPF+SGPF. For 
> ASP/SGP case the
> peers are ASP and SGP(or SG, because SG is just the name for 
> a group of
> SGPs) not AS and SG.
> Whether to have criss-crossed ASPF/SGPF relationships make 
> sense or not is a
> different story. But during the initial discussions, that was 
> the idea but
> we had to stop them because of time limitations.
> 

I was very involved from the beginning in the IPSP discussions and I can tell you that the idea was never having a criss-crossed model. In addition I think this is only a model you can use, but for me much better models exists...

What really happened is that we included the two approaches to close the RFC, because discussions had no end.

Cheers // Javier.

> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 31 May 2002 13:08:03 -0400

Javier,

> I was very involved from the beginning in the IPSP discussions
> and I can tell you that the idea was never having a criss-crossed
> model. In addition I think this is only a model you can use, but
> for me much better models exists...
>
> What really happened is that we included the two approaches to
> close the RFC, because discussions had no end.
[TOLGA] I was also involved on those discussions from the very beginning.
For DE, from protocol point of view, the idea was to make this happen with
the defined ASP/SGP state machines and with already defined messaging. That
was the reason, why people were attracted by it (including me). If one does
not have SS7 connectivity, it is obvious that no MTP3 interworking is
necessary, but this already belongs to non-protocol part. For example there
is a nice message from you explaining the DE approach during the initial
IPSP discussions. I think, it shows well, what people at that time were
referring to as DE approach.

(Date of message is 11/6/01)
Hi Amish,

From my point of view, IPSP needs to:

- Send data msg to the other IPSP in the way an SGP sends a message to an
ASP
- Receive data messages and distribute them to the ASs in the same way ASP
does
it
- Send ASPSM and ASPTM in the same way ASP does
- Receive and treat ASPTM and ASPSM in the same way as SGP.

Other classification of IPSP functionality:

As an SGP
- Send data msg to the other IPSP in the way an SGP sends a message to an
ASP
- Receive and treat ASPTM and ASPSM in the same way as SGP.

As an ASP
- Receive data messages and distribute them to the ASs in the same way ASP
does
it
- Send ASPSM and ASPTM in the same way ASP does

(This last point has the particularity that only one ASP-UP is needed. When
an
IPSP receives an ASPUP and sends back an ASPUP-Ack it does not need to send
another ASPUP to the peer and can consider the peer as INACTIVE)

Cheers // Javier.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 31 May 2002 12:11:11 -0500

Javier,

Javier Pastor-Balbas (ECE) wrote:                          (Fri, 31 May 2002 18:14:04)
> I was very involved from the beginning in the IPSP discussions and I can
> tell you that the idea was never having a criss-crossed model. In addition I
> think this is only a model you can use, but for me much better models
> exists...

Please describe this better model.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/