Subject: RE: [Sigtran] m3ua:SG-SG document status

From: "Bep Verberk" <[email-masked]>
Date: Tue, 28 May 2002 13:08:32 -0400

Thanks,
see below.

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Tuesday, May 28, 2002 12:50 PM
> To: Verberk, Bep [CAR:7M00:EXCH]
> Cc: 'Tolga Asveren'; [email-masked]
> Subject: Re: [Sigtran] m3ua:SG-SG document status
> 
> 
> Bep,
> 
> Bep Verberk wrote:                                            
> (Tue, 28 May 2002 12:23:07)
> > 
> >    Tolga,
> >    well you never answered one of my questions :)
> >    
> >    What is the advantages of your SG-SG proposal over
> >    simply using m2pa between 2 SGs.
> 
> Multiple streams, routes, and routesets over a single association.
> (M2PA can only support 1 link, not even a linkset).

[BEP] 1 m2pa association can carry traffic for multiple routesets, 
just as one link can. If you want 2 for redundancy - no biggy. 
What do you mean by multiple steams ? exactly what advantage does this give
?
> 
> >    I'm not against proceeding with the draft - but I don't
> >    see why anyone would use it - hopefully your answer to the
> >    above question will help me understand.
> 
> To understand the limitations of M2PA, you need only realize that
> it is exactly one link per association.  It requires a fully 
> functional
> SS7 MTP Level 3 layer to make it work.  SG-SG does not.  Also, SG-SG
> is not restricted to M3PA, it could to SPA, ISPA, TPA.

[BEP] SGs have a fully functional MTP3. The SG-SG draft adds
complications to try to mimick MTP3 behavior that is already
painstakingly defined as MTP3 and available at the SG.

> 
> Let me ask you the question: what are the advantages of M3UA?  Why not
> just use M2UA?

[BEP] I would use M3UA instead of M2UA because I want to mimimize
the SS7 transport related functions on my ASPs (ie ISUP+m3ua versus
ISUP+mtp3+m2ua). I want the SG to take care of MTP3 for me.

> --brian
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 28 May 2002 12:24:50 -0500

Bep,

Bep Verberk wrote:                                            (Tue, 28 May 2002 13:08:32)
>    > From: Brian F. G. Bidulock [[1]mailto:[email-masked]]
>    What do you mean by multiple steams ? exactly what advantage does this
>    give ?

Read the SCTP applicability statement.  Multiple streams allows SCTP to
address head-of-line blocking issues: the reason SCTP was developed in the
first place to address SIGTRAN applications.

>    painstakingly defined as MTP3 and available at the SG.

And now wonderfully available between SGs over IP.  Which was kinda the
intention of SIGTRAN: to carry SS7 over IP, not to force peer-to-peer
communication via the SS7 network.

>    ISUP+mtp3+m2ua). I want the SG to take care of MTP3 for me.

We want to use M3PA instead of M2PA so that the IP network is not treated
like some kind of wire (which it isn't).

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran