Subject: [Sigtran] ASP Id assignment when an ASP belongs to multiple ASes

From: "Umesha S Anand" <[email-masked]>
Date: Fri, 24 May 2002 08:23:48 +0200

Hi All,
   I have a question about what will be the ASP Id when an ASP belongs to
multiple ASes.  Will it be same across all ASes or can be different among
different ASes ??  Let's assume that a host has 2 ASes and a single ASP
serving a both ASes.  The ASP connects to a single SG.  In this case,
we have a single SCTP association. From the view point of SG, there is
a single ASP ( As it is a single SCTP End Point ).  So should the ASP
have the same ASP Id across both the ASes ??  Also, in this case, should
ASP send only a single ASP UP message and then send two ASP Active messages
with 2 different RCs ??

-thanks for your time,
Umesh.

---

From: "Manjunatha Shetty Kondalli" <[email-masked]>
Date: Fri, 24 May 2002 11:59:53 +0530

Umesh,
According to my understanding,
 
ASP ID is same in these cases.
It should send only one ASP UP message followed by a one registration
and one Asp active message with multiple routing Keys.
Guys, Correct me if I am wrong.
 
Regards, 
Manju

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Umesha S Anand
Sent: Friday, May 24, 2002 11:54 AM
To: [email-masked]
Subject: [Sigtran] ASP Id assignment when an ASP belongs to multiple
ASes
 
Hi All,
   I have a question about what will be the ASP Id when an ASP belongs
to
multiple ASes.  Will it be same across all ASes or can be different
among
different ASes ??  Let's assume that a host has 2 ASes and a single ASP
serving a both ASes.  The ASP connects to a single SG.  In this case,
we have a single SCTP association. From the view point of SG, there is
a single ASP ( As it is a single SCTP End Point ).  So should the ASP
have the same ASP Id across both the ASes ??  Also, in this case, should
ASP send only a single ASP UP message and then send two ASP Active
messages
with 2 different RCs ??
 
-thanks for your time,
Umesh.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 24 May 2002 02:23:31 -0500

Manjunatha,

Manjunatha Shetty Kondalli wrote:           (Fri, 24 May 2002 11:59:53)
>    ASP ID is same in these cases.

That is my understanding too.

>    and one Asp active message with multiple routing Keys.

Well, I suppose it could sent two registration messages and two ASP active
messages.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Sundaresan M G" <[email-masked]>
Date: Fri, 24 May 2002 13:05:12 +0530

Hi Umesh/Manju,

As Manju said to identify a particular ASP it needs to have same ID over all
AS.

So an ASP would send a REG_REQ to SG with "Multiple Routing Keys" so that it
wishes to register for multiple ASs whereever he is a member of. But its not
mandatory that it should send a SINGLE ASP_ACTIVE to bring up the ASPs
active in all AS.
So an ASP can send a Single Routing Context (Note: from now on it is
recognised by RCs and not RKs) or multiple RCs. At times it can send NO RCs.
In that case SG knows in which AS, the ASP is member of. With this data it
can make the ASPs active in those ASs.

Best Regards,
Sundar.
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of
Manjunatha Shetty Kondalli
  Sent: Friday, 24 May 2002 12:00 PM
  To: [email-masked]; [email-masked]
  Subject: RE: [Sigtran] ASP Id assignment when an ASP belongs to multiple
ASes

  Umesh,

  It should send only one ASP UP message followed by a one registration and
one Asp active message with multiple routing Keys.

  Regards,

  Manju

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]] On Behalf Of
Umesha S Anand
  Sent: Friday, May 24, 2002 11:54 AM
  To: [email-masked]
  Subject: [Sigtran] ASP Id assignment when an ASP belongs to multiple ASes

  Hi All,

  with 2 different RCs ??

  -thanks for your time,

  Umesh.

---

From: "Manjunatha Shetty Kondalli" <[email-masked]>
Date: Fri, 24 May 2002 12:57:05 +0530

Yah,
But, It can send one registration request with multiple routing keys or
two registration request one for each routing key.
If the AS's present in same SG then better to send in one registration
request right?
Any way registration supports multiple routing keys.
-Manju

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Brian F. G. Bidulock
Sent: Friday, May 24, 2002 12:54 PM
To: Manjunatha Shetty Kondalli
Cc: [email-masked]; [email-masked]
Subject: Re: [Sigtran] ASP Id assignment when an ASP belongs to multiple
ASes

Manjunatha,

>    and one Asp active message with multiple routing Keys.

Well, I suppose it could sent two registration messages and two ASP
active
messages.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/