Subject: [Sigtran] FW: Notify

From: "Ong, Lyndon" <[email-masked]>
Date: Fri, 17 May 2002 11:32:56 -0700

-----Original Message-----
From: Randy Haberman [mailto:[email-masked]]
Sent: Friday, May 17, 2002 11:21 AM
To: [email-masked]
Subject: Notify

I have quick question that I am not sure of. If SGP sends a Notify that
states the AS has become INACTIVE what should be the response from the ASP
( MGC). Should this be responded with a ASPDN (ASP down) or nothing.  So
what kind of message is anticipated in response to a NOTIFY that states the
AS is inactive.  thanks

Randy Haberman
Worldcom
Next Generation Architecture
[email-masked]

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 17 May 2002 14:18:43 -0500

Randy,

Notification messages are advisory only.  Even if the ASP cares to
react to the notification message, its reaction would depend on the
current state of the SGP as viewed by the ASP.  Perhaps you could
narrow down your question.  What state is the ASP in when it receives
the Notify message?

--brian

Lyndon Ong wrote:                                          (Fri, 17 May 2002 11:32:56)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Randy Haberman <[email-masked]>
Date: Fri, 17 May 2002 15:38:38 -0500

Thanks Brian for the info.  The discussion came up on sending a Notify
message that states the AS has become in INACTIVE and all of the ASPs are
unavailable. Two questions if a Notify message send out is it sufficient
enough to provoke the MGC to respond say with ASP down message and the other
questions is what kind of message is anticipated to a Notify that states the
AS is INACTIVE.

Randy

> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Friday, May 17, 2002 2:19 PM
> To: [email-masked]
> Cc: [email-masked]'
> Subject: Re: [Sigtran] FW: Notify
>
>
> Randy,
>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 17 May 2002 16:05:48 -0500

Randy,

Randy Haberman wrote:                                       (Fri, 17 May 2002 15:38:38)
> unavailable.

>Two questions if a Notify message send out is it sufficient
> enough to provoke the MGC to respond say with ASP down message

What response the ASP gives to Notify messages is implementation dependent.
Notify messages are advisory only.  Any response (or lack of response) is
acceptable for interorability.  The demands of your application may shed more
light on the answer to that question.

> and the other questions is what kind of message is anticipated to a Notify
> that states the AS is INACTIVE.

Because Notify messages are advisory only, no messsage is anticiapted in
response to a Notify message.  The SGP should never anticipate (or require
a response) to a Notify message.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/