Subject: RE: [Sigtran] IPSP vs AS (was RE: sg-sg communication)

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Fri, 31 May 2002 17:19:51 +0200

Tolga, 

See my comments below...

> -----Original Message-----
> From: Tolga Asveren [mailto:[email-masked]]
> Sent: Friday, May 31, 2002 5:13 PM
> To: [email-masked]
> Subject: RE: [Sigtran] IPSP vs AS (was RE: sg-sg communication)
> 
> 
> To show the difference between different RK approaches for IPSP let's
> consider the follwoing example:
> (I believe this will also clarify why I refer to one of them 
> as AS-AS and
> the other one ASP-ASP)
> 
> ASP-ASP (DE):
> ==============
> 
>   AS1: DPC=1-1-1              AS2: DPC=2-2-2 SIO=3
> 
>   +---------+               +---------+
>   |         |               |         |
>   |         |               |         |
>   |         |               |         |
>   | IPSP1   |               | IPSP2   |
>   |         +---------------+         |
>   |         |               |         |
>   |         +--------+      |         |
>   +---------+        |      +---------+
>                      |
>                      |
>                      |        AS3: DPC=2-2-2 SIO=5
>                      |      +---------+
>                      |      |         |
>                      |      |         |
>                      |      |         |
>                      |      | IPSP3   |
>                      +------+         |
>                             |         |
>                             |         |
>                             +---------+
> 
> Here symmetry is not needed for AS traffic ranges.
> 

AS traffic range = RK.

> RKs at IPSP1:
>    RK1: DPC=1-1-1  (local)
>    RK2: DPC=2-2-2 SIO=3 (remote)
>    RK3: DPC=2-2-2 SIO=5 (remote)
> 
> RKs at IPSP2:
>    RK4: DPC=2-2-2 SIO=3 (local)
>    RK5: DPC=1-1-1 (remote)
> 
> RKs at IPSP3:
>    RK6: DPC=2-2-2 SIO=5 (local)
>    RK7: DPC=1-1-1 (remote)
> 
> 
> Here, RK defines, which traffic range ASP can accept, hence ASP-ASP.
> 
RK as defined today defines what traffic an AS accepts. An AS that talks to another AS is implemented by means of IPSPs. There are not ASPs here, just IPSPs. An IPSP will accept the traffic that the AS' RK specifies
IPSP3 will accept all the traffic specified by RK3 coming from the IPSP1.

> 
> AS-AS (SE):
> ============
> 
>  AS1: DPC=1-1-1 SIO=3
>  AS2: DPC=1-1-1 SIO=5           AS3: DPC=2-2-2 SIO=3
> 
>  +---------+                    +---------+
>  |         |                    |         |
>  |         |                    |         |
>  |         |                    |         |
>  |         +--------------------+         |
>  | IPSP1   |                    |  IPSP2  |
>  |         +-----------+        |         |
>  |         |           |        |         |
>  +---------+           |        +---------+
>                        |
>                        |
>                        |
>                        |        AS4: DPC=2-2-2 SIO=5
>                        |
>                        |        +---------+
>                        |        |         |
>                        |        |         |
>                        |        |         |
>                        |        |         |
>                        +--------+ IPSP3   |
>                                 |         |
>                                 |         |
>                                 +---------+
> 
> Here symmetry is needed, because it is AS-AS communication.
> 
> RKs at IPSP1:
>        RK1: DPC=1-1-1 OPC=2-2-2 SIO=3
>        RK2: DPC=1-1-1 OPC=2-2-2 SIO=5
> 
> RKs at IPSP2:
>        RK3: DPC=2-2-2 OPC=1-1-1 SIO=3 (or maybe just 
> DPC=2-2-2 OPC=1-1-1 for
> this configuration)
> 
> RKs at IPSP3:
>        RK4: DPC=2-2-2 OPC=1-1-1 SIO=5 (or maybe just 
> DPC=2-2-2 OPC=1-1-1 for
> this configuration)
> 
> Here the RK really defines, which two AS is communicating, 
> hence AS-AS.
> 
> 

I agree on the explanation of symmetry/unsymmetry RKs.

But I don't understand what AS-AS communication has to do with symmetry. It is also AS-AS communication in DE and you don't need symmetry. 

Cheers // Javier.

> 
> 
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 31 May 2002 11:54:09 -0400

Javier,

For me, for the first case the peers are ASPs (or IPSPs) and for the second
case the peers are ASs.
For example for the case I refer ASP-ASP (or IPSP-IPSP) it is obvious that
the endpoints are not AS. How can AS1 and AS2 communciate peer to peer, if
they are not symmetric?
Now, what I understand is, you prefer model 1 (what I call ASP-ASP, or
IPSP-IPSP)?

   Tolga

> From: Javier Pastor-Balbas (ECE)
> [mailto:[email-masked]]
> Sent: Friday, May 31, 2002 11:20 AM
> To: 'Tolga Asveren'; [email-masked]
> RK as defined today defines what traffic an AS accepts. An AS
> that talks to another AS is implemented by means of IPSPs. There
> are not ASPs here, just IPSPs. An IPSP will accept the traffic
> that the AS' RK specifies
> But I don't understand what AS-AS communication has to do with
> symmetry. It is also AS-AS communication in DE and you don't need
> symmetry.
>
> Cheers // Javier.
>
> >
> >
> >
> >