Subject: RE: [Sigtran] (M3UA) Concern about lossy nature of M3UA connectio ns in certain configurations

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Fri, 31 May 2002 16:50:27 +0200

Jeffrey, 

Message loss can also happen in MTP3 when there is a link failure. So this is not a worse situation...  :-)

Cheers // Javier.

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Friday, May 31, 2002 4:49 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [Sigtran] (M3UA) Concern about lossy nature of M3UA
> connections in certain configurations
> Importance: High
> 
> 
> Jeffrey,
> 
> See draft-bidulock-sigtran-corid-00.txt for a discussion of same
> and a proposed solution.  This is the only proposed solution to
> avoid message loss in such a scenario.  Not even implementing full
> retrieval would help you completely.
> 
> --brian
> 
> [email-masked] wrote:         (Fri, 31 May 2002 09:31:06)
> > Hello All,
> > 
> > I am concerned about the lossy nature of M3UA connections 
> for the following
> > scenario:
> > 
> >      Very high bandwidth is required between two 
> M3UA-connected nodes.
> >      The scalable architecture of each side makes the node 
> appear as a set
> > of
> >      SCTP multi-homed nodes, called 'blades', and so a 
> single association
> >      cannot be used to connect the two nodes.  A single 
> association cannot
> >      connect more than two blades (multi-homing does not 
> cross blades).
> >      Multiple associations are used, perhaps one per blade. 
>  A single point
> >      of failure is an association failing (blade failing).
> > 
> > Messages will be lost, since full retrieval below the SCTP 
> layer is not
> > possible.
> > (Discussion of the challenges involved in SCTP retrieval is 
> beyond the
> > scope of
> > this posting). M3UA lacks the facility to enable full retrieval.
> > 
> > Is the answer simply that M3UA (even M3UA SG-SG) does not 
> support loss-less
> > connectivity between two nodes connected by multiple 
> associations, when an
> > association fails? Is the consensus that this message loss 
> is acceptable?
> > 
> > Just curious.
> > 
> > Regards,
> > 
> > Jeff
> > 
> > 
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 31 May 2002 10:07:57 -0500

Javier,

Javier Pastor-Balbas (ECE) wrote:               (Fri, 31 May 2002 16:50:27)
> is not a worse situation...  :-)

It is much worse in M3UA.  See draft-bidulock-sigtran-corid-00.txt for
an explanation of how much worse.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/