Subject: RE: [Sigtran] Problem with dynamic Registration In IPSP scenario

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Tue, 28 May 2002 14:50:20 +0200

Hi Reshma, 

> -----Original Message-----
> From: reshma [mailto:[email-masked]]
> Sent: Tuesday, May 28, 2002 1:50 PM
> To: Javier Pastor-Balbas (ECE); [email-masked]; [email-masked]
> Subject: Re: [Sigtran] Problem with dynamic Registration In IPSP
> scenario
> 
> 
> Hi Javier,
> 
> > When we were discussing about the Single Exchange some time 
> ago, Brian was
> in favour of having a unique RC for Single Exchange. This 
> unique Routing
> Context should be previously negociated between both peers 
> and use it as a
> representant of two RK. This is what is shown in the RFC: One RC that
> contains the information of the two RK. Nothing about registration was
> mentioned since the RC value should be negotiated before the 
> communication ,
> and therefore static configuration could be just OK.
> >
> > I would say that Dynamic Registration is not allowed in 
> Single Exchange
> based on the previous paragraph. If you want to have Dynamic 
> Registration,
> we can use the Double exchange where you just allow the other 
> peer to send
> messages to you as you do in the ASP-SGP case.
> 
> [Reshma]In such case can both of these interoperate..?
> 
> 
We have to make them to interop if possible. It make not sense having two methods to do things being not interoperable

> >
> > >From my point of view, your way of registering could be 
> the only way of
> allowing this dynamic registration. But I don't like it too 
> much since I
> think that each ASP/IPSP should be responsible of its own 
> registration. By
> using your approach is one side who registers two RK at once. 
> This is a
> different behavior of what is explain in the RFC. And 
> moreover the number of
> registrations should grow exponentially as the number of RK per IPSP
> increases.
> >
> > I would simply state that use Double Exchange whenever you 
> want to use the
> Dynamic Registration approach.
> 
> [Reshma] Is there any need for dynamic registration in case of IPSPs
> As brain said in one of the mails GTT tables are static 
> tables which is used
> by SCCP for conversion of  number to DPC /OPC .If there is no 
> practical use
> of this then why these complication of double ended and single ended
> registration?
> 

I also think registration is not needed. But if people want it, we should  include it as an option.

Cheers // Javier.

> 
> Thanks,
> Reshma
> >
> >
> > Cheers // Javier.
> >
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]]
> > > Sent: Tuesday, May 28, 2002 7:17 AM
> > > To: [email-masked]
> > > Subject: [Sigtran] Problem with dynamic Registration In 
> IPSP scenario
> > >
> > >
> > >
> > >
> > > Hi,
> > >
> > > 1)  Does Dynamic Registration in IPSP-IPSP communication
> > > require a single
> > >       exchange or a double exchange?
> > >
> > > 2)  In case of single exchange , I have a problem as stated below.
> > >       For example in case shown below , where both peer
> > > support single exchange
> > > , and
> > >       we dynamically register a Routing Key (DPC only from
> > > IPSP B to IPSP A).
> > >       After sending an ACTIVE from IPSP B to IPSP A , both
> > > ends can transfer
> > > traffic ,
> > >       Now IPSP B can accept traffic for PC X, but for what PC
> > > will IPSP A
> > > receive traffic.
> > >          ________                                 ________
> > >         |                   |                              |
> > >                  |
> > >         |   IPSP A  |---------------------- |   IPSP B  |
> > >         |________|                              |________ |
> > >
> > >                                   REG REQ (SINGLE exchange)
> > > RK = DPC only (value
> > > X )
> > >                              <---------------------
> > >                                   REG RSP
> > >                               ---------------------->
> > >                                   ACTIVE (Single exchange)
> > >                              <----------------------
> > >                                   Active ACK
> > >                               ----------------------->
> > >                                    DATA  for PC X ( Now both
> > > sides can send data
> > > )
> > >                               ----------------------->
> > >                                     DATA     (but for which
> > > PC will IPSP A
> > > receive data)
> > >                                 <-----------------------
> > >
> > > [but the same can be done in double exchange when both IPSP A
> > > & B exchange
> > > Routing Keys]
> > > How can the same be achieved in case of single exchange?
> > >
> > > 3) The scenario shown above can be achieved with single
> > > exchange if we use the
> > > Routing key
> > >      DPC+OPC , so does that mean that there some restriction
> > > on the type of
> > > Routing keys to be
> > >      used for Dynamic Registration in IPSP -IPSP scenario? Is
> > > Routing Key DPC
> > > only not valid in
> > >      this case ?
> > >
> > > Regards
> > > -Akhtar
> > >
> > >
> > >
> > > DISCLAIMER: This message is proprietary to Hughes Software Systems
> > > Limited (HSS) and is intended solely for the use of the individual
> > > to whom it is addressed. It may contain  privileged or 
> confidential
> > > information  and should not be circulated or used for any
> > > purpose other
> > > than for what it is intended. If you have received this
> > > message in error,
> > > please notify the originator immediately. If you are not 
> the intended
> > > recipient, you are notified that you are strictly prohibited
> > > from using,
> > > copying, altering, or disclosing the contents of this
> > > message. HSS accepts
> > > no responsibility for loss or damage arising from the use of
> > > the information
> > > transmitted by this email including damage from virus.
> > >
> > >
> > >
> > > _______________________________________________
> > > Sigtran mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/sigtran
> > >
> >
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "reshma" <[email-masked]>
Date: Tue, 28 May 2002 18:50:31 +0530

Hi Javier,

> We have to make them to interop if possible. It make not sense having two
methods to do things being not interoperable

[Reshma] But why there is a need for 2 types of RK Registration in IPSP ?
Just b'coz it was put in the draft initially are we following it..?
And also trying to make them interoperate?

> I also think registration is not needed. But if people want it, we should
include it as an option.

[Reshma] why do we need an option when we practically dont use it..?
Also i  did'nt see any objections in mailing list when Brian said dynamic
registration is not needed.
Looks like all have same opinion.

Thanks,
Reshma

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 28 May 2002 09:31:03 -0400

Hi Javier,

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Javier Pastor-Balbas (ECE)
> Sent: Tuesday, May 28, 2002 8:50 AM
> To: 'reshma'; Javier Pastor-Balbas (ECE); [email-masked];
> [email-masked]
> Subject: RE: [Sigtran] Problem with dynamic Registration In IPSP
> scenario
>
>
> Hi Reshma,
>
> We have to make them to interop if possible. It make not sense
> having two methods to do things being not interoperable
[TOLGA] Maybe on paper there is just one word difference to have "single" or
"double" ended approach, but in fact those are two totally different
methods. In my opinion they can't interoperate. "Double ended" is nothing
else 2 client/server relationships brought together, "single ended" seems
like a real peer-to-peer relationship on ASP level but whether it
practically makes sense or not is arguable.