Subject: [Sigtran] M3UA - HeartBeat Message

From: Arun Panda <[email-masked]>
Date: Thu, 9 May 2002 14:15:37 +0530

Hello,

I have a doubt regarding the Length and Format of the HeartBeat Data of the
HeartBeat(Section 3.5.5) Message.
The Draft doesn't say about the Length of the Field. 
It just says that the Data includes the "HEARTBEAT SEQUENCE NUMBER and/or
TIMESTAMP"
Are these two values encoded in 32bit fields or 16bit fields .
I'm facing the problem while encoding this message.
Which of the picture below depict the right format?

        HeartBeat Data Tag : 0x0009	               HeartBeat Data Length

        HeartBeat Sequence Number	               HeartBeat Timestamp

If this is the format then the length would be 8

             HeartBeat Data Tag : 0x0009	               HeartBeat
Data Length	
                                                 HeartBeat Sequence Number

                                                 HeartBeat Timestamp	

If this is the format then the Length would be 12

Please clarify

Arun

Things turn out the best for the people who make the best of the way things
turn out

Arun Panda
S/w Engg, Ind - Telesoft Pvt Ltd
104, Koramangala Indl Estate
V Block, Bangalore - 560095
Tel : 5521937 - 40 Ext : 419
mailto:[email-masked]

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 9 May 2002 04:18:49 -0500

Arun,

The contents of the heartbeat data is implementation dependent
and is opaque to the receiver of the heartbeat data and is
echoed back to the sender.  The parameter could be just about
any length.

--brian

Arun Panda wrote:                                            (Thu, 09 May 2002 14:15:37)
> Tel: 5521937 - 40 Ext : 419
> mailto:[email-masked]
> 
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/