Subject: RE: [Sigtran] RE: sg-sg communication

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Thu, 30 May 2002 18:29:36 +0200

Hi Tolga, 

An AS is basically what you call an SPC (Cosidering SPC grnularity) in IP. That SPC can talk to a SG and it can be implemented as a set of ASP for redundancy purposes being able of being configured following the n+k model defined in the RFC. But also that AS can talk with another AS and it can be implemented by one or more IPSPs (or ASP with the capability of talking to another peer ASP). 

An AS has sense and it can be composed of ASPs (when talking with SG), IPSPs (Talking with other ASes) or ASP/IPSPs (talking with both).

And the realisation of an AS is the M3UA peer of another AS or SG. For me, it is easier to understand it in the simple case: when there is only one ASP per AS and an SGP per SG. The ASP is the implementation of the AS. In this case you can see that SG (non distributed SG) is talking with an AS (a non distributed AS). I would conclude with the example:

 - AS is peer of an SG
 - SGP is peer of ASP

Cheers // Javier.

> -----Original Message-----
> From: Tolga Asveren [mailto:[email-masked]]
> Sent: Thursday, May 30, 2002 6:13 PM
> To: [email-masked]
> Subject: RE: [Sigtran] RE: sg-sg communication
> 
> 
> Javier,
> 
> Because in my opinion they are not peers. SG is consisting of 
> SGPs, but AS
> is not consisting of ASPs. AS does not correspond to 
> something physical and
> is a pure abstraction.
> 
>      Tolga
> 
> > -----Original Message-----
> > From: Javier Pastor-Balbas (ECE)
> > [mailto:[email-masked]]
> > Sent: Thursday, May 30, 2002 11:52 AM
> > To: 'Tolga Asveren'; [email-masked]
> > Subject: RE: [Sigtran] RE: sg-sg communication
> >
> >
> > Tolga,
> >
> > Why don't you see SG and AS as peers ?? Could you explain more?
> >
> > Cheers //Javier.
> >
> > > -----Original Message-----
> > > From: Tolga Asveren [mailto:[email-masked]]
> > > Sent: Thursday, May 30, 2002 6:00 PM
> > > To: [email-masked]
> > > Subject: RE: [Sigtran] RE: sg-sg communication
> > >
> > >
> > > Javier,
> > >
> > > Then you need to put both IPSP and ASP functionality in your
> > > node. Isn't
> > > this against your strategy of having one entity? I also
> > > strongly disagree to
> > > see AS and SGs as peers, in my opinion they aren't.
> > >
> > >    Tolga
> > >
> > > > -----Original Message-----
> > > > From: Javier Pastor-Balbas (ECE)
> > > > [mailto:[email-masked]]
> > > > Sent: Thursday, May 30, 2002 11:39 AM
> > > > To: 'Tolga Asveren'; [email-masked]
> > > > Subject: RE: [Sigtran] RE: sg-sg communication
> > > >
> > > >
> > > > Hi Tolga,
> > > >
> > > > My understanding is that you have an IP node, what we 
> call AS. An
> > > > AS can communicate to both: another AS or an SG. If the AS is
> > > > communicating to an SG you are using the AS-SG communication. If
> > > > the AS is talking to another AS you use the IPSP 
> communication.  :-D
> > > >
> > > > Cheers // Javier.
> > > >
> > > > > -----Original Message-----
> > > > > From: Tolga Asveren [mailto:[email-masked]]
> > > > > Sent: Thursday, May 30, 2002 5:43 PM
> > > > > To: [email-masked]
> > > > > Subject: RE: [Sigtran] RE: sg-sg communication
> > > > >
> > > > >
> > > > > Javier,
> > > > >
> > > > > For SGPF+ASPF case, we have different opinions because we
> > > > > have different
> > > > > understanding of what a protocol should define and what it
> > > > > shouldn't. But
> > > > > apart from this, if IPSP can't speak to SGPs as ASP, it won't
> > > > > be something
> > > > > very usefull for the reason Brian pointed out.
> > > > >
> > > > >    Tolga
> > > > >
> > > > > > -----Original Message-----
> > > > > > From: Javier Pastor-Balbas (ECE)
> > > > > > [mailto:[email-masked]]
> > > > > > Sent: Thursday, May 30, 2002 11:25 AM
> > > > > > To: 'Tolga Asveren'; [email-masked]
> > > > > > Subject: RE: [Sigtran] RE: sg-sg communication
> > > > > >
> > > > > >
> > > > > > Hi Tolga,
> > > > > >
> > > > > > See below,
> > > > > >
> > > > > > > -----Original Message-----
> > > > > > > From: Tolga Asveren [mailto:[email-masked]]
> > > > > > > Sent: Thursday, May 30, 2002 5:35 PM
> > > > > > > To: [email-masked]
> > > > > > > Subject: RE: [Sigtran] RE: sg-sg communication
> > > > > > >
> > > > > > >
> > > > > > > Hi Javier,
> > > > > > >
> > > > > > > > -----Original Message-----
> > > > > > > > From: Javier Pastor-Balbas (ECE)
> > > > > > > > [mailto:[email-masked]]
> > > > > > > > Sent: Thursday, May 30, 2002 11:16 AM
> > > > > > > > To: 'Tolga Asveren'; [email-masked]'
> > > > > > > > Subject: RE: [Sigtran] RE: sg-sg communication
> > > > > > > >
> > > > > > > >
> > > > > > > > Hi Tolga,
> > > > > > > >
> > > > > > > > Comments below...
> > > > > > > >
> > > > > > > > > -----Original Message-----
> > > > > > > > > From: Tolga Asveren [mailto:[email-masked]]
> > > > > > > > > Sent: Thursday, May 30, 2002 5:15 PM
> > > > > > > > > To: [email-masked]
> > > > > > > > > Subject: RE: [Sigtran] RE: sg-sg communication
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > Javier,
> > > > > > > > >
> > > > > > > > > > -----Original Message-----
> > > > > > > > > > From: Javier Pastor-Balbas (ECE)
> > > > > > > > > > [mailto:[email-masked]]
> > > > > > > > > > Sent: Thursday, May 30, 2002 10:53 AM
> > > > > > > > > > To: 'Tolga Asveren'; [email-masked]
> > > > > > > > > > Subject: RE: [Sigtran] RE: sg-sg communication
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > > Hi Tolga,
> > > > > > > > > >
> > > > > > > > > > A small comment on yours...
> > > > > > > > > >
> > > > > > > > > > > -----Original Message-----
> > > > > > > > > > > From: Tolga Asveren [mailto:[email-masked]]
> > > > > > > > > > > Sent: Thursday, May 30, 2002 4:56 PM
> > > > > > > > > > > To: [email-masked]
> > > > > > > > > > > Subject: [Sigtran] RE: sg-sg communication
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > > Reshma,
> > > > > > > > > > >
> > > > > > > > > > > > -----Original Message-----
> > > > > > > > > > > > From: reshma [mailto:[email-masked]]
> > > > > > > > > > > > Sent: Thursday, May 30, 2002 10:35 AM
> > > > > > > > > > > > To: Tolga Asveren
> > > > > > > > > > > > Cc: [email-masked]
> > > > > > > > > > > > Subject: sg-sg communication
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > > Hi  Tolga,
> > > > > > > > > > > >
> > > > > > > > > > > >     Thanks for your reply some more doubts :-(
> > > > > > > > > > > >
> > > > > > > > > > > > > >  [Reshma] Okay now its clear. But 
> how does SG1
> > > > > > > knows whether
> > > > > > > > > > > > the data is
> > > > > > > > > > > > > > from SG2 or from ASPs? Depending on which he
> > > > > > > might have to
> > > > > > > > > > > > act as relay
> > > > > > > > > > > > > > point or a normal SG?
> > > > > > > > > > > > > [TOLGA] With the same method, it can
> > > know, whether a
> > > > > > > > > message is
> > > > > > > > > > > > from ASP1
> > > > > > > > > > > > or
> > > > > > > > > > > > > ASP2, this is implemention dependent (but
> > > > > most probably
> > > > > > > > > > > based on the
> > > > > > > > > > > > source
> > > > > > > > > > > > > address of the SCTP message)
> > > > > > > > > > > >
> > > > > > > > > > > > [Reshma] As per M3UA draft , m3ua can act as an
> > > > > > > SGP,ASP,IPSP.
> > > > > > > > > > > > When it acts its an IPSP the peer is 
> always assumed
> > > > > > > to be IPSP.
> > > > > > > > > > > [TOLGA] No, IPSP will behaeve as ASP against SGPs.
> > > > > > > > > >
> > > > > > > > > > This is not true. IPSP has a specific behavior as
> > > > > Reshma says.
> > > > > > > > > > And if we consider SE even the State Machine
> > > changes...  :-)
> > > > > > > > > [TOLGA] I disagree with this. In my opinion, 
> IPSP needs to
> > > > > > > > > behaeve as ASP
> > > > > > > > > against SGPs.
> > > > > > > >
> > > > > > > > If you are handling received ASPUP or ASPAC, you
> > > are not acting
> > > > > > > > as an ASP. IPSP acts different to an ASP.
> > > > > > > [TOLGA] This is what it does against another IPSP 
> (and still
> > > > > > > there are so
> > > > > > > many issues to discuss there). Well, maybe it is better to
> > > > > > > put ASPF+SGPF in
> > > > > > > a box, so that ASPF can communicate with any SGP without
> > > > > problems ;-)
> > > > > >
> > > > > > If you read the mail I sent yesterday, you will get all the
> > > > > > problems this modelling arises...  ;-)
> > > > > >
> > > > > > > >
> > > > > > > > Cheers // Javier.
> > > > > > > >
> > > > > > > > > >
> > > > > > > > > > > > And when it is SG it knows the peer is ASP .And
> > > > > hence there
> > > > > > > > > > > was a set
> > > > > > > > > > > > of messages defined in the draft which they can
> > > > > receive and
> > > > > > > > > > > send for each
> > > > > > > > > > > > one.
> > > > > > > > > > > > But now we have SG-SG communication other
> > > than SG-ASP
> > > > > > > > > communication
> > > > > > > > > > > > The initial behavior that SG should have is
> > > > > > > different for SG-SG
> > > > > > > > > > > > communication and SG-ASP communication  ie SG
> > > > > expects a SSNM
> > > > > > > > > > > > followed by TAL
> > > > > > > > > > > > meessage in SG-SG communication whereas in case
> > > > > of SG-ASP
> > > > > > > > > > > has ASPUP and
> > > > > > > > > > > > ASPAC procedures.So it should be configured
> > > initially
> > > > > > > > > > > ..which all ASPs and
> > > > > > > > > > > > SGs will be connected and which peer is 
> an ASP/SG
> > > > > > > ?(and behave
> > > > > > > > > > > > differently?) OR SG should be 
> configured to either
> > > > > > > behave as STP
> > > > > > > > > > > > or as SEP?
> > > > > > > > > > > [TOLGA] This is configuration.
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > > > > Also once the TAL message is sent if
> > > any PC is not
> > > > > > > > > > > available then does
> > > > > > > > > > > > one
> > > > > > > > > > > > > > SG send DUNA to the other SG? How 
> it is handled?
> > > > > > > > > > > > > [TOLGA] After TAL, if one PC becomes 
> available,
> > > > > > > SG1 will send
> > > > > > > > > > > > DAVA to SG2.
> > > > > > > > > > > >
> > > > > > > > > > > > [Reshma] But the draft says "4.3 Traffic Allowed
> > > > > > > Message(TAL)
> > > > > > > > > > > >
> > > > > > > > > > > >    TAL is used to indicate to a peer the
> > > end of SSNM "
> > > > > > > > > > > >
> > > > > > > > > > > > Which is confusing
> > > > > > > > > > > [TOLGA] The draft says "TAL is used to indicate
> > > > > to a peer the
> > > > > > > > > > > end of SSNM ,
> > > > > > > > > > > which are sent
> > > > > > > > > > >    to declare list of not allowed/restricted
> > > point codes,
> > > > > > > > > after a SCTP
> > > > > > > > > > >    association is established. ". I have the
> > > > > impression, we
> > > > > > > > > > > will change how
> > > > > > > > > > > traffic is started and availability information
> > > > > is exchanged
> > > > > > > > > > > but still to be
> > > > > > > > > > > discussed.
> > > > > > > > > > > >
> > > > > > > > > > > > Thanks,
> > > > > > > > > > > > reshma
> > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > _______________________________________________
> > > > > > > > > > > > > > > Sigtran mailing list
> > > > > > > > > > > > > > > [email-masked]
> > > > > > > > > > > > > > > 
https://www1.ietf.org/mailman/listinfo/sigtran
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > > _______________________________________________
> > > > > > > > > > Sigtran mailing list
> > > > > > > > > > [email-masked]
> > > > > > > > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > > _______________________________________________
> > > > > > > > Sigtran mailing list
> > > > > > > > [email-masked]
> > > > > > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > > > > > >
> > > > > >
> > > > > >
> > > > > > _______________________________________________
> > > > > > Sigtran mailing list
> > > > > > [email-masked]
> > > > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > > > >
> > > >
> > > >
> > > > _______________________________________________
> > > > Sigtran mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > >
> >
> >
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> >

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 30 May 2002 13:21:08 -0400

Javier,

AS is not consisting of ASPs (or IPSPs), ASPs are just serving one or more
AS. It is for sure that AS does not correspond to something physical but is
just an abstraction. The relationship between AS/ASP and SG/SGP is not the
same. Anyway, this is not the main discussion. How IPSPs are going to
communicate with SGPs? That is the main question. Because both of those are
physically existing and are exchanging messages.

   Tolga

> Sent: Thursday, May 30, 2002 12:30 PM
> An AS is basically what you call an SPC (Cosidering SPC
> grnularity) in IP. That SPC can talk to a SG and it can be
> implemented as a set of ASP for redundancy purposes being able of
> being configured following the n+k model defined in the RFC. But
> also that AS can talk with another AS and it can be implemented
> by one or more IPSPs (or ASP with the capability of talking to
> another peer ASP).
>
> An AS has sense and it can be composed of ASPs (when talking with
> SG), IPSPs (Talking with other ASes) or ASP/IPSPs (talking with both).
>
> And the realisation of an AS is the M3UA peer of another AS or
> SG. For me, it is easier to understand it in the simple case:
> when there is only one ASP per AS and an SGP per SG. The ASP is
> the implementation of the AS. In this case you can see that SG
> (non distributed SG) is talking with an AS (a non distributed
> AS). I would conclude with the example:
>
>  - AS is peer of an SG
>  - SGP is peer of ASP
>
>
> Cheers // Javier.
>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 30 May 2002 12:27:23 -0500

Javier,

Javier Pastor-Balbas (ECE) wrote:                          (Thu, 30 May 2002 18:29:36)
> And the realisation of an AS is the M3UA peer of another AS or SG. For me, it is easier to understand it in the simple case: when there is only one ASP per AS and an SGP per SG. The ASP is the impl…

AS is a client of an SG
SGP is a server to an ASP

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/