Subject: Re: [Sigtran] (M2PA) Please standardize M2PA protocol timer identifiers

From: [email-masked]
Date: Fri, 10 May 2002 16:57:54 -0400

Hello Brian,

Having M2PA timers correspond to Q.703 is a good idea.

That would mean that the current M2PA timer, T2 Proving, ought to be T4, as
per Q.703....
Or am I missing something?

This would also suggest that M2PA should reserve timers T2, T5, and T7 in
addition to
the current requirements for T1, T3, and T6.

Perhaps implementation-dependent timers should start at T11...

Regards,

Jeff

"Brian F. G. Bidulock" <[email-masked]> on 05/10/2002 04:16:38 PM

Please respond to [email-masked]

To:   [email-masked]
cc:   [email-masked]
Subject:  Re: [Sigtran] (M2PA) Please standardize M2PA protocol timer
      identifiers

Jeffrey,

Timer identifiers should correspond to Q.703 where possible.

--brian

[email-masked] wrote:                    (Fri, 10 May 2002
15:13:22)
> Hello All,
>
> The M2PA v5 draft refers to four specific timer identifiers (T1, T2, T3,
> and T6) and assigns
> specific functional requirements on them. The draft also discusses at
least
> four more
> implementation-dependent timers, such as the 'status_interval' timer.
>
> I think it would be a good idea for the M2PA specification to reserve a
> block of timer
> identifiers (T1, T2,..., T10) for timers having required functionality
and
> assign a starting
> timer identifier (e.g. T11)  for implementation-dependent timers (such as
> Proving Rate).
>
> This would help reduce confusion as to the purpose of a given protocol
> timer between
> different M2PA implementations.
>
> Having said that,  I would like to see the described
> implementation-dependent timers identified in
> the draft as follows:
>      T4 - proving rate timer (interval between sending LSP messages
during
> PROVING)
>      T5 - ready rate timer (interval between sending LSR messages during
> READY-ALIGNED)
>      T7 - processor outage rate timer (interval between sending LSPO
> messages during INS)
>      T8 - busy rate timer (interval between sending LSB messages during
> INS)
>
> Regards,
>
> Jeff
>
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 10 May 2002 17:32:39 -0500

Jeffrey,

To avoid confusion with Q.704 timers, it might be advisable to
name M2PA timers that do correspond to a Q.703/704 timer with
"T1, etc," M2PA timers that do not correspond to a Q.703/704
timer with a name such as "T-ack," and implementation timers
with names such as "T-proving-rate".

Come to think of it, all the implementation timers in your
list describe a "rate" and not a timer at all.  An interval
timer is only one way of implementing a "rate".  Another
approach, such as for proving, would be to send P proving
messages to SCTP and wait an overall interval T-P for all
proving messages to be acknowledged received by SCTP.  It
would say that, given the implementation specifics of these
rates, that naming implementation-dependent timers is of
little use.

Then all that needs to be done is rename T2 Proving to T4 and
describe these implementation-dependent things as
implementation-depenent rates rather than timers.

If you look at the conformance test suite, you will see that
there is value in describing Q.703 timers T2, T3 and T7 as
they make the state machine more robust and more compatible
with Q.703.

--brian

[email-masked] wrote:                    (Fri, 10 May 2002 16:57:54)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/