Subject: AW: [Sigtran] informal meeting notes

From: "Eva Weilandt" <[email-masked]>
Date: Thu, 5 Dec 2002 15:59:05 -0000

Brian, Ranjith,

as I can remember from an internal discussion some 2 years ago, V5 and
GR-303 are not that similar, I'm not sure if combining these two drafts is
such a good idea.

But I need to have a look into the GR-303 draft and specs first. I have no
issue to discuss the combination of the drafts then.

Eva

Dr. Eva Weilandt
V5.2 Platform Architect / V5.2 Development
Nortel Networks Germany
88039 Friedrichshafen / Germany
Tel. +49-7545-96-7267    Fax +49-7545-96-8160
ESN 565-7267

-----Ursprüngliche Nachricht-----
Von: Ranjith Mukundan [mailto:[email-masked]]
Gesendet: Donnerstag, 5. Dezember 2002 15:41
An: [email-masked]
Cc: Ong, Lyndon; [email-masked]'
Betreff: Re: [Sigtran] informal meeting notes

Brian,

We missed that, as an oversight. If it is strongly felt that this should be
combined with v5ua, we could coordinate with the v5ua author and submit an
DLCua (or the kind).

Lyndon, pls suggest the way forward.

Thanks,
ranjith..

"Brian F. G. Bidulock" wrote:

> Ranjith,
>
> Why was not GR-303 included in V5UA?  (See attached.)
>
> Ranjith Mukundan wrote:
(Thu, 05 Dec 2002 19:16:12)
> >
> > We don't want to see a iua-extension pardigm shift wrt GR303UA - and
review
> > it in a totally different light from say V5UA or DUA - that's the only
> > reasoning I can see in your observation that  "the existing RFC to the
> > maximum extent possible" is not being used.
> >
>
> --
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
>
>   ------------------------------------------------------------------------
>
> Subject: Re: [Sigtran] Backhauling GR-303 signaling messages
> Date: Wed, 15 May 2002 08:11:03 -0400
> From: Ken Morneault <[email-masked]>
> To: Al Varney <[email-masked]>, [email-masked]
> References: <[email-masked]>
>      <[email-masked]>
>      <[email-masked]>
>
> Al,
>
> Thanks for your useful advice.  We'll definitely take it into
consideration
> when we finish the GR303 draft.
>
> Regards,
>
> Ken
>
> At 12:26 PM 5/14/2002 -0500, Al Varney wrote:
> >At 07:43 PM 5/14/02 +0530, Ranjith Mukundan wrote:
> >>Ken and myself were in the process working on GR303UA extension to IUA
for backhauling the
> >>EOC and TMC/CSC messages from the SG to AS - I'll chk with Ken as to
when this can be
> >>submitted and revert to you.
> >>
> >>As for the inband part there are Megaco packages (like the advanced
anlog lines package)
> >>for transporting these events and signals (for LS, GS, LRB equivalent) -
though I am not
> >>convinced that these would suffice (so dont be surprised if you see a
megaco-gr303 package)
> >>soon.
> >
> >Ranjith & Ken,
> >
> >   Would it be more useful to extend/modify V5UA for GR303UA, rather than
grafting it onto IUA?  While 303 message encoding is based on Q.931-style
ISDN, the signals, events, maintenance aspects and explicit control of
in-band connections might be a better fit with V5UA.
> >
> >   Also, unless you can find a switch that's actually implemented CSC
messaging, you might want to reduce the effort by just marking CSC "for
future study".  I believe CSC is considered incomplete even in the official
GR-303-CORE requirements.  Leaving out CSC would also reduce much of the
confusion introduced by mixing the TMC and CSC call models in a single IETF
draft and standard.
> >
> >Al Varney
> >
> >
> >
> >_______________________________________________
> >Sigtran mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/sigtran
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Ranjith Mukundan" <[email-masked]>
Date: Sat, 7 Dec 2002 14:55:23 +0530

we'll correct that and re-submit. thanks.

ranjith..

-----Original Message-----
From:	Brian F. G. Bidulock [mailto:[email-masked]]
Sent:	Thu 12/5/2002 8:33 PM
To:	Ken Morneault
Cc:	Ranjith Mukundan; Ong, Lyndon; [email-masked]'
Subject:	Re: [Sigtran] informal meeting notes
Ken,

It might be a good idea, particularly as the gr303 draft has rather
blatant errors in it:  It describes the GR303 message header as the
same as the IUA header, but shows it as:

      0                   1                   2                   3
      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |           Tag (0x1)           |             Length            |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |                     Interface Identifier                      |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |            DLCI               |              Spare            |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

                          Figure 3 IUA Message Header

which is obviously incorrect as the IUA message header is:

    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |           Tag (0x1)           |             Length            |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                 Interface Identifier (integer)                |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |           Tag (0x5)           |             Length=8          |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |            DLCI               |              Spare            |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

    Figure 4 IUA Message Header (Integer-based Interface Identifier)

V5UA draft does not make this error.

--brian

Ken Morneault wrote:                                    (Thu, 05 Dec 2002 09:32:40)
> 
> 
>  From my point of view, we forgot Al's advice as we worked on the GR303UA
> draft sporadically over many months in our spare time.  It is still good advice and I
> don't have a problem working with the V5UA authors to combine the
> two drafts.
> 
> Regards,
> 
> Ken
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Ranjith Mukundan" <[email-masked]>
Date: Sat, 7 Dec 2002 14:54:30 +0530

Eva,

Protocol wise, we agree that gr303 and v5 are two different things - I did point this out in an earlier mail in this thread. But the difference between the UAs, however significant, is still similar and have a common root as IUA extension. 

It is just that, there seems to be a preference to see a single IUA extension draft instead of independent ones for gr303, v5 & may be for dpnss too.

Given this, the work involved would mandate combining the two  (or three if dpnss is also to be combined) only from a document perspective - which, IMO should be ok; keep the common parts in one place and have three logical sections, one each for v5ua, gr303ua & dua.

As a case in point and as an example, off the top off my head I recollect seeing two indepedent MIME type descriptions of QSIG and ISUP objects for carriage in SIP in the same RFC (on SIPPING WG) - though QSIG is as far away from ISUP as V5 is from GR303, if not more. 

I see two ways forward from here:

1- continue to have three separate I-Ds for the IUA extensions and maintain the status quo.

2- combine the 3 I-Ds and re-submit one I-D.

either way, it is ok by me and the impact would be from the document perspective.

Cheers,
ranjith..

-----Original Message-----
From:	Eva Weilandt [mailto:[email-masked]]
Sent:	Thu 12/5/2002 9:29 PM
To:	Ranjith Mukundan; [email-masked]
Cc:	Ong, Lyndon; [email-masked]'
Subject:	AW: [Sigtran] informal meeting notes
Brian, Ranjith,

Eva

Dr. Eva Weilandt

-----Ursprüngliche Nachricht-----
Von: Ranjith Mukundan [mailto:[email-masked]]
Gesendet: Donnerstag, 5. Dezember 2002 15:41
An: [email-masked]
Cc: Ong, Lyndon; [email-masked]'
Betreff: Re: [Sigtran] informal meeting notes

Brian,

Thanks,
ranjith..

review
consideration
for backhauling the
when this can be
anlog lines package)
though I am not
megaco-gr303 package)