Subject: RE: [Sigtran] SUA 14, section 1.6.1

From: "Richard Adams" <[email-masked]>
Date: Wed, 11 Dec 2002 11:32:16 +0100

Brian,
in SUA 14 section 1.6.1 there is a table of N- primitives between SUA and the SCCP-user. So I think N-STATE and N-PCSTATE need adding to this.
Kind regards,
Dick.
P.S. Sorry I missed the wording about the RIL !

	-----Original Message----- 
	From: Brian F. G. Bidulock [mailto:[email-masked]] 
	Sent: Mon 09/12/2002 18:07 
	To: Richard Adams 
	Cc: [email-masked] 
	Subject: Re: [Sigtran] SUA 14, section 1.6.1

	Richard,
	
	What list?
	
	--brian
	
	Richard Adams wrote:                                                             (Mon, 09 Dec 2002 14:18:46)
	> Thanks Brian,
	> then N-STATE and N-PCSTATE need to be in the list !
	> Kind regards,
	> Dick.
	>
	>       -----Original Message-----
	>       From: Brian F. G. Bidulock [mailto:[email-masked]]
	>       Sent: Fri 06/12/2002 17:36
	>       To: Richard Adams
	>       Cc: [email-masked]
	>       Subject: Re: [Sigtran] SUA 14, section 1.6.1
	>      
	>      
	>
	>       Richard,
	>      
	>       No glitch.  You will find that TCAP (being an SCCP user) requires N-STATE and
	>       N-PCSTATE from SCCP.  In ANSI SCCP, N-STATE and N-PCSTATE are passed directly
	>       to the user.
	>      
	>       For Restricted importance level, use Congestion Level in SCON.  See
	>       description in SUA 3.10.24.  (But this is just a little off: for US networks,
	>       Congestion Level is set to MTP congestion level, for ITU networks, Congestion
	>       Level is set to RIL in SCON corresponding to N-PCSTATE (US network don't
	>       have RIL)).
	>      
	>       --brian
	>      
	>       Richard Adams wrote:                               (Fri, 06 Dec 2002 15:59:02)
	>       > Dear all,
	>       > The definition of the upper boundary between SUA and the SCCP users does not
	>       > contain N-COORD, N-STATE and N-PCSTATE. So are these users different to
	>       > those in the SS7 network, or is this just a glitch ? (Q.711 tables 15, 16,
	>       > 17).
	>       >
	>       > And if the SCCP user is just remoted from the SCCP in the SG, as in 1.3.1.1,
	>       > how does the restricted importance level (RIL) get reported from SCCP to
	>       > user ? The SCON message, which is where I think this RIL should optionally
	>       > be, doesn't have it as a parameter.  Kind regards,
	>       >
	>       > Dick Adams.
	>       > [email-masked]
	>       >
	>       >  
	>       > _______________________________________________
	>       > Sigtran mailing list
	>       > [email-masked]
	>       > https://www1.ietf.org/mailman/listinfo/sigtran
	>      
	>       --
	>       Brian F. G. Bidulock
	>       [email-masked]
	>       http://www.openss7.org/
	>      
	>

	--
	Brian F. G. Bidulock
	[email-masked]
	http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 11 Dec 2002 04:35:32 -0700

Richard,

They are listed in section 1.4.4.  Whether these are actually
delivered to the SCCP-Subsystem or SCCP-Management at the ASP is
rather dependent on the SCCP implementation.  As they are
categorized the same as Q.711, I don't see a problem with the
SUA specification.

It is clear from Q.771 that SCCP must pass these up to TCAP, so
they must be delivered to the ASP and are not handled entirely
within the SG, so, again, the SUA specification is correct.

Why did you feel that anything needs to be changed?

--brian

Richard Adams wrote:                      (Wed, 11 Dec 2002 11:32:16)
> Brian,
> in SUA 14 section 1.6.1 there is a table of N- primitives between SUA and
> the SCCP-user. So I think N-STATE and N-PCSTATE need adding to this.
> Kind regards,
> Dick.