Subject: [Sigtran] Re:[Sigtran]ASP load sharing..

From: "PSK Chakravarthi" <[email-masked]>
Date: Tue, 17 Dec 2002 17:17:30 +0530

Brian,

Please correct me, if I am wrong.

There should not be any problem for the traffic mode OVERRIDE.  This is
because, SGP can divert the traffic of failed ASP to stand-by ASP only when
SGP receives ASP-ACTIVE message from STAND-BY.  So in this case the ASP
which detected the failure of another ASP and want to take over the traffic
of that ASP can send ASP ACTIVE message, and the SGP should now know that
there is some thing wrong with current ACTIVE ASP and respond for
ASP-ACTIVE.  SGP may send NOTIFY message to the current ACTIVE ASP to
indicate that STAND-BY ASP became ACTIVE.

The problem comes for LOAD_SHARE.
Let us assume that ASP1 and ASP2 are in LOAD_SHARE for RK1 and ASP1 is
failed.
ASP2 has detected that ASP1 is down and sends ASP-Inactive message with IP
address of ASP1 and Port Number of ASP1 (two new parameters) to SGP.  SGP
should have IP Address and port number of each ASP to lay SCTP associations.
So SGP can now detect which ASP is down by analyzing IP address and port
number of ASP.  I feel this is better than sending ASP ID in
ASP-Inactive/ASP-DOWN message as there is no guarantee that ASP ID is unique
across all the ASP's supported by SGP. (ASP ID is not unique across multiple
ASs)

Thanks
Chak

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tolga Asveren <[email-masked]>
Date: Tue, 17 Dec 2002 08:37:24 -0800 (PST)

Chak,
--- PSK Chakravarthi <[email-masked]>
> not unique across multiple
[TOLGA] If one plans to use ASP-INACTIVE for that
purpose, ASPID is fine even with current definition
because ASP-INACTIVE message already has RC inside.
If one wants to use ASP-DOWN, it is better to make
ASPID globally unique.
> Chak

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 17 Dec 2002 12:49:43 -0700

PSK,

ASP Failure is also useful for active/standby, to indicate to the
active ASP when a standby fails and which standby.  Also, to indicate
to other standby ASPs whether the state change was as a result of a
failure or a switchover.

--brian

PSK Chakravarthi wrote:                                                                (Tue, 17 Dec 2002 17:17:30)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "PSK Chakravarthi" <[email-masked]>
Date: Wed, 18 Dec 2002 17:19:15 +0530

Tolga,

How do we make ASP ID globally unique?

regards
Chak

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 18 Dec 2002 04:47:12 -0700

Chak,

By sayin in the IG that the ASP Id must uniquely identify
and ASP to an SG, which it already must in many cases.

--brian

PSK Chakravarthi wrote:                                                                (Wed, 18 Dec 2002 17:19:15)

---

From: "PSK Chakravarthi" <[email-masked]>
Date: Wed, 18 Dec 2002 17:49:38 +0530

Brian,

As per RFC 3332 (3.5.1 Asp Up)
      The optional ASP Identifier parameter contains a unique value that
      is locally significant among the ASPs that support an AS.

How ASP1 knows that an ASP ID 1 is already used by another ASP2 when ASP1
and ASP2 are controlling different ASs?

thanks
Chak

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 18 Dec 2002 05:19:52 -0700

Chak,

By saying in the IG that the ASP Id must uniquely identify
and ASP to an SG.

--brian

PSK Chakravarthi wrote:                    (Wed, 18 Dec 2002 17:49:38)