Subject: RE: [Sigtran] Open Issue 3rd M3UA Plugtest: NTFY

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Wed, 11 Dec 2002 10:21:12 +0100

Hi Tolga, 

I don't consider that sending NTFY when "Alternate ASP Active" is said to be a MUST. This case does not imply an AS state change. And the only MUST for the NTFY section is for that case.

The sentence that you mention is within the first paragraph in section 3.4.4.5 what talks about the fact that NTFY MUST be sent when an AS state change happens. This may be due to ASPSM arrival or ASP failure. But it may happens that an ASP fails and the AS state does not change. This case does not force to send NTFY. The "must" was not capitalized to show that this sentence was not a new requirement, but it was inside the main one: AS state change.

Cheers // Javier.

> -----Original Message-----
> From: Tolga Asveren [mailto:[email-masked]]
> Sent: Tuesday, December 10, 2002 3:56 PM
> To: [email-masked]
> Subject: RE: [Sigtran] Open Issue 3rd M3UA Plugtest: NTFY
> 
> 
> Hi Javier,
> --- "Javier Pastor-Balbas (ECE)"
> <[email-masked]> wrote:
> > Hi Tolga et al., 
> > 
> > You are right. But I see the contradiction between
> > "MAY" and "required". When is sending that message
> > required? Is it required but optional (we use MAY)
> > at the same time? I'm afraid that "required" has
> > been historically kept from a previous version where
> > MAY was MUST... With the current wording, I'd
> > suggest to remove it.
> [TOLGA] I also would think MAY already indicates "if
> required", so removing is fine IMO.
> > 
> > If we state that NTFY is compulsory for the "AS
> > state changes" but optional for "other cases", we
> > should indicate it clearly in the NTFY section. It
> > may be easily included in the first sentence. I
> > think this could help for a better understanding.
> [TOLGA] There are also other cases, where sending NTFY
> is a MUST. For example for "Alternate ASP Active". I
> am not sure but I think also for "ASP Failure"(related
> with this I could find the following sentence in
> 4.3.4.5 
> "The Notify message must be sent whether the AS state
> change was a result of an ASP failure or reception of
> an ASP State management (ASPSM) / ASP Traffic
> Management (ASPTM) message." 
> The "must" in this sentence is not a "MUST" but I
> don't know, whether this is on intention. 
> So, it seems only "Insufficient ASP Resources Active"
> is a MAY, the rest is MUST.
> > 
> > Any comments on this?  
> > 
> > Are there any additional comments from the people
> > attending the Plugtest on this issue?
> > 
> > 
> > Cheers // Javier.
> > 
> > 
> > > -----Original Message-----
> > > From: Tolga Asveren
> > [mailto:[email-masked]]
> > > Sent: Monday, December 09, 2002 11:54 PM
> > > To: [email-masked]
> > > Subject: Re: [Sigtran] Open Issue 3rd M3UA
> > Plugtest: NTFY
> > > 
> > > 
> > > Hi Javier,
> > > --- "Javier Pastor-Balbas (ECE)"
> > > <[email-masked]> wrote:
> > > > Hi guys, 
> > > > 
> > > > During the last M3UA Plugtest, there was a doubt
> > > > whether NTFY is mandatory in all the cases or
> > not.
> > > > The RFC clearly indicates that it is in the NTFY
> > > > Procedures Section (4.3.4.5). But there are some
> > > > wordings in the ASP Inactive (4.3.4.4.)where it
> > is
> > > > said that: 
> > > [TOLGA] 4.3.4.5 says that sending NTFY is a MUST,
> > when
> > > AS state changes. NTFY("Insufficient ASP resources
> > > active in AS") does not indicate an AS state
> > change.
> > > So, I would think that there is no contradiction.
> > > > 
> > > >   "A Notify message ("Insufficient ASP resources
> > > > active in AS") MAY be sent to allinactive ASPs,
> > if
> > > > required"
> > > >                                                 
> >    
> > > >            ^^^
> > > > I propose to change the "MAY" into "MUST" to
> > align
> > > > it with the procedures described in 4.3.4.5
> > > > 
> > > > Also some examples have to be update to include
> > the
> > > > NTFY whenever it is missing: 5.1.3 and 5.2.1
> > > > 
> > > > 
> > > > Comments?
> > > > 
> > > > 
> > > > Cheers // Javier.
> > > > _______________________________________________
> > > > Sigtran mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > 
> > > 
> > > __________________________________________________
> > > Do you Yahoo!?
> > > Yahoo! Mail Plus - Powerful. Affordable. Sign up
> > now.
> > > http://mailplus.yahoo.com
> > > _______________________________________________
> > > Sigtran mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > 
> 
> 
> __________________________________________________
> Do you Yahoo!?
> Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
> http://mailplus.yahoo.com
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 11 Dec 2002 02:56:02 -0700

Javier,

There is no difference between "must" and "MUST".  Both have the
same force and effect.  At least that's what Scott tells us, and
since he wrote the RFC on it, he must/MUST be right.

Although these keywords are usually capitalized, not capitalizing
them does not lessen their effect.

Besides, I'm sure Tolga was referring to section 4.3.4.3 which says:

	" ... The SGP or IPSP then MUST send a Notify message
	 ("Alternate ASP_Active") to the previously active ASP in
	 the AS, and SHOULD stop traffic to/from that ASP. ... "

I think this is fairly clear that sending of "Alternate ASP Active"
is a MUST.

--brian

Javier Pastor-Balbas (ECE) wrote:                (Wed, 11 Dec 2002 10:21:12)
> Hi Tolga, 
> 
> I don't consider that sending NTFY when "Alternate ASP Active" is said to be
> a MUST. This case does not imply an AS state change. And the only MUST for
> the NTFY section is for that case.
> 
> The sentence that you mention is within the first paragraph in section
> 3.4.4.5 what talks about the fact that NTFY MUST be sent when an AS state
> change happens. This may be due to ASPSM arrival or ASP failure. But it may
> happens that an ASP fails and the AS state does not change. This case does
> not force to send NTFY. The "must" was not capitalized to show that this
> sentence was not a new requirement, but it was inside the main one: AS state
> change.
> 
> 
> Cheers // Javier.
> 
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/