Subject: [Sigtran] M3UA/SUA Tags

From: "Maurel, Celine" <[email-masked]>
Date: Fri, 6 Dec 2002 11:57:52 +0100

Hi,
 
Some tags referenced in SUA draft 14 as common parameters across the different adaptation layers are mentioned as M3UA specific parameters in RFC3332.
These parameters are in red in the following tables:
 
Tag	 M3UA Common Parameter Name	 SUA Common Parameter Name	
0x0000	 Reserved	 Reserved	
0x0001	 Not used in M3UA	 Not used in SUA 	
0x0002	 Not used in M3UA	 Not used in SUA 	
0x0003	 Not used in M3UA	 Not used in SUA 	
0x0004	 Info String	 Info String	
0x0005	 Not used in M3UA	 Not used in SUA 	
0x0006	 Routing Context	 Routing Context	
0x0007	 Diagnostic Information	 Diagnostic Info	
0x0008	 Not used in SUA 	Not used in SUA 	
0x0009	 Heartbeat Data	 Heartbeat Data	
0x000A	 Not used in SUA 	Not used in SUA 	
0x000B	 Traffic Mode Type    	Traffic Mode Type    	
0x000C 	Error Code	 Error Code	
0x000D	 Status	 Status	
0x000E 	Not used in M3UA	 Not used in SUA	
0x000F	 Not used in M3UA	 Not used in SUA	
0x0010 	Not used in M3UA	 Not used in SUA	
0x0011	 ASP Identifier	 ASP Identifier	
0x0012	 Affected Point Code  	Affected Point Code  	
0x0013	 Correlation ID 	Correlation ID 	
0x0014 	 	 Registration Result	
0x0015 	 	 Deregistration Result 	
0x0016 	 	 Registration Status	
0x0017 	 	 Deregistration Status  	
0x0018 	 	 Local Routing Key Identifier	

Tag	 M3UA protocol specific	
0x0200	 Network Appearance 	
0x0201	 Reserved 	
0x0202	 Reserved 	
0x0203	 Reserved 	
0x0204	 User/Cause 	
0x0205	 Congestion Indications 	
0x0206	 Concerned Destination   	
0x0207	 Routing Key 	
0x0208	 Registration Result 	
0x0209	 Deregistration Result 	
0x020A	 Local_Routing Key Identifier 	
0x020B	 Destination Point Code	
0x020C	 Service Indicators    	
0x020D	 Reserved 	
0x020E	 Originating Point Code List 	
0x020F	 Circuit Range 	
0x0210	 Protocol Data 	
0x0211	 Reserved	
0x0212	 Registration Status    	
0x0213	 Deregistration Status	
0x0214 to 0xffff	 Reserved by the IETF	

Could you please tell me if these parameters are SUA specific as they are mentioned in M3UA RFC3332.
 
Regards,

MAUREL Celine 
Atos Origin 
COMPAQ - HP Group- System Test - TPU Engineering
* +33 (0) 4 92 95 56 28

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 6 Dec 2002 16:03:18 -0700

Celine,

Red doesn't show up well on text-based mail programs and html attachments
are bad form on IETF mailing lists...

Nevertheless, I think you are referring to the following:

SUA
>    0x0018                            Local Routing Key Identifier

These were supposed to be common across the UAs and were coded by SUA in the
"common" numbering range.  But, as you say, you will find that M2UA and M3UA
both number these in their specific range and do not use the common tagging.

For RFC 3331, I can say that the WG agreed that the nature of the
registration/deregistration on M2UA was sufficiently different (uses a Link
Key and Local Link Key Identifier rather than a Routing Key and Local Routing
Key Identifier) that M2UA should use "specific" versions of these tags.

For RFC 3332, perhaps ask the M3UA "editors" why the numbering was done this
way.

It does not change the fact that SUA uses the common numbering for these
parameter tags.  New UAs (e.g. see TUA proposal) might choose to use the
common range.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 6 Dec 2002 16:07:09 -0700

Celine,

Just another point on tags:  You will find that parameters that are
formatted identically, and used identically in M3UA and SUA are still

>    0x0206           Concerned Destination

Quite frankly, its mess, and always has been.  (Well, actually it
has been worse, there used to be no common parameter range.)

--brian