Subject: RE: [Sigtran] M3UA/SUA Tags

From: [email-masked]
Date: Mon, 9 Dec 2002 11:22:40 +0200

Hi Celine,

Good catch, I have fixed it now.

thanks,
John

> -----Original Message-----
> From: ext Maurel, Celine [mailto:[email-masked]]
> Sent: 09 December, 2002 11:20
> To: [email-masked]; Loughney John (NRC/Helsinki)
> Cc: [email-masked]; Fremont, Anne; Giogli, Eric
> Subject: RE: [Sigtran] M3UA/SUA Tags
> 
> 
> Hi,
> 
> In SUA Registration Result message, the routing key 
> Identifier has not the right value (Tag = 0x0014). The 
> routing key identifier tag is 0x0018. 
> 
>    Registration Result                  0x0014 
>    Deregistration Result                0x0015 
>    Registration Status                  0x0016 
>    Deregistration Status                0x0017 
>    Local Routing Key Identifier         0x0018 
> 
> 
> 3.9.20 Registration Result 
>     
>       0                   1                   2                   3 
>       0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 
>      
> +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>      |          Tag = 0x0014         |             Length     
>        | 
>      
> +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>      |                     Routing Key Identifier             
>        | 
>      
> +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>      |          Tag = 0x0016         |             Length     
>        | 
>      
> +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>      |                       Registration Status              
>        | 
>      
> +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>      |          Tag = 0x0006         |             Length     
>        | 
>      
> +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>      |                         Routing Context                
>        | 
>      
> +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
> 
> Regards,
> Celine Maurel
> 
> MAUREL Celine
> Atos Origin 
> COMPAQ - HP Group- System Test - TPU Engineering
> * +33 (0) 4 92 95 56 28 
> 
> 
> 
> 
> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Sunday, December 08, 2002 10:00 PM
> To: [email-masked]
> Cc: Maurel, Celine; [email-masked]; Fremont, Anne; Giogli, Eric
> Subject: Re: [Sigtran] M3UA/SUA Tags
> 
> 
> John,
> 
> Unfortunately it was the editors of M2UA and M3UA (and the WG chair)
> that though there was no value in it last year (see threads issues
> for M2UA, M3UA and SUA last January).  Changing SUA only 
> would do nothing
> to exploit commonality now.  It is M2UA and M3UA that needed
> changing.
> 
> --brian
> 
> John Loughney wrote:                                          
>                         (Sun, 08 Dec 2002 14:09:18)
> > Hi Brian,
> > 
> > > Just another point on tags:  You will find that 
> parameters that are
> > > formatted identically, and used identically in M3UA and 
> SUA are still
> > > labelled as UA-specific as well, such as:
> > > 
> > > >    0x0200           Network Appearance
> > > >    0x0204           User/Cause
> > > >    0x0205           Congestion Indications
> > > >    0x0206           Concerned Destination
> > > 
> > > Quite frankly, its mess, and always has been.  (Well, actually it
> > > has been worse, there used to be no common parameter range.)
> > 
> > Since SUA is still not an RFC, is there anything in SUA that
> > can be done to help out?
> > 
> > John
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Maurel, Celine" <[email-masked]>
Date: Mon, 9 Dec 2002 10:19:34 +0100

Hi,

In SUA Registration Result message, the routing key Identifier has not the right value (Tag = 0x0014). The routing key identifier tag is 0x0018. 

    
      0                   1                   2                   3 
      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
     |          Tag = 0x0014         |             Length            | 
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
     |                     Routing Key Identifier                    | 
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
     |          Tag = 0x0016         |             Length            | 
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
     |                       Registration Status                     | 
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
     |          Tag = 0x0006         |             Length            | 
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
     |                         Routing Context                       | 
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 

Regards,
Celine Maurel

MAUREL Celine
Atos Origin 

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Sunday, December 08, 2002 10:00 PM
To: [email-masked]
Cc: Maurel, Celine; [email-masked]; Fremont, Anne; Giogli, Eric
Subject: Re: [Sigtran] M3UA/SUA Tags

John,

Unfortunately it was the editors of M2UA and M3UA (and the WG chair)
that though there was no value in it last year (see threads issues
for M2UA, M3UA and SUA last January).  Changing SUA only would do nothing
to exploit commonality now.  It is M2UA and M3UA that needed
changing.

--brian

John Loughney wrote:                                                                  (Sun, 08 Dec 2002 14:09:18)
> Hi Brian,
> 
> > Just another point on tags:  You will find that parameters that are
> > formatted identically, and used identically in M3UA and SUA are still