Subject: RE: [Sigtran] Open Issue 3rd M3UA Plugtest: NTFY

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Tue, 10 Dec 2002 09:04:54 +0100

Hi Tolga et al., 

You are right. But I see the contradiction between "MAY" and "required". When is sending that message required? Is it required but optional (we use MAY) at the same time? I'm afraid that "required" has been historically kept from a previous version where MAY was MUST... With the current wording, I'd suggest to remove it.

If we state that NTFY is compulsory for the "AS state changes" but optional for "other cases", we should indicate it clearly in the NTFY section. It may be easily included in the first sentence. I think this could help for a better understanding.

Any comments on this?  

Are there any additional comments from the people attending the Plugtest on this issue?

Cheers // Javier.

> -----Original Message-----
> From: Tolga Asveren [mailto:[email-masked]]
> Sent: Monday, December 09, 2002 11:54 PM
> To: [email-masked]
> Subject: Re: [Sigtran] Open Issue 3rd M3UA Plugtest: NTFY
> 
> 
> Hi Javier,
> --- "Javier Pastor-Balbas (ECE)"
> <[email-masked]> wrote:
> > Hi guys, 
> > 
> > During the last M3UA Plugtest, there was a doubt
> > whether NTFY is mandatory in all the cases or not.
> > The RFC clearly indicates that it is in the NTFY
> > Procedures Section (4.3.4.5). But there are some
> > wordings in the ASP Inactive (4.3.4.4.)where it is
> > said that: 
> [TOLGA] 4.3.4.5 says that sending NTFY is a MUST, when
> AS state changes. NTFY("Insufficient ASP resources
> active in AS") does not indicate an AS state change.
> So, I would think that there is no contradiction.
> > 
> >   "A Notify message ("Insufficient ASP resources
> > active in AS") MAY be sent to allinactive ASPs, if
> > required"
> >                                                     
> >            ^^^
> > I propose to change the "MAY" into "MUST" to align
> > it with the procedures described in 4.3.4.5
> > 
> > Also some examples have to be update to include the
> > NTFY whenever it is missing: 5.1.3 and 5.2.1
> > 
> > 
> > Comments?
> > 
> > 
> > Cheers // Javier.
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> 
> __________________________________________________
> Do you Yahoo!?
> Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
> http://mailplus.yahoo.com
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tolga Asveren <[email-masked]>
Date: Tue, 10 Dec 2002 06:55:33 -0800 (PST)

Hi Javier,
--- "Javier Pastor-Balbas (ECE)"
<[email-masked]> wrote:
> Hi Tolga et al., 
> 
> You are right. But I see the contradiction between
> "MAY" and "required". When is sending that message
> required? Is it required but optional (we use MAY)
> at the same time? I'm afraid that "required" has
> been historically kept from a previous version where
> MAY was MUST... With the current wording, I'd
> suggest to remove it.
[TOLGA] I also would think MAY already indicates "if
required", so removing is fine IMO.
> 
> If we state that NTFY is compulsory for the "AS
> state changes" but optional for "other cases", we
> should indicate it clearly in the NTFY section. It
> may be easily included in the first sentence. I
> think this could help for a better understanding.
[TOLGA] There are also other cases, where sending NTFY
is a MUST. For example for "Alternate ASP Active". I
am not sure but I think also for "ASP Failure"(related
with this I could find the following sentence in
4.3.4.5 
"The Notify message must be sent whether the AS state
change was a result of an ASP failure or reception of
an ASP State management (ASPSM) / ASP Traffic
Management (ASPTM) message." 
The "must" in this sentence is not a "MUST" but I
don't know, whether this is on intention. 
So, it seems only "Insufficient ASP Resources Active"
is a MAY, the rest is MUST.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 10 Dec 2002 10:26:15 -0700

Javier,

Read the whole paragraph:

	"In the case of a Loadshare mode AS, the SGP moves the ASP to the
	 ASP-INACTIVE state and the AS traffic is reallocated across the
	 remaining ASPs in the state ASP-ACTIVE, as per the loadsharing
	 algorithm currently used within the AS.  A Notify message
	 ("Insufficient ASP resources active in AS") MAY be sent to all
	 inactive ASPs, if required. ..."

"If required" refers to when the number of ASP-ACTIVE ASP falls below
the minimum number of active ASPs for the AS, as there is also the
possibility that when an ASP goes ASP-INACTIVE, the minimum number is
not reached.

I would think that this is rather obvious, and IMO no additional
explanation is required.

--brian

Javier Pastor-Balbas (ECE) wrote:                  (Tue, 10 Dec 2002 09:04:54)
> Hi Tolga et al., 
> 
> You are right. But I see the contradiction between "MAY" and "required".
> When is sending that message required? Is it required but optional (we use
> MAY) at the same time? I'm afraid that "required" has been historically kept
> from a previous version where MAY was MUST... With the current wording, I'd
> suggest to remove it.
> 
> If we state that NTFY is compulsory for the "AS state changes" but optional
> for "other cases", we should indicate it clearly in the NTFY section. It may
> be easily included in the first sentence. I think this could help for a
> better understanding.
> 
> Any comments on this?  
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/