Subject: RE: [Sigtran] M3UA :regarding NA

From: "May, Howard" <[email-masked]>
Date: Tue, 10 Dec 2002 03:54:14 -0800

Hi,

This thread has discussed ASs registering in more than one NA.  My
understanding is that this is not strictly in accordance with the
specification.  I believe the gateway application should manage a separate
and distinct AS for each Network Appearance it has.  The Gateway Application
may then interwork between the networks as appropriate.  M3UA and MTP3 have
the same understanding of Point Code Address Spaces, and if multiple NAs are
used the Address Spaces cannot be allowed to overlap. It is the MTP3/M3UA
Users job to provide this interworking.

It may also be useful to reiterate that a NA does not just identify a
particular MTP Network but an 'Appearance' into a Network. An Appearance may
be a Local Point Code (The SG may present a number of point codes to the
same MTP network) or it may be Associations to other SGs or ASs that are in
the networks Address Space without any accessibility via MTP.

I don't believe this is anything new for you guys but still felt it useful
to say it.

Howard.

> 
> In addition to Brian's comments, I wouldn't think that
> a "Gateway AS" is a very good idea. For example how
> can be user part unavailability in network1 informed
> to network2? Sorry to repeat this again and again but
> also here IMO the correct solution is to have M3PA
> like behavior.
> 
>     Tolga
> --- "Brian F. G. Bidulock" <[email-masked]>
> wrote:
> > Samuel,
> > 
> > What network is PC 2-2-2 in?  What network is PC
> > 3-3-3 in?  To act
> > as a gateway STP, the GATEWAY STP requires a point
> > code in Network 1
> > and a point code in Network 2.  The same is true for
> > the Gateway AS.
> > 
> > --brian
> > 
> > On Mon, 09 Dec 2002, Samuel Dur D. Jeyaseelan wrote:
> > 
> > > > If you want a "gateway" AS, that moves messages
> > from one network to
> > > > another, it should register separately in both
> > networks.  To do so,
> > > > however, it will require (just as an SS7 gateway
> > node does) point codes
> > > > in each network.
> > > 
> > > [samuel]You mean to say Gateway AS - fig below
> > > 
> > > ----------------+                                 
> >  +--------------
> > >   NET 1         |             GATEWAY 'AS'        
> >  | NET 2
> > >                 |             +-------+           
> >  |      
> > >        +-----+  |  M3UA       |       | M3UA      
> >  |  +-----+
> > >  SS7   |STP/ |--|-------------|      
> > |-------------|--|SG / |   SS7
> > >  ------|  /  |  |             |       |           
> >  |  |  /  |------
> > >        | / SG|--|--+          +-------+         
> > +--|--| /STP|
> > >        +-----+  |   \         PC 2-2-2          / 
> >  |  +-----+
> > >       PC 1-1-1  |    \            |            /  
> >  |  PC 1-1-1
> > > ----------------+     \           |           /   
> >  +---------------
> > >                        \          |          /
> > >                         \         |M3UA     /
> > >                      SS7 \        |        / SS7
> > >                           \       |       /
> > >                            \      |      /
> > >                             \     |     /
> > >                              \ GATEWAY /
> > >                               \  STP  /
> > >                                +-----+
> > >                                |SG/  |
> > >                                | /STP|
> > >                                +-----+
> > >                                PC 3-3-3
> > >                                
> > >                                
> > >  
> > > GATEWAY STP can not route any message to PC 1-1-1
> > with the help of
> > > point code alone, It needs to distinguish the
> > network context, So it
> > > it refers NA (in his internal database) before
> > routing the message.
> > > 
> > > right ?
> > > 
> > > If it is correct then can you please tell me how
> > REG REQ 
> > > would have taken place between NET 1 to AS, NET 2
> > to AS and
> > > GATEWAY STP to AS?
> > > 
> > > i think the following way:
> > > 
> > > 1. From AS NET 1
> > > REG REQ(DPC=1-1-1,NA=1)
> > > 
> > > 2. From AS to NET 2
> > > REG REQ(DPC=1-1-1,NA=2)
> > > 
> > > 3. FROM AS to GATEWAY STP
> > > REG REQ(OPC=3-3-3,DPC=1-1-1,NA1)
> > > REG REQ(OPC=3-3-3,DPC=1-1-1,NA2)
> > > 
> > > Please correct me if am wrong ?
> > > 
> > > -Samuel
> > 
> > -- 
> > Brian F. G. Bidulock    ¦ The reasonable man adapts
> > himself to the ¦
> > [email-masked]    ¦ world; the unreasonable
> > one persists in  ¦
> > http://www.openss7.org/ ¦ trying  to adapt the 
> > world  to himself. ¦
> >                         ¦ Therefore  all  progress 
> > depends on the ¦
> >                         ¦ unreasonable man. --
> > George Bernard Shaw ¦
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> 
> __________________________________________________
> Do you Yahoo!?
> Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
> http://mailplus.yahoo.com
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tolga Asveren <[email-masked]>
Date: Tue, 10 Dec 2002 06:13:36 -0800 (PST)

Hi Howard,

Even with separate layer3 entites for each network and
with interworking functionality, ASP/SGP model is not
suitable for relaying, because it is similar to
MTP3/MTP user part interface. For example there is no
DUPU from ASP to SGP allowed (which is totally correct
IMO). Also for the case where there is one point code
space but for example different operators, I wouldn't
think there should be a need for an interworking
functionality on top of M3UA (of course if one has
relaying capability there)

BTW, I have to say that I disagree with your
interpretation of NA. It sounds to me like the
definition in draft6, where RC was not introduced to
DATA/SSNM. I would think, NA on SG maps to a network.

   Tolga 
--- "May, Howard" <[email-masked]> wrote:
> > > >        +-----+  |   \         PC 2-2-2        
>  / 
> > > >       PC 1-1-1  |    \            |           
> /  
> > > > ----------------+     \           |          
> /   
> > > >                      SS7 \        |        /
> SS7
> > >                         ¦ Therefore  all 
> progress