Subject: [Sigtran] Open Issue 3rd M3UA Plugtest: NTFY

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Mon, 9 Dec 2002 16:19:43 +0100

Hi guys, 

During the last M3UA Plugtest, there was a doubt whether NTFY is mandatory in all the cases or not. The RFC clearly indicates that it is in the NTFY Procedures Section (4.3.4.5). But there are some wordings in the ASP Inactive (4.3.4.4.)where it is said that: 

  "A Notify message ("Insufficient ASP resources active in AS") MAY be sent to allinactive ASPs, if required"
                                                                ^^^
I propose to change the "MAY" into "MUST" to align it with the procedures described in 4.3.4.5

Also some examples have to be update to include the NTFY whenever it is missing: 5.1.3 and 5.2.1

Comments?

Cheers // Javier.
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 9 Dec 2002 10:46:10 -0700

Javier,

This was addressed some time ago (see attached) and the text is
correct as it stands.

--brian

Javier Pastor-Balbas (ECE) wrote:                                                 (Mon, 09 Dec 2002 16:19:43)
> Hi guys, 
> 
> During the last M3UA Plugtest, there was a doubt whether NTFY is mandatory
> in all the cases or not. The RFC clearly indicates that it is in the NTFY
> Procedures Section (4.3.4.5). But there are some wordings in the ASP
> Inactive (4.3.4.4.)where it is said that: 
> 
>   "A Notify message ("Insufficient ASP resources active in AS") MAY be sent
>   to allinactive ASPs, if required" ^^^
>

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

Subject: Re: M3UA-10: Insufficient ASP Resources
From: Greg Sidebottom <[email-masked]>
To: "sigtran" <[email-masked]>
Date: Thu, 3 Jan 2002 11:56:01 -0500

Hi Brian,

See below ...

----- Original Message -----
From: "Brian F. G. Bidulock" <[email-masked]>
To: "sigtran" <[email-masked]>
Cc: "Greg Sidebottom" <[email-masked]>
Sent: Thursday, January 03, 2002 8:22 AM
Subject: M3UA-10: Insufficient ASP Resources

4.3.4.4 says: (in two places)

"  Notify message ("Insufficient ASP resources active in AS")
"  MAY be sent to all inactive ASPs, if required.

4.3.4.5 says:

"  ... or where a Notify ("Insufficient ASP resources active in
"  AS") message MUST be sent in the Loadshare or Broadcast mode,
"  ...

And that's all that said on the subject...

When "MUST" an Ins_ASPs be sent?

[Greg] Not sure why there is a "MUST' in 4.3.4.5.    The sentance does not
place a requirement on when the Notify is sent, only if it is sent the
receiver is not compelled to act.  should just be:

"  ... or where a Notify ("Insufficient ASP resources active in
"  AS") message is sent in the Loadshare or Broadcast mode,
"  ...

Cheers,

    Greg

--brian

--

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Tolga Asveren <[email-masked]>
Date: Mon, 9 Dec 2002 14:54:04 -0800 (PST)

Hi Javier,
--- "Javier Pastor-Balbas (ECE)"
<[email-masked]> wrote:
> Hi guys, 
> 
> During the last M3UA Plugtest, there was a doubt
> whether NTFY is mandatory in all the cases or not.
> The RFC clearly indicates that it is in the NTFY
> Procedures Section (4.3.4.5). But there are some
> wordings in the ASP Inactive (4.3.4.4.)where it is
> said that: 
[TOLGA] 4.3.4.5 says that sending NTFY is a MUST, when
AS state changes. NTFY("Insufficient ASP resources
active in AS") does not indicate an AS state change.
So, I would think that there is no contradiction.
> 
>   "A Notify message ("Insufficient ASP resources
> active in AS") MAY be sent to allinactive ASPs, if
> required"
>                                                     
>            ^^^
> I propose to change the "MAY" into "MUST" to align
> it with the procedures described in 4.3.4.5
> 
> Also some examples have to be update to include the
> NTFY whenever it is missing: 5.1.3 and 5.2.1
> 
> 
> Comments?
> 
> 
> Cheers // Javier.

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran