Subject: RE: [Sigtran] M3UA distributing ISUP group messages

From: "Wung, Joseph" <[email-masked]>
Date: Fri, 27 Dec 2002 16:30:23 -0500

Brian,

"don't split up your circuit groups across ASPs" would
solve the problem of distributing group messages for the
SG.  What if an ASP serves multiple ASes, which cover
a spectrum of contiguous CICs.  For example, an ASP
serves AS1(CIC=5000~5071), AS2(CIC=5072~5143).  Now
the ASP receives a message about CICs(5060~5083).
How would the ASP distribute the received message to
the ASes it serves?

Thanks,
Joe

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Friday, December 27, 2002 3:59 PM
To: Wung, Joseph
Cc: [email-masked]'
Subject: Re: [Sigtran] M3UA distributing ISUP group messages

Joseph,

Section A.2.1 says:

  "For example, where Application Servers are defined using ranges of
   ISUP CIC values, the Operator is implicitly splitting up control of
   the related circuit groups.  Some CIC value range assignments may
   interfere with ISUP circuit group management procedures."

The solution is: don't split up your circuit groups across ASPs: which
makes sense anyway.

--brian

Wung, Joseph wrote:                              (Fri, 27 Dec 2002 15:14:38)
> Each of the ISUP group related messages, i.e., CGB, CGU, GRS, GRA, etc.,
has
> a range field in addition to the CIC parameter that together specify a
range
> of circuits to operate on.  I would assume that the SGP that receives
those
> message would distribute them toward an ASP based on the CIC parameter in
> the messages without looking at the range field.  This may be ok if the
> entire range fall into the same AS as the CIC.  What if the range crosses
> the boundary of the AS?  This may seem like an implementation dependent
> issue, but it does impact how ISUP messages are distributed based on the
> routing key.  Any solution?
> 
> Joe
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 27 Dec 2002 15:07:53 -0700

Joseph,

That would be up to the ASP.  If you want to make things easier
for the ASP, don't split circuit groups across AS either.

--brian

Wung, Joseph wrote:                                                                  (Fri, 27 Dec 2002 16:30:23)