Subject: [Sigtran] Network appearance/routing context

From: "Mohan Parthasarathy" <[email-masked]>
Date: Wed, 18 Dec 2002 18:43:33 -0800

Hello,

A few questions/clarifications.

Routing context is useful for the ASP when there is a single SCTP association between SG and ASP and
you need a way to demux messages for various AS. Is that correct ? 
Assuming it is correct, can one not infer the "AS" from the addresses (source/destination addreses) in the
header itself ? Is the routing context just making the job easier for the ASP to know which AS it is ?

Similarly when there is more than one SG serving a single routing key, network appearance tells the ASP
which SG the packet came from ? Could someone explain how the network appearance value is used ?

I did not understand the following sentence :

	Routing Keys MUST NOT span multiple network appearances.

Routing key contains a network appearance field. What does it mean by "span" ? Also, there is no real
definition for "SS7 network context". It might be useful to define one.

thanks
mohan

error code has network appearance..

The Network Appearance field identifies the SS7 network context for the Routing Key. The Network Appearance value is of local significance only, coordinated between the SG and ASP. Therefore, in the case where the ASP is connected to more than one SG, the same SS7 Network context may be identified by different Network Appearance values depending upon to which SG the ASP is registering. In the Routing Key, the Network Appearance identifies the SS7 Point Code and Global Title Translation Type format used, and the SCCP and possibly the SCCP-User protocol (type, variant and version) used within the specific SS7 network.

Note 1: The Network Appearance parameter must be included in the Routing Key when the ASP is able to register in multiple SS7 Network contexts.
 If the SGP operates within a single SS7 network appearance, then all ASPs are informed.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 19 Dec 2002 02:37:42 -0700

Mohan,

Mohan Parthasarathy wrote:                 (Wed, 18 Dec 2002 18:43:33)
>    the ASP to know which AS it is ?

A Routing Context identifies a Routing Key and the Application Server
to which the Routing Key corresponds.  By identifying a Routing Key,
the Routing Context also identifies the traffic flow to and from an
Application Server.  The Routing Context is used both to identify the
Application Servier and the traffic flow corresponding to the Application
Server in ASPTM, DATA and SSNM messages.

>    appearance value is used ?

Network Appearance does not tell the ASP which SG the packet came from.
Network Appearance identifies the network context, or basically the
point code numbering space.

>    definition  for  "SS7  network  context". It might be useful to define

A dynamically registered Routing Key can only contain one Network
Appearance.  (That is, all point codes identified in the Routing Key
correspond to the same SS7 network, or point code numbering space.)
This statement covers the case where Routing Keys are statically
allocated.  They are not allowed to contain point codes from different
numbering spaces (different Network Appearances).

IMO: SS7 network context == SS7 point code numbering space

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran