Subject: RE: [Sigtran] SUA 14, section 1.6.1

From: "Richard Adams" <[email-masked]>
Date: Fri, 13 Dec 2002 12:30:44 +0100

Brian,
Q.711 (03/2001 version), section 6.3.2 give the primitives between SCCP management and SCCP users. So an ASP "homed" on an SG, even if the SCCP management is done at the SG, needs its users on top of SUA to get these primitives (N-COORD, N-STATE and N-PCSTATE). 
There are no primitives as such defined between SCCP and SCCP management. SCCP management is an internal part of SCCP. The management of SCCP, on the other hand, is actually OMAP, and this uses the horizontal layer management interface (LMI), see Figure 10/Q.1400 or Q.750.
The N- primitives are used on the SCCP-SAP (see Figure 3/Q.711).
Kind regards,
Dick Adams

-----Original Message----- 
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Thu 12/12/2002 10:20 
To: Richard Adams 
Cc: [email-masked] 
Subject: Re: [Sigtran] SUA 14, section 1.6.1

	Richard,
	
	Q.771 shows them between the SCCP and the SCCP-User.  Q.711 does not.
	Q.711 show these between SCCP and SCCP-Management.  SUA is consistent
	with Q.711, so there is no nit.
	
	--brian
	
	Richard Adams wrote:                            (Thu, 12 Dec 2002 10:13:51)
	>
	> I agree that Q.771 (and Q.711) show these between SCCP and the SCCP user.
	> SUA 14 section 1.6.1 doesn't, but it does show the other N- primitives. It's
	> a drop off, so perhaps just a nit!
	
	> Kind regards,
	> Dick Adams.
	> 
	>
	>       -----Original Message-----
	>       From: Brian F. G. Bidulock [mailto:[email-masked]]
	>       Sent: Wed 11/12/2002 12:35
	>       To: Richard Adams
	>       Cc: [email-masked]
	>       Subject: Re: [Sigtran] SUA 14, section 1.6.1
	>      
	>      
	>
	>       Richard,
	>      
	>       They are listed in section 1.4.4.  Whether these are actually
	>       delivered to the SCCP-Subsystem or SCCP-Management at the ASP is
	>       rather dependent on the SCCP implementation.  As they are
	>       categorized the same as Q.711, I don't see a problem with the
	>       SUA specification.
	>      
	>       It is clear from Q.771 that SCCP must pass these up to TCAP, so
	>       they must be delivered to the ASP and are not handled entirely
	>       within the SG, so, again, the SUA specification is correct.
	>      
	>       Why did you feel that anything needs to be changed?
	>      
	>       --brian
	>      
	>       Richard Adams wrote:                      (Wed, 11 Dec 2002 11:32:16)
	>       > Brian,
	>       > in SUA 14 section 1.6.1 there is a table of N- primitives between SUA and
	>       > the SCCP-user. So I think N-STATE and N-PCSTATE need adding to this.
	>       > Kind regards,
	>       > Dick.
	>       > P.S. Sorry I missed the wording about the RIL !
	>       >
	>      
	>       --
	>       Brian F. G. Bidulock
	>       [email-masked]
	>       http://www.openss7.org/
	>      
	>

	--
	Brian F. G. Bidulock
	[email-masked]
	http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 13 Dec 2002 04:56:38 -0700

Richard,

Yes SCCP-Management to SCCP-User, but SUA Section 1.4.4 shows these and
Section 1.4.5 describes them as providing management indications to the
SCCP-user at an ASP.  Even Q.714 groups these to the side, shows separate
state machines, and separate delivery to the SCCP-User.  So what?  The SUA
spec does not need changing.

--brian

Richard Adams wrote:                          (Fri, 13 Dec 2002 12:30:44)
> Brian,
> Q.711 (03/2001 version), section 6.3.2 give the primitives between SCCP
> management and SCCP users. So an ASP "homed" on an SG, even if the SCCP
> management is done at the SG, needs its users on top of SUA to get these
> primitives (N-COORD, N-STATE and N-PCSTATE).  There are no primitives as
> such defined between SCCP and SCCP management. SCCP management is an
> internal part of SCCP. The management of SCCP, on the other hand, is
> actually OMAP, and this uses the horizontal layer management interface
> (LMI), see Figure 10/Q.1400 or Q.750.