Subject: RE: FW: [Sigtran] ID-Tracker on SUA

From: "Richard Adams" <[email-masked]>
Date: Wed, 4 Dec 2002 08:51:42 +0100

Brian,
Just a comment on the SCON and Importance issues, I'll reply later to
the others!
Kind regards, 
Dick
-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: 03 December 2002 17:36
To: Richard Adams
Cc: [email-masked]
Subject: Re: FW: [Sigtran] ID-Tracker on SUA

Richard,

Aside from adding a brief definition for Network Appearance and changing
"included" to "included in the SCCP party address" in a couple places,
the changes you propose are largely unnecessary.  See comments below...

Richard Adams wrote:
(Tue, 03 Dec 2002 16:53:00)
> SUA suggestions for next draft:
 
> 
> 3.4.4 Network Congestion (SCON)
> If SCON is used to indicate ASP or SUA congestion in response to a 
> message from the SG, then an SSC might need to be sent from SG to the 
> message originator. This is a similar case to that in M3UA. So I
suggest 
> we need to define an extra parameter (and rather than using say 
> Destination Address, for consistency with M3UA I suggest Concerned
DPC).

There is no such case in SCCP as in ANSI T1.113.  That is, there is
no case in SCCP which is equivalent to MTP nodal TFC.

This change is unnecessary.
{RAA} SCCP defines an SSC message meaning "SCCP or subsystem congested"
in Q.713 and Q.714, 2001 edition (see Q.714 section 5.2.7). So if an
SCCP node has its SCCP or a subsystem congested, it can send such an SSC
to the message originator. If the SG has sufficient SCONs  containing
SSNs from ASPs (as in 1.5.6 of SUA 14), then it might need to send SSC
(or even TFC - in the SUA case!) back to a message originator. And if
M3UA thinks a node can be congested, then so does SUA, so I suspect an
SUA ASP could send a SCON without SSN to the SG. SSC is not broadcast,
just like TFC.
I'm not arguing the network design issue here, and whether or not the SG
can actually determine this, but the  ITU SCCP and draft 14 SUA imply
it!  {RAA}
> 
> Old text:
> 
>    The SCON message can be sent from the SG or relay node to all 
>    concerned ASPs to indicate that the congestion level in the SS7 
>    network to a specified destination has changed. 
> 
> 
>        0                   1                   2                   3 
>        0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       |         Tag = 0x0006          |            Length
| 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       /                       Routing Context
/ 
>       \
\ 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       |         Tag = 0x0012          |            Length
| 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       /                        Affected Point Code
/ 
>       \
\ 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       |         Tag = 0x8003          |            Length
| 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       |                              SSN
| 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       |         Tag = 0x0118          |             Length
| 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       |                       Congestion Level
| 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       |         Tag = 0x0112          |            Length
| 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       |                              SMI
| 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       |         Tag = 0x0004          |             Length
| 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       /                          Info String
/ 
>       \
\ 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>     
>    Parameters 
>      Routing Context               Optional 
>      Affected Point Code           Mandatory *1 
>      SSN                           Optional *1 
>      Congestion Level              Mandatory 
>      SMI                           Optional 
>      Info String                   Optional 
>  
>    Note 1:    When the SSN is included, the SCON message corresponds
to 
>               the SCCP N-STATE primitive. When SSN is not included,
the 
>               SCON message corresponds to the SCCP N-PCSTATE
primitive. 
>     
>    
> New text:
> 
>    The SCON message can be sent from the SG or relay node to all 
>    concerned ASPs to indicate that the congestion level in the SS7 
>    network to a specified destination has changed. 
>    The SCON message MAY also be sent from the SUA layer of an ASP to
an SUA 
>    peer indicating that the SUA layer or the ASP is congested (see
1.5.6).
> 
> 
>        0                   1                   2                   3 
>        0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       |         Tag = 0x0006          |            Length
| 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       /                       Routing Context
/ 
>       \
\ 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       |         Tag = 0x0012          |            Length
| 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       /                        Affected Point Code
/ 
>       \
\ 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       |         Tag = 0x8003          |            Length
| 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       |                              SSN
| 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       |         Tag = 0x0118          |             Length
| 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       |                       Congestion Level
| 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       |         Tag = 0x0112          |            Length
| 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       |                              SMI
| 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       |         Tag = 0x0119          |             Length = 8
|
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>       |    reserved   |                 Concerned DPC
|
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>       |         Tag = 0x0004          |             Length
| 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       /                          Info String
/ 
>       \
\ 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>     
>    Parameters 
>      Routing Context               Optional 
>      Affected Point Code           Mandatory *1 
>      SSN                           Optional *1 
>      Congestion Level              Mandatory 
>      SMI                           Optional
>      Concerned DPC                 Optional *2 
>      Info String                   Optional 
>  
>    Note 1:    When the SSN is included, the SCON message corresponds
to 
>               the SCCP N-STATE primitive. When the SSN is not
included, the 
>               SCON message corresponds to the SCCP N-PCSTATE
primitive.
>               When the SSN is included the Affected Point Code
parameter 
>               contains just one point code.
> 
>    Note 2:    The Concerned DPC is included when the SCON is sent from
>               ASP to SG, it is the point code in the Source Address
>               of the message triggering the SCON.
>     
> 
> 3.10 SUA-Specific parameters 
> 
> Need to add in Concerned DPC

An SCCP subsystem does not send the equivalent of nodal TFC.  This
change is unnecessary.
{RAA} This is SSC, and is sent from an SCCP endpoint or relay point. If
the SG is not acting as a GTT relay point, then it could need to send
SSC if it receives a SCON. It all depends on the implementation of the
network. {RAA} 
> 
> Old text: 
>     
>    These TLV parameters are specific to the SUA protocol. 
>  
>    Parameter Name                     Parameter ID 
>    ==============                     ============ 
>    SS7 Hop Counter                      0x0101 
>    Source Address                       0x0102 
>    Destination Address                  0x0103 
>    Source Reference Number              0x0104 
>    Destination Reference Number         0x0105 
>    SCCP Cause                           0x0106 
>    Sequence Number                      0x0107 
>    Receive Sequence Number              0x0108 
>    ASP Capabilities                     0x0109 
>    Credit                               0x010A 
>    Data                                 0x010B 
>    User/Cause                           0x010C 
>    Network Appearance                   0x010D 
>    Routing Key                          0x010E 
>    DRN Label                            0x010F 
>    TID Label                            0x0110 
>    Address Range                        0x0111 
>    SMI                                  0x0112 
>    Importance                           0x0113 
>    Message Priority                     0x0114 
>    Protocol Class                       0x0115 
>    Sequence Control                     0x0116 
>    Segmentation                         0x0117 
>    Congestion Level                     0x0118 
>     
>    Destination/Source Address Sub-Parameters 
>    =========================================== 
>    Global Title                         0x8001  
>    Point Code                           0x8002 
>    Subsystem Number                     0x8003 
>    IPv4 Address                         0x8004 
>    Hostname                             0x8005           
>    IPv6 Addresses                       0x8006 
> 
> New text:
>     
>    These TLV parameters are specific to the SUA protocol. 
>  
>    Parameter Name                     Parameter ID 
>    ==============                     ============ 
>    SS7 Hop Counter                      0x0101 
>    Source Address                       0x0102 
>    Destination Address                  0x0103 
>    Source Reference Number              0x0104 
>    Destination Reference Number         0x0105 
>    SCCP Cause                           0x0106 
>    Sequence Number                      0x0107 
>    Receive Sequence Number              0x0108 
>    ASP Capabilities                     0x0109 
>    Credit                               0x010A 
>    Data                                 0x010B 
>    User/Cause                           0x010C 
>    Network Appearance                   0x010D 
>    Routing Key                          0x010E 
>    DRN Label                            0x010F 
>    TID Label                            0x0110 
>    Address Range                        0x0111 
>    SMI                                  0x0112 
>    Importance                           0x0113 
>    Message Priority                     0x0114 
>    Protocol Class                       0x0115 
>    Sequence Control                     0x0116 
>    Segmentation                         0x0117 
>    Congestion Level                     0x0118
>    Concerned DPC                        0x0119 
>     
>    Destination/Source Address Sub-Parameters 
>    =========================================== 
>    Global Title                         0x8001  
>    Point Code                           0x8002 
>    Subsystem Number                     0x8003 
>    IPv4 Address                         0x8004 
>    Hostname                             0x8005           
>    IPv6 Addresses                       0x8006 
>         
{snip} 
> 3.10.19 Importance 
> We need to define Importance values for all messages, even those that
do 
> not have Importance as a parameter! My suggestion is:

No we don't.  The SG may, at its discretion, ignore importance
values provided by the ASP.  The purpose of the importance value
is to tell the SG the ASP's view of the importance of some messages
which might have a range of importance values at the SG.

This change is not necessary.
{RAA} Just because the SG might ignore them doesn't mean that the
Importance values shouldn't be defined! They tell (in the SCCP case) an
SCCP asked to send a message to a congested node/SCCP/subsystem whether
or not the message can be dropped. And this could be any message, not
just CO and CL ones. Hence I've suggested ASPSM, ASPTM, MGMT messages
should have the highest possible values in case the message transmission
function thinks it might drop them. For CO and CL messages without the
Importance parameter included, from ASP through the SG, they would  also
allow the SCCP to discard or not messages towards a congested SS7
SP/SCCP/subsystem. So I think they should be included !
{RAA}  

> 
> Original text:
>  
> 
>        0                   1                   2                   3 
>        0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       |         Tag = 0x0113          |             Length = 8
| 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       |                Reserved                       |   Importance
| 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       
>    Importance (3.19/Q.713) 
>     
>    Possible values of the Importance Parameter are between 0 and 7, 
>    where the value of 0 indicates the least important and 7 indicates 
>    the most important. 
>  
> 
> New text:
> 
>        0                   1                   2                   3 
>        0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       |         Tag = 0x0113          |             Length = 8
| 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       |                Reserved                       |   Importance
| 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
>       
>    Importance (3.19/Q.713) 
>     
>    Possible values of the Importance Parameter are between 0 and 7, 
>    where the value of 0 indicates the least important and 7 indicates 
>    the most important. 
> 
> The default Importance value for MGMT messages is 8 for NTFY and 7 for

> ERR.
> The default Importance value for SNM messages is 6 for DUNA, DAVA,
DUPU, 
> DAUD and SCON, it is 5 for DRST.
> The default Importance value for ASPSM messages is 8 for all except
BEAT 
> and BEAT ACK, which is 7.
> The default Importance value for ASPTM messages is 8.
> The default Importance values for CL and CO messages are the same as 
> those defined in [ITU Q714] Table 2/Q.714 for the equivalent messages.

> The maximum Importance values for CL and CO messages are the same as 
> those defined in [ITU Q714] Table 2/Q.714 for the equivalent messages.
>    
 
> 3.10.25 Concerned DPC

Again, no concerned point code is necessary because SCCP does not have
the equivalent of nodal TFC in MTP.
{RAA} but it does have SSC. And maybe it should be able to generate TFC
also ! {RAA}
> 
> Old text:
> None
> 
> New text:
> 
> 
>        0                   1                   2                   3
>        0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
>
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>       |         Tag = 0x0119          |             Length = 8
|
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>       |    reserved   |                 Concerned DPC
|
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>       
>       The Concerned DPC parameter is only used in a 
>       SCON message sent from an ASP to the SGP. It contains the point
>       code of the originator of the message that triggered the SCON
>       message taken from that message's Source Address. The 
>       Concerned DPC parameter contains one Concerned Destination Point
Code 
>       field, a three-octet parameter to allow for 14-, 16- and 24-bit
binary 
>       formatted SS7 Point Codes.  A Concerned DPC that is less than
24-bits 
>       is padded on the left to the 24-bit boundary.  Any resulting
SCCP/Subsystem 
>       Congested (SSC) message from the SG is sent to the signalling
point 
>       concerned using the Concerned DPC to populate the MTP label DPC
of the SSC message. 
>       The reserved field is set to 0 on transmission, and not examined
on reception.
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 4 Dec 2002 01:13:49 -0700

Richard,

Please see comments below...

Richard Adams wrote:                          (Wed, 04 Dec 2002 08:51:42)
<snip>
> can actually determine this, but the  ITU SCCP and draft 14 SUA imply

SUA messages correspond to SCCP/SCCP-User primitives (not SCCP messages).
Which primitive does an SCCP-User use to request congestion of SCCP?

<snip>
> SSC if it receives a SCON. It all depends on the implementation of the

SUA messages correspond to SCCP/SCCP-User primitives (not SCCP messages).
Which primitive does an SCCP-User use to request congestion of SCCP?

> SP/SCCP/subsystem. So I think they should be included !

Actually, the use of importance for flow control in SCCP is "for further
study".  We agreed not to load messages down with unnecessary parameters.

<snip>
> {RAA} but it does have SSC. And maybe it should be able to generate TFC

SUA messages correspond to SCCP/SCCP-User primitives (not SCCP messages).
Which primitive does an SCCP-User use to request congestion of SCCP?

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/