Subject: RE: [Sigtran] Open Issue 3rd M3UA Plugtest: NTFY

From: John McLaine <[email-masked]>
Date: Thu, 12 Dec 2002 03:30:29 -0800 (PST)

Hi Brain Tolga and Javier,
Let me assert to remain NOTIFY(ASP Failure) an
optional message.
IMHO, the role of SGP is to provide MTP-3 Signaling
Transportation b/w SS7 and IP, which is defined in
terms of RK/AS in RFC 3332. And an ASP Failure, due to
whatever practical or theoretical reason, can affect
the state of AS(es) (And hence the signaling
transportation), served by this ASP, only in the
following three ways:-
1. AS still has sufficient no. of ACTIVE ASPs to serve
it.
2. AS still has sufficient no. of ACTIVE ASPs to serve
it.
3. AS still has no ACTIVE ASP to serve it.
Only 2 and 3 are impacting the function (Signaling
Transportation) of an SGP. And to combat that, we
already have NOTIFY(Insufficient resources….) and
NOTIFY(AS STATE CHANGE) respectively. So SGP perfumes
its work even without NOTIFY(ASP Failure); still if
some respected fellows want to use it, then please use
it only as an optional message, as it is not necessary
for SGP function.

As for the meaning/interpretation of following text in
the RFC 3332:
“4.3.4.5 Notify Procedures
The Notify message must be sent whether the AS
   state change was a result of an ASP failure or
reception of an ASP
   State management (ASPSM) / ASP Traffic Management
(ASPTM) message.
”
To me, this is just an explanation that why
NOTIFY(STATE Changes) are MUST/mandatory, rather than
meaning that NOTIFY(ASP Failure) itself being
MUST/Mandatory.
Regards,
John.

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 16 Dec 2002 14:28:28 -0700

John,

Although an SG might not be ale to send "Insufficient
resources" if the value of "n" is not provisioned at
the SG, why would the SG ever not send "ASP Failure"
when an ASP fails?  The SG has all of the information
necessary to generate the notification and the
ASPs in the AS can use the information regardless of
traffic mode.

--brian

John McLaine wrote:                           (Thu, 12 Dec 2002 03:30:29)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/