Subject: [Sigtran] SUA relay function

From: "Richard Adams" <[email-masked]>
Date: Thu, 5 Dec 2002 16:16:41 +0100

Hello all,
could anyone tell me of any SS7 network containing nodes that can receive an SCCP message, routed on SSN, at an MTP signalling end point (containing SCCP), where there is a DPC in the message's called party address that is different from the DPC in the MTP label.
If so, is this message a (X)(L)UDT, and how did it get out from  SCCP routing control (SCRC) at the origin into the MTP-TRANSFER request ?   

The SUA draft 14 allows the addressing possibility in section 1.5.3 at a relay node, and it possibly gives me problems with SCCP management there.

Q.714 section 2.3.2.3 applies for the originating node. 

Kind regards,
Dick Adams.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 5 Dec 2002 09:42:36 -0700

Richard,

Richard Adams wrote:                               (Thu, 05 Dec 2002 16:16:41)
> Hello all,
> could anyone tell me of any SS7 network containing nodes that can receive an
> SCCP message, routed on SSN, at an MTP signalling end point (containing
> SCCP), where there is a DPC in the message's called party address that is
> different from the DPC in the MTP label.

All SCCP nodes following Q.714 should be capable of receiving such a message
and will deliver it to the local DPC (MTP label) + SSN subsystem.
>
> If so, is this message a (X)(L)UDT, and how did it get out from  SCCP
> routing control (SCRC) at the origin into the MTP-TRANSFER request ?   

PC1: GT + PC2 + SSN, Route on GT, MTP DPC = PC2

PC2: after GTT
     GT + PC2 + SSN, Route on SSN, MTP DPC = PC3

PC3: GT + PC2 + SSN, Route on SSN, MTP DPC = PC3
	MTP DPC == PC3, deliver to SSN

> 
> The SUA draft 14 allows the addressing possibility in section 1.5.3 at a
> relay node, and it possibly gives me problems with SCCP management there.

That's an SUA relay node's equivalent of an MTP transfer but using SUA.
In SUA's case, the DPC in the Destination Address in such a message is
the MTP DPC instead of the Called Party Address DPC.  The SUA node knows
that with route on PC + SSN that this DPC != local DPC and the relay
node transfers the message.

How else did you expect it to route normal TCAP response messages?
Or, to route forward to a SUA node to do GTT for that matter?

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/