Subject: [Sigtran] M3UA :regarding NA

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Fri, 6 Dec 2002 08:15:12 -0600 (CST)

Hi Valerie,Brian,John and others,
	
	Network Appearance is used in multiple networks scenario.
	It has been used (within the scope of M3UA) to find the specific
	network in the multiple networks, that's ok.

Can u pls clarify the doubts below,

	                              AS
	                         +----------+
                                 |          |
                                 | PC 3-3-3 |SCP
                                 |          |
                                 +----------+
	                             X
	                             X
	                             X M3UA(single association)
	                             X
-----------------------+             X            +-------------
NETWORK 1              |             X            | NETWORK 2 
	+----------+   |       +----------+       | +----------+
	|          |   | SS7   | STP/     | M3UA  | |          |
	| PC 1-1-1 |   |-------|   /      |XXXXXXX| | PC 2-2-2 |
	|          |   |       |  /   SG  |       | |          |
	+----------+   |       +----------+       | +----------+
	 MGC           |         PC 4-4-4  X      |  MGC
-----------------------+                    X     +------------
	                                     X
	                                      X  M3UA
	                                       X
	                                        X
	                                         X
	                                          X
	                                           X
                                                    X 
                                                     +----------
	                                             | NETWORK 3
	                                             | +----------+
                                                     | |          |
	                                             | | PC 2-2-2 |
	                                             | |          |
	                                             | +----------+
	                                             |    MGC
	                                             +-----------

     """Is this network diagram correct? (i assume correct ,if not please
explain!)"""

ASSUMPTION:
           one)   PC(1-1-1) gets a MSU1(may be an IAM) and should be
                  routed to PC 2-2-2 (NETWORK 2)

           two)   PC(1-1-1) gets a MSU2(another IAM) and should be
                  routed to PC 2-2-2 (NETWORK 3)
  
         three)   Connection b/w PC 4-4-4 (SG-STP) to NETWORK 2 and
                  NETWORK 3 can be either SS7 or M3UA.                                         

Lets start with REG REQ message

1. AS sends REG  rk1->[dpc=2-2-2,na=2,...]  to SG-STP and receives rc1
   
2. AS sends REG  rk2->[dpc=2-2-2,na=3,...]  to SG-STP and receives rc2
(assume ASP ACT ...everything is alright)

3. PC(1-1-1) sends MSU1 to (SG-STP).
      now How this MSU1 will be routed to PC(2-2-2) of NETWORK 2 ?
      Based on what, MSU1 will pick up rc1-rk1-na?

3. PC(1-1-1) sends MSU2 to (SG-STP).
      now How this MSU2 will be routed to PC(2-2-2) of NETWORK 3 ?
      Based on what, MSU2 will pick up rc2-rk2-na?
      
  NOTE: OPC and DPC will be same for both MSU1 and MSU2.

--Sam

  Alcatel USA, Inc.                  Internet: <userid>@ssd.usa.alcatel.com
  1000 Coit Road, Plano, Texas 75075
  ******* The opinions expressed are not those of Alcatel USA, Inc. *******

On Fri, 29 Nov 2002, Valerie Gastaud wrote:

> Samuel,
> 
> The Sigtran archives are located here:
> ftp://ftp.ietf.org/ietf-mail-archive/sigtran/
> Valerie
> -----Original Message-----
> From: Samuel Dur D. Jeyaseelan [mailto:[email-masked]]
> Sent: vendredi 29 novembre 2002 12:22
> To: Valerie Gastaud
> Subject: M3UA mails
> 
> 
> 
> Hi,
> 	Recently i subscribed as a member for M3UA stack. Can you please
> 	guide me , where i can see the all the M3UA mails right from the
> 	beginning?
> 
> 	If you have any idea about this please help me.
> 
> Thanks & Regards
> Samuel J.
> Axes Technologies,
> Bangalore,
> India.
> 
>  Alcatel USA, Inc.                  Internet: <userid>@ssd.usa.alcatel.com
>   1000 Coit Road, Plano, Texas 75075
>   ******* The opinions expressed are not those of Alcatel USA, Inc. *******
> 
> 
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tolga Asveren <[email-masked]>
Date: Fri, 6 Dec 2002 06:50:41 -0800 (PST)

Hi Sam,

I think your question is more related with MTP3
itself, i.e. the question would be also applicable for
the case, where all nodes use conventional SS7
signalling between them.
SG can decide based on link, from which the message
arrives, for which network it is sent for.(I
furthermore would think, it is better to think that SG
adn MGC are represented with different MTP3 entities
for each network)

     Tolga
--- "Samuel Dur D. Jeyaseelan"
<[email-masked]> wrote:
> NETWORK 1              |             X            |
> NETWORK 2 
> 	|          |   |       |  /   SG  |       | |      
>    |
> 	                                             |
> NETWORK 3
> 	                                             |
> 	                                             | | PC
> 2-2-2 |
>       |
> 	                                             |
> 	                                             |   
> MGC

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 6 Dec 2002 10:44:22 -0700

Samuel,

Network Appearance is really meant to denote (at least) point code
numbering spaces.  In SS7, messagse are only sent between two
point codes in the same network, so I am rather confused by your
examples.  PC 1-1-1 in Network 1 should not be sending any messages
to PC 2-2-2 in Network 2 for example.  The MGC would require a
point code (network appearance) in Network 2 to send messages to another
signalling point in Network 2.  This is no different for M3UA.
What newtwork is the AS (PC 3-3-3) in?

--brian

Samuel Dur D. Jeyaseelan wrote:                                                     (Fri, 06 Dec 2002 08:15:12)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Sat, 7 Dec 2002 02:35:29 -0600 (CST)

Brian,Tolga,

I understood that NA is used for 1st level of traffic discrimination to 
find the network and RC is used for 2nd level discrimination to find 
the particular point code in the network context(NA).
Right ?

I agree with you that PC 1-1-1 in Netowork 1 can not send(directly) 
message to PC 2-2-2 in  NETWORK 2.

Assume PC 3-3-3 belongs to NETWORK 2(figure it was missed).

My question here is ,Does AS(PC 3-3-3) know that PC 2-2-2 exists
in NETOWRK 2 and NETWORK 3 ? 
If yes, then HOW ?

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sat, 7 Dec 2002 11:52:40 -0700

Samuel,

Samuel Dur D. Jeyaseelan wrote:                                                     (Sat, 07 Dec 2002 02:35:29)
> the particular point code in the network context(NA).

Not really.  RC implies NA, so NA is never required when RC is given or
implied.

NA is needed in ASPTM, SNMM and DATA only when multiple AS at PC only
granularity (where the PCs belong to multiple networks) are multiplexed over
the same SCTP association, and in REG REQ when the ASP can register routing
keys in multiple networks.

RC is needed in ASPTM, SNMM and DATA when multiple AS at PC granularity
or better (e.g. SI) are multiplexed over the same SCTP association, and
is returned in successful REG RESP.

RC is not a refinement of NA in the manner that one would provide both
NA and RC in ASPTM, SNMM or DATA, which is what I believe you meant by
2nd level discrimination.

> in NETOWRK 2 and NETWORK 3 ? 

This kinda depends on what you mean by "know".  The AS would not normally
be informed of the accessibility of destinations outside the scope of the
network in which it appears.  (That is, the AS as shown could not expect
to receive SNMM for NA=3).

If you want a "gateway" AS, that moves messages from one network to
another, it should register separately in both networks.  To do so,
however, it will require (just as an SS7 gateway node does) point codes
in each network.

--brian

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 9 Dec 2002 10:33:22 -0700

Samuel,

What network is PC 2-2-2 in?  What network is PC 3-3-3 in?  To act
as a gateway STP, the GATEWAY STP requires a point code in Network 1
and a point code in Network 2.  The same is true for the Gateway AS.

--brian

On Mon, 09 Dec 2002, Samuel Dur D. Jeyaseelan wrote:

> [samuel]You mean to say Gateway AS - fig below
> 
> ----------------+                                   +--------------
>   NET 1         |             GATEWAY 'AS'          | NET 2
>                 |             +-------+             |      
>        +-----+  |  M3UA       |       | M3UA        |  +-----+
>  SS7   |STP/ |--|-------------|       |-------------|--|SG / |   SS7
>  ------|  /  |  |             |       |             |  |  /  |------
>        | / SG|--|--+          +-------+          +--|--| /STP|
>        +-----+  |   \         PC 2-2-2          /   |  +-----+
>       PC 1-1-1  |    \            |            /    |  PC 1-1-1
> ----------------+     \           |           /     +---------------
>                        \          |          /
>                         \         |M3UA     /
>                      SS7 \        |        / SS7
>                           \       |       /
>                            \      |      /
>                             \     |     /
>                              \ GATEWAY /
>                               \  STP  /
>                                +-----+
>                                |SG/  |
>                                | /STP|
>                                +-----+
>                                PC 3-3-3
>                                
>                                
>  
> GATEWAY STP can not route any message to PC 1-1-1 with the help of
> point code alone, It needs to distinguish the network context, So it
> it refers NA (in his internal database) before routing the message.
> 
> right ?
> 
> If it is correct then can you please tell me how REG REQ 
> would have taken place between NET 1 to AS, NET 2 to AS and
> GATEWAY STP to AS?
> 
> i think the following way:
> 
> 1. From AS NET 1
> REG REQ(DPC=1-1-1,NA=1)
> 
> 2. From AS to NET 2
> REG REQ(DPC=1-1-1,NA=2)
> 
> 3. FROM AS to GATEWAY STP
> REG REQ(OPC=3-3-3,DPC=1-1-1,NA1)
> REG REQ(OPC=3-3-3,DPC=1-1-1,NA2)
> 
> Please correct me if am wrong ?
> 
> -Samuel

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tolga Asveren <[email-masked]>
Date: Mon, 9 Dec 2002 14:46:53 -0800 (PST)

In addition to Brian's comments, I wouldn't think that
a "Gateway AS" is a very good idea. For example how
can be user part unavailability in network1 informed
to network2? Sorry to repeat this again and again but
also here IMO the correct solution is to have M3PA
like behavior.

    Tolga
--- "Brian F. G. Bidulock" <[email-masked]>
wrote:
> >                 |             +-------+

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Tue, 10 Dec 2002 03:52:30 -0600 (CST)

> and a point code in Network 2.  The same is true for the Gateway AS.
 [samuel] GATEWAY AS (PC 2-2-2) and GATEWAY STP (PC 3-3-3) appear in NET2.  
PC 4-4-4 and PC 6-6-6 are point codes of GATEWAY AS and GATEWAY STP
to the view of NET1(not shown in figure).

-Samuel

> > 1. From AS to NET 1

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 10 Dec 2002 10:17:52 -0700

Samuel,

Samuel Dur D. Jeyaseelan wrote:                                                     (Tue, 10 Dec 2002 03:52:30)
> to the view of NET1(not shown in figure).

Then the gateway AS registers NA=1,PC=4-4-4 and NA=2,PC=2-2-2 with
the SG.

--brian

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Wed, 11 Dec 2002 04:26:36 -0600 (CST)

Brian,

> Then the gateway AS registers NA=1,PC=4-4-4 and NA=2,PC=2-2-2 with

[samuel]
I dont think AS registers as you said. 

Following may be true

Suppose point codes(10-10-10,20-20-20,30-30-30) are part of NET2.

AS point code(4-4-4) is configured as GATEWAY AS at PC 1-1-1(NET1).

AS registers with PC 1-1-1(NET1) as 
   RK1(loc-rt-keyId=1,dpc=(10-10-10,20-20-20,30-30-30,1-1-1),NA=1) 
   and returns RC as RC1
   
   So at PC 1-1-1 
   
   DPC - ROUTING CONTEXT mapping table
   ===================================
   RC          DPC        NA
   --------------------------
   RC1         1-1-1       2
               10-10-10    2
               20-20-20    2
               30-30-30    2

   ROUTING CONTEXT - AS mapping table
   ==================================
   RC           AS
   ---------------
   RC1          AS1(4-4-4)

   Whenever GTT takesplace at PC 1-1-1(NET1) and resulted PC is
   any one(e.g 10-10-10)of them as per above table.
   then message will be routed to destination(GATEWAY AS)
   based on NA.
   
----------------+        +-----------------------------------------
  NET 1         |        |    GATEWAY 'AS'            NET 2 
                |        |    +-------+                
       +-----+  |  M3UA  |    |       | M3UA           +-----+
 SS7   |STP/ |--|--------|----|       |----------------|SG / |   SS7
 ------|  /  |  |        |    |       |                |  /  |------
       | / SG|--|--+     |    +-------+          +-----| /STP|
       +-----+  |   \    |    PC 2-2-2          /      +-----+
      PC 1-1-1  |    \   |        |            /       PC 1-1-1
----------------+     \  |        |           /                      
                       \ |        |          /
                        \|        |M3UA     /
                     SS7 \        |        / SS7
                         |\       |       /
                         | \      |      /
                         |  \     |     /
                         |   \ GATEWAY /
                         |    \  STP  /
                         |     +-----+
                         |     |SG/  |
                         |     | /STP|
                         |     +-----+
                         |     PC 3-3-3
                         |     
                         +-------------------------------------------

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 11 Dec 2002 04:26:58 -0700

Samuel,

Your missing the point.  Just as the Gateway STP requires a separate
point code in each network, so does the Gateway AS.  The Gateways AS
registers/activates once for NA=1,OPC=4-4-4,DPC=*(RK1,RC1,AS1) and
once for NA=2,OPC=2-2-2,DPC=*(RK2,RC2,AS2).  The MTP-User at the AS
is responsible for interworking messages on AS1,RC1 with messages on
AS2,RC2.

--brian

Samuel Dur D. Jeyaseelan wrote:                                                     (Wed, 11 Dec 2002 04:26:36)

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Wed, 11 Dec 2002 07:03:50 -0600 (CST)

Brian,

        means,M3UA stack at Gateway AS(say SCP) can not register NET2
        point codes with NET1?.

-Samuel

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 11 Dec 2002 06:16:29 -0700

Samuel,

Of course not.  The Routing Key in the REG REQ can only contain one Network
Appearance parameter.  This Network Appearance parameter is applied against
all of the point codes that appear in the Routing Key.  Therefore there is
not even a way to specify to the SG that one wants, for example,  to register
an originating point code from NA=1 against a destination point code from
NA=2.

You are restricted by the REG REQ format to registering an NA=1 opcs against
NA=1 dpcs, and NA=2 opcs against NA=2 dpcs.

--brian

Samuel Dur D. Jeyaseelan wrote:                     (Wed, 11 Dec 2002 07:03:50)

---

From: Tolga Asveren <[email-masked]>
Date: Wed, 11 Dec 2002 06:47:59 -0800 (PST)

Hi,

IMO, it also might be more appropriate to speak of a
"Gateway ASP", instead of a "Gateway AS".

    Tolga
wrote:
> Samuel Dur D. Jeyaseelan wrote:                     
>                                (Wed, 11 Dec 2002
> 04:26:36)
> > 
> > Brian,
> > > Samuel Dur D. Jeyaseelan wrote:                 
>                                    (Tue, 10 Dec 2002
> 03:52:30)
> > > > 
> > ----------------+       
> +-----------------------------------------
> >   NET 1         |        |    GATEWAY 'AS'        
>    NET 2 
> >                 |        |    +-------+           
>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 11 Dec 2002 07:51:46 -0700

Tolga,

How about "Gateway MGC"?

--brian

Tolga Asveren wrote:                      (Wed, 11 Dec 2002 06:47:59)

---

From: Tolga Asveren <[email-masked]>
Date: Wed, 11 Dec 2002 07:02:34 -0800 (PST)

Brian,
> How about "Gateway MGC"?
[TOLGA] Probably better. My point was that from M3UA
terminology point of view it is inappropriate to think
of Gateway AS and I felt this term maybe brought some
confusion to some people's mind.