Subject: Re: [Sigtran] SUA relay function

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 6 Dec 2002 11:22:01 -0700

Philippe,

I think your AS 1 and AS 2 have overlapping routing keys (non-unique
address mapping function).  How did you ever intend to reach AS1?

--brian

Bouckaert, Philippe wrote:                                                      (Fri, 06 Dec 2002 15:47:44)
> Richard, Brian,
> 
> the called party address, for a message coming from ss7, should normally not
> include a PC (Q.714, 2.2.2.1). But if it is present, it must be ignored by
> SCCP (Q.7142.2.1 "Even if an SPC is present in the "called party address"
> parameter, it shall not be used by SCRC.").  And ,as Brian mentioned, it
> should be delivered to the local DPC. 
> 
> But if we check the following configuration, there is a problem for message coming from ss7,
>        ------           --------------
>       | SG  |----------| AS 1         |
>       | PC=3|          |  PC=2, SSN=6 |
>        ------           --------------
>               \            --------
>                \----------|AS 2    |
>                           |  SSN=6 |
>                            --------
> 
> message with MTP3 DPC=3, SCCP Cld add=(rtg on SSN, PC=2, SSN=6).  According
> SCCP recommendation, this message will be sent to AS 2 (or discarded if AS 2
> is not defined). 
> 
> Does that mean that, in order to reach AS1, a message must be sent either by
> using GT, or by using PC =2 as MTP DPC? In this case, the SG should manage
> several PCs...
> 
> What do you think?
> Regards,
> Philippe
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Bouckaert, Philippe" <[email-masked]>
Date: Fri, 6 Dec 2002 15:47:44 +0100

Richard, Brian,

the called party address, for a message coming from ss7, should normally not include a PC (Q.714, 2.2.2.1). But if it is present, it must be ignored by SCCP (Q.7142.2.1 "Even if an SPC is present in the "called party address" parameter, it shall not be used by SCRC.").
And ,as Brian mentioned, it should be delivered to the local DPC. 

But if we check the following configuration, there is a problem for message coming from ss7,
	------		 --------------
	| SG 	|---------- | AS 1         |
 	| PC=3|		|  PC=2, SSN=6 |
	------		 --------------
		\            --------
		 \----------|AS 2    |
				|  SSN=6 |
				 --------

message with MTP3 DPC=3, SCCP Cld add=(rtg on SSN, PC=2, SSN=6). 
According SCCP recommendation, this message will be sent to AS 2 (or discarded if AS 2 is not defined). 

Does that mean that, in order to reach AS1, a message must be sent either by using GT, or by using PC =2 as MTP DPC? In this case, the SG should manage several PCs...

What do you think?
Regards,
Philippe

-----Original Message-----
From: Richard Adams [mailto:[email-masked]]
Sent: Friday, December 06, 2002 1:36 PM
To: [email-masked]
Cc: [email-masked]
Subject: RE: [Sigtran] SUA relay function

Sorry Brian,
I omitted the essential extra part to the first question, which was "and
can this message be routed to the DPC in the CdPA ?"
But your answer is valuable, pls see below!
Kind regards,
Dick.  

Brian wrote:

Richard Adams wrote:                               (Thu, 05 Dec 2002
16:16:41)
> Hello all,
> could anyone tell me of any SS7 network containing nodes that can receive an
> SCCP message, routed on SSN, at an MTP signalling end point(containing
> SCCP), where there is a DPC in the message's called party address that is
> different from the DPC in the MTP label.
{RAA} Should have had "and is this CdPA DPC route-able to for this
message?" 
{RAA}
All SCCP nodes following Q.714 should be capable of receiving such a
message and will deliver it to the local DPC (MTP label) + SSN subsystem.
{RAA} OOPs, yes {RAA}
>
> If so, is this message a (X)(L)UDT, and how did it get out from  SCCP
> routing control (SCRC) at the origin into the MTP-TRANSFER request ?

PC1: GT + PC2 + SSN, Route on GT, MTP DPC = PC2

PC2: after GTT
     GT + PC2 + SSN, Route on SSN, MTP DPC = PC3

PC3: GT + PC2 + SSN, Route on SSN, MTP DPC = PC3
	MTP DPC == PC3, deliver to SSN

{RAA} Here, PC2 denotes a node earlier in the message's path, it might
even be in a different PC domain than PC3's. So, if the _SUA_ gets this
message to push it towards the SSN, it must not  attempt to route to PC2
(so the _relay_ function in SUA must not use the PC to route to)
{RAA}
> 
> The SUA draft 14 allows the addressing possibility in section 1.5.3 at a
> relay node, and it possibly gives me problems with SCCP management there.

That's an SUA relay node's equivalent of an MTP transfer but using SUA.
In SUA's case, the DPC in the Destination Address in such a message is
the MTP DPC instead of the Called Party Address DPC.  The SUA node knows
that with route on PC + SSN that this DPC != local DPC and the relay
node transfers the message.

How else did you expect it to route normal TCAP response messages?
Or, to route forward to a SUA node to do GTT for that matter?
{RAA} It's fine for messages in the direction SCTP to SUA, but not in
the direction SCCP to SUA. SUA 14 doesn't distinguish this in section
1.5.3. Also, once the RI = "SSN" in SCCP, there is no chance of using GT
routing further along the path. Does the translation/resolution of the
address information of 1.5.3 (sometimes) yield a new RI 
(= "GT") when routing is on SSN[+PC] ?  

Kind regards,
Dick.

--brian

> 
> Q.714 section 2.3.2.3 applies for the originating node. 
> 
> Kind regards,
> Dick Adams.
>

---

From: "Valerie Gastaud" <[email-masked]>
Date: Mon, 9 Dec 2002 09:37:04 +0100

All,

AS1 and AS2 don't have overlapping Routing Keys if RK for AS1 is PC2 SSN6
and RK for AS2 is PC3 SSN6.
AS1 can be reached if the SG receives a message with MTP DPC=3, SCCP Cld
add=(rtg on GT) and the GT resutls is PC=2, SSN=6.
As discussed earlier in the mailing list, the issue is how to receive
subsequent messages for AS2 that will be routed on SSN:
SCCP Cld add=(rtg on SSN, PC=2, SSN=6) but should MTP DPC=3 or 2?
The default or standard behavior in SS7 will be MTP DPC=2, but this requires
the SG to support multiple Point Codes at MTP level.
If there is a way to "force" MTP DPC=3, we could reach the SCCP layer in the
SG that will call AMF with the SCCP Cld add=(rtg on SSN, PC=2, SSN=6). AMF
will then use the RK to route to AS1.
Valerie
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Brian F. G. Bidulock
Sent: vendredi 6 decembre 2002 19:22
To: Bouckaert, Philippe
Cc: Richard Adams; [email-masked]
Subject: Re: [Sigtran] SUA relay function

Philippe,

--brian

Bouckaert, Philippe wrote:
(Fri, 06 Dec 2002 15:47:44)
> But if we check the following configuration, there is a problem for
message coming from ss7,
According

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 9 Dec 2002 01:54:10 -0700

Valerie,

PC=2 of AS1 should be a local alias at the SG (as the SG is obviously
an STP).  Then it can accept directly MTP DPC=2 or GTT resulting in
DPC=2.

--brian

Valerie Gastaud wrote:                               (Mon, 09 Dec 2002 09:37:04)