Subject: [Sigtran] Open Issue 3rd M3UA Plugtest: Duplicate RK

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Mon, 9 Dec 2002 16:32:28 +0100

Hi guys, 

From the last M3UA Plugtest:

<<
There was interest to make the duplicate ASPSM/ASPTM/Registration
handling procedures consistent on the SGP.  Currently, when the SGP
receives a duplicate ASP Up or ASP Active, it accepts them and 
sends the appropriate positive response.  However, when it receives a 
duplicate REG REQ response error.

The recommendations were:

a)  SGP accepts the duplicate REG REQ and sends positive response
(REQ RSP - Successful)

b)  Add a new REG RESP error (Duplicate Routing Key).  ASP would
then have to DEREG, then RE-REG.
  
In principle I would suggest option b, for security reasons.

Is there any preference in the mailing list? 

Cheers // Javier.
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 9 Dec 2002 10:17:04 -0700

Javier,

As it is awkward for the SGP to be able to detect duplicate
routing keys (the only whay I can think of doing it is to
maintain LRKI's for some period of time) I would prefer
that you leave it as it is: Error = Cannot Support Unique Routing.

In principle I don't see any difference between "Error - Cannot
Support Unique Routing" and "Duplicate Key", except that there
are situations in which the SGP cannot possibly detect a duplicate.

--brian

Javier Pastor-Balbas (ECE) wrote:                                                 (Mon, 09 Dec 2002 16:32:28)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/