Subject: RE: [Sigtran] M3UA: Redundant RKM error codes

From: "Barry Nagelberg" <[email-masked]>
Date: Wed, 10 Dec 2003 12:54:49 -0500

Cristophe,

I am confused about your typo explanation. If the SGP supports RKM, and the
Registration request is valid, and the RK does not currently exist, then why
would the SGP return an error? Why wouldn't it just create a new RK?

Barry Nagelberg

> -----Original Message-----
> From: Anzile, Christophe [mailto:[email-masked]]
> Sent: Wednesday, December 10, 2003 12:12 PM
> To: Barry Nagelberg; SIGTRAN Mailing List
> Subject: RE: [Sigtran] M3UA: Redundant RKM error codes
>
>
> Hi,
> I don't think these are redundant.
> You should be able to differentiate the 2 error cases.
>
> Therefore, I think there is a typo in the second case.
> You should read:
> "  If an SGP determines that a received Routing Key does not currently
>    exist and the SGP supports dynamic configuration, the SGP
>    returns a Registration Response message to the ASP, containing a
>    Registration Result "Error - Routing Key not Currently Provisioned"."
>
> You have another example in SUA-15, that is:
> "  If an SGP determines that a received Routing Key does not currently
>    exist and the SGP supports dynamic configuration but does not have
>    the capacity to add new Routing Key and Application Server entries,
>    the SGP returns a Registration Response message to the ASP,
>    containing a Registration Result "Error - Insufficient Resources".
>
> Regards,
> Christophe.
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Barry Nagelberg
> Sent: Wednesday, December 10, 2003 5:47 PM
> To: SIGTRAN Mailing List
> Subject: [Sigtran] M3UA: Redundant RKM error codes
>
>
> I think that we have 2 redundant RKM error codes, one of which should be
> removed for clarity's sake. The use of these codes is explained in section
> 4.4.1 of the RFC.
>
> In the case in which an SGP doesn't support RKM procedures, the RFC covers
> it twice, with 2 different error codes:
>
> "  If the SGP does not support the registration procedure, the SGP
>    returns an Error message to the ASP, with an error code of
>    "Unsupported Message Class"."
>
> AND
>
> "  If an SGP determines that a received Routing Key does not currently
>    exist and the SGP does not support dynamic configuration, the SGP
>    returns a Registration Response message to the ASP, containing a
>    Registration Result "Error - Routing Key not Currently Provisioned"."
>
> Barry Nagelberg
>

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Anzile, Christophe" <[email-masked]>
Date: Wed, 10 Dec 2003 18:11:34 +0100

Hi,

Regards,
Christophe.

-----Original Message-----

AND

Barry Nagelberg