Subject: [Sigtran] doubts

From: manish rathi <[email-masked]>
Date: Wed, 10 Dec 2003 14:25:52 +0530

hi,
to implement media gateway controller there are 2 options
1) Use M3UA on signalling gateway
2) Use of M2UA on signalling gateway

Tell me the advantages/disadvantages of each approach?

thanks
regards
Manish

--
Things work out best for those who make the best use of it.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 10 Dec 2003 03:04:01 -0700

manish,

Well, there is also:

   4) SUA
   5) M2PA
   6) IUA
   7) DUA
   8) GR303UA
   ...

Which you use depends on what your needs are and implementation-
and deployment- and operational-specific considerations.  In one
situation one of these is more advantageous than another.  In
another situation the reverse might be true.  That is the stuff
of network engineering and is best left to those that are practiced
at it.

See RFC 2719 for a high level view.

--brian

manish rathi wrote:                                                                 (Wed, 10 Dec 2003 14:25:52)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: manish rathi <[email-masked]>
Date: Wed, 10 Dec 2003 16:22:03 +0530

hi,
that's correct.
My requirement is to use MGC in 3G network for pstn interworking.
Not interested in ISDN(Q.931) interworking.

i don't know abt DUA or GR303UA. I hope that it'll not be for simple pstn connectivity.

Now i've 2 choices .

Use M2UA at SG & MTP3, M2UA at MGC
Use M3UA at SG & MGC & MTP-3 at SG

I've read that choice depends on density of ss7 links

M2UA is used when
 There is a low density of SS7 links at a par-ticular physical point in the network (per-haps as low as one)
There are a large number of physically seperate SG functions (due to the SS7 links   being physically located
remotely from each other)
The SG function is co-located with an MG (usually due to one or more of the previ-ous conditions)

In this case, it makes sense to host MTP3 in the MGC. The SS7 address (the pointcode) of the sys-tem resides with
MTP3. If each SG had its own MTP3 layer, a large number of pointcodes would be required to implement a (logically)
single gateway. This particular Sigtran configuration is likely to be common in European networks, where the SS7
signaling links share the physical medium with voice circuits.

Pls explain the above with some example.

thanks
regards
Manish

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 10 Dec 2003 07:23:05 -0700

manish,

You still have M2PA and SUA as choices...

manish rathi wrote:                                                                 (Wed, 10 Dec 2003 16:22:03)
>    in the network (per-haps as low as one)

Not really.  Density of links has little to do with it.

>    There  are  a large number of physically seperate SG functions (due to
>    the SS7 links   being physically located remotely from each other)

Not necessarily.  We use M2UA to distribute MTP3 inside a platform on a
PCMIG 2.17 backplane with very high densities and concentrations...

> 
>    In  this case, it makes sense to host MTP3 in the MGC. The SS7 address
>    (the  pointcode)  of the sys-tem resides with MTP3. If each SG had its
>    own  MTP3  layer,  a  large  number of pointcodes would be required to
>    implement  a  (logically)  single  gateway.  This  particular  Sigtran
>    configuration  is  likely to be common in European networks, where the
>    SS7 signaling links share the physical medium with voice circuits.

No.  M2UA has not point code assigned.  M3UA SG does not need to have a
point code (its own) either.  There is no difference there...

>    Pls explain the above with some example.

Please provide an example of how you jumped to such conclusions.

--brian

>      manish rathi
>      wrote:
>          (Wed, 10 Dec 2003 14:25:52)
>      >
>      >    hi,
>      [1]http://www.openss7.org/
> 
> --
> References
>    1. http://www.openss7.org/

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: manish rathi <[email-masked]>
Date: Wed, 10 Dec 2003 20:19:39 +0530

hi brian,
I m attaching a pdf of SIGTRAN by  spider software in which the below things mentioned.
SUA doesn't seem to be a choice as my pstn connectivity can not have sccp layer.
i suppose m2pa can be used of we keep mtp-3,m2pa at SG  and mtp3 & m2pa at MGC.
Say an aim comes from pstn node in mtp-3 message, u send it in m2pa data to MGC. MGC take mtp-3 from m2ua packet.
Then iam from mtp3 pkt.

Isn't it twice processing my m2pa, mtp-3 layer at SG & MGC?

While processing is less in case when we implement m2ua/m3ua on SG.

i've read rfc 2719, m3ua, m2ua rfc already,
Is there any rfc which guide me how to implement signalling gateway?

What's the convention in using m3ua/m2ua by designer of signalling gateway to
be used by VOIP network.

thanks
regards
Manish