Subject: RE: [Sigtran] M3UA: More redundant RKM error codes

From: "J.Javier Pastor (ML/EEM)" <[email-masked]>
Date: Wed, 14 Jan 2004 15:30:10 +0100

Barry, 

You are right. And that is valid only for the overlapping case. You can not create a new AS whose associated RK overlaps another existing registered RK. In the duplicate case it is already included that the check is against the RK previosly registered by the sending ASP. The latter makes sense but not the former.

Go back to my first proposal.

Thanks // Javier.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> Barry Nagelberg
> Sent: miércoles, 14 de enero de 2004 14:49
> To: SIGTRAN Mailing List
> Subject: RE: [Sigtran] M3UA: More redundant RKM error codes
> 
> 
> Javier,
> 
> No, Brian's suggestion is not correct, nor is this updated 
> text. Routing
> keys are independent of ASPs or associations. I think perhaps Brian is
> thinking of the routing context, which may be unique for each ASP or
> association.
> 
> Barry Nagelberg
> 
> > -----Original Message-----
> > From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> > J.Javier Pastor (ML/EEM)
> > Sent: Wednesday, January 14, 2004 8:38 AM
> > To: [email-masked]'
> > Cc: SIGTRAN Mailing List; Ken Morneault (E-mail)
> > Subject: RE: [Sigtran] M3UA: More redundant RKM error codes
> >
> >
> > Brian,
> >
> > Tell me if the following is OK.
> >
> > If the SGP determines that the requested RK partially, but 
> not exactly,
> > matches an existing RK already registered for the sender ASP, and
> > that an incoming signalling message received at
> > an SGP could possibly match both the requested and the existing
> > RK, the SGP
> > returns a Registration Response message to the ASP, with a 
> Registration
> > Status of "Error - "Cannot Support Unique Routing. An 
> incoming signalling
> > message received at an SGP should not match against more 
> than one Routing
> > Key.
> >
> >
> > THanks // JAvier.
> >
> > > -----Original Message-----
> > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > Sent: miércoles, 14 de enero de 2004 13:20
> > > To: J.Javier Pastor (ML/EEM)
> > > Cc: SIGTRAN Mailing List; Ken Morneault (E-mail)
> > > Subject: Re: [Sigtran] M3UA: More redundant RKM error codes
> > >
> > >
> > > J.Javier,
> > >
> > > J.Javier Pastor (ML/EEM) wrote:
> > >                     (Wed, 14 Jan 2004 12:36:54)
> > >
> > > --snip--
> > > >
> > > > --------
> > > > New text: (Section 4.4.1)
> > > > ---------
> > > >
> > > > If the SGP determines that the requested RK partially, but
> > > not exactly,
> > > > matches an existing RK, and that an incoming signalling
> > > message received at
> > > > an SGP could possibly match both the requested and the
> > > existing RK, the SGP
> > > > returns a Registration Response message to the ASP, with a
> > > Registration
> > > > Status of "Error - "Cannot Support Unique Routing. An
> > > incoming signalling
> > > > message received at an SGP should not match against more
> > > than one Routing
> > > > Key.
> > > >
> > > --snip--
> > >
> > > I think you mean for a given ASP (Association) in the 
> above.  Correct?
> > >
> > > It should be mentioned that the "matching" of RKs is done
> > > only against other
> > > RKs belonging to the same ASP (Association).
> > >
> > > --brian
> > >
> > > --
> > > Brian F. G. Bidulock
> > > [email-masked]
> > > http://www.openss7.org/
> > >
> >
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Wed, 14 Jan 2004 09:38:59 -0500

Just to refine it a bit more:
We should also mention about the case, where there is a full RK match, but
this RK is registered by another ASP (not by the ASP, which sent REGREQ). In
such a case, SGP should assign a RC value for the RK/ASP and should fill the
RC value in REGRESP with it (if the RK was already registered by ASP sending
REGREQ, SGP would have used the already allocated RC value).

   Tolga

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> J.Javier Pastor (ML/EEM)
> Sent: Wednesday, January 14, 2004 9:30 AM
> To: 'Barry Nagelberg'; SIGTRAN Mailing List
> You are right. And that is valid only for the overlapping case.
> You can not create a new AS whose associated RK overlaps another
> existing registered RK. In the duplicate case it is already
> included that the check is against the RK previosly registered by
> the sending ASP. The latter makes sense but not the former.
>

---

From: "Barry Nagelberg" <[email-masked]>
Date: Wed, 14 Jan 2004 09:49:18 -0500

Tolga,

This is already covered in section 4.4.1:

<snip>

   If the received Routing Key matches an existing SGP Routing Key entry,
and
   the ASP is not currently included in the list of ASPs for the related
   Application Server, the SGP MAY authorize the ASP to be added to the
   AS.

<snip>

Barry Nagelberg

> Tolga Asveren
> Sent: Wednesday, January 14, 2004 9:39 AM
> To: J.Javier Pastor (ML/EEM); 'Barry Nagelberg'; SIGTRAN Mailing List

---

From: "Tolga Asveren" <[email-masked]>
Date: Wed, 14 Jan 2004 09:55:17 -0500

Yes, you are right, my oversight.

  Tolga

> Sent: Wednesday, January 14, 2004 9:49 AM
> To: SIGTRAN Mailing List

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 14 Jan 2004 11:15:45 -0700

J.Javier,

Just to clarify, there should be nothing stopping an implementation from
allowing ASP1 to register for, say, 5-5-5 (ISUP), ASP2 to register for
5-5-5 (SCCP) and ASP3 to register for 5-5-5(*).

In this case, although ASP3 registers after ASP1 and ASP2, there is nothing
stopping an SG from assigining a RK and RC to 5-5-5(*) for ASP3.

An SG implementation could choose to refuse 5-5-5(*) and require ASP3
to register separately for 5-5-5(ISUP) and 5-5-5(SCCP), or it might not.
I don't think it is the RFC's place to require one or the other.  So,
for in the case where there is an overlap between "different" APSs, it
should be left up to the SG implementation as it is now.

Your additional text below, now clarifies that.  Thank you.

--brian

J.Javier Pastor (ML/EEM) wrote:                                                   (Wed, 14 Jan 2004 15:30:10)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/