Subject: AW: [Sigtran] M2PA draft 10 - Processor outage

From: Gaiser Franz <[email-masked]>
Date: Mon, 12 Jan 2004 12:27:42 +0100

Tom,

there are two more questions about PO:
1.) If MTP3 decides to resume operation after LPO ends (by sending CONTINUE instead of FLUSH), shall M2PA also exchange LS 'Ready' messages between the peers before resuming operation ? 
2.) What happens when one side gets CONTINUE (e.g. after LPO ends), but the other side a FLUSH command from MTP3? 
3.) In chapter 4.1.4 it is written that when M2PA experiences local processor outage, it MAY put the link out of service ... . Does this imply that also the side receiving a LS 'processor outage' may put the link out of service by sending a LS 'OOS'?

Thanks & Best regards, Franz

-----Ursprungliche Nachricht-----
Von: Tom George [mailto:[email-masked]]
Gesendet: Freitag, 9. Januar 2004 22:00
An: Gaiser Franz
Cc: [email-masked]'
Betreff: Re: [Sigtran] M2PA draft 10 - Processor outage

Franz,

I think you are right. That is implied by the example, though it is not 
stated explicitly.

tomG.

Gaiser Franz wrote:
 > Hi All,
 >
 > I have a question to figure 16: There is not mentioned the behavior
 > of the messages in the retransmission buffer. Is it correct, when A
 > flushes (request from MTP3) the incoming messages 14-16 (the messages
 > that were buffered without acknowledgement) the messages 5-6 still
 > stored in the retransmission buffer of A are to be discared too?  The
 > same applies to side B: when flushing the incoming message 6, the
 > messages 14-16 in the retransmission buffer are discarded.
 >
 >
 > Thanks for clarification.
 >
 >
 > Best regards, Franz

-- 
* Tom George       PB7-24001 (near B-21)      [email-masked]  *
* 972-519-3168   Intranet:  http://www.ssd.usa.alcatel.com/~tgeorge/  *
*   I actively disclaim speaking for Alcatel.  I do not purport to    *
*   advertise or represent its position, operations, or activities.   *

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tom George <[email-masked]>
Date: Thu, 22 Jan 2004 16:38:28 -0600

Franz,

Replies are below.

tomG.

 > 1.) If MTP3 decides to resume operation after LPO ends (by sending
 > CONTINUE instead of FLUSH), shall M2PA also exchange LS 'Ready'
 > messages between the peers before resuming operation ?

Yes.

 > 2.) What happens when one side gets CONTINUE (e.g. after LPO ends),
 > but the other side a FLUSH command from MTP3?

I think everything still works OK. The LS Ready messages help them get 
their sequence numbers OK.

 > 3.) In chapter 4.1.4 it is written that when M2PA experiences local
 > processor outage, it MAY put the link out of service ... . Does this
 > imply that also the side receiving a LS 'processor outage' may put
 > the link out of service by sending a LS 'OOS'?

Only if it is allowed by the applicable MTP2 standard. I am not aware of 
any that do, but I have not researched it.

 > Thanks & Best regards, Franz
   [...]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 22 Jan 2004 18:07:58 -0700

Tom,

Tom George wrote:                                                                      (Thu, 22 Jan 2004 16:38:28)
> any that do, but I have not researched it.

MTP3b does.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Tom George <[email-masked]>
Date: Fri, 23 Jan 2004 08:49:06 -0600

I forgot to mention that section 4.1.6 covers this case.

Brian F. G. Bidulock wrote:
   [...]
   [...]