Subject: AW: [Sigtran] M2PA - draft 10 - Link Status Ready received during T4 period

From: Gaiser Franz <[email-masked]>
Date: Tue, 13 Jan 2004 15:34:20 +0100

Hi Frank,

Follow MTP2 behavior: If M2PA has already received a LS 'ready' from its peer when its timer T4 expires, there is no need to start T1. M2PA can just send LS 'ready' to the peer and continue along.

regards, Franz

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]]Im Auftrag
von Franck Boesch
Gesendet: Montag, 12. Januar 2004 18:25
An: [email-masked]
Betreff: [Sigtran] M2PA - draft 10 - Link Status Ready received during
T4 period

Hello,

I would like to know if we should ignore a received 'Link Status Ready' message during the proving period (T4) or memorize that the remote end is ready to skip T1 period (just send 'Link Status Ready') when T4 expires. Please find below a modified Figure 12 page 35 of M2PA draft 10 to explain what I am saying.

Thanks for the reply,
Regards,
Franck Boesch.

Internet Draft  SS7 MTP2-User Peer-to-Peer Adaptation Layer   Oct 2003

    MTP3        M2PA        SCTP        SCTP        M2PA        MTP3
    ----        ----        ----        ----        ----        ----
     .           .           .           .           .           .
     .           Start timer T3          .           .           .
     .           Link Status Proving     .           .           .
     .           ------------------------------------>           .
     .           .           .           .           .           .
     .           .           .     Link Status Proving           .
     .           <------------------------------------           .
     .           .           .           .           .           .
     .           Stop timer T3           .           .           .
     .           .           .           .           .           .
     .           Start timer T4          .           .           .
     .           Link Status Proving     .           .           .
     .           ------------------------------------>           .
     .           ------------------------------------>           .
     .           ------------------------------------>           .
     .           .           .       Link Status Ready           .
     .           <------------------------------------           .
     .           ------------------------------------>           .
     .           ------------------------------------>           .
     .           ------------------------------------>           .
     .           .           .           .           .           .
     .           Timer T4 expires        .           .           .
     .           .           .           .           .           .

     Send Link Status Ready (one or more) 

     .           .           .           .           .           .
     .           Link Status Ready       .           .           .
     .           ------------------------------------>           .
     .           .           .           .           .           .
     In Service              .           .           In Service
     <------------           .           .           ------------>
     .           .           .           .           .           .

     MTP3 MAY begin sending data messages.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Franck Boesch" <[email-masked]>
Date: Tue, 13 Jan 2004 16:09:06 +0100

Thank you Franz - our MTP2 layer ignores a FISU received during T4 period (we consider that FISUs received afterwards due to FISU permanent transmission from remote will end local T1 period) and that explains why I have met this problem on M2PA layer.
regards,
Franck Boesch.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Gaiser Franz
Sent: mardi 13 janvier 2004 15:34
To: [email-masked]'; [email-masked]
Subject: AW: [Sigtran] M2PA - draft 10 - Link Status Ready received
during T4 period

Hi Frank,

Follow MTP2 behavior: If M2PA has already received a LS 'ready' from =
its peer when its timer T4 expires, there is no need to start T1. M2PA =
can just send LS 'ready' to the peer and continue along.

regards, Franz

-----Urspr=FCngliche Nachricht-----

Hello,

I would like to know if we should ignore a received 'Link Status Ready' =
message during the proving period (T4) or memorize that the remote end =
is ready to skip T1 period (just send 'Link Status Ready') when T4 =
expires. Please find below a modified Figure 12 page 35 of M2PA draft =
10 to explain what I am saying.

Thanks for the reply,
Regards,
Franck Boesch.

     Send Link Status Ready (one or more)=20

     .           .           .           .           .           .

---

From: Tom George <[email-masked]>
Date: Thu, 22 Jan 2004 16:26:48 -0600

Yes, follow the MTP2 behavior. In an earlier draft of M2PA, I had said 
this explicitly. I decided to remove it as one of those items that 
duplicated MTP2.

tomG.

-- 
* Tom George       PB7-24001 (near B-21)      [email-masked]  *
* 972-519-3168   Intranet:  http://www.ssd.usa.alcatel.com/~tgeorge/  *
*   I actively disclaim speaking for Alcatel.  I do not purport to    *
*   advertise or represent its position, operations, or activities.   *