Subject: RE: [Sigtran] M3UA: More redundant RKM error codes

From: "J.Javier Pastor (ML/EEM)" <[email-masked]>
Date: Thu, 15 Jan 2004 12:11:40 +0100

Brian, 

Why don't you take the following approach...

Define two different ASes:
- AS1 -> 5-5-5 (ISUP)
- AS2 -> 5-5-5 (SCCP)

ASP1 registers within AS1
ASP2 registers within AS2
ASP3 registers within both AS1 and AS2

It is important to keep one unique routing per AS. ASes MUST not overlap.

Cheers // Javier.

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: miércoles, 14 de enero de 2004 19:16
> To: J.Javier Pastor (ML/EEM)
> Cc: 'Barry Nagelberg'; SIGTRAN Mailing List
> Subject: Re: [Sigtran] M3UA: More redundant RKM error codes
> 
> 
> J.Javier,
> 
> Just to clarify, there should be nothing stopping an 
> implementation from
> allowing ASP1 to register for, say, 5-5-5 (ISUP), ASP2 to register for
> 5-5-5 (SCCP) and ASP3 to register for 5-5-5(*).
> 
> In this case, although ASP3 registers after ASP1 and ASP2, 
> there is nothing
> stopping an SG from assigining a RK and RC to 5-5-5(*) for ASP3.
> 
> An SG implementation could choose to refuse 5-5-5(*) and require ASP3
> to register separately for 5-5-5(ISUP) and 5-5-5(SCCP), or it 
> might not.
> I don't think it is the RFC's place to require one or the other.  So,
> for in the case where there is an overlap between "different" APSs, it
> should be left up to the SG implementation as it is now.
> 
> Your additional text below, now clarifies that.  Thank you.
> 
> --brian
> 
> 
> J.Javier Pastor (ML/EEM) wrote:                               
>                     (Wed, 14 Jan 2004 15:30:10)
> > Barry, 
> > 
> > You are right. And that is valid only for the overlapping 
> case. You can not create a new AS whose associated RK 
> overlaps another existing registered RK. In the duplicate 
> case it is already included that the check is against the RK 
> previosly registered by the sending ASP. The latter makes 
> sense but not the former.
> > 
> > Go back to my first proposal.
> > 
> > Thanks // Javier.
> > 
> > > -----Original Message-----
> > > From: [email-masked] 
> > > [mailto:[email-masked]]On Behalf Of
> > > Barry Nagelberg
> > > Sent: miércoles, 14 de enero de 2004 14:49
> > > To: SIGTRAN Mailing List
> > > Subject: RE: [Sigtran] M3UA: More redundant RKM error codes
> > > 
> > > 
> > > Javier,
> > > 
> > > No, Brian's suggestion is not correct, nor is this updated 
> > > text. Routing
> > > keys are independent of ASPs or associations. I think 
> perhaps Brian is
> > > thinking of the routing context, which may be unique for 
> each ASP or
> > > association.
> > > 
> > > Barry Nagelberg
> > > 
> > > > -----Original Message-----
> > > > From: [email-masked] 
> > > [mailto:[email-masked]]On Behalf Of
> > > > J.Javier Pastor (ML/EEM)
> > > > Sent: Wednesday, January 14, 2004 8:38 AM
> > > > To: [email-masked]'
> > > > Cc: SIGTRAN Mailing List; Ken Morneault (E-mail)
> > > > Subject: RE: [Sigtran] M3UA: More redundant RKM error codes
> > > >
> > > >
> > > > Brian,
> > > >
> > > > Tell me if the following is OK.
> > > >
> > > > If the SGP determines that the requested RK partially, but 
> > > not exactly,
> > > > matches an existing RK already registered for the 
> sender ASP, and
> > > > that an incoming signalling message received at
> > > > an SGP could possibly match both the requested and the existing
> > > > RK, the SGP
> > > > returns a Registration Response message to the ASP, with a 
> > > Registration
> > > > Status of "Error - "Cannot Support Unique Routing. An 
> > > incoming signalling
> > > > message received at an SGP should not match against more 
> > > than one Routing
> > > > Key.
> > > >
> > > >
> > > > THanks // JAvier.
> > > >
> > > > > -----Original Message-----
> > > > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > > > Sent: miércoles, 14 de enero de 2004 13:20
> > > > > To: J.Javier Pastor (ML/EEM)
> > > > > Cc: SIGTRAN Mailing List; Ken Morneault (E-mail)
> > > > > Subject: Re: [Sigtran] M3UA: More redundant RKM error codes
> > > > >
> > > > >
> > > > > J.Javier,
> > > > >
> > > > > J.Javier Pastor (ML/EEM) wrote:
> > > > >                     (Wed, 14 Jan 2004 12:36:54)
> > > > >
> > > > > --snip--
> > > > > >
> > > > > > --------
> > > > > > New text: (Section 4.4.1)
> > > > > > ---------
> > > > > >
> > > > > > If the SGP determines that the requested RK partially, but
> > > > > not exactly,
> > > > > > matches an existing RK, and that an incoming signalling
> > > > > message received at
> > > > > > an SGP could possibly match both the requested and the
> > > > > existing RK, the SGP
> > > > > > returns a Registration Response message to the ASP, with a
> > > > > Registration
> > > > > > Status of "Error - "Cannot Support Unique Routing. An
> > > > > incoming signalling
> > > > > > message received at an SGP should not match against more
> > > > > than one Routing
> > > > > > Key.
> > > > > >
> > > > > --snip--
> > > > >
> > > > > I think you mean for a given ASP (Association) in the 
> > > above.  Correct?
> > > > >
> > > > > It should be mentioned that the "matching" of RKs is done
> > > > > only against other
> > > > > RKs belonging to the same ASP (Association).
> > > > >
> > > > > --brian
> > > > >
> > > > > --
> > > > > Brian F. G. Bidulock
> > > > > [email-masked]
> > > > > http://www.openss7.org/
> > > > >
> > > >
> > > > _______________________________________________
> > > > Sigtran mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > 
> > > 
> > > _______________________________________________
> > > Sigtran mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > 
> > 
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 15 Jan 2004 05:14:34 -0700

J.Javier,

Where does it say ASes must not overlap?  This is precisely
one of the example cases we used for IPSP discussions.
I certainly don't see where retricting this is necessary
for proper interworking or to protect the network.

The only problem case we had for "Unique Routing" was were
two RC's exist for the same traffic for the same ASP.  It is
then abivalent which RC the SG is to assign to the traffic.

In this example case, it is clear which RC value is to be
assigned to each message for each ASP.  There is no problem
of "Unique Routing".

The problem of "Unique Routing" exists where one attempt to
configure or register overlapping RKs for the same ASP.  So
if ASP4 tries to register for 5-5-5(ISUP) and 5-5-5(*) there
is a problem of unique routing.  To which RC is ISUP traffic
to go?

For the case of different ASPs, the SG can choose to support
it, if capable, or refuse it if not.  The IG need not attempt
to dictate a restriction to SG capabilities in this regard.

--brian

J.Javier Pastor (ML/EEM) wrote:                                                   (Thu, 15 Jan 2004 12:11:40)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/