Subject: RE: [Sigtran] M3UA: More redundant RKM error codes

From: "J.Javier Pastor (ML/EEM)" <[email-masked]>
Date: Wed, 14 Jan 2004 14:37:45 +0100

Brian, 

Tell me if the following is OK. 

If the SGP determines that the requested RK partially, but not exactly,
matches an existing RK already registered for the sender ASP, and that an incoming signalling message received at
an SGP could possibly match both the requested and the existing RK, the SGP
returns a Registration Response message to the ASP, with a Registration
Status of "Error - "Cannot Support Unique Routing. An incoming signalling
message received at an SGP should not match against more than one Routing
Key.

THanks // JAvier.

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: miércoles, 14 de enero de 2004 13:20
> To: J.Javier Pastor (ML/EEM)
> Cc: SIGTRAN Mailing List; Ken Morneault (E-mail)
> Subject: Re: [Sigtran] M3UA: More redundant RKM error codes
> 
> 
> J.Javier,
> 
> J.Javier Pastor (ML/EEM) wrote:                               
>                     (Wed, 14 Jan 2004 12:36:54)
> 
> --snip--
> > 
> > -------- 
> > New text: (Section 4.4.1) 
> > ---------
> > 
> > If the SGP determines that the requested RK partially, but 
> not exactly,
> > matches an existing RK, and that an incoming signalling 
> message received at
> > an SGP could possibly match both the requested and the 
> existing RK, the SGP
> > returns a Registration Response message to the ASP, with a 
> Registration
> > Status of "Error - "Cannot Support Unique Routing. An 
> incoming signalling
> > message received at an SGP should not match against more 
> than one Routing
> > Key.
> > 
> --snip--
> 
> I think you mean for a given ASP (Association) in the above.  Correct?
> 
> It should be mentioned that the "matching" of RKs is done 
> only against other
> RKs belonging to the same ASP (Association).
> 
> --brian
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Barry Nagelberg" <[email-masked]>
Date: Wed, 14 Jan 2004 08:49:12 -0500

Javier,

No, Brian's suggestion is not correct, nor is this updated text. Routing
keys are independent of ASPs or associations. I think perhaps Brian is
thinking of the routing context, which may be unique for each ASP or
association.

Barry Nagelberg

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> J.Javier Pastor (ML/EEM)
> Sent: Wednesday, January 14, 2004 8:38 AM
> To: [email-masked]'
> Subject: RE: [Sigtran] M3UA: More redundant RKM error codes
>
>
> Brian,
>
> matches an existing RK already registered for the sender ASP, and
> that an incoming signalling message received at

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 14 Jan 2004 11:07:09 -0700

J.Javier,

Sounds good.

--brian

J.Javier Pastor (ML/EEM) wrote:                                                   (Wed, 14 Jan 2004 14:37:45)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/