Subject: [Sigtran] M3UA IG Last Call Comment: Routing Key not Currently Provisioned

From: "Barry Nagelberg" <[email-masked]>
Date: Tue, 17 Feb 2004 11:41:34 -0500

Javier and Ken,

My suggested text change below doesn't appear in IG v7. I think that it is
necessary, and I didn't receive any negative comments after posting it on
the list.

Barry Nagelberg

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Barry Nagelberg
> Sent: Wednesday, December 10, 2003 2:15 PM
> To: SIGTRAN Mailing List
> Subject: RE: [Sigtran] M3UA: Redundant RKM error codes
>
>
> Christophe,
>
> OK, now I understand. Thanks. Then we must fix this typo, and add a little
> more explanation. I suggest this:
>
> "  If an SGP determines that a received Routing Key does not currently
>    exist, and the SGP supports dynamic configuration but requires that
>    the Routing Key first be manually provisioned at the SGP, the SGP
>    returns a Registration Response message to the ASP, containing a
>    Registration Result "Error - Routing Key not Currently Provisioned".
>
> Barry Nagelberg
>
> > -----Original Message-----
> > From: Anzile, Christophe [mailto:[email-masked]]
> > Sent: Wednesday, December 10, 2003 1:08 PM
> > To: Barry Nagelberg; SIGTRAN Mailing List
> > Subject: RE: [Sigtran] M3UA: Redundant RKM error codes
> >
> >
> > Barry,
> > that's typically the case when the received Routing Key
> > does not match any existing SGP Routing Key entry
> > (meaning that the routing key is not valid for that specific SGP),
> > even if the REQ REQ is fine.
> > There are SGs that do not support full dynamic reg. procedures,
> > so that RK should be provisioned first at SGP before being valid.
> > Christophe.
> >
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]On Behalf Of
> > Barry Nagelberg
> > Sent: Wednesday, December 10, 2003 6:55 PM
> > To: SIGTRAN Mailing List
> > Subject: RE: [Sigtran] M3UA: Redundant RKM error codes
> >
> >
> > Cristophe,
> >
> > I am confused about your typo explanation. If the SGP supports
> > RKM, and the
> > Registration request is valid, and the RK does not currently
> > exist, then why
> > would the SGP return an error? Why wouldn't it just create a new RK?
> >
> > Barry Nagelberg
> >
> > > -----Original Message-----
> > > From: Anzile, Christophe [mailto:[email-masked]]
> > > Sent: Wednesday, December 10, 2003 12:12 PM
> > > To: Barry Nagelberg; SIGTRAN Mailing List
> > > Subject: RE: [Sigtran] M3UA: Redundant RKM error codes
> > >
> > >
> > > Hi,
> > > I don't think these are redundant.
> > > You should be able to differentiate the 2 error cases.
> > >
> > > Therefore, I think there is a typo in the second case.
> > > You should read:
> > > "  If an SGP determines that a received Routing Key does not currently
> > >    exist and the SGP supports dynamic configuration, the SGP
> > >    returns a Registration Response message to the ASP, containing a
> > >    Registration Result "Error - Routing Key not Currently
> Provisioned"."
> > >
> > > You have another example in SUA-15, that is:
> > > "  If an SGP determines that a received Routing Key does not currently
> > >    exist and the SGP supports dynamic configuration but does not have
> > >    the capacity to add new Routing Key and Application Server entries,
> > >    the SGP returns a Registration Response message to the ASP,
> > >    containing a Registration Result "Error - Insufficient Resources".
> > >
> > > Regards,
> > > Christophe.
> > >
> > > -----Original Message-----
> > > From: [email-masked]
[mailto:[email-masked]]On Behalf Of
> > Barry Nagelberg
> > Sent: Wednesday, December 10, 2003 5:47 PM
> > To: SIGTRAN Mailing List
> > Subject: [Sigtran] M3UA: Redundant RKM error codes
> >
> >
> > I think that we have 2 redundant RKM error codes, one of which should be
> > removed for clarity's sake. The use of these codes is explained
> in section
> > 4.4.1 of the RFC.
> >
> > In the case in which an SGP doesn't support RKM procedures, the
> RFC covers
> > it twice, with 2 different error codes:
> >
> > "  If the SGP does not support the registration procedure, the SGP
> >    returns an Error message to the ASP, with an error code of
> >    "Unsupported Message Class"."
> >
> > AND
> >
> > "  If an SGP determines that a received Routing Key does not currently
> >    exist and the SGP does not support dynamic configuration, the SGP
> >    returns a Registration Response message to the ASP, containing a
> >    Registration Result "Error - Routing Key not Currently Provisioned"."
> >
> > Barry Nagelberg
> >

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 17 Feb 2004 10:23:18 -0700

Barry,

I, for one, agree wholeheartedly with your proposed change.  Your
proposed text is a vast improvement on the original paragraph.

Could the editor's of the IG please edit this into the document?

--bria

Barry Nagelberg wrote:                                                               (Tue, 17 Feb 2004 11:41:34)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/