Subject: RE: [Sigtran] Silent changes to V5UA draft 04 before moving to RF C ?

From: "Ong, Lyndon" <[email-masked]>
Date: Thu, 12 Feb 2004 09:49:36 -0800

Hi Pascal,

Thanks for your cooperation and comments on V5UA.  As it turns out
we will need to put out another version when we get to the authors'
review part of the RFC process, so you will see a version 5 at that
point.

Regarding the IGs, we did decide to put out a new version of IUA
rather than an IG for that spec, in response to your and others'
comments.  We're very close to completing the IG for M3UA now,
and when we have agreement on this we can consider whether to
update the RFC or put out a separate document, I think.

Cheers,

Lyndon

-----Original Message-----
From: Pascal Bouveron (Netbricks) [mailto:[email-masked]]
Sent: Thursday, February 12, 2004 9:46 AM
To: [email-masked]
Cc: Ong, Lyndon; Eva Weilandt; [email-masked]; Michael Tuexen
(Sigtran); Alain CHAMPENOIS
Subject: Re: [Sigtran] Silent changes to V5UA draft 04 before moving to
RFC ?

Brian,

The fact is that in the past two years significant efforts were made to push
towards consistency over UAs.
For instance, M3UA drafts from 2000/2001 (draft-02 for instance) were really
"early" drafts, with some fields not even being described as full Parameters
(no Tag/Length for instance).
But all this was changed thanks to guys like you.
I haven't had a look at M2PA yet, but i can tell that IUA, M2UA and M3UA do
not suffer inconsistency anymore, and it is pretty straightforward to
implement a "UA core" which suits well all these UAs (i wrote one!).

There is little to be done to achieve consistency with V5UA as well, and
that is exactly what I proposed to Eva, who detailed all changes that will
be part of the next draft -- or RFC.

If the future V5UA RFC needs changes, we can still move to those
"Implementor's Guides" anyway...

BTW: i posted a remark about the format of the IGs back in october 2003,
saying that full documents would be a lot easier to read and understand than
simply listing the incremental changes.
People seemed to agree with me on this point.
But it looks like nothing was done yet in that direction...
Lyndon, how do we proceed here ?

Best regards / Meilleures salutations
Pascal Bouveron
=============================================
www.netbricks.com
Netbricks - Provence - FRANCE
Tel: (+33) (0)4 42 91 44 77 -- Fax:  (+33) (0)4 42 91 44 71
=============================================

----- Original Message ----- 
From: "Brian F. G. Bidulock" <[email-masked]>
To: "Pascal Bouveron (Netbricks)" <[email-masked]>
Cc: "Ong, Lyndon" <[email-masked]>; "Eva Weilandt"
<[email-masked]>; <[email-masked]>; "Michael Tuexen
(Sigtran)" <[email-masked]>; "Alain CHAMPENOIS"
<[email-masked]>
Sent: Thursday, February 12, 2004 5:46 PM
Subject: Re: [Sigtran] Silent changes to V5UA draft 04 before moving to RFC
?

| Pascal,
|
| Pascal Bouveron (Netbricks) wrote:
(Thu, 12 Feb 2004 15:08:37)
| > Hello,
| >
| > As Brian says, drafts are working group documents.
| > And as such, they are meant to be criticized by the working group
community,
| > which is a good way to rapidly improve the protocol and make it a fairly
| > stable and supported protocol in the end, ie when it becomes an RFC.
| >
| > My point was that the draft 04, which was approved as "Proposed
standard" by
| > the IESG back in november 2003, was about to move to RFC status, but at
the
| > same time, the RFC document would include major changes which were not
| > announced to the working group.
| > And that is what desappointed me.
| > These protocols are meant to be implemented by vendors some day  (like
us,
| > but also Nortel and others), and therefore there needs to be full
| > transparency on the decisions that are taken to modify the documents.
| >
| > The changes i suggested for V5UA (Message Class and Parameter Tags) were
| > motivated by the fact that all the UAs should be seen as the same family
of
| > protocols, and therefore there should be an overall consistency between
the
| > different documents.
|
| > This simply makes life easier to everybody, and allowing implementations
to
| > handle multiple UAs with the same UA "core".
|
| You can give up on that.  I tried to push in that direction several years
| ago, however, each UA is unique.  The "common" procedures are not common
and
| the "common" parameters do not align either.
|
| If this is of concern to you, I suggest you get involved earlier in the
| process: (several years earlier) see the thread
|
|   "SUA09, M3UA-10, M2UA-11, RFC2057: Common parameters." December 30, 2001
|
| for the general attitutde of the editors and chair towards the "unified UA
| theory."
|
| >
| > M2UA and M3UA have overcome several changes to make them consistent
(error
| > code values, etc) while they were still drafts, and once they had moved
to
| > RFC status.
|
| See the above cited thread for the inconsistencies that were not addressed
| at draft and were not addressed before RFC either.
|
|
| > But these changes where largely discussed on the mailing list, and
that's
| > fine to me because everybody is made aware of the propositions, and can
| > therefore give their point of view, and everybody wins in the end.
|
| In fact they did not receive much discussion: aside from myself, the
editors
| and the chair, there were three or four others (rarely) in the
discussions.
| I don't see your name on the thread.
|
| >
| > Calling this modified document "draft-05" rather than "RFCxxxx" would be
| > better in my opinion, although these proposed changes will probably make
the
| > V5UA spec much more stable in the future.
| > Then we can move it to RFC with a high probability that it will remain
| > stable, and therefore allow companies to have a strong confidence in it.
| > And that is the purpose of an RFC, correct ?
|
| That is the purpose of a "Standard", however, the document will only be a
| "Proposed Standard".  It has many changes to suffer from the experience of
| implementation.
|
| --brian
|
| >
| > Now i'm happy that Eva has clearly stated the list of changes to the
draft
| > document.
| > I agree with these changes.
| >
| > Best regards / Meilleures salutations
| > Pascal Bouveron
| > =============================================
| > www.netbricks.com
| > Netbricks - Provence - FRANCE
| > Tel: (+33) (0)4 42 91 44 77 -- Fax:  (+33) (0)4 42 91 44 71
| > =============================================
| >
| >
| > _______________________________________________
| > Sigtran mailing list
| > [email-masked]
| > https://www1.ietf.org/mailman/listinfo/sigtran
|
| -- 
| Brian F. G. Bidulock
| [email-masked]
| http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Pascal Bouveron (Netbricks)" <[email-masked]>
Date: Thu, 12 Feb 2004 19:10:44 +0100

I saw the RFC3057bis-00 document.
I think the full M3UA document will be welcome!
Many thanks for the effort, Lyndon.

----- Original Message ----- 
From: "Ong, Lyndon" <[email-masked]>
To: "'Pascal Bouveron (Netbricks)'" <[email-masked]>;
<[email-masked]>
Cc: "Eva Weilandt" <[email-masked]>; <[email-masked]>;
"Michael Tuexen (Sigtran)" <[email-masked]>; "Alain
CHAMPENOIS" <[email-masked]>
Sent: Thursday, February 12, 2004 6:49 PM
Subject: RE: [Sigtran] Silent changes to V5UA draft 04 before moving to RFC
?

| Hi Pascal,
|
| Thanks for your cooperation and comments on V5UA.  As it turns out
| we will need to put out another version when we get to the authors'
| review part of the RFC process, so you will see a version 5 at that
| point.
|
| Regarding the IGs, we did decide to put out a new version of IUA
| rather than an IG for that spec, in response to your and others'
| comments.  We're very close to completing the IG for M3UA now,
| and when we have agreement on this we can consider whether to
| update the RFC or put out a separate document, I think.
|
| Cheers,
|
| Lyndon
|