Subject: RE: [Sigtran] SUA v16: TID and DRM labels

From: [email-masked]
Date: Thu, 19 Feb 2004 08:11:08 +0200

Hi Brian,

> If you look back to the thread "SUA-09: SCCP Connections and TCAP
> Transactions" from Dec 2001/Jan 2002, you will find that at that
> "late date" it was too late to remove or fix the labels.  In that
> thread there was a proposal for a working solution.  The draft was
> advanced to IESG LC Feb 2002.  Now, two years later, it is neither
> fixed nor removed, and it is still a late date.  At this rate, expect
> corrections some time in 2006, if, of course, it is not still too
> late by then ;)
> 
> I am concerned, however, that the approach is not clearly marked as
> optional.  Which it should be and was always intended to be.  That
> change can certainly be made before SUA goes out the door (unless
> the authors have been stripped ala M3UA).

If you want to send text and get support, I can probably make the text
change - if the text change is not too substantial.

Delays due to IESG issues are beyond my control.

John

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 18 Feb 2004 23:57:15 -0700

John,

John Loughney wrote:                                                                  (Thu, 19 Feb 2004 08:11:08)
> Delays due to IESG issues are beyond my control.

Proposed text addition: "Label procedures are OPTIONAL."

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Barry Nagelberg" <[email-masked]>
Date: Thu, 19 Feb 2004 08:52:33 -0500

It is not good enough to simply state in the draft that the "Label
procedures are OPTIONAL.".

As I noted earlier, there is no mechanism through which the SGP can indicate
to the ASP that it doesn't support the
TID Label parameter in the ASPAC message (there is no "Unsupported
parameter" error code).

So when an ASP implementation _does_ send the TID and/or DRM labels to an
SGP that does not support them, we will be in "non-interoperability hell".
The ASP will assume that the SGP is supporting the labels, while in reality
the SGP will not be supporting them. The ASP will receive transaction IDs
that it does not expect.

These procedures must either be fixed or removed. Why are we rushing to push
through a flawed draft?

Barry Nagelberg

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Thursday, February 19, 2004 1:57 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [Sigtran] SUA v16: TID and DRM labels
>
>
> John,
>
> John Loughney wrote: